Information ausblenden

studio one v2: control link

Dieses Thema im Forum "Studio One" wurde erstellt von techno, 03.12.11.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    also :) :

    ein riesen danke an euch alle für eure hilfe!!!
    ich hab es jetzt ohne neuinstallation hinbekommen! es klappt !!!!!! :)
    tatsächlich musste ich nur das hauptaugenmerk auf die eingänge direkt in der midi-spur richten.
    und da es gestern mit dem remote le erst mal nicht geklappt hatte, hab ich grad noch die nummern des midi-kanals meines remote le durchprobiert: kanal 14 war dann der volltreffer. da werd ich mir nochmal ein neues template für das remote le einrichten, um künftig immer kanal 1 zu erwischen. oder vielleicht lass ich es auch, jetzt wo ich das weiß :)

    lag also wieder mal am user, und nicht am studio one! :)
    nochmal vielen dank an euch!
    studio one kann das also schon! :)
     
    techno, 27.04.12
    #41
  2. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    eine frage, die sich bei mir dazu noch aufgeworfen hatte, muss ich noch stellen, damit ich damit endlich (hoffentlich :D ) ruh geben kann:

    ich kann diese midi-cc-steuerung nur über das midi-keyboard(das als standardeingabegerät eingerichtet wurde) und den jeweils eingerichteten empfangskanal bewerkstelligen.

    richte ich z.b eine andere midi-steueroberfläche (z.b. bcr) ein, kann ich diese nicht in der eingangsauswahl der s1-spuren auswählen, um zwecks soundschrauben z.b. auch nicht angelernte controller vom bcr für die cc-steuerung zu verwenden.

    oder geht das vielleicht doch?
     
    techno, 05.06.12
    #42
  3. Serious

    Serious

    Registriert seit:
    21.06.07
    Punkte:
    460
    460
    Ich bin mir nicht ganz sicher ob ich dich richtig verstanden habe, aber ich versuch mal mein Glück:

    Du willst also deinen bcr als Eingang für deine Midi-Spur benutzen, um damit z.b. die (hier schon viel diskutierte ;-) ) LFO-Rate beim Tyrell zu steuern.
    Hab ich das richtig verstanden?

    Wenn ja:
    Versuche mal den bcr nicht als Midi-Controller, sondern als "Keyboard" im Studio One anzulegen. Dann sollte er auch als Eingang für eine Midi-Spur wählbar sein.

    Gruß
    Simon
     
    Serious, 05.06.12
    #43
    techno bedankt sich.
  4. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    hallo Serious!
    danke für deinen vorschlag, den werd ich morgen mal probieren.
    ich hoff bloß, dass ich die bcrs dafür nicht in einem neuen control-link-fenster einrichten muss.
    aber ich werde berichten, wie ich es dann gemacht und hoffentlich hinbekommen hab.
    beste grüße
     
    techno, 05.06.12
    #44
  5. Serious

    Serious

    Registriert seit:
    21.06.07
    Punkte:
    460
    460
    Ich glaube daran wirst du nicht vorbei kommen
     
    Serious, 05.06.12
    #45
    techno bedankt sich.
  6. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    oh weh. das riecht nach zeitaufwand. gut, wenns nicht anders geht, dann muss ich da notfalls durch.
    aber nochmal danke. manchmal ist die lösung doch so naheliegend... ;)
     
    techno, 05.06.12
    #46
  7. Bademantel

    Bademantel

    Registriert seit:
    18.10.11
    Punkte:
    45
    45
    Wie habt Ihr das geschafft? Ich schaffe es immer noch nicht LFO Rate mit einem Controller zu verknüpfen.
    Sugar Bytes Thesys hat nämlich auch so einen Midilearn für die einzelnen Steps und meine Hoffnung ist, wenn ich es mit Tyrell schaffe, dann sollte es auch mit Thesys funktionieren.

    Habt Ihr den Controller als Keyboard, Instrument oder Bedienoberfläche eingerichtet?
    Muss Fokusgerät (gelber Knopf) im Plugin Fenster aktiviert sein oder nicht?
     
    Bademantel, 02.07.12
    #47
  8. Elias57

    Elias57

    Registriert seit:
    30.01.17
    Punkte:
    517
    517
    Ich hab's als "Neues Keyboard" eingerichtet.
     
    Elias57, 02.07.12
    #48
  9. Bademantel

    Bademantel

    Registriert seit:
    18.10.11
    Punkte:
    45
    45
    Hast Du per Midilearn verknüpft? Und welchen Parameter hast Du verknüpft? weil Lfo Sync und Lfo Delay schaffe ich auch, da sie im Controll Link auftauchen.
     
    Bademantel, 02.07.12
    #49
  10. Elias57

    Elias57

    Registriert seit:
    30.01.17
    Punkte:
    517
    517
    Dein synth habe ich nicht, hier der Arturia minimoog. MIDI learn, Controller bewegt, gelingt. Damit hat es hier funktioniert.

    Nebenbei, du bist nicht auf Mac und AU unterwegs? Ich habe festgestellt, dass es mit AU an einigen Stellen anders ist.
     
    Elias57, 02.07.12
    #50
  11. Bademantel

    Bademantel

    Registriert seit:
    18.10.11
    Punkte:
    45
    45
    Nein, bin mit PC´s unterwegs.
    Den Arturia Minimoog habe ich wiederum nicht.
    Es geht darum Bedienoberflächen zu verlinken, die nicht im controll link auftauchen.

    Hier ist die MAC freeware version von Tyrell zu finden:
    http://www.amazona.de/index.php?page=26&file=2&article_id=3978

    Versuch mal LFO Rate mit midilearn zu verlinken, wenn Du magst. Auf dem PC ist das Rechtsklick, auf den Apples Command-Klick, Apfel-Klick?
     
    Bademantel, 03.07.12
    #51
  12. Elias57

    Elias57

    Registriert seit:
    30.01.17
    Punkte:
    517
    517
    Ich denke, wenn ein Parameter beim Bewegen mit der Maus NICHT im linken Fenster des Control Link auftaucht, dann wird er auch nicht über sonstjedweden Controller controllert werden können. Das ist aber kein Manko von SO, sondern liegt wohl eher am Hersteller des Plugs.

    Mit dem Tyrell kann man das wunderbar verfolgen. Oder unwandelbar.

    Ganz schrill. Als Audio Unit wird der Tyrell (neueste Version) z.B. gar nicht angezeigt, sprich leeres Plugin-Fenster. In Ableton geht das allerdings.
     
    Elias57, 04.07.12
    #52
  13. Serious

    Serious

    Registriert seit:
    21.06.07
    Punkte:
    460
    460
    Falsch. Les dir mal meine Posts in diesem Thread durch.
     
    Serious, 04.07.12
    #53
  14. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    so nochmal ich :)

    ich bin ja mit dem control-link-konzept total zufrieden. funktioniert soweit alles ganz prima!
    nachdem ich zwar in v2.0.6 noch kleine probleme mit dem wertefeedback beim auslesen von automationsdaten hatte, scheinen diese auch bei 2.0.7 nicht mehr vorhanden zu sein.
    aber ein kleines ärgernis gibt es für mich im moment:

    beim anlernen neuer kontrollregler von der hardware, muss ich leider immer für jeden einzelnen befehl nochmals extra ein häkchen für "wert senden" setzen, um auch ein wertefeedback zu erhalten (=rechtsklick auf das ausgewählte reglerelement-->popup geht auf-->"Wert senden" auswählen).
    beim belegen des bcr mit hunderten reglerwerten ist das leider doch sehr lästig, gerade weil auch leicht die gefahr besteht, dass man doch etwas übersieht.
    es gibt wohl keine möglichkeit, dieses häkchen automatisch für jeden angelernten regler anzuwenden? denn eigentlich macht der control-link ja gerade bei feedback-fähigen controllern sinn, da müsste das doch am sinnvollsten gleich automatisch das "werte senden" aktiv halten.
    wäre es vielleicht möglich, das programm immer automatisch die zusatzinfos des vorherig eingerichteten reglers automatisch für den nächsten angelernten regler übernehmen zu lassen?
    das wäre eine prima sache, die mir meine zeit ziemlich versüßen würde :D
     

    Anhänge:

    techno, 19.09.12
    #54
  15. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    [​IMG] -push-
     
    techno, 19.09.12
    #55
  16. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    also dann noch ein push :)

    ich hab jetzt folgende idee:

    Ari hat mir ja in post#2 bereits ein verzeichnis genannt, in dem ich bestimmte parameter finde.

    in einem anderen unterpfad hab ich ein steuergeräte-xml gefunden, in dem alle bislang angelernten parameter aufgeführt werden.

    bei allen parametern, in denen die wertefeedback-funktion in der gui noch nicht angehakt ist, steht

    options= "receive public"

    in denen, die wertefeedback senden, steht stattdessen

    options= "receive transmit nofeedback public"

    so, und jetzt zur frage:
    kennt jemand ein texttool, das mich die erste formulierung vollautomatisiert durch die zweite formulierung ersetzen lässt?
    finde ich so eine funktion ggf. auch schon in open office?
    hoffentlich hat jemand von euch eine idee, wär ja schlimm, wenn ich da morgen stunden mit der korrektur zubringen müsste... :)

    edit: ich habe es nun gelöst. hat mit einem texteditor funktioniert.
     
    techno, 20.09.12
    #56
  17. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    hallo,
    ich hoffe, dass sich heute wenigstens jemand von presonus bei mir meldet, denn beim einrichten habe ich gerade wieder ein zwar kleines problem bemerkt.
    ich hab gerade bemerkt, dass der control-link erstmals vier regler nicht anlernen will.

    es handelt sich um die midi-werte:

    ch: 4, cc: 65, "Portamento on/off"
    ch: 4, cc: 66, "Sostenuto on/off"
    ch: 4, cc: 67, "Soft Pedal on/off"
    ch: 4, cc: 68, "Legato Footswitch"

    die midi-eingangsanzeige von s1 2.0.7 prof. v2 leuchtet dabei auch kurz auf, wenn ich die regler drehe. über midi-ox wird in jedem fall der eingang dieser signale am rechner bestätigt.
    aber der control-link lernt sie nicht an!
    werden die möglicherweise durch einen filter vom control-link ignoriert? kann man dieses verhalten abstellen?

    kann mir jemand dieses verhalten mit anderer hardware bestätigen?
    über hilfe wäre ich dankbar :)

    edit: noch als zusätzliche information:
    ich schleife das signal der bcrs zusammen als keyboard ein... daran liegt es wohl. (in jedem fall werden die betroffenen midi-werte bei steuerung über eine sonstige bedienoberfläche im control-link angenommen...)
    tja, dann muss ich wegen gleichzeitiger cc-nutzung (so wie ich mir das heuer schon mal in diesem thread angedacht hatte) wohl wieder umdenken?
    gibt es von presonus vielleicht eine liste an ch und cc, die beim controllink beim keyboard als steuergerät ignoriert werden?
     
    techno, 20.09.12
    #57
  18. Ari

    Ari Gesperrter User

    Registriert seit:
    24.06.04
    Artikel:
    1
    Punkte:
    141.847
    141847
    Wir haben das hier nachgebaut und ausprobiert und die Werte werden NICHT gefiltert.
    Hast du sie vielleicht schon irgendwo anders verwendet?

    Grüße
    Ari
     
    Ari, 27.09.12
    #58
  19. techno

    techno Themenersteller

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    hallo Ari,
    danke für die antwort.
    nein, die werte wurden bei mir nicht gefiltert und auch nicht anderweitig verwendet.

    das beschriebene verhalten trat auf, als das häkchen bei "kanäle trennen" nicht gesetzt war. (ich weiß natürlich nicht, ob bei diesem modus die funktionsweise des control-link beeinträchtigt wird?).
    nachdem ich das häkchen gesetzt hatte, ließen sich die parameter und alle weiteren durchgehend belegen.

    alle regler funktionieren damit nun für mich durchgehend, ohne weitere probleme und mit vollständigem wertefeedback. :)
     
    techno, 27.09.12
    #59
  20. audiosync

    audiosync

    Registriert seit:
    16.02.06
    Punkte:
    39
    39
    Sorry für das Wiederbeleben dieses alten Threads, aber hier gibt es wohl einige User mit Novation Controllern:
    Werden denn die Endlosdrehregler bei diesen Geräten von S1 aktualisiert, sodass der LED-Kranz den aktuellen Wert anzeigt, also der Regler diesen quasi „abholt“, wenn er rein über Control-Link verbunden ist? Oder nur mit Automap? Oder überhaupt?

    @techno: Geht das mit dem BCR? Ich meine Deine letzten Beiträge dahingehend interpretiert zu haben, dass dies funktioniert...
     
    audiosync, 20.04.14
    #60
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.