Latenz bei Midi

Dieses Thema im Forum "Studio One" wurde erstellt von Wolle33, 07.01.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Wolle33

    Wolle33 Themenersteller Neues Mitglied

    Registriert seit:
    06.12.11
    Punkte:
    16
    16
    Hallo Zusammen,
    ich habe das Problem, dass Midi Signale, die ich über ein extermes Keyboard oder direkt über die Computer Tastatur spiele, über Studio One verzögert aufnehme, sofern die Anschläge entsprechend schnell sind. Von der Tendenz her, klappen 1/4 noch, aber 1/8 werden nach 4 oder 5 Takten verzögert (das Signal verschiebt sich zeitlich nach vorne) aufgenommen.

    Hat jemand eine Idee, woran dies liegen könnte? Falls es noch weiterer Informationen bedarf, um die Fehlerwirkung zu analysieren, freue ich mich über entsprechende Fragen. Besten Dank vorab!

    Viele Grüße
    Wolle
     
  2. BeatsProMInute

    BeatsProMInute

    Registriert seit:
    25.01.11
    Punkte:
    294
    294
  3. Wennto

    Wennto Moderator Mitarbeiter

    Registriert seit:
    13.08.06
    Punkte:
    123.940
    123940
    Hi,

    welches Audiointerface, welche Treiber?
     
  4. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Der mit MIDI nur nichts am Hut hat, weswegen er auf Verzögerungen bei MIDI-Signalen auch keinen Einfluss hat.
     
  5. BeatsProMInute

    BeatsProMInute

    Registriert seit:
    25.01.11
    Punkte:
    294
    294
    @tubeless wenn du das Sagst ^^

    ich sehe das anders

    das dingt gleicht die Latenz aus bei mir läuft das super und habe kaum merkliche verzögerung wenn ich mit meinem Laptop unterwegs bin. von daher ist der Asio treiber für mich eine super lösung gewesen.
     
  6. Wennto

    Wennto Moderator Mitarbeiter

    Registriert seit:
    13.08.06
    Punkte:
    123.940
    123940
    dann siehst Du das, streng genommen, falsch....

    aber dennoch wird es wohl die Lösung sein, nur hat das mit Midi ansich wirklich nix zu tun!
     
  7. BeatsProMInute

    BeatsProMInute

    Registriert seit:
    25.01.11
    Punkte:
    294
    294
    Hey Wennto,

    Das der Asio nichts mit Midi zu hat ist mir klar. Ich meinte damit den satz von Tubless
    und Einfluss hat der Asio ja "irgendwie" dann schon oder etwa nicht .

    Gr
     
  8. Wennto

    Wennto Moderator Mitarbeiter

    Registriert seit:
    13.08.06
    Punkte:
    123.940
    123940
    Latenz entsteht durch Audioausgabe und nicht durch Midi-Übertragung

    Latenz hat nichts mit dem Midi-Signal zu tun. Bleibt nun die Frage ob der TS es so meinte?
     
  9. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Ist denkbar.
    Aber nur unter der Bedingung, dass die Beschreibung des TE falsch ist.
    Er schreibt:

    Wenn ich das wörtlich nehme, und das muss ich, denn eigentlich ist freies Interpretieren bei der Fehlersuche nicht der Bringer, dann werden die Noten verzögert aufgezeichnet - wir sind also noch im MIDI-Bereich und nicht im Audiobereich.

    Wenn der User natürlich meint, seine Töne kommen zu spät, das Wort "aufnehmen" ist genauso wenig Bedeutungslos wie "Schuhe putzen", dann mag die verzögerung schon im Audionereich leigen und sie MAG mit A4A bekämpft werden können.
    Aber selst dann, wenn dem so ist, ist die Ansage: Mach mir den AA2 ohne irgendwelche weitere Infos schon recht frech. Denn woher weiss man, welche Soundkarte da läuft, woher weiss man, welche Treiberkonstruktion da unterwegs ist?

    Gut, wenn solche Sachen kommen wie:

    ........darf man sich allerdings getrost fragen, ob man den Worten trauen darf. :D

    @TE:
    Was hast du da für Hardware am Start? Welche Treiber benutzt Du überhaupt? Was macht bei Dir den Sound? VSTi? Oder der Windows Synthie? Oder der örtliche Orgelpfeifenverein?
     
  10. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    @ BeatsProMInute

    Nein.
    Wenn es um MIDI geht, dann nicht.
    Wenn die Töne verzögert kommen, ist es möglicherweise ein Audioproblem - und dann eben möglicherweise ein ASIO-Problem. Muss aber nicht. Nicht alle Treibermodelle ausser ASIO sind in der Tat langsam.
     
  11. BeatsProMInute

    BeatsProMInute

    Registriert seit:
    25.01.11
    Punkte:
    294
    294
    Ok Wennto und tubless ich würde sagen, dann werden wir uns so einig ok?

    Damit wird dem TE schließlich auch nicht geholfen also Back to Topic ?
     
  12. Wennto

    Wennto Moderator Mitarbeiter

    Registriert seit:
    13.08.06
    Punkte:
    123.940
    123940
    wir warten ja nur drauf zu erfahren, was eigentlich Topic ist ;-)
     
  13. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Das Problem ist schlichtweg, dass die Beschreibung zu ungenau ist, als dass man da konkrett ne Ansage zu machen könnte.

    Eingabe über die Computertastatur muss nicht zwingend zu MIDI-Verzögerung führen - das hängt vom Treiber ab.
    Und sie muss auch nicht zwingend zu Audioverzögerung führen. Das hängt vom Audiotreiber und vom Synthie ab.....

    Und so weiter..... :D
     
  14. Wolle33

    Wolle33 Themenersteller Neues Mitglied

    Registriert seit:
    06.12.11
    Punkte:
    16
    16
    Hallo Zusammen,
    erstmal vielen Dank für die entstandene Diskussion! Ich bitte es zu entschuldigen, wenn meine Beschreibung zu ungenau war / ist. Beschäftige mich gerade mal ein paar Wochen nebenbei mit der Materie und bin mit den Begrifflichkeiten noch nicht so vertraut.

    Ich versuche die Vorgehensweise noch einmal genauer zu beschreiben: Ich arbeite mit Studio One Artits. Habe keine weiteren Treiber neben der eigentlichen Sofwareinstallation vorgenommen und habe über Midi ein Keyboard angeschlossen. Habe 1/8 auf dem Keyboard einspielen lassen und über die Software aufgenommen. Ergebnis war eben, wenn man sich das Ergebnis dessen anhört, dass die Latenz nach einigen Takten beginnt. Dabei war es egal, ob wir das bei einem song gemacht haben, bei dem noch gar keine oder Spur existierte oder ein Song war, der bereits einige Spuren beinhaltet hat. Auch das Tempo des Songs hat keinen Einfluss auf die Fehlerwirkung gehabt. Mein Betriebssystem ist Windows 7.

    Viele Grüße
    Wolle
     
  15. Wennto

    Wennto Moderator Mitarbeiter

    Registriert seit:
    13.08.06
    Punkte:
    123.940
    123940
    Ich versteh es immer nocht nicht? Sorry!

    Was ist der Klangerzeuger? Das Keyboard oder ein virtuelles Software- Instrument ?
    Nimmst Du Audio oder Midi auf?
    Welches Audiointerface nutzt Du? Sind dessen Treiber installiert?
     
  16. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Hmmm.
    Mal sehen.

    "Einspielen lassen." Du ahst nicht selber eingespielt?

    "Latenz beginnt nach ein paar Takten."
    Bist Du sicher, dass Du den Begriff Latenz richtig verwendest?
    Nimmst Du MIDI auf? Und: verschiebts Dir die Noten nach hinten, je später im Song desto mehr?

    Oder erklingt der Ton immer später, je länger der Song läuft, baut sich die Latenz also immer mehr auf?

    "Wenn man sich das Ergebnis dessen anhört"
    Das Ergebnis wessen? Der Audioaufnahme? Der MIDI-Aufnahme? von Beidem?

    Und natürlich: Die Fragen von Wennto nicht vergessen.... :D
     
  17. Wolle33

    Wolle33 Themenersteller Neues Mitglied

    Registriert seit:
    06.12.11
    Punkte:
    16
    16
    Leider komme ich erst jetzt wiede dazu mich dem Thema zu widmen.

    Also:
    Ich habe ein Keyboard. Dort Midi Out, dann bei der USB Audiobox in Midi in.

    Das keyboard habe bei Studio One - wie in der Bedienungsanleitung beschrieben - als externes Gerät bekannt gemacht. Das wars. Einen Treiber habe ich nicht expliziet installiert. Hat aber auch die Software nicht von mir verlangt.

    Wenn ich nun auf dem Keyboard achtel spiele und über Studio One aufnehme, ist bei den achteln am Anfang des Spielens der Ton genau auf der 1 u. 2. u / usw. Nach ein paar Takten ist er aber vor der 1 u. 2. u. /usw. Ich hoffe, dass man mein Problem auf dem angehängten Bild ganz gut sehen kann.

    Bin gespannt, viele Grüße
    Wolle
     

    Anhänge:

  18. anthe

    anthe

    Registriert seit:
    13.08.08
    Punkte:
    10.683
    10683
    Gut, das ist also def ein Midi Problem. Hättest Du jetzt Cubase unter Windows würde ich sagen "Hake überall, wo Du es findest 'Systemzeit verwenden' an", sprich Taktgeber ist das System u nicht der Sequenzer ...
    Evtl hat S1 ähnliches

    lg
    Andi
     
  19. Wolle33

    Wolle33 Themenersteller Neues Mitglied

    Registriert seit:
    06.12.11
    Punkte:
    16
    16
    Vielen Dank! Leider habe ich so eine Einstellung nicht gefunden. Das einzige - ohne so wirklich genau zu wissen, was es bedeutet - habe ich folgendes - Bild - gefunden. Habe die interne Blockgröße runtergeschraubt und meine Besserung zu verspüren ...
     

    Anhänge:

  20. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Sieht eigentlich so aus, als ob mit Deiner Rastereinstellung was nicht stimmt. Das Raster scheint mir merkwürdig zu sein. Du spielst Achtel, also müssten irgendwo ja auch Taktstriche zu finden sein - je nach Taktart natürlich. Aber generell müssten welche da sein. Sind aber keine.

    Die dickeren Striche können keine Taktstriche sein, oder der von Dir angegebene Notenwert stimmt nicht.

    Ausserdem scheint es so, als ob die Verschiebung der Noten einem relativ gleichmässigen Mass folgen würde. Das finde ich auch seltsam.

    Gut denn:
    Wie ist Dein Raster eingestellt? Welche Taktart verwendest Du? Welche Zeitbasis ist eingestellt für Deine Timeline? Mit welchen Werten quantisierst Du, wenn überhaupt?

    PS: Die Einstellungen in der Audiobox-Optionen gelten fürs Audio, die haben wzar Einfluss aufs Erklingen der MIDI-Noten, weil das ja ne Audogeschichte ist, aber nicht aufs Aufzeichnen, das ist MIDI, und damit hat der ASIO-Treiber nicht wirklich was am Hut
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.