Information ausblenden

.wav-samples knacksen beim abspielen

Dieses Thema im Forum "Musik produzieren" wurde erstellt von scifish, 22.09.02.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. scifish

    scifish Themenersteller

    Registriert seit:
    22.08.02
    Punkte:
    105
    105
    moinsen leute!

    also das automationsproblem habe ich zwar gelöst (siehe unter topic "logic automation greift nicht korrekt"), aber da gäbe es noch ein kleines problem was mir sorge bereitet:

    der song spielt optimal ab, alle instrumente ohne knackser, keine overloads, aber sobald ein audiosample mit im arrangement vorkommt knackst es ungefähr jede sekunde. auf der audio auslastungsanzeige geht der DISK I/O wert exakt beim knackser immer hoch. immer wenn er daten von der platte liest eben --> knacks. wenn die stelle mit dem audiosample vorbei ist, ist alles wieder im grünen bereich.

    ich habe unter "audio > audiovoreinstellungen > audio treiber 2, asio" schon das kästchen "larger disc process buffer" angewählt, aber es bringt nix.

    dieses knacksen habe ich auch, wenn ich den gesamten track bounce, allerdings nicht nur wenn audio samples kommen sondern permanent, von anfang bis ende. das gebouncte audiofile ist dann allerdings komplett knacksfrei und ohne störgeräusche (wenn ich es extern in z.b. winamp abspiele). allerdings ist es schon nervig wenn es beim songwerkeln bei jedem audiosamples knackst, das zerstört den workflow :-(

    noch ne anmerkung: die audiosamples in native instruments battery, oder halion oder sonst einem sampler knacksen beim abspielen NICHT, es handelt sich lediglich um .wav-samples die direkt auf die audiospuren abgelegt wurden!

    für hilfe ultrakrass dankbar!

    greetz,
    martin
     
  2. NULL

    NULL Guest

    Punkte:
    0
    mit logic kenne ich mich nicht aus, spontan fällt mir nur ein

    festplatte im dma-modus?
    evtl. defragmentieren
    eigenen irq für soundkarte/ggf. anderen pci-steckplatz
    latenzzeit erhöhen/ alle samplingrates probieren (44.1/48/96)
    audioblock-grösse hast du ja schon erhöht.

    wenn du xp verwendest:
    XP für Audioanwendungen optimieren
     
  3. NULL

    NULL Guest

    Punkte:
    0
  4. scifish

    scifish Themenersteller

    Registriert seit:
    22.08.02
    Punkte:
    105
    105
    hmm also ich bin von win2k ja zu win98 gewechselt, zumindest für das audio zeugs. wo ich noch in win2k gearbeitet habe gab es soweit ich weiss diese probleme nicht, ist erst in 98 dazugekommen. ist mir allerdings ein rätsel. aber ich werd die pladde ma defragmentieren und versuchen die latenzzeit zu erhöhen! allerdings ist die ja schon bei 23ms (bei 44khz) :/ die festplatten sind soweit ich weiss auch im dma modus, aber ich bin mir nicht sicher, wo kann ich das nachschauen?

    greetz,
    martin
     
  5. NULL

    NULL Guest

    Punkte:
    0
    dma:
    systemsteuerung>gerätemanager>ide/atapi controller

    dann wahrscheinlich primärer ide kanal
    (sekundär sollte cd-rom, dvd und/oder brenner sein)

    >erweiterte einstellungen>übertragungsmodus
     
  6. NULL

    NULL Guest

    Punkte:
    0
    aber ist dma nicht irgendwie schneller? oder ist das standard? ich kenn mich da leider nicht so aus :-? was bewirkt dma? kann mir das einer erklären?

    greetz,
    martin
     
  7. scifish

    scifish Themenersteller

    Registriert seit:
    22.08.02
    Punkte:
    105
    105
    (das post war von mir)

    greetz,
    martin
     
  8. neil

    neil

    Registriert seit:
    15.09.02
    Punkte:
    1.041
    1041
    hi,

    dma bedeutet "direct memory access": wenn der modus <i>nicht</i> aktiviert ist, laufen die plattenzugriffe über deine cpu, die dann natürlich mehr zu tun hat - bzw. wenn sie gerade was anderes macht, muss der festplattenzugriff eben mal kurz warten. folge: audio-recording ohne dma kannste leider knicken... :-x

    martin
     
  9. NULL

    NULL Guest

    Punkte:
    0
    hi,
    hab ich mich wohl missverständlich ausgedrückt, natürlich sollte der dma-modus aktiviert sein.

    gast alex
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.