Program Change/Klänge: Scheinbar wahlloses wechseln

Dieses Thema im Forum "Cubase & Nuendo" wurde erstellt von thephantom, 09.12.17.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. thephantom

    thephantom Themenersteller Deaktivierter Benutzer

    Registriert seit:
    21.08.06
    Punkte:
    2.471
    2471
    Leider finde ich partout keine eigene Lösung - vielleicht hat hier auch jemand das Problem und konnte es bereits lösen:

    An Cubase (aktuelle Version) sind zwei externe Synths angeschlossen und entsprechend eingebunden, so dass ich alles komfortabel über Cubase steuern kann.
    Ich habe mir ein Preset angelegt, in dem für beide Geräte alle 16 Kanäle vorbelegt sind, um schnell arbeiten zu können.
    Ein Kanal beim Kurzweil PC3K8 ist fest auf den Sound 997 "Silent Program" eingestellt, so dass ich über diesen Kanal keinen internen Sound spiele, sondern den jeweils in Cubase per Rec-Button ausgewählten.

    Jetzt gibt es aber leider das Problem, dass genau dieser Kanal oft das Programm wechseln.

    Beispiel:
    Ich spiele über das Kurzweil-Keyboard mit dem Programm 997 "Silent Program" einen Sound in Halion. Nun wechsel ich den Klang in Halion - und das Kurzweil-Keyboard wechselt auch seinen Sound (was es ja nicht tun soll). Ich stelle das Kurzweil dann wieder händisch auf 997 (habe im Kurzweil eingesellt, dass keine Program-Change-Befehle gesendet (!) werden sollen). Wenn ich nun wieder einen Sound in Halion wechsel passiert das oben genannte Verhalten nicht zwangsläufig wieder.

    Hat jemand dafür eine Lösung parat?
    Woran könnte das liegen?
     

    Anhänge:

    • 01.JPG
      01.JPG
      Dateigröße:
      95,6 KB
      Aufrufe:
      32
    • 02.JPG
      02.JPG
      Dateigröße:
      91,8 KB
      Aufrufe:
      28
    • 03.JPG
      03.JPG
      Dateigröße:
      62,1 KB
      Aufrufe:
      28
    • 04.JPG
      04.JPG
      Dateigröße:
      43,4 KB
      Aufrufe:
      28
    Zuletzt bearbeitet: 09.12.17
  2. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    9.267
    9267
    In Bild Nr. 03 sehe ich, dass kein Gerät am MIDI-Eingang anliegt wobei in Bild Nr. 04 das Kurzweil am MIDI-Eingang anliegt. Kann es sein, dass das Kurzweil einen Programm-Change sendet, welcher über Cubase wieder zurückgeleitet wird?
    Falls ja, dann dieses Verhalten im Kurzweil versuchen abzustellen.

    Eine 2. Möglichkeit ist, dass da irgendetwas mit dem "Bank-Select" schief läuft. MIDI kann ja grundsätzlich nur 128 Programme adressieren.
    Und Dein "Silent Sound" liegt auf Platz 997, benötigt für die korrekte Addressierung also zusätzlich drn "Bank-Select"-Befehl über MIDI.
     
    thephantom bedankt sich.
  3. thephantom

    thephantom Themenersteller Deaktivierter Benutzer

    Registriert seit:
    21.08.06
    Punkte:
    2.471
    2471
    Zu Bild 3:
    Dort liegt keines an, weil es sonst eine Schleife geben würde.
    Das ist der Kanal, der mit dem "Silent Program" belegt ist.

    Die 2. Möglichkeit werde ich nun mal untersuchen!
    Vielen Dank für die Tipps.
     
  4. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    9.267
    9267
    Aber im Inspector sollte oben (also MIDI-Eingang) das Kurzweil stehen (was es in Bild 4 auch tut) und in der Zeile darunter der Halion - und nicht wie bei Dir auch das Kurzweil.
     
    thephantom bedankt sich.
  5. acblitzdc

    acblitzdc

    Registriert seit:
    20.10.16
    Punkte:
    457
    457
    Wenn Du den einfachen" Weg ohne Forschungsprojekt gehen willst, dann sage doch Deinem "Kurzweil PC3K8", dass es auf dem Midi Kanal auf dem es sendet (der mit deinem Leer-Programm) kein Prg-Ch/Bnk-Select annehmen soll. (in dessen Hardware-Config). Alle anderen 15 Kanäle kannst Du ja weiter benutzen; und durch Cubase Prg-Changes senden lassen. Deine Tastatur kriegt quasi 'n eigenen reservierten Midi "Sende- Kanal" nur für die Tastatur. (der eben nicht auf Prg-Changes reagiert)

    Forschungsprojekt wäre:
    1. Im List- Editor gucken (für jeden fraglichen Midi Track), ob sich da irgendwo beim Aufnehmen ein Prg-Change mit eingenistet hat, den Du nicht haben willst (Sollte man echt immer als erstes machen bevor man in die falsche Richtung sucht). (Sieht man im List Editor am schnellsten/einfachsten)

    2. Auf dem Track, der die "doofen" Prg-Changes an Deinen "Kurzen" sendet: Das "Midi- Monitor" Plugin von Cubase in den Insert und so einstellen, das es dauerhaft allen Mid-Kram in Echtzeit angezeigt.

    Jetzt mal die Program Changes im Halion auslösen (die, die immer Deinen "Kurzen" umschalten) und im Midi- Monitor gucken was da genau passiert.

    3. Mit --DEM Wissen-- gucken, ob die BankSelect/PrgChanges sich vielleicht decken mit der Syntax Deines "Kurzen" (dann bleibt am Ende eben doch wieder nur filtern), oder gucken, ob man dem Halion eben einen Midi Kanal dauerhaft klaut, der dann eben für Deinen Input der Tastatur reserviert ist...

    Mann... War das jetz kauderwelschig oder was hier?
     
    thephantom bedankt sich.
  6. thephantom

    thephantom Themenersteller Deaktivierter Benutzer

    Registriert seit:
    21.08.06
    Punkte:
    2.471
    2471
    Hi,
    vielen Dank für die vielen Denkanstöße und Lösungsvorschläge.
    Ich habe nun eine Mischform gewählt und bin auf die Lösung durch Eure Ideen gekommen! Also: Dankeschön.

    Ich habe dem Kurzweil nun "gesagt", dass er auf Kanal 1 niemals einen Sound ausgeben soll.
    Im Midi-Mode konnte man für jeden Kanal unter "Channels" einstellen, ob sie "Enable" oder "Disable" sind.
    Midi-Daten geben sie trotzdem weiterhin aus - also die perfekte Lösung.
    Jetzt können Program-Change-Befehle kommen, wie sie wollen ;).
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.