Information ausblenden

M-Audio FTP und Midi

Dieses Thema im Forum "Audio-Interfaces & Soundkarten" wurde erstellt von Neuromancer, 28.12.11.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Neuromancer

    Neuromancer Themenersteller

    Registriert seit:
    28.12.11
    Punkte:
    8
    8
    Hallo zusammen,

    ich habe zu Weihnachten ein Fast Track Pro bekommen. Ich wusste zunächst nicht, dass das Interface auch MIDI-fähig ist. Also hab ich gleich mal 2 MIDI-Kabel bestellt, weil ich eigentlich meinen microKORG dazu nutzen wollte, die Drums via VSTi (Addictive Drums) ins REAPER (gegen nen Mac) einzuspielen. Über das Virtual Keyboard von REAPER funktionierte das ja alles super.

    Heute kamen die Kabel mit der Post. Ich habe den MIDI-OUT des microKORG mit dem MIDI-IN des FTP verbunden. Dann ergibt sich folgende Situation: die MIDI-IN-LED des FTP leuchtet grün, und zwar ständig! Erst wenn ich eine Taste am MicroKORG drücke, wird das Leuchten der LED kurz unterbrochen, wenn ich wieder eine Taste drücke, dann wieder usw.
    Dieses Verhalten finde ich schon seltsam, denn ich hätte eigentlich erwartet, dass standardmäßig nichts leuchtet und erst, wenn ich eine Taste drücke, die LED grün aufleuchtet.

    Schließe ich hingegen MIDI-OUT vom FTP an MIDI-IN vom MicroKORG an (um quasi den microKORG lediglich als Klangerzeuger zu nutzen) leuchtet die MIDI-OUT-LED des FTP überhaupt nicht.

    An REAPER kommt nichts an. (Track -> INPUT: MIDI -> All MIDI inputs -> All channels, Record-armed, monitoring on) Was mich jetzt auch nicht weiter wundert, denn das Verhalten am FTP finde ich schon merkwürdig.

    Ich habe 2 Kabel bestellt, somit schließe ich einen Fehler seitens des Kabels aus.


    2 Fragen:

    1.) ist das Verhalten bei MIDI-IN im FTP so richtig? grün leuchten, sobald verbunden und sobald Taste gedrückt, wird das grüne Leuchten unterbrochen?

    2) Falls ein Fehler vorliegt: Wo ist die "Schuld" eher zu suchen? Beim FTP oder beim microKORG? Leider hab ich kein 2. MIDI-fähiges Gerät um das zu testen... :-(


    Danke für Eure Antworten im Voraus!

    Gruß

    Armin

    //Edit:
    ich habe jetzt mal gegen meine Win7-Kiste gearbeitet: neueste Treiber drauf, das FTP installiert, selbes Verhalten.
     
  2. tomric

    tomric Rocker

    Registriert seit:
    10.12.06
    Punkte:
    35.080
    35080
    Erstmal willkommen im Forum. Soweit ich weiß sollte die jeweilige LED nur leuchten, wenn ein entsprechendes Midisignal anliegt. Kann es sein, daß der Microkorg die ganze Zeit Daten sendet ?
     
  3. Neuromancer

    Neuromancer Themenersteller

    Registriert seit:
    28.12.11
    Punkte:
    8
    8
    Danke für die Willkommensgrüße.

    Die Einstellungen am microKORG:
    MIDI-Channel: 1
    Local: OFF
    Clock: INT(ernal)

    MIDI-Filter (SHIFT + 4):
    Program change: Disabled
    Control change: Disabled
    Pitch bend: Disabled
    SysEx: Disabled

    Nach wie vor das selbe Verhalten: die LED leuchtet grün und bei Tastendruck wird das Leuchten kurz unterbrochen. Auch ein RESET des FTP ändert daran nichts.
     
  4. slowhand73

    slowhand73

    Registriert seit:
    10.10.08
    Punkte:
    9.649
    9649
    Schon mal alles auf enable geschalten ?
    MicroKorg mal abgesteckt und nur das Kabel am Interface angeschlossen.
    2. Kabel mal ausprobiert.
     
  5. Neuromancer

    Neuromancer Themenersteller

    Registriert seit:
    28.12.11
    Punkte:
    8
    8
    a) ja, klar
    b) nein, hab ich aber eben gemacht. Ergebnis: wenn das Kabel abgesteckt ist, leuchtet nichts. Wenn es an den Korg angesteckt wird und der Korg aus ist: kein Signal. Wenn der Korg angeschalten wird und hochgefahren ist: ständiges grünes Leuchten.
    c) ja
     
  6. djbobo

    djbobo

    Registriert seit:
    23.10.09
    Punkte:
    7.107
    7107
    Ich würde mit einem einfachen MIDI Monitor schauen was am FTP ankommt.
    Bei Reaper kann ich nichts zu sagen, weil ich das Programm nicht habe. Da gibt es möglichweise einen MIDI Event Manager. Aber es geht auch einfach mit MIDIOx für Windows oder Snoize MIDI Monitor für Mac.

    Die MIDI Out LED des FTP leuchtet nur wenn Du MIDI Daten explizit an den Treiber MIDI Out des Fast Tracks schickst.

    Du kannst übrigens auch FTP MIDI Out mit FTP MIDI In verbinden ein paar MIDI Events ausgeben und die sollten am Eingang dann wiederum ankommen und 'aufnehmbar' sein.
     
  7. Neuromancer

    Neuromancer Themenersteller

    Registriert seit:
    28.12.11
    Punkte:
    8
    8
    Na, da wird doch der Hund in der Pfanne verrückt....

    Wollte eben Midiox für Win installieren, aber nachdem mein NOD Antivirus das Paket schnurstracks in die Mülltonne befördert hat, warf ich diesen Plan schnell wieder über Bord.
    Dann hab ich nochmal alles an den Mac angeschlossen, wurschtel mich da irgendwie durch die Menüs (u.a. durch die MIDI-Devices) und sehe, dass da plötzlich die MIDI-Inputs und Outputs des FTP auftauchen. Also hab ich den Input des Track auf das FTP Midi-Input geschalten und siehe da: ich kann die Drums mit dem Microkorg spielen! Und nicht nur die Drums, sondern jedes Virtuelle Instrument. Sauber! :)

    Stutzig macht mich aber immer noch, dass die LED die ganze Zeit leuchtet...seltsam...kann dieses Verhalten von jemandem bestätigt werden, der ebenfalls das FTP als MIDI-Interface nutzt?

    Teste jetzt Midi-Out, denn es müsste sich doch eigentlich das MIDI-Signal wieder zurück routen lassen, oder?

    Das hört sich irgendwie sehr cool an. Werde das testen, sobald ich es geschafft habe, das MIDI-Signal wieder auf den Korg zu routen.

    Danke an alle, die geantwortet haben!

    Armin
     
  8. djbobo

    djbobo

    Registriert seit:
    23.10.09
    Punkte:
    7.107
    7107
    Die meisten MIDI Geräte senden permanent ein 'Active Sensing' per MIDI Out, quasi ein 'Hallo hier ist was angeschlossen'
     
    Neuromancer bedankt sich.
  9. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    35.523
    35523
    +1 für Active Sensing.

    Eventuell auch Tempoinformationen.

    Clemens
     
  10. Neuromancer

    Neuromancer Themenersteller

    Registriert seit:
    28.12.11
    Punkte:
    8
    8
    Ja, auch von mir ein "+1", nachdem ich nachgeforscht habe:

    ----------------------------------------------
    1-2 System Realtime Messages
    F8: Timing Clock *4
    FE: Active Sensing

    *4 This message is transmitted when the "Clock" is set to "internal".
    ----------------------------------------------

    Jo, da haben wir es ja: nicht nur active sensing, sondern die Clock triggert auch noch ihre Timer-Events (ich hab die Clock ja auf Internal gestellt).

    Außerdem habe ich das eben mal genauer überprüft: setze ich die Clock auf "External" flackert die LED plötzlich, wobei das durchaus die Frequenz des active sensing sein könnte (alle 300ms).

    Stelle ich die Clock jedoch auf "Internal" oder "Auto", leuchtet die LED wieder ununterbrochen, wobei ich mir vorstellen könnte, dass die LED in Wirklichkeit so schnell flackert (eben wegen der Clock), dass mein Auge es als kontinuierliches Leuchten auffasst.

    Und nachdem ich noch weiter geforscht habe, bestätigt das meine Vermutung: stelle ich die Clock wieder auf Internal, leuchtet die LED wieder beständig grün. Wenn ich nun aber über den Arpeggiator die Frequenz runterschraube (was ja mehr oder weniger die Frequenz der Clock beeinflusst) auf 20 BPM, so wird aus dem beständigen Leuchten wieder ein Flackern.

    Es ist also alles in bester Ordnung. :)

    Quellen:
    http://www.zem-college.de/midi/mc_srm5.htm
    http://inside.massart.edu/Documents/ANImicroKORG_MIDI.pdf
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.