Information ausblenden

Hohe Latenzen - nicht hörbar?

Dieses Thema im Forum "Ableton Live" wurde erstellt von Fahnenflucht, 06.09.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    Hallo zusammen,

    habe grade mal die Demon von Ableton Live installiert, Voreinstellungen auf meine Hardware getätigt und bekomme jetzt folgende Werte angezeigt:

    Eingangslatenz: 23ms
    Ausgangslatenz: 33ms
    Globale LAtenz: 56 ms

    Mirkommt die Latenz nicht so hoch vor wenn ich meine Gitarre anschließe... würde sagen es ist so gut wienicht hörbar. Weiß wer woran das liegen könnte? Multicore probleme oder 32 bit trotz 64 bit System etc.?

    Gruß

    FaFlu
     
    Fahnenflucht, 06.09.12
    #1
  2. zehnvorsechs

    zehnvorsechs

    Registriert seit:
    30.01.17
    Punkte:
    10.510
    10510
    na, 56 ms Latenz würde man beim Gitarre spielen schon sehr merken. Aber kann es sein, dass Du die Gitarre über Hardware Monitoring abhörst und nicht über Software ?

    Vielleicht ist´s ja auch nur ein Programmfehler. Was ich aber nicht glaube.

    Mit 32 und 64 Bit und so hat das nichts zu tun. Aber welches Audio Interface ist das und was hast Du in Ableton denn als Quelle ausgewählt ?
     
    zehnvorsechs, 06.09.12
    #2
    Fahnenflucht bedankt sich.
  3. Marcel_H

    Marcel_H

    Registriert seit:
    11.09.05
    Punkte:
    846
    846
    Hi,

    56ms wären definitiv deutlich spürbar - hörst Du möglicherweise doch direkt über Dein Interface ab, während Du spielst?

    Gruss
    Marcel

    Edit: too late... danke an den Reiner :-D
     
    Marcel_H, 06.09.12
    #3
    Fahnenflucht bedankt sich.
  4. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    Hab ich mir gedacht... :D

    Interface: Focusrite Saffire 2i2 über USB. Direct Monitoring ist definitiv aus! Treiber sind aktuell und auf das Saffire angepasst.
    Ich habe mir einen Windows PC zusammengebaut - grob: 8GB Ram, Intel Core i5-3570K - an der Hardware dürfte es doch auch nicht liegen...
     
    Fahnenflucht, 06.09.12
    #4
  5. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    Fahnenflucht, 06.09.12
    #5
  6. zehnvorsechs

    zehnvorsechs

    Registriert seit:
    30.01.17
    Punkte:
    10.510
    10510
    und in Ableton .. wird Dir da zufällig die Latenz von Windows angezeigt und nicht die Messung vom ASIO- Treiber ? Hast Du überhaupt den ASIO Treiber ausgewählt ? Also entweder Du merkst > 50 ms Latenz oder Du bist ein echt zäher Typ (was ich nicht glaube und nicht behaupte ;) )
     
    zehnvorsechs, 06.09.12
    #6
    Fahnenflucht bedankt sich.
  7. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    schau selbst... falls ich was doofes falsch gemacht hab bitte sagen :D
     
    Fahnenflucht, 06.09.12
    #7
  8. zehnvorsechs

    zehnvorsechs

    Registriert seit:
    30.01.17
    Punkte:
    10.510
    10510
    ah da ist ein Screenshot . Gut.

    Also das steht > 400 Samples Latenz. Da ist doch bestimmt das Audiokontrollfeld des 2i2 und da ist bestimmt irgendwo eine extra Latenzeinstellung versteckt. Denn > 400 Samples das ist für ein modernes USB Interface auch zuviel. So was wie 128 Samples sollte es schon packen damit dürftest Du knapp um die 10 ms landen.

    In meinem Saffire Mix Control sieht das z.B. so aus, das das ein kleiner versteckter Button "Settings" ist und darunter kann man die Driver Latency auf "short" stellen. Default war bei mir glaube ich auch "Medium".
     
    zehnvorsechs, 06.09.12
    #8
    Fahnenflucht bedankt sich.
  9. zehnvorsechs

    zehnvorsechs

    Registriert seit:
    30.01.17
    Punkte:
    10.510
    10510
    ah da ist jetzt auch ein 2. Screenshot den hatte ich gar nicht bemerkt nachdem ich den 1. schon nicht bemerkt hatte, und da werden Dir ähnliche Werte angezeigt. Schiebe mal an dem Regler rum.
     
    zehnvorsechs, 06.09.12
    #9
    Fahnenflucht bedankt sich.
  10. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    Hab jetzt mal den Regler auf 1ms gestellt... De unterschiede sind wirklich nur MINIMAL hörbar, jetzt habe ich

    Input 3.3
    Output 4.3
    Global 11

    Bei zu niedriger einstellung gibts ja knacksen... wo würdest du denn den "mittelwert" empfehlen? und in wie fern sollte ich noch mit der latenzkorrektur spielen?
     
    Fahnenflucht, 06.09.12
    #10
  11. zehnvorsechs

    zehnvorsechs

    Registriert seit:
    30.01.17
    Punkte:
    10.510
    10510
    Das ist wohl in der Nähe des Machbaren, schätze ich. Vielleicht zeigt Dir der Ableton Dialog jetzt auch was in der Nähe von 128 Samples an, was für USB kein ganz schlechter Wert wäre. Wenn Du glück hast und das Projekt noch nicht so derbe aufwändig, dann kann es sein, dass Du bei kleineren Projekten auch ein bisschen drunter gehen kannst. Vielleicht 96 oder 64. Aber exakt diesen Einstellungsdialog kenne ich auch nicht.
     
    zehnvorsechs, 06.09.12
    #11
    Fahnenflucht bedankt sich.
  12. Fahnenflucht

    Fahnenflucht Themenersteller

    Registriert seit:
    01.09.11
    Punkte:
    328
    328
    bei 1ms komme ich auf 45 samples... wichtig ist es ja jetzt nur den mittelwert zu finden oder? ich hätte bei 3ms 133 samples. steig einfach durch das ganze thema noch nicht so durch als dass ich jetzt sagen könnte ob das reicht. du orientierst dich ja zb nur an der puffergröße in samples?

    ein weiteres phänomen ist, wenn ich die pufferlänge runtersetze kriegt mein gitarrenton merh höhe. ist das auch normal?
     
    Fahnenflucht, 07.09.12
    #12
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.