Information ausblenden

Bitwig Latency Compensation Recording Audio

Dieses Thema im Forum "Bitwig" wurde erstellt von Schlumpfpeter, 12.08.20.

  1. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Bin ich zu blöd oder ist Bitwig der einzige Sequenzer den ich kenne, der noch keine vernünftige Latenzkompensation für Audioaufnahmen hat!?

    Ich habe einen externen synthie, den ich mit midi befeuer und den ich auf dieser Grundlage aufnehmen möchte. Wenn ich abspiele, läuft alles synchron. Wenn ich aufnehme, ist alles auf einmal verschoben.

    Wo ist der Haken!?

    VG
     
    Schlumpfpeter, 12.08.20
    #1
    synthpark bedankt sich.
  2. petera

    petera

    Registriert seit:
    23.10.09
    Punkte:
    297
    297
    Ich habe keine externe Hardware. Aber so wie es auf der Webseite steht, sollte Bitwig das eigentlich schon können:
    Quelle: https://www.bitwig.com/en/bitwig-studio/devices.html
     
    petera, 13.08.20
    #2
  3. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Genau das habe ich gemacht.... Der Support ist dran, heute Abend wissen wir mehr.
     
    Schlumpfpeter, 13.08.20
    #3
  4. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.918
    22918
    Haste mal überprüft, ob dein Interface wirklich ohne Aufnahmeversatz arbeitet? Klickspur (Audio) ausspielen (ohne jegliche Effekte in einem ansonsten leeren Projekt) und wieder aufnehmen, dann Aufnahme und Original vergleichen.
     
    Sascha Franck, 13.08.20
    #4
  5. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Das werde ich heute Abend tun. Wenn ich abhöre, wird ja Latenz korrekt kompensiert, alles synchron. Nur beim Aufnehmen nicht...
     
    Schlumpfpeter, 13.08.20
    #5
  6. Loop_Breaker

    Loop_Breaker Hippie

    Registriert seit:
    19.11.10
    Punkte:
    5.884
    5884
    Fährst Du NATIV (also ASIO Puffer In + ASIO Puffer Out = Signal mit VSTs bewaffnet) durch die Spur, oder via Direct Monitoring?
     
    Loop_Breaker, 13.08.20
    #6
  7. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Keine vsts, einfach nur Midi raus, Audio rein. Ich hab das Gefühl dass er die Aufnahme der Buffergröße entsprechend versetzt aufnimmt. Beim abspielen kompensiert er für den Puffer und beim Aufnehmen "dekompensiert" er nicht.
     
    Schlumpfpeter, 13.08.20
    #7
  8. Loop_Breaker

    Loop_Breaker Hippie

    Registriert seit:
    19.11.10
    Punkte:
    5.884
    5884
    Oder DirectMonitoring beim MIDI-Bespielen und beim Aufnehmen (b.z.w. Audio-Abspielen) Nativ (ASIO-In + ASIO-Out + DAW-Latenzen)?

    Tu mal ein VST beim abspielen rein zum schauen ob es wirkt. Wenn nicht wahrsch. DirectMonitoring.

    Fahre deshalb gerne gleich durch Cubendo durch, dann wird genau so wiedergeben wie eingespielt wurde, geht aber nicht in jeden Szenario.
     
    Zuletzt bearbeitet: 14.08.20
    Loop_Breaker, 13.08.20
    #8
  9. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Super seltsam, einfach nur Metronom raus und wieder rein ist korrekt bzgl. Timing.
     
    Schlumpfpeter, 13.08.20
    #9
    Loop_Breaker bedankt sich.
  10. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Ich probiere nachher mal, statt vom Ausgang des Hw synthesizer Pluginausgang den sound direkt vom Eingang abzugreifen. Ich habe das Gefühl dass durch das abgreifen vom Plugin doppelt Latenz kompensiert wird.
     
    Schlumpfpeter, 14.08.20
    #10
  11. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.918
    22918
    Du musst das alles erst einmal mit 'nem leeren Projekt probieren. Wobei, wenn das Re-Recording eines Klicks funktioniert, dann sollte es an sich schon mal nicht am Aufnahmeversatz liegen. Als Resultat müsste dann direkt über die Hardware abgespielter MIDI-Kram eigentlich identisch mit einem davon aufgenommenen Signal sein. Aber auch das muss man erstmal mit einem leeren Projekt testen, um sicherzustellen dass an der Audio/MIDI-Interface Front nix komisch läuft.
     
    Sascha Franck, 14.08.20
    #11
  12. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Alles schon längst geschehen, bin ja nicht von vorgestern.

    Völlig egal ob im leeren Projekt, ob oplugins auf der spur oder auf dem master oder nicht, sobald es erst per midi raus und dann als audio wieder rein gehen soll, haut es nicht hin. Der Kick wird sogar tatsächlich vorgezogen, d.h. da wird überkompensiert. Buffergröße spielt dabei keine Rolle.
     
    Schlumpfpeter, 14.08.20
    #12
  13. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Gleiches Ergebnis...
     
    Schlumpfpeter, 14.08.20
    #13
  14. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.918
    22918
    Aber wenn du einen Audiotrack rausschickst und den wieder aufnimmst, ist der synchron mit dem Original?
     
    Sascha Franck, 14.08.20
    #14
  15. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    genau.
     
    Schlumpfpeter, 14.08.20
    #15
  16. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.918
    22918
    Jungejunge, das ist echt schräg und entzieht sich für mich jeglicher Erklärung. Denn ob das, was aufgenommen wird jetzt von einem MIDI-Klangerzeuger kommt oder augespieltes Audio ist, ist an sich scheißegal. Und vor allem schließt es sowohl Aufnahmeversatz wie auch Probleme mit der Latenzkompensation aus. Kann mir da überhaupt keinen Reim drauf machen.
     
    Sascha Franck, 14.08.20
    #16
    Schlumpfpeter bedankt sich.
  17. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Gut, dann bin ich wenigstens nicht der Einzige :D

    Die vom Support haben auch irgendwie nur Fragezeichen in den Augen.... Das ist total bekloppt, ich gehe davon aus das er doppelt latenz kompensiert, obwohl er nur einmal müsste, sieht zumindest danach aus, weil das Audio vorgezogen aufgenommen wird. Geil oder? Siehe Anhang.
     

    Anhänge:

    Schlumpfpeter, 14.08.20
    #17
  18. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.918
    22918
    Aber da gibt es doch gar nix zu kompensieren. Jedenfalls nichts, was nicht auch bei einer ausgespielten Audiospur passieren würde.
     
    Sascha Franck, 14.08.20
    #18
  19. Loop_Breaker

    Loop_Breaker Hippie

    Registriert seit:
    19.11.10
    Punkte:
    5.884
    5884
    Und VSTs im Aufnahmeweg funktionieren?

    (liest sich für mich so, als wenn MIDI Latenz kompensiert wird...)
     
    Loop_Breaker, 14.08.20
    #19
  20. Schlumpfpeter

    Schlumpfpeter Themenersteller Loudness-Opfer

    Registriert seit:
    23.06.10
    Punkte:
    29.065
    29065
    Doch, na klar. Das midi muss ja versetzt ausgegeben werden, da sonst der Sound aus dem volca zu früh kommen würde, da das gesamte Audio aus dem PC ja systembedingt zeitlich nach hinten versetzt ausgegeben wird. Zumindest, wenn man direkt monitoring betreiben würde, was ich aber nicht tue.
     
    Schlumpfpeter, 14.08.20
    #20
    rkdk und Loop_Breaker bedanken sich.