S1 keine Blacklist für kritische Plugins?

Dieses Thema im Forum "Studio One" wurde erstellt von pefra, 17.08.17.

Schlagworte:
  1. pefra

    pefra Themenersteller

    Registriert seit:
    11.08.17
    Punkte:
    474
    474
    Versuche seit einer halben Stunde, die S1-Demo zu starten. Das Programm hängt sich beim Einlesen der Plugins immer an der gleichen Stelle auf. Ich hab aus diversen (u.a. beruflichen) Gründen jede Menge Plugins im Ordner (Mac, Sierra), davon sind einige garantiert abgelaufen, da Demos.

    Kann es sein, dass S1 beim Hochfahren nicht mal die kritischen Plugins in eine Blacklist schreibt, damit die beim nächsten Hochfahren (oder Versuch davon) ignoriert werden?

    screen_of_death.png
     
  2. musicdevil

    musicdevil Gesperrter User

    Registriert seit:
    22.11.09
    Punkte:
    21.362
    21362
    Doch, es gibt ne Blacklist und Plugins die nicht gestartet werden können, schreibt S1 da auch ganz normal rein.
     
  3. andreee

    andreee

    Registriert seit:
    29.01.15
    Punkte:
    1.276
    1276
    Wie musicdevil schreibt gibt es eine Blacklist, wo die Plugins dann reingeschrieben und beim nächsten Start nicht mehr geladen werden. In seltenen Fällen will das aber mal mit dem ein oder anderen Plugin nicht funktionieren. Einfach beim Crash mal den Fehlerbericht anzeigen lassen und schauen, welches Plugin da nicht so mitspielen will.
     
    Zuletzt bearbeitet: 17.08.17
  4. rz70

    rz70

    Registriert seit:
    18.11.11
    Punkte:
    448
    448
    Das funktioniert leider bei S1 nie richtig. Da ich S1 selten verwende, ist das immer eine Lotterie wann und wie oft ich S1 starten muss. Habs auch schon mehrmals mit Berichten, etc. bei Presonus gemeldet. Hat dort aber fast nie jemanden interessiert. Übrigens auch auf dem Mac mit 10.11 und 10.12.
     
  5. pefra

    pefra Themenersteller

    Registriert seit:
    11.08.17
    Punkte:
    474
    474
    Danke für die Hilfestellung. Wie kann ich mir die Liste ansehen? Und wieso komme ich nie weiter, irgendwann dürften ja mal alle Plugins durch sein (sind auch nicht so viele, die abgelaufen sind), und dann sollte das Programm normal an den Start gehen. Es gibt auch keine Meldung, was S1 da macht. Sagen wir sowas wie: "Das Plugin XYZ verursachte beim Hochfahren einen Fehler und wird geblockt."

    Kein Problem in allen (!) anderen DAWs, es gibt eine Meldung, dann geht es weiter, sagen wir mal in Cubase, Logic, DP9, Renoise, Waveform, Reaper, um nur mal die wichtigsten zu nennen. Auch Ardour macht keinen Stress...
     
    Zuletzt bearbeitet: 17.08.17
  6. NorthernDecay

    NorthernDecay

    Registriert seit:
    02.12.14
    Punkte:
    2.879
    2879
    Mahlzeit!
    C:/User/xxx/AppData/Roaming/Presonus/Studio One/x64 dort Blacklist... und VSTPlugins... löschen, und nochmal probieren.
     
  7. Can

    Can Administrator Mitarbeiter

    Registriert seit:
    05.04.04
    Artikel:
    33
    Punkte:
    84.278
    84278
    Das bringt nichts, du musst die Plugin-Hersteller anschreiben und meckern. Oder die fehlerhaften Plugins löschen. Bei mir trat das in S1 immee nur mit Freeware-Bastel-VSTis auf, nie mit ordentlicher Software. PreSonus hat keine Lust, die Fehler und Nachlässigkeit von Plugin-Herstellern auszubügeln.
     
  8. Can

    Can Administrator Mitarbeiter

    Registriert seit:
    05.04.04
    Artikel:
    33
    Punkte:
    84.278
    84278
    Genauso ist es bei mir in Studio One... in fast genau dem Wortlaut :)
     
  9. rz70

    rz70

    Registriert seit:
    18.11.11
    Punkte:
    448
    448
    Das kann man so oder so sehen. In Logic, Ableton, Maschine und Cubase läuft das alles einwandfrei. Ich bin S1 Nutzer seit der 1.6 Version und kenne seitdem die Probleme. Und es sind ja immer andere VSTs die S1 mal mag und mal nicht. Und Roland oder Korg anzuschreiben - nee da hab ich besseres zu tun. Die ändern Ihre Plugs nie und schon gar nicht wegen S1.

    Für mich übrigens immer noch der Hauptgrund, warum ich S1 nur für Audiomischungen nutze.
     
  10. andreee

    andreee

    Registriert seit:
    29.01.15
    Punkte:
    1.276
    1276
    Du kommst wahrscheinlich nicht weiter, weil S1 das Plugin nicht auf die Blacklist setzen kann und dieses immer wieder versucht zu laden. Du bekommst von OS doch ein Fenster geöffnet nachdem S1 abstürzt. Dort den Bericht öffnen und das letzte Plugin raussuchen, welches von S1 geladen wurde. Dieses Plugin dann aus dem Ordner entfernen.

    Edit: Wenn alles korrekt laufen würde, würdest du von S1 auch eine Meldung bekommen: "Plugin XY wird nicht verwendet, da es zuvor zum Absturz führte."
     
    Zuletzt bearbeitet: 17.08.17
  11. pefra

    pefra Themenersteller

    Registriert seit:
    11.08.17
    Punkte:
    474
    474
    Okay, danke für den Tipp mit der Blacklist. Mac-User suchen hier:

    Home/Library/Application Support/PreSonus Software/Studio One 3/x64/VstBlacklist.settings

    Dort war als Störer eingetragen der Linear L-Phase Equalizer von Cakewalk, sicher kein Bastel-Plugin von einem Hersteller, der für nachlässige Programmierarbeit bekannt ist. Zu diesem Plugin wurde durch S1 keine Block-Meldung ausgegeben. Gelöscht und neu.

    Alles auf Anfang, aber: Gleiches Spiel, diesmal eingetragen vinyl.vst von Izotope, ein Klassiker, 64-Bit und up-to-date. Läuft in allen meinen anderen DAWs. Nicht in S1, und diesmal kam die Blockmeldung in Rot dazu. Naja gut, umbenannt und damit quasi gelöscht. Mach ich jetzt jedes Mal, wenn ich das Plugin in Cubase benutzen will, oder wie?

    Dann fährt S1 hoch. Hat nur 2 Stunden gedauert, in der Zeit hätte ich in Reaper einen kompletten Mix abgefeiert.

    S1 läuft an, aber man muss anscheinend erst mal zwingend zumindest die minimale Basis-Library laden, sonst geht's nicht weiter. Na gut. Dann will ich beenden, kriege aber die Meldung, dass S1 nicht beendet werden kann, weil im Hintergrund noch Daten übertragen werden. Lieber Gott, es ist 2017, und ich entscheide selbst, wann ich ein Programm schließe. Nicht Presonus, und auch nicht Äppel. Also Programm zwangsweise beendet.

    Also, ich teste S1 mal weiter, aber der Einstieg war schon mal zäh. Und ich weiß wieder, warum ich Reaper unter Linux schon jetzt so liebe.

    Danke für die Hilfe an die Gruppe, läuft gut bei Euch!
     
  12. pefra

    pefra Themenersteller

    Registriert seit:
    11.08.17
    Punkte:
    474
    474
    Nur mal am Rande. Apple benennt Ordner so: Application Support. Oder MIDI Configurations. Also mit mehreren Bezeichnern OHNE Unterstrich. Nun gibt es User, die UNIX kennen (meiner einer, z.B.) und auch im Terminal arbeiten. Schon ist erst mal wieder nachdenken, weil du einen Ordner "cd /application support" nicht so ohne weiteres ansteuern kannst, weil er aus zwei Bezeichnern besteht. Apple hat stark bei BSD-Unix eingekauft, aber irgendwo unterwegs haben sie erst mal angehalten und kräftig einen durchgezogen.
     
  13. pefra

    pefra Themenersteller

    Registriert seit:
    11.08.17
    Punkte:
    474
    474
    Ich zitier mich mal selbst:

    snip/// ...diesmal kam die Blockmeldung in Rot dazu. Naja gut, umbenannt und damit quasi gelöscht. Mach ich jetzt jedes Mal, wenn ich das Plugin in Cubase benutzen will, oder wie?

    Blöd nachgedacht von mir. Ist ja jetzt offiziell geblockt - muss ich ja gar nicht löschen. Eigentor, klassisches. Okay, S1, du hast einen (nur einen!) gut bei mir.
     
  14. bafc24

    bafc24

    Registriert seit:
    30.08.12
    Punkte:
    2.767
    2767
    Schade dass durch Dich so Grabenkämpfe entstehen. Du bist doch auf Linux und Reaper und alles scheint da absolut perfekt zu laufen. Warum willst Du jetzt noch S1 auf einem Mac testen? Doch nicht so zufrieden? Oder geht es Dir nur darum allen zu beweisen (Grabenkampf), wie unglaublich kompliziert OSX mit S1 zum laufen zu bringen ist..... im Gegensatz zu Linux und Reaper?

    Wenn Du Dich schon mit der Installation schwer tust und schimpfst wie ein Rohrspatz (empfinde ich jetzt als provokative Grabenkampfansage?), dann würde ich persönlich die Aktion ziemlich schnell abrechen und mit Linux und Reaper genüsslich meine Tracks produzieren;) Zwingt Dich doch keiner, Dich mit dem komplizierten OSX und S1 rumzuschlagen. Versteh das ehrlich nicht, zzzzzzzzzzz

    Im Gegensatz zu Dir - scheinen ja zu abertausende ihr S1 auf OSX und/oder Win ohne Probleme zum laufen zu bringen:) Also immer schön den Ball flach halten.

    Ich z.B. bin seit über zehn Jahren begeisterter Mac und ProTools User. Mochte früher nichts anderes und möchte auch heute nichts anderes:headbang:
     

    Anhänge:

  15. Can

    Can Administrator Mitarbeiter

    Registriert seit:
    05.04.04
    Artikel:
    33
    Punkte:
    84.278
    84278
    Das ist natürlich wirklich ärgerlich... ich hab solche VST-Erkennungs-Probleme in S1 wirklich nie gehabt... allerdings muss ich auch sagen, dass ich hauptsächlich auf Win unterwegs bin und auf meinem MacBook mit S1 nur 4-5 VST-Plugins benutze und nicht 30 wie unter Windows. Unter den 4-5 ist aber auch Ozone und noch Iris von Izotope... hat alles direkt geklappt.

    Aber bleib mal dran, wenn die Plugins laufen, wirst du mit Studio One bestimmt erstmal bisschen Spaß haben. Also ich gehe mal davon aus, dass du dich informiert hast und S1 nicht ohne Grund ausprobieren willst. Anders als REAPER ist es ja keine Feature- und Options-Schleuder, aber dafür geht so manches m.E. deutlich einfacher und schneller als in REAPER (wobei eingefleischte REAPER-Pros hier sicher auch widersprechen, weil sie z.B. 2000 selbstdefinierte Shortcuts auswendig gelernt haben o.ä. :D).

    Dass es in Logic, Cubase etc. läuft, heißt nicht, dass der Fehler bei PreSonus liegt. Tut er nämlich auch nicht, denn es gibt keine VST-komformere DAW als S1... nein, auch nicht Cubase :)
    Aber du hast natürlich völlig Recht, Korg und Roland wird das alles nicht interessieren und sie werden ihre Plugins deshalb nicht ändern. Aber dann nur aus Arroganz und weil sie sich's leisten können.... zumindest einige Korg-Plugins (z.B. Wavestation, M1) sind nämlich ziemlich buggy und hätten es dringend nötig. Wobei ein paar Dinge in der WS schon gefixt wurden und gefühlt ist die 64bit-Version auch schon deutlich stabiler als vor 2 Jahren.
     
  16. musicdevil

    musicdevil Gesperrter User

    Registriert seit:
    22.11.09
    Punkte:
    21.362
    21362
    bafc24 und dann kommt ja auch noch das dazu:
    Da läuft also schon Cubase, Logic, DP9, Renoise, Waveform, Reaper und Ardour auf seinem Mac und nun soll noch S1 zukommen.
    Und selbst das sind nur seine "wichtigsten" DAWs, wer weiß was da noch alles installiert ist.
    Ich würde vorschlagen mal ein sauberes OS X aufzusetzen.
     
  17. Can

    Can Administrator Mitarbeiter

    Registriert seit:
    05.04.04
    Artikel:
    33
    Punkte:
    84.278
    84278
    Muss ja trotzdem funktionieren :)
     
  18. musicdevil

    musicdevil Gesperrter User

    Registriert seit:
    22.11.09
    Punkte:
    21.362
    21362
    Eigentlich schon, aber zumindest von Windows her kennt man es ja so, dass wenn der Rechner regelrecht zugemüllt ist, kann es dadurch auch Probleme geben. Gerade die vielen DAWs und Demo-Plugins lassen die Vermutung zu, dass da nen ziemliches Chaos auf dem Mac herrschen könnte.
     
  19. bafc24

    bafc24

    Registriert seit:
    30.08.12
    Punkte:
    2.767
    2767
    Da ist natürlich Linux im Vorteil. Da kann man - zur Zeit - noch nichts zumüllen, Reaper und Ardour kommen sich da wohl noch nicht so in die Quere.
    Aber nochmal, warum ziehst Du Dir S1 auf OSX, wenn Du mit Linux und Reaper den heiligen Gral entdeckt hast?
     
  20. andreee

    andreee

    Registriert seit:
    29.01.15
    Punkte:
    1.276
    1276
    @pefra

    Den Content beim ersten Start musst du nicht laden. Die selektieren Felder kannst du deselektieren und dir aussuchen was du brauchst. Falls du nichts davon haben möchtest gibt es das Feld abbrechen oder man schliesst das Fenster einfach auf dem roten x symbol.

    Das izotope vinyl plugin läuft bei mir leider auch nicht. Hab auch gehört, dass es mit Roland und einigen Arturia Probleme gibt (nicht nur bei S1). Also wenn nochmal sowas vorkommt das S1 abstürzt ohne etwas auf die Blacklist setzen zu können öffne den Fehlerbericht der nach dem Abstürz erscheint. Da steht dann drinne welches Plugin den Fehler verursacht hat.
    Du kannst wenn S1 dann das erste mal richtig gestartet ist die Plugins nach und nach wieder in den Ordner ziehen und S1 neu starten. Oft nimmt er dann Plugins die es beim ersten Start nicht wollte. Ich kenne das Problem was du hattest wenn S1 beim ersten Start mehrere hundert Plugins laden muss, es sich um sehr alte Plugins handelt oder auch mal bei gecrackten Plugins.

    Schade, dass du so einen schwierigen Start hattest. Ich wünsche dir das es jetzt besser läuft.

    Kleine Anmerkung. Ich habe gesehen, dass du 3.5.1 auf OSX am laufen hast. Die Version ist für OSX ziemlich buggy. Zum Beispiel kannst du mit der Tab Taste nicht ins nächste Feld springen ohne das die Tastatureingane im Feld davor gelöscht wird. Ich empfehle dir auf OSX mit 3.5 zu arbeiten.