Information ausblenden

Logic Pro sehr langsam bei Multitrack Aufnahmen

Dieses Thema im Forum "Logic" wurde erstellt von raketenmann, 01.10.20.

  1. raketenmann

    raketenmann Themenersteller

    Registriert seit:
    25.10.12
    Punkte:
    965
    965
    Hey Logic-Cracks

    ich komme hier mal mit einer Frage auf euch zu - vielleicht habt ihr eine passende Idee dazu:

    Ich hatte die letzten Tage eine Aufnahmesession, in der Logic irgendwie ein etwas sonderbares Verhalten zeigte. Ich habe gleichzeitig ca. 12 Spuren aufgenommen. Auf keiner der Spuren lag ein Plugin - alle Plugins, die für das Recording verwendet wurden liefen auf der DSP eines Apollo Interfaces. Nur 2 oder 3 einfache Plugins lagen auf dem Stereo Out.

    Logic hatte echt mühe, diese Aufnahmen zu handeln. Nach dem drücken des rec-Buttons dauerte es rund 2 sek. bis die Aufnahme startete, auch nach dem Drücken der Stopp-Taste dauerte es wieder eine weile, bis Logic stoppte.

    Ich habe durchaus schon mehrere Aufnahmen gemacht, dieses Verhalten ist mir noch nie aufgefallen. Ich habe einen iMac 3,1 GHz i7 mit 32GB RAM und einer SSD - das funktionierte bisher immer super schnell und ich kam nur bei Mixsessions mit vielen Spuren, Aux Sends und gaaanz vielen Plugins an den Anschlag.

    Logic zeigte ebenso ein paar seh sonderbare andere Dinge, die ich so von Logic nicht kannte. Hier drei Beispiele:

    1) Wenn ich bspw. auf einer Spur noch den Rec-Button aktiviert hatte und die gerade aufgenommene Region anhören wollte, so war es mir nicht möglich während dem Playback die Volume dieser Spur zu verändern. Den Regler konnte ich natürlich bewegen, aber die Region spielte in einer fixen Lautstärke ab.

    2) Wenn ich 2 Spuren gleichzeitig aufgenommen habe (2 Gitarrenmikros), aber eine Spur stumm geschaltet habe, wurde diese beim Anhören der gerade aufgenommenen Region trotzdem abgespielt, solange der Rec-Button aktiviert war (obwohl stumm geschalten).

    3) Es war mir nicht möglich, die Drumtakes (8 Spuren) direkt nach der Aufnahme nochmals anzuhören, ohne die Rec-Buttons zu deaktivieren. Es kam eine Fehlermeldung im Stil, dass nicht genügend Mono-Spuren zur Verfügung stehen würden, um Auto Punch zu aktivieren. Ich habe dann Auto Punch ausgeschaltet, dann hat das funktioniert.

    Alle diese Bugs sind mir zum ersten Mal aufgefallen und ich habe weder Logic aktualisiert noch irgendwie meinen Workflow geändert. Ich habe einfach mit einem neuen Projekt begonnen, wo ich vorher ev. vielleicht manchmal mit einer Vorlage gestartet habe.


    Ich vermute, da muss irgendwie was mit dem Input-Monitoring, Software Monitoring oder so irgendwas nicht stimmen. Aber ich habe auf keiner Spur das Input Monitoring aktiviert, all mein Monitoring wird direkt über das Interface geregelt.

    Hat da wer Ideen, was da los sein könnte?

    Vielen Dank für eure Hilfe!
     
    raketenmann, 01.10.20
    #1
  2. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Wie ist es denn, wenn du testweise ein altes Projekt nimmst, bei dem es reibungslos geklappt hat, da alles rauswirfst (nach "save as" natürlich) und dann da aufnimmst? Wenn es da besser läuft, ließe das vielleicht Rückschlüsse auf irgendwelche versehentlich verstellten Projekteinstellungen zu.
     
    Sascha Franck, 01.10.20
    #2
    raketenmann bedankt sich.
  3. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    36.080
    36080
    Das Problem könnte auch von den Audioeinstellungen kommen. Seit einiger Zeit bestehen Probleme, wenn Logic mehrmals automatisch das Interface gewechselt hat.
    Schau mal in den Audioeinstellungen, ob Dein Audiogerät in Klammern steht oder so was wie "verwendet ..." dabei steht.
    Wähle explizit das gerade aktive Interface aus - evtl. auch mal hin und her - ggf. mit Neustart.
    Vielleicht hilft das?

    Und natürlich der Standard-Tip für Aufnahmen:
    - genug Platz auf der SSD
    - noch besser externe Festplatte/SSD für Aufnahmen/Logic-Projekt
     
    clemenserwe, 01.10.20
    #3
    raketenmann bedankt sich.
  4. raketenmann

    raketenmann Themenersteller

    Registriert seit:
    25.10.12
    Punkte:
    965
    965
    Das könnte ich natürlich mal probieren, aber ev. etwas umständlich... Check ich dann mal im Studio!


    Ich habe tatsächlich irgendwie mal kürzlich so ein Problem auch gehabt. Da ich teilweise Sonwarworks Systemwide verwende (ein Programm, welches einen eigenen Audiotreiber hat und sozusagen als Interface fungiert), fällt dann manchmal das Apollo da raus...

    Wegen Festplatte: meine 500GB SSD ist tatsächlich schon etwas über die Hälfte voll. Könnte dies ein Problem sein?

    wegen externer Festplatte: Ich habe immer gedacht, das sei Kontraproduktiv. Bzw. ich habe halt nur eine 800FiWi Festplatte. Wenn extern, dann müsste es vermutlich schon eine SSD über Thunderbolt oder so sein, oder? Gibt es da Empfehlungen?
     
    raketenmann, 01.10.20
    #4
  5. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Naja, speichern unter, alles nicht benötigte rauswerfen, 1 Minute.

    Nein, es sei denn, die ist defekt. Und das würde ja der oben angedachte Test ebenfalls zeigen.

    Ich konnte schon 2008 auf einer bus-gepowerten 5400RPM USB 2 Festplatte elend viele Tracks gleichzeitig aufnehmen, USB 3 ist für Audiotracks mehr als vollkommen ausreichend und die externen Gehäuse sind deutlich günstiger als welche mit TB Anschluss (und kompatibler ist man auch). Aber das wird hier mMn ohnehin nicht das Problem sein.
     
    Sascha Franck, 01.10.20
    #5
    raketenmann bedankt sich.
  6. raketenmann

    raketenmann Themenersteller

    Registriert seit:
    25.10.12
    Punkte:
    965
    965
    Naja, die tracks müssten ja auch noch erstellt werden usw. Ich weiss ja auch nicht, ob sich das Projekt gleich verhält, wenn keine Mikros dran hängen - wobei das wohl keine Rolle spielt.

    Wie ist denn das eigentlich: ich besitze einen alten Mac von 2011, der hat Thunderbolt 1 oder 2 (?) - kein USB 3 und auch kein USB C. Kann ich da auch irgendwie was anderes dran hängen als eine Thunderbolt Platte? Also kann eine USB3 oder USB C (ist das gleiche, oder?) an einen USB-C - to - Thunderbolt Adapter hängen? Oder gab / gibt es SSD's für FireWire 800 - das hätte ich auch...

    Die THunderbolt Platten sind einfach viel zu teuer!
    Danke für die Hilfe!
     
    raketenmann, 01.10.20
    #6
  7. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Nee, das spielt wirklich keine Rolle, da kannste auch leerlaufende Inputs benutzen.

    Was die TB Anschlüsse angeht, kann ich dir nix sagen, müssteste selber gucken, aber da gibt es USB Adapter - ob jetzt direkt auf USB 3, wie gesagt, weiß ich nicht.
     
    Sascha Franck, 01.10.20
    #7
    raketenmann bedankt sich.
  8. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Und natürlich kannste 'ne SSD auch in ein FW Gehäuse reinbauen, ich würde da aber auf gar keinen Fall was fertig konfiguriertes kaufen, denn beim nächsten Rechner gibt's FW nicht mehr.
     
    Sascha Franck, 01.10.20
    #8
  9. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Und nochwas: USB 3 und USB C sind nicht das Gleiche, USB 3 (bzw. 3,1) beschreibt das Datenformat, USB C eigentlich nur den Verbindungsstecker. Es gibt auch USB 3 mit klassischen USB A Steckern, mittlerweile sind aber viele Hersteller auf USB C umgeschwenkt.
     
    Sascha Franck, 01.10.20
    #9
  10. raketenmann

    raketenmann Themenersteller

    Registriert seit:
    25.10.12
    Punkte:
    965
    965
    Ich habe mir die verschiedenen Optionen mal angesehen... es ist einfach ein wenig kompliziert...

    - USB 3 auf Thunderbolt 1/2 ist nicht möglich
    - externe Gehäuse mit Thunderbolt 1/2 sind nicht erhältlich
    - gebrauchte SSD's mit Thunderbolt in der Bucht sind echte Mangelware
    - kaufe ich eine neue SSD mit Thunderbolt 3, benötige ich einen Adpapter von TB3 (USB-C) auf TB2. Kostet nochmals 50 Euronen.

    Die günstigste Option ist wohl einfach eine Transcend JetDrive für ca. 200 Euro

    andere Frage: mein iMac hat einen SDXC-Slot. Mit einer sehr schnellen Karte könnte das auch eine Option sein für Multitrackrecordings, oder nicht?
     
    raketenmann, 01.10.20
    #10
  11. Wird schon

    Wird schon Faderhalter

    Registriert seit:
    09.01.20
    Punkte:
    1.789
    1789
    Korrekt. Und während usb3.1 auf tb3 adaptiert werden kann, geht es nicht in die entgegengesetzte Richtung. Auch wenn der Stecker es suggeriert kann man kein tb-Gerät an einem usb3.1 Slot betreiben.
     
    Wird schon, 01.10.20
    #11
  12. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    USB 2 ist für reine Aufnahmezwecke locker schnell genug. Ansonsten hol dir ein günstiges FW800 Gehäuse und schraub 'ne SSD deiner Wahl rein. Da hast du dann noch mal extra Luft im Vergleich mit USB 2.
    Solche Gehäuse sollte es mittlerweile auch gut gebraucht geben, da FW ein Auslaufprotokoll ist.

    Aber wie gesagt, das wird eh nicht dein Problem sein, von daher gilt es erst einmal, dem auf den Grund zu gehen.
     
    Zuletzt bearbeitet: 01.10.20
    Sascha Franck, 01.10.20
    #12
  13. Paxi

    Paxi Newcomer

    Registriert seit:
    30.11.18
    Punkte:
    906
    906
    Was ja logisch ist, wenn man weiß, dass Intel und Apple TB3 mit 40 Gigabit pro Sekunde, also der vierfachen Geschwindigkeit von USB 3.1. spezifiziert haben. Dazu sollte man auch beachten, dass das nur mit den teuren aktiven Kabeln funktioniert. Und wenn man die volle TB Leistung in Geschwindigkeit und Ladestrom benötigt, muss der Stecker mit einem Blitz gelabelt sein.
     
    Paxi, 01.10.20
    #13
    Wird schon bedankt sich.
  14. raketenmann

    raketenmann Themenersteller

    Registriert seit:
    25.10.12
    Punkte:
    965
    965
    OK - nein, ich denke, das Problem wird wo anders gelegen sein. Aber trotzdem möchte ich - wenn das möglich ist - auch nocht optimieren. Beim mischen komme ich manchmal an meine Grenzen, das meldet Logic dann auch.

    Verstehe ich das also richtig: Ich werde eine bessere Performance haben, wenn ich auf eine externe USB 2 Festplatte recorde und von da auch mische, als wenn das Projekt auf meiner internen SSD vorliegt - nur aus dem Grund, weil Logic schon auf der internen SSD installiert ist und läuft? Es soll dabei keine Rolle spielen, dass die interne SSD um ein Vielfaches schneller ist?

    Ein günstiges FiWi 800 Gehäuse finde ich auch nicht gerade... Die doofen Apple Schnittstellen sind einfach echt Mangelware...
     
    raketenmann, 01.10.20
    #14
  15. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    36.080
    36080
    Es ist jedenfalls einen Versuch wert.
    Ich habe auch schon 16 Spuren auf die (drehende) Systemplatte aufgenommen. Aber den Festplatten-Traffic macht ja nicht nur Logic. Und die SSD ist vermutlich nicht der Flaschenhals, sondern der Sata-Bus - soweit ich weiss, war das beim 2011er ein Sata mit 3 Gigabit.

    Eine externe USB(2)-Platte wirst Du doch irgendwo rumliegen haben. Probier's einfach aus :)
     
    clemenserwe, 01.10.20
    #15
    raketenmann bedankt sich.
  16. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Ich weiß nicht, an sich sollte das auf der internen SSD bei deinem recht moderaten Bedarf einfach vollkommen unproblematisch laufen. Wenn du nicht noch brutal viele streamende Samplerpatches zeitgleich laufen hast, dann geht das mit den 12 Spuren ja wirklich auf uralten Rechnern. Ich musste mal für ein paar Tage mein altes 2008er Macbook von einer externen USB 2 Platte booten und auch auf der Platte arbeiten. Das Booten dauerte zwar so lange, dass ich dachte, das würde ein absoluter Reinfall werden, aber wenn das System erstmal da war, ging alles fast wie normal (allerdings war das auch vor SSD Zeiten, übrigens der Grund, weshalb ich die interne Platte nicht nutzen konnte, die wurde da gerade getauscht).

    Ich würde, bevor du dich um mögliche externe Plattenanbindungen kümmerst (da gibt's sicherlich irgendne gute Lösung), erstmal das aktuelle Problem beheben (für das es hoffentlich auch eine Lösung gibt.
     
    Sascha Franck, 01.10.20
    #16
  17. Wird schon

    Wird schon Faderhalter

    Registriert seit:
    09.01.20
    Punkte:
    1.789
    1789
    Also ich mach auf meinem MacBook Late 2013 völlig problemlos 32-Spur Aufnahmen. Ich vermute mal, dass eine externe Festplatte dein Problem nicht löst. Falls doch, denke ich, dass deine interne Platte einen Weg hat (in deinem Mac. Nicht die persönliche). Vielleicht kannst du die mal im festplattendientprogramm checken lassen...
     
    Wird schon, 01.10.20
    #17
  18. Paxi

    Paxi Newcomer

    Registriert seit:
    30.11.18
    Punkte:
    906
    906
    Zuletzt bearbeitet: 02.10.20
    Paxi, 02.10.20
    #18
  19. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Sascha Franck, 02.10.20
    #19
  20. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    22.988
    22988
    Zuletzt bearbeitet: 02.10.20
    Sascha Franck, 02.10.20
    #20