Latenzprobleme mit ESI Juli@

  • Ersteller der_skeptiker
  • Erstellt am

D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
Hi,
als Neueinsteiger für's digitale Homerecording hab ich mir letzten Herbst eine ESI Juli@ als Audiointerface bei Thomann gekauft. Ich will derzeit ausschließlich im Sequenzer [g=77]VST[/g]-Instrumente per [g=32]Midi[/g] steuern und aufnehmen. Also jedes Instrument einzeln nacheinander, wobei natürlich die zuvor aufgenommenen incl. ihren Effekten mitlaufen sollen.

Am Anfang hab ich die Juli@ noch mit 1GB Speicher und 'nem Athlon XP 2400 unter WinXP Professional SP3 betrieben. Als Sequenzer nutze ich Ableton Live 7. Midicontroller ist der Novation Remote SL25 Compact.
Bei dem System gab's unterhalb von 256 Samples [g=5]Latenz[/g] heftige Kanckser, wenn mehr als 2 VTS-Instrumente incl. Effekten gleichzeitig liefen. War klar - der Rechner gab nicht mehr her.

Also läuft die Juli@ jetzt unter einem Phenom X4 (also 4 Prozessorkerne) mit je 2,2GHz und 2 GB DDR800-Speicher (vom Boardhersteller ausdrücklich empfohlener Speicher von Kingston) und ner schnellen 750GB-Festplatte auf einem ASUS-Mittelklasse-Mainboard unter WinXP Prof. SP3. Das Netzteil ist von BeQuiet, hat zwar nur 350 Watt, aber selbst bei Systemvolllast läuft der Rechner stabil. Der Juli@-Treiber hat die Versionsnr. 1.23, ist der Neueste für Win 32Bit. Der Rechner hängt noch per WLAN-Stick an einem DSL-Router, ein einfaches Heimnetzwerk mit dem Laptop meiner Freundin habe ich eingerichtet.
Der Support von Ableton hat mir auch explizit zu einem Mehrkernrechner geraten, weil Live auch darauf ausgelegt ist, seine Last schön zu skalieren. Funktioniert ja auch gut, wenn der Schalter in den Programmoptionen dafür eingeschaltet ist.

Jetzt kommt's: Wenn ich nun unter Live sagen wir z.B. 4 VSTs (Arturia Analog Factory ohne Effekte, 2 Live-Impulse-Instrumente davon 1 mit [g=322]Compressor[/g] und Reverb, und 1 Operator ohne Effekte) spiele, habe ich unterhalb von _2048_ Samples Knackser! Spätestens ab 1024 Samples [g=5]Latenz[/g] macht das Spielen für mich aber schon keinen Spaß mehr, das brauch ich aber nicht einstellen, da hab ich heftige Knackser.
Dabei ist der Speicher nur zu ca. 40% genutzt, der Prozessor in der Summe zu max. 40% (auf jeden Kern wird hübsch von Live und Windows fließend skaliert).

Virenscanner und Personal Firewall habe ich schon deaktiviert, das bringt nix. Wenn Live steht, ist der Rechner schwankend bei max. 2% Prozessorlast.

Hab auch schon bei ESI angerufen. Die haben nur geraten, den neuesten Treiber zu installieren. Sonst wussten die auch nix.

Nun bin ich leider ratlos, warum auf erheblich "langsameren" Rechnern in diversen Foren (auch hier) von teils 1-Stelligen Latenzzeiten mit der Juli@ berichtet wird. Leider wird oft nicht gesagt, was genau die Leute damit machen: Live-Instrumente wie [g=422]Gitarre[/g] einspielen oder Softwaresynths nutzen oder oder...
Verlange ich mit 4 VSTs schon so viel von der Karte, dass sie nicht mehr nachkommt und die Pufferung ins Unermessliche steigen müsste? Mach ich was falsch, habe ich was bei der Konfiguration übersehen? Ist der Rechner immer noch zu knapp dimensioniert?

Für Hilfe wäre ich sehr dankbar. Ich weiß nicht mehr weiter und will schon zu einem anderen Interface greifen. Nur, zu welchem?

Viele Grüße
Jens
 
H
HipHopMacher
Gesperrter User
Registriert
30.09.08
Beiträge
3.158
Reaktionen
2
Punkte
3.206
Ich würde mal sagen, Dein Computer ist zu schwach.
Du kannst nicht beliebig viele Instanzen von Arturia
aufrufen. Diese Plugins ziehen extrem viel CPU-Leistung.

Gewöhne Dir eine sparsamere Arbeitsweise an.
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
Danke für die schnelle Antwort :)

Dein Computer ist zu schwach.
Hm, die Systemressourcen sind aber offensichtlich zumindest bei Prozessor und Speicher bei Weitem nicht erschöpft. Ist dann das PCI-Interface am Ende?

Du kannst nicht beliebig viele Instanzen von Arturia
aufrufen.

Es war nur eine, sonst nur Live-interne Instrumente. Arturia schreibt zu den _empfohlenen_ Anforderungen:
PC/Windows: 512 MB RAM; 1,5 GHz CPU

Nun ich nutze 4x2.2GHz und 4 Mal so viel Speicher. Also zum Arturia noch die Anderen Synths, Live selbst und das Betriebssystem und der _Rechner_ sollte am Ende sein. Ist er aber nicht, wie die Systemparameter verraten.

Gewöhne Dir eine sparsamere Arbeitsweise an.

Hm, ok, auf WLAN kann ich verzichten, das hab ich ausprobiert, bringt nicht wirklich was. Auch wenn im Background nix Auffälliges an Software läuft, gibt's die Knackser. Wenn ich denn nun sparsamer sein soll, kann ich nur die [g=77]VST[/g]-Anzahl begrenzen. Das würde bedeuten, aufgenommene Midis zunächst fix als Audio zu rendern, zu importieren und bei der Aufnahme weiterer VSTs im Background laufen zu lassen. Das kann es doch nicht sein, oder? Die Juli@ und Live 7 sowie der Arturia wurden entwickelt, als 4-Kerner noch unbezahlbar oder garnicht verfügbar waren.
Nun, wo könnte ich effektiv "Leistung" sparen, ohne meinen Workflow empfindlich zu stören?
 
Lacunaflow
Lacunaflow
Influencer
Teammitglied
Registriert
25.12.06
Beiträge
23.300
Reaktionen
4.866
Ort
Ostfriesland
Punkte
88.803
der_skeptiker schrieb:
...die Systemressourcen sind aber offensichtlich zumindest bei Prozessor und Speicher bei Weitem nicht erschöpft. Ist dann das PCI-Interface am Ende?
Was sagt denn die [g=77]VST[/g] auslastung?

Auch wenn im Background nix Auffälliges an Software läuft, gibt's die Knackser.

Drück mal Strg + Alt + Entf und sag mir wieviele prozesse laufen wenn NIX an ist (unten links!)



Gruss...
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
Lacunaflow schrieb:
der_skeptiker schrieb:
...die Systemressourcen sind aber offensichtlich zumindest bei Prozessor und Speicher bei Weitem nicht erschöpft. Ist dann das PCI-Interface am Ende?
Was sagt denn die [g=77]VST[/g] auslastung?

Auch wenn im Background nix Auffälliges an Software läuft, gibt's die Knackser.

Drück mal Strg + Alt + Entf und sag mir wieviele prozesse laufen wenn NIX an ist (unten links!)



Gruss...

Das hört sich interesant an: Wo kann ich die [g=77]VST[/g]-Auslastung einsehen?

Hab einen Screenshot des Taskmanagers angehangen. Der ist incl. WLAN, nur Opera-Browser, TotalCommander, aber ohne Virenscanner und ohne Firewall.
Ohne alles sind's 44 Prozesse und 390MB zugesicherter Speicher.

Gruß
Jens
 

Anhänge

  • VST-Probs.gif
    VST-Probs.gif
    58,5 KB · Aufrufe: 74
Lacunaflow
Lacunaflow
Influencer
Teammitglied
Registriert
25.12.06
Beiträge
23.300
Reaktionen
4.866
Ort
Ostfriesland
Punkte
88.803
der_skeptiker schrieb:
Das hört sich interesant an: Wo kann ich die [g=77]VST[/g]-Auslastung einsehen?

Bei Live? Kein plan, mal das Manual befragen!

Hab einen Screenshot des Taskmanagers angehangen. Der ist incl. WLAN, nur Opera-Browser, TotalCommander, aber ohne Virenscanner und ohne Firewall.
Ohne alles sind's 44 Prozesse und 390MB zugesicherter Speicher.

Zuviel, und zum Thema Optimierung auf Music:

http://www.musicxp.net/dnn/

http://forum.electronicattack.de/showthread.php?t=3724&highlight=optimieren

http://www.audioforums.com/resources/windows-xp-optimization.html

http://www.soundonsound.com/sos/sep06/articles/pcmusician_0906.htm


Gruss...
 
H
HipHopMacher
Gesperrter User
Registriert
30.09.08
Beiträge
3.158
Reaktionen
2
Punkte
3.206
Falschen Audiotreiber ausgewählt?
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
Ok, danke Lacunaflow. Also doch der Rechner. Deine Links schau ich mir alle an, vielen Dank.

Lives Manual sagt nix zu [g=77]VST[/g]-Auslastung oder sowas. Die Prozessorlast rechts oben zeigt wie gesagt max. 30% an, bevor es anfängt zu knacksen. Das ASUS-Board nutzt übrigens einen NVIDIA-Chipsatz mit integrierter Grafik, unnnötige Komponenten habe ich im BIOS deaktiviert.

Also, ich probier auch mal ein bisschen rum mit nem abgespeckten Useraccount, also weniger Prozessen. Auch Abletons Clip Freeze probier ich mal aus.

Erstmal Schluss für heute.
Gruß
Jens
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
HipHopMacher schrieb:
Falschen Audiotreiber ausgewählt?

Nee nee, es is schon der Treiber der Juli@ in den Systemeinstellungen und Live gewählt.
 
Lacunaflow
Lacunaflow
Influencer
Teammitglied
Registriert
25.12.06
Beiträge
23.300
Reaktionen
4.866
Ort
Ostfriesland
Punkte
88.803
Viel erfolg beim Optimieren!


Nur noch kurz als anmerkung:

CPU Last und [g=77]VST[/g] last sind zwei verschieden Dinge!



Gruss und :n8:
 
H
HipHopMacher
Gesperrter User
Registriert
30.09.08
Beiträge
3.158
Reaktionen
2
Punkte
3.206
Probier mal eine andere Soundkarte.
z.B. RME ...

2048 Samples klingt für mich schwer nach MME-Treiber...
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
HipHopMacher schrieb:
Probier mal eine andere Soundkarte.
z.B. RME ...

2048 Samples klingt für mich schwer nach MME-Treiber...

Der MME-Treiber wird bei der Juli@ automatisch mit installiert. Im Nachhinein kann man dann in Live den [g=12]ASIO[/g]-Treiber wählen. Genauso wie DirectX oder MME.

Lässt mir aber heute keine Ruhe das Ganze. Und: _Ein_ Übeltäter ist gefunden! AMDs Cool 'n Quiet-Technik. Die taktet den Prozessor (und den Chipsatz?) je nach Leistungsbedarf herunter. Die hab ich im BIOS deaktiviert. Dazu noch den Prozi um 7% übertaktet, von 2,2 auf 2,35GHz pro Kern.
Damit hab ich insgesamt die Prozessolast bei der oben beschriebenen Live-Session HALBIERT (!) und die [g=5]Latenz[/g] von 2048 auf für mich sagenhafte 256 (!) Samples herunterschrauben können, ohne einen Knackser. Damit kann ich erstmal gut leben... Mal sehen, was sich noch so findet an Übeltätern.

Großes Danke für eure Hilfe! Schöne Ostern noch.
Viele Grüße
Jens
 
D
der_skeptiker
Registriert
12.04.09
Beiträge
7
Reaktionen
0
Punkte
8
Lacunaflow schrieb:
Viel erfolg beim Optimieren!


Nur noch kurz als anmerkung:

CPU Last und [g=77]VST[/g] last sind zwei verschieden Dinge!



Gruss und :n8:

Danke. Nun ja, klar, aber Live zeigt leider keine [g=77]VST[/g]-Last an. Zumindest steht in dem Handbuch nix davon. Ich werd Ableton mal anrufen, vielleicht gibt's da ja ein Tool.

Gruß
Jens
 

Ähnliche Themen

tim_heinrich
    • Danke
  • Artikel
Antworten
2
Aufrufe
157
tim_heinrich
tim_heinrich
M
Antworten
48
Aufrufe
2K
Soundloch
Soundloch
tim_heinrich
Antworten
2
Aufrufe
166
tim_heinrich
tim_heinrich
 

Aktuelle Beiträge


Oft gelesene Themen

Oben