Information ausblenden

Kontakt startet sehr langsam

Dieses Thema im Forum "Software-Instrumente und Sample-Libraries" wurde erstellt von ModulationMatrix, 02.12.18.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. ModulationMatrix

    ModulationMatrix Themenersteller Faderhalter

    Registriert seit:
    10.09.13
    Punkte:
    37.607
    37607
    Moin moin,

    wie lange braucht bei euch Kontakt beim ersten Start? Bei mir wird Kontakt gefühlt immer langsamer, aktuell dauert der erste Start 35 Sekunden. Kein anderes Plugin brauch derart lange zum starten. Der Independence Sampler ist in wenigen Sekunden da. Woran liegt das? Ich habe nun eine Terabyte-Platte voll an Libraries, scannt er die alle bei jedem Start durch? So ein Scan ist komplett idiotisch da man eh jede neue Library im Native Access anmelden muss. Kann man das irgendwie abschalten? Haben die Datenbankeinstellungen damit was zu tun?

    Danke & Gruß, Moduma :)

    Nochmal die Fakten kurz und knackig:

    - erster Start von Kontakt nach Rechner-Boot dauert 35 Sekunden
    - Standalone und Plugin verhalten sich gleich
    - Libraries sind auf SSD im NTFS Format
    - Libraries erscheinen korrekt im Native Access, Pfade sind korrekt.
    - "show foreign formats" an oder aus bringt keine Änderung
    - Ethernetkabel angeschlossen oder nicht bringt keine Änderung
    - DB komplett löschen und deaktivieren bringt keine Änderung
    - kompletten AppData/.../Kontakt Ordner löschen bringt keine Änderung
    - Quickload komplett geleert bringt keine Änderung
     
    Zuletzt bearbeitet: 17.01.19
    ModulationMatrix, 02.12.18
    #1
    pitto bedankt sich.
  2. pitto

    pitto

    Registriert seit:
    14.12.07
    Punkte:
    8.379
    8379
    Kann ich nur zustimmen, startrt verhältnismäßig langsam und verbraucht auch verhältnismäßig viel Ressourcen (CPU). Das ist einer der Gründe, warum ich es viel zu wenig nutze und in vielen Fällen lieber auf Omnisphere gehe....
     
    pitto, 02.12.18
    #2
  3. oliveramberg

    oliveramberg Ex-Rockstar

    Registriert seit:
    23.08.17
    Punkte:
    4.182
    4182
    Kontakt ist der Bremser beim Aufstarten von Projekten (Reaper). Grauslig. Aber ich brauch das Teil leider oft.
     
    oliveramberg, 02.12.18
    #3
  4. semox

    semox

    Registriert seit:
    16.08.17
    Punkte:
    60
    60
    Ich nutze Kontakt jetzt eher selten, aber bei mir starten auch andere NI-PlugIns langsamer als VSTs von anderen Anbietern. Wenn ich z.B. in Reaper ein Projekt öffne, werden ja alle verwendeten PlugIns geladen und bei Battery 4 hängt es dann doch einige Sekunden länger als beim Rest.
     
    semox, 02.12.18
    #4
  5. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    53.678
    53678
    Innerhalb von Kontakt gibt es doch so 'ne Möglichkeit, die Datenbanken neu zu organisieren - vielleicht liegt's daran?

    Ich schaue später mal die genauen Einstellungen nach.
     
    Kosaken-Kaffee, 02.12.18
    #5
    TheSarge und Dodo_I bedanken sich.
  6. KDthe2nd

    KDthe2nd DJ

    Registriert seit:
    08.07.17
    Punkte:
    3.776
    3776
    In der Standalone Version (Vers.5) vl. max. 5 Sekunden, habe aber auch nur NI eigene Librarys.
    Kontakt 4 startet sogar noch schneller.
    Einstellungen sind alle Standard.

    Beim zweiten Start gibt's kaum eine Verzögerung.

    EDIT: Auch nach einem PC Neustart, startet Kontakt schneller, als zuvor...
     
    KDthe2nd, 02.12.18
    #6
  7. KDthe2nd

    KDthe2nd DJ

    Registriert seit:
    08.07.17
    Punkte:
    3.776
    3776
    SSD oder HDD ?

    und nö, der scannt nicht jedesmal durch. Höchstens wenn neuer Content erkannt wurde. So jedenfalls bei mir...
     
    KDthe2nd, 02.12.18
    #7
  8. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    53.678
    53678
    So, hab mal geguckt, bin mir aber wie gesagt nicht sicher, ob es das wirklich ist.

    Im Hauptfenster gibt es rechts oben das Diskettensymbol. Im Dropdown Menü steht "Batch re-save". Eigentlich verwendet man diese Funkion, wenn einer Library Sounds fehlen.

    In der NI-Doku heisst es dazu unter anderem:
    Die Funktion Batch re-save korrigiert die Dateipfade der Samples in allen KONTAKT Instruments, die zu der jeweiligen Library gehören.

    Testen, ob das was bringt, kann man aber allemal.
     
    Kosaken-Kaffee, 02.12.18
    #8
    ModulationMatrix bedankt sich.
  9. ModulationMatrix

    ModulationMatrix Themenersteller Faderhalter

    Registriert seit:
    10.09.13
    Punkte:
    37.607
    37607
    Die Batchresave Funktion habe ich immer angewandt wenn eine neu gekaufte Library zu langsam lädt. D.h. habe ich auf den meisten Libs schon gemacht. Glaube aber eher nicht dass das für den Start von Kontakt wichtig ist?
     
    ModulationMatrix, 02.12.18
    #9
  10. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    53.678
    53678
    Ja, keine Ahnung, aber in der Not frisst der Teufel Fliegen. :)

    Ansonsten würde ich mal eine www Suche starten. Du bist auf Win, gelle?
     
    Kosaken-Kaffee, 02.12.18
    #10
  11. ModulationMatrix

    ModulationMatrix Themenersteller Faderhalter

    Registriert seit:
    10.09.13
    Punkte:
    37.607
    37607
    Ja, Win, und SSD.

    Hab gerade mal gestoppt. Also das Standalone Fenster geht beim ersten Start nach ungefähr ner halben Minute auf (hab den genauen Augenblick verpasst), die Festplatte rödelt aber noch bis fast 1 Minute herum. Im File Zugriff sehe ich dass er einen LibraryCache durchnudelt und außerdem die .nicnt Files aller Libraries lädt. Zum Thema cache finde ich nix in den Options.

    Gegoogelt hab ich schon, da steht was von Netzwerk und Virenscanner. Letzteres hab ich nicht, ersteres ist natürlich Pflicht. Viele schreiben auch dass es eben lange dauert weil die GUI so komplex ist.

    Zweiter Start der Standalone dauert so 5-7 Sekunden.
     
    ModulationMatrix, 02.12.18
    #11
    pitto bedankt sich.
  12. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    53.678
    53678
    Kontakt lädt beim Start aber nicht erst alle Libraries in den RAM, oder?
     
    Kosaken-Kaffee, 02.12.18
    #12
  13. ModulationMatrix

    ModulationMatrix Themenersteller Faderhalter

    Registriert seit:
    10.09.13
    Punkte:
    37.607
    37607
    Neeeeeeee. Glaube der liest nur irgendwas aus um die Bilderliste links im Browser darzustellen.
     
    ModulationMatrix, 02.12.18
    #13
  14. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    53.678
    53678
    Ist der Treiber der GraKa aktuell?
     
    Kosaken-Kaffee, 02.12.18
    #14
  15. SilentWarrior

    SilentWarrior Schrauber

    Registriert seit:
    21.07.17
    Punkte:
    23.613
    23613
    Bei mir startet das Plugin in 3 Sekunden, auch als Standalone. Keine Ahnung warum das bei manchen so lange dauert.
    Liegt eher am System und nicht am Plugin.
     
    SilentWarrior, 02.12.18
    #15
  16. notebynote

    notebynote

    Registriert seit:
    10.10.06
    Punkte:
    11.221
    11221
    Auf meiner alten kleinen Kiste MBA 11" von Mitte 2013 mit schlappen 4GB startet Kontakt 5 in Nullkommanix. Liegts bei Dir am System? Ein TB Libraries - mein Gott, hast Du da noch Zeit, Musik zu machen? :cool:
     
    notebynote, 02.12.18
    #16
    Dodo_I bedankt sich.
  17. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.744
    30744
    Nee, ist nur wichtig zum Laden der Patches.

    Bei mir dauert es unter Cubase auch ne gewisse Zeit, wenn ich Kontakt das erste Mal öffne. Ab und an hab ich auch erst ne weiße GUI und Cubase ist in der Zeit nicht bedienbar. Beim zweiten Öffnen geht es dann ruckzuck.
    Ich hatte mich mal mit der Thematik befasst und ich denke so ein bissel hat es mit der Anzahl/Kopierschutz der Libraries zu tun. Auch das NI seine Daten über verschiedene Ordner verteilt macht es nicht besser. Beim Übergang vom Service Center zu Native Access war es ganz schlimm. Service Center war gefühlt schneller. Jetzt mit NA ist es deutlich schlechter.
    Ich hatte mal Prcess Lasso laufen, während ich Kontakt in Cubase geladen habe und dort kann man sehr gut sehen, wie erst die ganzen Libraries und deren Lizenzen abgefragt werden. Das kann dann schonmal ne Zeit dauern, wenn man sieht was da für Prozesse durchrattern.

    Play von EW, der BestService- und IKM-Sampler sind bei mir immer sofort da und stellenweise auch resourcenschonender als Kontakt.
    Play läuft ja über iLok und da habe ich auch das Gefühl, dass die Plugins, welche iLok nutzen, auch schneller öffnen in Cubase.

    Es scheint m.M. nach einen Zusammenhang zwischen dem Abrufen verschiedener Lizenzen in Verbindung mit Cubase zu geben.Ein weiteres Beispiel: Letztens hatte ich z.B. eine Meldung über Cubase, dass ich den iLok-Manager aktualisieren soll, weil sonst Lexicon LPX nicht geladen werden kann.
    Also, Cubase testet die Lizenzen definitv und wahrscheinlich dauert es dann mal etwas länger.
     
    Realist, 02.12.18
    #17
    Dodo_I und ModulationMatrix bedanken sich.
  18. ModulationMatrix

    ModulationMatrix Themenersteller Faderhalter

    Registriert seit:
    10.09.13
    Punkte:
    37.607
    37607
    Ahhhhhhhh das ergibt Sinn. na toll, und je mehr Libraries ich kaufe desto schlimmer wird es werden. Müsste mich dann mal von altem Zeug trennen was ich nicht mehr so viel benutze. Oder besser noch eine Nörgel E-Mail an NI schicken dass die das mal verbessern sollen.
     
    ModulationMatrix, 02.12.18
    #18
    Realist und Dodo_I bedanken sich.
  19. notebynote

    notebynote

    Registriert seit:
    10.10.06
    Punkte:
    11.221
    11221
    Oder ins Forum gehen und dort nachfragen. Auch FB Gruppen sind manchmal ganz hilfreich (aber nicht immer, es gibt einfach zu viele Schwätzer dort)
     
    notebynote, 03.12.18
    #19
  20. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.744
    30744
    Okay, ich hab gestern im Forum von NI geschaut. Es gibt wohl etliche User, welche dieses Problemchen haben.
    Anscheinend ist da NI aber etwas immer noch ahnungslos, obwohl es eindeutig mit deren Database-Management zu tun hat.
    Die Database funktioniert bei anderen NI-Produkten ja auch nicht zufriedenstellend.
    Nach diversen Post in verschiedenen Foren habe ich vorhin mal rumprobiert.
    Hier mal ein exemplarischer Post.
    https://support.native-instruments.com/hc/en-us/community/posts/211829145-Kontakt-Opens-Slowly-

    Als erstes darf beim Schliessen und Öffnen von Kontakt der Dateibrowser nicht geöffnet bleiben. Der Dateipfad muss in der Ansicht auf der untersten Ordnerebene sein, sonst sucht sich Kontakt beim Starten wohl nen Wolf und wenn man viele Libraries hat umso mehr.
    Klingt für mich eigentlich nach etwas, dass NI fixen könnte. Man denkt sicherlich nicht immer daran, die Ordner zu schliessen.
    Hier mal ein Screenshot was gemeint ist. Ist etwas schwer zu erklären.

    KonFiles.PNG

    2. In den Database-Options mal alle Libraries rausschmeissen. Das kostet wohl auch Zeit bei vielen Libs.
    KonDB2.PNG

    3. Generell mal die Database aufräumen. Bei mir hat Kontakt da schon fast insgesamt zweitausend Einträge hinterlassen. U.a. jede popelige Änderung steht da drin. Ich hab da vorher nie reingeschaut und der Sinn erschliesst sich mir auch nicht so richtig. Mit Rechtsklick kann man die Einträge löschen. Da muss man nur aufpassen, dass man nicht die kompletten Files deleted. Das ist die Funktion darunter. ;)
    KonDB1.PNG

    4. Kein Quickload nutzen.

    Seitdem ich das gemacht habe startet Kontakt wieder rasend schnell.
    Negative Auswirkungen konnte ich noch nicht feststellen, aber alle Angaben ohne Gewähr. ;)
     
    Realist, 03.12.18
    #20
    RK79, SoulFrontier, Dodo_I und 5 andere bedanken sich.
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.