Information ausblenden

Irres RealTimePeak Problem mit Cubase 8.5pro

Dieses Thema im Forum "Cubase & Nuendo" wurde erstellt von RawberrY, 10.03.19.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. RawberrY

    RawberrY Themenersteller

    Registriert seit:
    03.01.07
    Punkte:
    1.900
    1900
    Hi!

    So etwas irres habe ich noch nicht erlebt. Ich komme auch nicht dahinter, wie das funktionieren soll...
    Das Problem besteht nur auf der Drumspur. Ansonsten habe ich überhaupt keine Probleme mit Knacksern und Peaks...

    Ich erzähle mal drauf los.

    Ich habe das Projekt geladen. Dies ist das Bild meiner aktuellen Performance: Ok.jpg
    Nun will ich in die FX Sektion meiner Drumspur. Dort habe ich folgendes geladen:
    Effekte.jpg

    Auf einmal rasten meine RealTimePeaks total aus. Dabei ist es auch völlig egal, ob ich die Engine von BFD3 neu starte oder sämtliche PlugIns rausschmeiße. Das geht die ganze Zeit so weiter und erholt sich nicht.
    Absturz.jpg

    Und jetzt kommt das Irre, was ich durch Zufall herausgefunden habe. Öffne ich die Effektsektion eines anderen Instrumentes, hier beispielsweise der Bass, wo ich folgende PlugIns geladen habe...
    BassFX.png

    ...passiert genau das:
    AllesOK.jpg
    Es hat sich wieder alles erholt und die Peaks sind verschwunden!

    Was ist da los? Das bringt mich völlig um den Verstand.
     
    RawberrY, 10.03.19
    #1
  2. SilentWarrior

    SilentWarrior Schrauber

    Registriert seit:
    21.07.17
    Punkte:
    22.993
    22993
    Cubase. War schon immer so mit den Peaks. Ist aber immer "normal".
     
    SilentWarrior, 10.03.19
    #2
  3. JeZe

    JeZe

    Registriert seit:
    26.10.10
    Punkte:
    3.068
    3068
    Besteht das Problem wirklich nur auf der Drumspur oder ist das eben die Spur, die Du durch Aktivierung der Aufnahme/des Monitorings realtime abhörst?

    Wie ist den Deine Puffereinstellung? Hast Du den Dropoutschutz aktiviert?
    Izotope-Plugins erzeugen meiner Erfaherung nach oftmals Realtime-Peaks - ob daraus Aussetzer werden hängt von der Puffer-Einstellung ab.
     
    JeZe, 10.03.19
    #3
  4. RawberrY

    RawberrY Themenersteller

    Registriert seit:
    03.01.07
    Punkte:
    1.900
    1900
    Es besteht nur, wenn ich die Drumspur FX-Sektion geöffnet habe.
    Mittlerweile habe ich auch herausgefunden, dass es schon reicht, die Spur ein mal mit der Maus anzuklicken, so dass sie als "ausgewählt" gilt und grau hinterlegt ist. Sobald ich eine andere Spur anklicke, ist das komplett weg.

    Es ist dabei völlig egal, welche Plugins ich gerade im FX geladen habe.
     
    RawberrY, 10.03.19
    #4
  5. RawberrY

    RawberrY Themenersteller

    Registriert seit:
    03.01.07
    Punkte:
    1.900
    1900
    Jetzt auch mit Video. Zwar ohne Sound, aber man sieht das Problem:
     
    RawberrY, 10.03.19
    #5
  6. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.596
    30596
    Wie Jeze schon geschrieben hat, wechselt Cubase, je nach aktiver Spur, in einen anderen Audiomodus.
    Bei deiner Drumspur z.B. ist der Record-Button aktiv. Den würde ich mal testweise ausmachen.
    Desweiteren, falls ASIO Guard aktiviert ist, diesen auch mal testweise ausschalten.
    Die Izotope-Plugins haben stellenweise ne tierische Latenz.
    Das Projekt scheint ja generell noch recht übersichtlich und dafür ist die Auslastungsanzeige schon ziemlich hoch, finde ich.
    Es kann also auch sein, dass eins deiner Plugins die Performance in den Keller zieht.
     
    Realist, 10.03.19
    #6
  7. RawberrY

    RawberrY Themenersteller

    Registriert seit:
    03.01.07
    Punkte:
    1.900
    1900
    An dem Izotope kann es auf der Spur zumindest nicht liegen, da das Problem auch auftritt, wenn ich das PlugIn rauswerfe.
    Am AsioGuard liegt es auch nicht- bereits alle Einstellungen durch.

    Aber: am Record-Button liegt es :D
    Du hast es gefunden! Tausend Dank. War schon kurz davor, die 200€ für Cubase10 auszugeben, in der Hoffnung, dass es sich bessert.

    Aber wieso/ weshalb/ warum am Aufnahmeknopf?
     
    RawberrY, 10.03.19
    #7
  8. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.596
    30596
    Wie schon geschrieben, schaltet Cubase dann in eine Art Realtime-Modus, weil ja Aufnahmedaten erwartet werden.
    Bzgl. Izotope, es kann auch eines der anderen Plugins eine höhere Latenz erzeugen.
    Die Werte kann man sich im Plugin-Manager anzeigen lassen.
    Während der Komponier/Findungs/Aufnahme Phase nutze ich ausschliesslich nur Plugins die keine Latenz oder kaum Latenz erzeugen und hatte bisher noch keine Probleme mit so krassen Leistungssprüngen.

    Ich habe in Cubase die Funktion "Aufnahme aktivieren" ausgeschaltet. Die scheint bei Dir noch an zu sein, deshalb schaltet Cubase auch immer automatisch in den Aufnahmemodus, obwohl Du eigentlich nichts aufnehmen möchtest.
    https://steinberg.help/cubase_pro_a...rding/recording_record_enabling_tracks_c.html

    Für die Aufnahme gibt es desweiteren den Button "Verzögerungsausgleich einschränken", der latenzbehaftete Plugins aus dem Echzeitpfad vorübergehend ausschaltet.
    https://steinberg.help/cubase_eleme...struments_constrain_delay_compensation_c.html
     
    Realist, 10.03.19
    #8
    LM18 bedankt sich.
  9. PlanNine

    PlanNine

    Registriert seit:
    08.11.13
    Punkte:
    2.451
    2451
    Ich habe auch ein Projekt wo das so ist.
    Also Record an/aus ergibt Knakser.
    Wenn ich so ein Projekt geladen habe wird dieses
    Verhalten vererbt wenn ich dann ein neues Projekt erzeuge.
    Schliesse ich Cubase erst und starte es wieder und erzeuge dann
    ein neues Projekt so ist das Verhalten weg.
     
    PlanNine, 11.03.19
    #9
  10. fender_rhodes

    fender_rhodes

    Registriert seit:
    11.03.19
    Punkte:
    146
    146
    Das Problem ist ja schon lange bekannt. Umso erstaunlicher ist es, dass es dafür einen Workaround gibt, den ich zufällig entdeckt habe.
    Der Effekt tritt ja nur bei Midispuren, die auf virtuelle Instrumente im Rack geroutet sind, oder bei Instrumentenspuren auf. Wenn man nun diesen Spuren eine Drum-Map zuweist verschwindet der Effekt ( nach dem Zuweisen der Drum-Map einmal kurz eine andere Spur selektieren!).
    Offensichtlich ist es so, dass bei selektierten Spuren der ASIO Guard deaktiviert wird. Mit Drum-Map ist dies nicht der Fall. Natürlich hat das Ganze auch Nachteile. Wenn in den Programmeinstellungen nicht anders gewählt, öffnet sich nun der Drum Editor . Das heißt, man muss die Programmeinstellungen ändern um wie gewohnt den MIDI-Editor zu öffnen und für den Drum Editor einen Shortcut verwendenden.
    Für besonders resourcenhungrige Projekte oder Spuren ist dies aber eine gute Lösung. Ich habe mir dafür extra leere Drum Maps für die jeweiligen MIDI Kanäle erstellt. Auf Wunsch kann ich die gerne hier mal hochladen.
    Gruß
    Thilo
     
    Zuletzt bearbeitet: 11.03.19
    fender_rhodes, 11.03.19
    #10
    cauerpower bedankt sich.
  11. Glutamatjunkie

    Glutamatjunkie Gruftie

    Registriert seit:
    26.09.10
    Punkte:
    14.909
    14909
    J37 ist auch ein hungriger Hugo.
    Interface: Welche Buffergröße???
    PC: Altertümliche HDDs oder SSDs?
     
    Glutamatjunkie, 11.03.19
    #11
  12. fender_rhodes

    fender_rhodes

    Registriert seit:
    11.03.19
    Punkte:
    146
    146
    Die Buffergröße scheint in Ordnung zu sein, da ja die Realtime-Peaks bei nicht selektierter Spur sehr gering sind. Den Buffer würde ich nur vergrößern wenn bei nicht selektierter Spur die Realtime-Peaks unruhig oder zu groß werden. Da der Disk Performance Balken keine Ausschläge zeigt kann man die Harddisk als Ursache auch ausschließen.
    In diesem Fall handelt es sich ja um die einzige virtuelle Instrumentenspur im Projekt, die zudem ja noch eine Drum Spur ist. In diesem Fall drängt sich der Einsatz einer Drum Map geradezu auf. Vor allem da sie sich ja leicht mit der Funktion "aus dem Instrument erzeugen" einsetzen lässt.
    Gruß
    Thilo
     
    fender_rhodes, 11.03.19
    #12
    cauerpower bedankt sich.
  13. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.596
    30596
    So wie ich es verstanden habe, hat der TE den ASIO-Guard auch testweise deaktiviert gehabt?
    Das war ja zumindest ein Ratschlag von mir.
    Man kann auch Plugins vom ASIO Guard ausschliessen. Über den Plugin Manager.
     
    Realist, 11.03.19
    #13
    LM18 bedankt sich.
  14. fender_rhodes

    fender_rhodes

    Registriert seit:
    11.03.19
    Punkte:
    146
    146
    Wenn man den ASIO Guard deaktiviert, erhält man die Realtime Peaks auch bei nicht selektierter Spur. Das Problem ist ja, dass das "Scharfschalten" der Spur den ASIO Guard für diese Spur deaktiviert. Und genau das passiert nicht wenn in dieser Spur die Drum Map aktiviert ist. Kurios, ist aber so.
    Gruß
    Thilo
     
    fender_rhodes, 11.03.19
    #14
    cauerpower bedankt sich.
  15. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.596
    30596
    Ich hab mal kurz ne Suche zu BFD3 gestartet.
    Kann auch sein, dass es am Plugin (BFD) selbst liegt.
    In diversen Foren wird dort unabhängig von der DAW von peaks und CPU-Hunger berichtet.
    Ich würde nach einem Update schauen und auch nochmal in den Einstellungen des Plugins, ob man da noch etwas ändern kann.
     
    Realist, 11.03.19
    #15
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.