Garageband Neuinstallation

  • Ersteller radiouli
  • Erstellt am

R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14
Hallo liebes Mitstreiter, leider hat bei mir die Neuinstallation von Garageband 10 nicht funktioniert. Ich bekomme dauernd Fehlermeldungen. Nachdem ich Garageband installiert hatte, habe ich mich mit dem Programm beschäftigt, es hat mir nicht gefallen und ich habe es mit dem Appcleaner gelöscht. Es sind diverse Ordner mitgelöscht worden. Als ich mich nun noch einmal mit dem Programm beschäftigen wollte und es neu installiert habe, aus dem AppStore, kommen auf einmal Fehlermeldungen das bestimmte Effekte und Plugins nicht gefunden werden.
Dauernd wird nach der Location von bestimmten Dateien gefragt. Es wurden Dateien in Ordner u.a. in Libary/Audio gelöscht. Das alte Garageband läuft problemlos!
Wie kann ich Garageband noch einmal neu installieren ?

Danke für eure Mühe
Uli
 
tubeless
tubeless
Gesperrter User
Registriert
02.05.09
Beiträge
15.308
Reaktionen
2.067
Punkte
22.901
Hallo liebes Mitstreiter
Da liegst Du falsch.
So viele Ritter des angebissenen Apfels gibts hier nicht. Jedenfalls sinds nicht alle.... ;)

kommen auf einmal Fehlermeldungen das bestimmte Effekte und Plugins nicht gefunden werden.
Dauernd wird nach der Location von bestimmten Dateien gefragt.

Da hat der AppCleaner wohl ein bisschen zu gründlich gecleant. Sowas kann passieren, wenn man solchen Programmen zu sehr vertraut. :D

Wie kann ich Garageband noch einmal neu installieren ?
Die Installationsdatei doppelklicken?
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.099
Reaktionen
7.295
Punkte
38.842
Time Machine?

Clemens
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.099
Reaktionen
7.295
Punkte
38.842
Dann hast Du aus Deinem Experiment hoffentlich die Lehre gezogen, dass Dir die Time-Machine den allerwertesten retten kann.

Wenn ich das richtig mitgekriegt habe, hast Du direkt das neue OSX und das zugehörige iLife aufgespielt.
Da wirst Du in einem Musikerforum wenig ähnlich experimentierfreudige User finden. (Ich z.B. bin noch glücklich auf 10.6.8)

Die Fehlermeldungen lassen mich vermuten, dass Du Systemdateien "abgeschossen" hast - wie Tubeless schon sagt.
(Nochmal der Hinweis - ALLE Mac-"Tuning"-Tools nur mit Backup verwenden)

Du wirst das System von Hand wiederherstellen müssen.
Benutzerordner sichern - Neuinstallation - Benutzerordner zurückspielen.
Eventuell kannst Du die Maverick-Installation einfach so drüberlaufen lassen (Aber trotzdem Backup!)

Und falls jetzt die Frage kommt: "Ich dachte Mac wäre so sicher und stabil"
Einen Feuerlöscher an die Wand zu hängen, bringt auch nix, wenn man ihn nicht benutzt und trotzdem zündelt ...

Clemens
 
R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14
Dann hast Du aus Deinem Experiment hoffentlich die Lehre gezogen, dass Dir die Time-Machine den allerwertesten retten kann.

Wenn ich das richtig mitgekriegt habe, hast Du direkt das neue OSX und das zugehörige iLife aufgespielt.
Da wirst Du in einem Musikerforum wenig ähnlich experimentierfreudige User finden. (Ich z.B. bin noch glücklich auf 10.6.8)

Die Fehlermeldungen lassen mich vermuten, dass Du Systemdateien "abgeschossen" hast - wie Tubeless schon sagt.
(Nochmal der Hinweis - ALLE Mac-"Tuning"-Tools nur mit Backup verwenden)

Du wirst das System von Hand wiederherstellen müssen.
Benutzerordner sichern - Neuinstallation - Benutzerordner zurückspielen.
Eventuell kannst Du die Maverick-Installation einfach so drüberlaufen lassen (Aber trotzdem Backup!)

Und falls jetzt die Frage kommt: "Ich dachte Mac wäre so sicher und stabil"
Einen Feuerlöscher an die Wand zu hängen, bringt auch nix, wenn man ihn nicht benutzt und trotzdem zündelt ...

Clemens

Hallo Clemens,

es war so: Ich habe Maverics installiert, läuft wirklich super! Dann habe ich Garageband geupdatet, bzw. es entstand eine Parallelinstallation. Ich habe eine Weile damit rumgespielt und festgestellt, dass es nix ist. Ich habe es dann einfach gelöscht! Nun packt mich mein Ehrgeiz und ich wills nochmal probieren. Habe es aus dem AppStore runtergeladen undnun kommen die Fehlermeldungen. Wenn ich dich richtig verstehe meinst du, dass die Verschwundenen Ordner Maverics installiert hat und nicht Garageband? Glaube ich nicht. Ich habe mir nämlich in Time Machine genau diesen Ordner angesehen, in dem jetzt die Dateien durch AppCleaner gelöscht wurden sind. Sie müssen erst bei der Installation von Garageband entstanden sein.

Grüße
Uli
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.099
Reaktionen
7.295
Punkte
38.842
Glaube ich nicht. Ich habe mir nämlich in Time Machine genau diesen Ordner angesehen, in dem jetzt die Dateien durch AppCleaner gelöscht wurden sind. Sie müssen erst bei der Installation von Garageband entstanden sein.

Tja - ich habe keine Vorstellung, woran das liegen könnte.

Clemens
 
tomric
tomric
Rocker
Registriert
10.12.06
Beiträge
10.296
Reaktionen
1.730
Punkte
35.508
R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14
Ich habe mir nämlich in Time Machine genau diesen Ordner angesehen, in dem jetzt die Dateien durch AppCleaner gelöscht wurden sind.

Time Machine wär schön, hab aber kein Backup vorher gemacht.

Jetzt wird's spannend...

In wie fern?

Nochmal kurz zur Erklärung: neues Garageband geladen, getetstet, gelöscht. Hab dann nachgesehen was Garageband noch so alles installiert haben muss. Da waren Odrner und viele Dateien (Libary/Audio) die vorher nicht da waren. Das konnte ich ja in Time Machine sehen. Diese Ordner und Dateien hab ich dann noch mit der Hand entfernt. Ich dummkopf habe eben kein Backup vor dem löschen gemacht, sonst hätte ich sie ja noch. In meiner Erinnerung waren es Loops und andere Dateien (ne ganze Menge).

Nach meiner gestrigen Neuinstallation von Garageband (das Neue) kommen die Ordner nicht wieder. Ich habe auch noch einmal Mavericks drüber laufen lassen - nix!

An eins kann ich mich noch erinnern: Bei der Erstinstallation von neuen Garageban hat er nach dem Start des Programms noch etliches runtergeladen, hat bestimmt 15 min gedauert. Das machte er bei der Neuinstallation von Garageband nicht mehr.

Grüße
Uli
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.099
Reaktionen
7.295
Punkte
38.842
App-Cleaner löscht nicht alle Dateien.

Vermutlich sind noch Dateien da, die die Garageband-Installation dazu bringen, nicht vollständig durchzulaufen.

Deshalb (ohne Garantie):
Time-Machine-Wiederherstellung auf den Punkt vor der ersten Garageband-10-Installation.
Garageband neu installieren.

Zu App-Cleaner:
Ich verwende den nur als "Suchhilfe". Ich lasse mir anzeigen, welche Dateien "seiner Meinung nach" zu einer Software gehören. Ob ich die lösche, entscheide ich selbst. Vertraue nie einem Tool.

Zu Deinem Vorgehen:
Die "Deinstallation" war unnötig. Nicht so viel "installieren und gleich wieder löschen" - erst nachdenken.

Clemens
 
tomric
tomric
Rocker
Registriert
10.12.06
Beiträge
10.296
Reaktionen
1.730
Punkte
35.508

Weil Du von Time Machine redest und davon, daß Du kein Backup gemacht hast und wir uns fragen, wie das zusammenpasst...

Da waren Odrner und viele Dateien (Libary/Audio) die vorher nicht da waren. Das konnte ich ja in Time Machine sehen.

Kann es sein, daß Du gerade Finder und Time Machine durcheinanderbringst ?

An eins kann ich mich noch erinnern: Bei der Erstinstallation von neuen Garageban hat er nach dem Start des Programms noch etliches runtergeladen, hat bestimmt 15 min gedauert. Das machte er bei der Neuinstallation von Garageband nicht mehr.

Schau mal unter Library jeweils in der Root, als auch unterhalb Deines Benutzerordners (den musst Du aber erst einblenden). Dort gibt es die Unterordner "Application Support" und "Preferences", in denen sich ggf. weitere Ordner und Dateien befinden, die zu Garageband gehören (z.B. die Loops, usw...). Wenn Du alles saubermachst, dann sollte sich das Ding bei Neuinstallation wieder wie gewohnt verhalten.
 
R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14

Weil Du von Time Machine redest und davon, daß Du kein Backup gemacht hast und wir uns fragen, wie das zusammenpasst...

Da waren Odrner und viele Dateien (Libary/Audio) die vorher nicht da waren. Das konnte ich ja in Time Machine sehen.

Kann es sein, daß Du gerade Finder und Time Machine durcheinanderbringst ?

An eins kann ich mich noch erinnern: Bei der Erstinstallation von neuen Garageban hat er nach dem Start des Programms noch etliches runtergeladen, hat bestimmt 15 min gedauert. Das machte er bei der Neuinstallation von Garageband nicht mehr.

Schau mal unter Library jeweils in der Root, als auch unterhalb Deines Benutzerordners (den musst Du aber erst einblenden). Dort gibt es die Unterordner "Application Support" und "Preferences", in denen sich ggf. weitere Ordner und Dateien befinden, die zu Garageband gehören (z.B. die Loops, usw...). Wenn Du alles saubermachst, dann sollte sich das Ding bei Neuinstallation wieder wie gewohnt verhalten.

Hallo.

Time Machine läuft bei mir auf manuel, nicht automatisch. Ich mache die Backups einmal die Woche oder manchmal auch öfter. Nein, Finder und Time Machine verwechsle ich nicht:)

Das mit der Libary und Root verstehe ich nicht so ganz. Was ich gefunden habe, waren Ordner unter Libary/Audio.

Grüße
Uli
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.099
Reaktionen
7.295
Punkte
38.842
Wenn Du alles saubermachst, dann sollte sich das Ding bei Neuinstallation wieder wie gewohnt verhalten.

Weil's jetzt doch wieder unklar ist, ob Du Timemachine (=Backup) hast, oder nicht - NIE OHNE BACKUP in diesen Ordnern "rumspielen".
 
tomric
tomric
Rocker
Registriert
10.12.06
Beiträge
10.296
Reaktionen
1.730
Punkte
35.508
Das mit der Libary und Root verstehe ich nicht so ganz. Was ich gefunden habe, waren Ordner unter Libary/Audio.

Ja, der ist schon mal richtig, da liegen einmal unter Apple-Loops die Loops für Garageband drin und unter ./Plug-Ins/Components etwaige installierte AU-Plugins. Unter /Library/Application Support/ kann ggf. auch ein Ordner Garageband liegen, bei etlichen Programmen werden zudem unter /Library/Preferences/ Einstellungen abgelegt, entweder in Dateien oder manchmal auch in entsprechend benannten Unterordnern.

Die selbe Verzeichnisstruktur gibt es dann auch nochmal für den Benutzer, je nach gewählter Installation und/oder Anwendung können dort nochmal entsprechende Dateien/Ordner bzw. Teile davon abgelegt sein. Um diesen Ordner (also /Users/<name>/Library) auch im Finder sehen und bearbeiten zu können, kannst Du im Terminal den Befehl "sudo chflags nohidden ~/library" verwenden... ;)
 
R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14
Danke erst mal für die vielen Infos!

Wenn ich euch richtig verstehe, sollte ich Garageband erst mal komplett und restlos entfernen und dann einfach nochmal neu installieren?

Ich hoffe, ich finde alle versteckten Garageband-Komponenten.

Grüße
Uli
 
R
radiouli
Registriert
21.10.13
Beiträge
12
Reaktionen
0
Punkte
14
Hallo Leute, es klappt! Ich habe alle Files von Garageband vom iMac gelöscht. Dann Rechner noch mal neu gestartet und Garageband aus dem AppStore runtergeladen. Neu installiert und siehe da er hat sich jetzt die fehlenden Elemente bei ersten Systemstart nachgeladen. Es dauerte noch einmal 20 Minuten bis Garageband dann da war. Ich denke euch für die vielen Tips. radiouli
 

Ähnliche Themen

moonbooter
    • Danke
  • Artikel
Antworten
15
Aufrufe
59K
musikproduzent
musikproduzent
Can
    • Danke
  • Artikel
Antworten
11
Aufrufe
35K
oove
oove
brokaaa
Antworten
10
Aufrufe
2K
brokaaa
brokaaa
 

Oft gelesene Themen

Oben