Information ausblenden

A Disk read error occurred

Dieses Thema im Forum "Musik-PC & sonstige Hardware" wurde erstellt von NoisiaTHX, 06.08.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Seit ein paar Tagen macht mir mein Produktionsrechner etwas Kummer.

    Er läuft so weit problemlos, nur beim Booten gibt es unter einer Bedingung eine Fehlermeldung:


    A Disk read error occurred. Press CTRL ALT DEL to continue


    Die Bedingung: Der Rechner muss vorher komplett vom Strom getrennt worden sein.
    Bleibt der Kippschalter der Verteilerdose auf "On" lässt er sich beliebig oft neustarten.
    Wird der Verteiler abgeschalten lässt sich dieser Fehler reproduzieren.

    Bei einem "Disk read error" bin ich als erstes von einer defekten Festplatte ausgegangen. Nach verschiedenen Tests gab es tatsächlich eine Platte mit erkennbaren Fehlern. Diese war nur nicht die Systemplatte. Trotzdem erst mal das System mit nur einer der drei Platten betrieben und eine neue Plattte besorgt. Bei beiden traten bei keinem Testprogramm Fehler auf. Auf beiden habe ich jeweils das Windows neu installiert. Der Fehler tritt trotzdem weiterhin auf. Ich habe verschiedene Bios-Versionen ausprobiert, die keine Besserung brachten. Kabel und MB-Steckplätze habe ich schon durchgetauscht. Mittlerweile habe ich alle vier Platten verbaut und das System wieder komplett eingerichtet. Alles läuft bestens - wäre da nicht das Startproblem. Ich befürchte nun das Schlimmste:

    Board defekt oder Netzteil defekt.

    Ich tendiere zu letzteren. Ich hoffe ich komme die nächsten Tage an mein altes Netzteil um diesen Fehler evtl. zu bestätigen oder auszuschließen.

    Vielleicht hat noch einer von euch eine Idee.

    ps.: PC --> siehe Signatur
     
    NoisiaTHX, 06.08.12
    #1
  2. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Möglicherweise ist nur die BIOS-Batterie müde und der Rechner kommt mit der Plattenerkennung beim Start nicht schnell genug hinter dem POST her.
    Das Verhalten, dass er bei mit Strom versorgtem Netzteil normal tut, ist jedenfalls ein typisches Zeichen für ne schwache BIOS-Batterie.
     
    tubeless, 06.08.12
    #2
    NoisiaTHX bedankt sich.
  3. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Thx, darauf bin ich noch nicht gekommen. Das wäre ja natürlich der Idealfall. Ist das denn nach einem Jahr Betriebsdauer schon möglich? Das Innenleben ist recht neu.
     
    NoisiaTHX, 06.08.12
    #3
  4. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Denkbar ist es. Wieso sollen solche Batterien nicht auch Macken haben können?
    Ist zwar sicherlich recht selten. Andererseits könnte es ja auch sein, dass irgendwas auf dem Board die Batterie leersuckelt.....

    Und ich werde ganz bestimmt nicht meine Hand dafür ins Feuer legen, dass es die Batterie ist. Aber das Verhalten ist irgendwie typisch.
    Ein Versuch schadet nichts, die Dinger sind ja nicht wirklich teuer.... ;)

    PS:
    Du kannst auch mal im BIOS den Schnell-Boot abschalten. Dann lässt sich die Kiste mehr Zeit, speziell mit dem Speichertest, und kommt dann gerne eher zu Potte.
    Ne andere Möglichkeit wäre, eine Wartezeit für die Plattenerkennung einzuschalten. Möglicherweise ist der POST zu schnell und die Platten sind noch nicht richtig da.
     
    tubeless, 06.08.12
    #4
    NoisiaTHX bedankt sich.
  5. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Werd nachher gleich mal eine holen. [​IMG]
     
    NoisiaTHX, 06.08.12
    #5
  6. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Nein, die Batterie wars nicht. [​IMG]
     
    NoisiaTHX, 06.08.12
    #6
  7. Marc1610

    Marc1610

    Registriert seit:
    30.03.12
    Punkte:
    9.505
    9505
    Hast du mal die Ramspeicher ausgebaut und umgesteckt?
    Einfach mal tauschen.
     
    Marc1610, 06.08.12
    #7
  8. anthe

    anthe

    Registriert seit:
    13.08.08
    Punkte:
    6.057
    6057
    Also ganz aalglatt u evtl obergescheit klingend gesagt, kann bei einem "disc read error" nur die gelesene disc den error produzieren. im aeussersten fall evtl der controller (sata? ) bzw das kabel;

    batterie, netzteil, ram wuerde ich gar nicht denken. ..

    nochmal den ausgangspost gelesen, wird wohl der onboard (?) controller sein, evtl moechtest du als einen ext controller probieren, falls du nicht richtung mb tausch tendierst. ..

    lg
    andi
     
    anthe, 06.08.12
    #8
  9. Rainer_Hain

    Rainer_Hain

    Registriert seit:
    23.12.11
    Artikel:
    2
    Punkte:
    4.354
    4354
    Hat das Board zufällig so etwas wie eine BIOS- oder Overclock-Recovery-Funktion?

    Ich hatte das mal vor längerer Zeit mit einem Asus-Board (glaub' ich wenigstens), für das die völlige Netztrennung das Signal war, Overclock-Einstellungen zurückzusetzen und bei Bedarf ein BIOS-Image von Diskette oder CD-Rom zu laden. Nicht dass ich das jemals gebraucht hätte, aber es warf mir auch immer eine Fehlermeldung aus, wenn in dem damals noch vorhandenen Diskettenlaufwerk keine Diskette steckte.

    Warum das aber aus heiterem Himmel auftritt - vor allem, wenn es nicht die Batterie ist - wüsste ich aber im Moment auch nicht zu erklären. Um die Platten würde ich mir aber keine Sorgen machen, denn das BIOS liest beim Start nur die Parameter der Platten aus, prüft die Kommunikation und startet sie dann. Ob die Laufwerke tatsächlich Fehler haben, kann es sowieso nicht erkennen, höchstens über die SMART-Funktionen, aber dann müsste die Meldung eigentlich anders lauten und deutlich auf einen SMART-Befund hinweisen (und DIr gleich noch sagen, welche Platte es genau betrifft) und nicht nur vage auf "Disk Read Error".

    Wenn Deine Hardware irgendeinen anderen Schuss hätte, müsstest Du das eigentlich auch und vor allem im normalen Betrieb unter Windows merken. Speicherfehler und Boarddefekte wirken sich sehr drastisch aus und nicht nur als eine kurze Fehlermeldung nach dem Start.
     
    Rainer_Hain, 07.08.12
    #9
    anthe bedankt sich.
  10. techno

    techno

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    wenn die platte nicht defekt ist, und motherboard-bios und sämtliche treiber auf dem aktuellsten stand sind und ein mobo-defekt/ bios-fehleinstellung auszuschließen ist, dann könntest du dich sonst auch folgendes noch fragen:
    hast du denn das sata-kabel schon mal gewechselt? (ist es vielleicht auch zu lang, altes sata1- kabel an sata2/3- festplatte (sollte aber eigentlich funktionieren)?) sind alle steckkontakte in ordnung, oder möglicherweise etwas korrodiert/ verunreinigt?
    wie verläuft das kabel im gehäuse? gibt es vielleicht irgendwo kreuzungspunkte mit elkos, stromkabeln, etc...? (sonst einfach die kabelführung so ändern, dass das nicht mehr der fall ist).
    ist dein rechnergehäuse vielleicht (einseitig, plexiglasfenster, etc. ) offen? ungeschirmte sata-kabel können bei offenen oder kunststoff-gehäusen unter umständen auch auf die datensicherheit und das was sozusagen vom lesen der platte am motherboard ankommt, negative effekte haben.

    ansonsten hab ich grad beim googlen bei manchen leuten den hinweis auf die repartur der partitionstabelle gesehen.
    mit dieser preboot-environment-cd kannst du evtl. die mbr reparieren:
    http://www.chip.de/downloads/Partition-Wizard-Bootable-CD_38297298.html

    wenn du die möglichkeit hast: vor reparatur der mbr bitte alle daten sichern, die sich auf der platte befinden (falls was schiefgeht). ;) :)

    edit, weil erst jetzt gesehen::
    schöne signatur :), danke für die bilder!
    wenn du das plexi-fenster tatsächlich so am rechner dran hast, dann solltest du vielleicht über geschirmte interne sata-kabel nachdenken. ich verwende geschirmte kabel vom conrad, die miefen leider etwas, aber wenn der gehäusekäfig mal offen sein sollte und der rechner läuft, hat man zumindest etwas mehr datensicherheit ähnlich wie bei externen sata-kabeln. ;) (die internen geschirmten sollte es für sata2 und 3 geben, wenn ich das recht in erinnerung hab, oder sonst einfach mal bei anderen händlern gucken.)

    eigentlich würde ich sonst nochmal versuchen, das betriebssystem mit geschirmten kabeln komplett neu zu installieren.

    edit #2:
    das offene computergehäuse würde ich auch etwas weiter von den lautsprechern weg stellen.
    sind die boxen geschirmt?
    auch den ram-tipp würd ich notfalls mal in erwägung ziehen. hast du denn schonmal mit memtest geschaut, ob damit alles in ordnung ist?
     
    techno, 07.08.12
    #10
    NoisiaTHX bedankt sich.
  11. anthe

    anthe

    Registriert seit:
    13.08.08
    Punkte:
    6.057
    6057
    noch was: schalte versuchsweise mal den wahrscheinlich eingeschaltenen quickboot modus im bios aus ...


    lg
    Andi
     
    anthe, 07.08.12
    #11
  12. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Thx für die Hilfe. Kann ich aber erst heute Abend testen. Bin noch im Studio.
     
    NoisiaTHX, 07.08.12
    #12
  13. Rainer_Hain

    Rainer_Hain

    Registriert seit:
    23.12.11
    Artikel:
    2
    Punkte:
    4.354
    4354
    Ich weiß, das ist alles lieb gemeint von Dir, aber sei mir nicht bös': Mit den Tipps wirst Du ihn noch eher ins Unglück (nächtelange, fruchtlose Bastelstunden) stürzen. Sein Problem hat ja nicht wirklich etwas mit Festplattenfehlern zu tun. Auch nicht mit einem fehlerhaften MBR (falls er den überhaupt noch hat, bei einer Platte über 2 TB gibt's den nämlich gar nicht mehr. Wenn Du eine solche Platte MBR-formatierst, verlierst Du die Kapazität über 2 TB). Wenn es daran liegen würde, könnte er Windows gar nicht mehr starten.

    Wenn es irgendeines von den Dingen wäre, für das deine Ratschläge eine Lösung wären, hätte er das an anderen Symptomen gemerkt. Es ist aber nur eine unschuldige Meldung des BIOS an einer Stelle, an der es noch gar keine echten Fehler gegeben haben kann.

    Schlechte SATA-Kabel, defekte Controller, defekten Speicher - gibt es natürlich alles. Aber das merkt man recht schnell an defekten Dateien und Blue-Screens und das hat er ja nun gerade nicht.

    Also bitte nicht gleich den Leuten empfehlen, mit Kanonen auf Spatzen zu schießen, auch wenn es noch so gut gemeint ist.
     
    Rainer_Hain, 07.08.12
    #13
  14. Cyclotron

    Cyclotron

    Registriert seit:
    06.05.11
    Punkte:
    259
    259
    Ich hatte das Problem neulich auch: Erst solche Disk Error Meldungen beim Start und beim Arbeiten öfter mal die Nachricht, dass bestimmte Dateien nicht geschrieben werden konnten (obwohl sie hinterher intakt und vollständig waren).

    Bei mir war es der langsame Netzteiltod. Seit dem Tausch gibt es keine deratigen Meldungen und Probleme mehr. Habe das aber erst herausgefunden, als sich sie Kiste erst nicht mehr aus- und dann nicht mehr einschalten lies. Offenbar hat die Leistung des NT schrittweise nachgelassen und immer mehr dieser merkwürdigen Ausfälle hervorgerufen.
     
    Cyclotron, 07.08.12
    #14
  15. techno

    techno

    Registriert seit:
    31.10.10
    Punkte:
    7.289
    7289
    wie ausdrücklich gesagt:
    die vorgeschlagenen punkte sind als weitere möglichkeiten zu verstehen.

    ich habe noch nie erlebt, dass ich bei der fehlersuche bei meinem rechner auf anhieb richtig gelegen bin. deshalb ist es zu diesem zeitpunkt auch nicht falsch, den hinweis mit den kabeln in die runde zu werfen.

    bei seinem offenen gehäuse würde ich ohnehin jedem ganz sicher zu geschirmten kabeln raten.

    übrigens hat er 3x 500gb-platten im rechner verbaut (siehe seine signatur). die laufen bestimmt mit mbr. ;)
     
    techno, 07.08.12
    #15
  16. Rainer_Hain

    Rainer_Hain

    Registriert seit:
    23.12.11
    Artikel:
    2
    Punkte:
    4.354
    4354
     
    Rainer_Hain, 07.08.12
    #16
  17. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    @ Rainer_Hain

    Was ja kein Problem ist, denn seine hat ja nur 2 Tb.
    Also ist die MBR-Ansage in diesem Fall fürn Wind.

    Naja.
    Dass während des Post Kabel und MBR keine Rolle spielen, hate ich für ein übles Gerücht. Es scheint mir, dass Du Deine Erfahrungen nur aus der Sorglos-Kabel Zeit hast. Ich kann mich jedenfalls noch gut erinnern an Situationen, bei denen die Kabel, der Controller und der MBR ne Rolle gespielt haben.
    Ausserdem weisst Du doch gar nicht, wie die Platte betrieben wird. Woher kannst Du dann sagen, dass es kein MBR-Fehler ist?

    Das halte ich dann für eine ziemlich freche Ansage.
    Mal soll einfach weitermachen, bis der Schaden gross genug ist? Würdest Du tatsächlich einem Kunden, der über Festplattenprobleme klagt, dazu raten, halt abzuwarten, bis die Platte wirklich die Grätsche macht und seine Daten in den Orkus schiesst?

    Das ist schon recht weit aus dem Fenster gelehnt.
     
    tubeless, 07.08.12
    #17
  18. NoisiaTHX

    NoisiaTHX Themenersteller

    Registriert seit:
    13.02.09
    Punkte:
    1.521
    1521
    Ist schon irgendwie witzig und traurig zugleich. Da habe ich mein Problem jetzt in vier Foren gepostet. Hier und auf Computerhardware-Foren. Hier wird versucht mir zu helfen und bei den Experten gibts wenig bis gar kein Feedback. Auf euch kann ich mich wenigstens verlassen! [​IMG]
     
    NoisiaTHX, 07.08.12
    #18
  19. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Hast Du jetzt mal Quick Boot ausgeschaltet?

    Alternativ kannst Du auch mal den Reset-Taster drücken, halten, den Rechner einschalten und die Resettaste fünf Sekunden oder so festhalten.
    Wenns dabei auch Fehler gibt, dürfte das Netzteil ausm Schneider sein, weil es Zeit genug hatte, hochzulaufen.

    Sollten die Platten zu spät gestartet werden, könntest Du sie auch mal extern mit Strom versorgen, sodass sie einfach durchlaufen.
     
    tubeless, 07.08.12
    #19
  20. anthe

    anthe

    Registriert seit:
    13.08.08
    Punkte:
    6.057
    6057
    Aus meiner Sicht ist es so, dass wenn man schon Tag u Nacht in dem Bereich arbeitet, treibt man sich kaum freiwillig in solchen ( Hardware) Foren herum ... ( das soll kein Seitenhieb für die AudioProfis sein :D )

    Ich persönlich würde vermutlich bei einem derartigen Fehler nicht zur Tagesordnung übergehen. Du hast auch nicht geschrieben wie Du die vorhandenen Platten genau getestet hast ? Wer ( welches TestProgramm ) sagt was genau ? Wie sehen die SMART Status Daten der Platten aus ? Genauere HW Daten ( MB, Platten(Typen) hast Du bis dato auch nicht bekannt gegeben ( o überlesen ? ). Sicherungen der relevanten Daten sind vorhanden ? Wie gesagt, easy BilligTests wären: andere Batterie ( done, richtig ?), andere/s Kabel ( done, richtig ?), ext. Controller ( billig ) evtl anderes Netzteil anklemmen ( ohne Ausbau des Originals)

    lg
    Andi
     
    anthe, 07.08.12
    #20
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.