Transmidifier


Rex
Rex
Registriert
19.07.12
Beiträge
2.001
Reaktionen
1.037
Punkte
5.265
Hallo,

Ich bin auf das tool "transmidifier" aufmerksam geworden, bringe es aber nicht zum laufen. Herstellervideo und Kommentare bzg. Cubase, VSE Logic haben mich auch nicht weitergebracht.

http://www.bewaryprods.com/software/products/TransMIDIfier/

Wie im Herstellervideo wollte ich mittels transmidifier mit Kontakt als VI verschiedene Artikulationen ansteuern. Alles spielt sich auf einem PC ab.


Als virtuelles Midicable verwendete ich "loopmidi"

http://www.tobias-erichsen.de/software/loopmidi.html


Wer von euch hat transfermidi auf studio one zum laufen gebracht und vor allem wie?

Oder weiß jemand generell was ich da wie einstellen muss (speziell die midi cable-Geschichte mittels externen Geräte)?

Selbst der Hinweis, dass es mit studio one nicht realisierbar ist, wäre schon hilfreich.
 
tubeless
tubeless
Gesperrter User
Registriert
02.05.09
Beiträge
15.308
Reaktionen
2.067
Punkte
22.901
Das Teil läuft nicht "auf", sondern "neben", so wie es aussieht, falls Loopmidi und externes Midi involviert ist. Da heissts dann S1 -> loopmidi -> TM _> midi output. Für den Fall, das Du es auf ein VSTi loslassen wiolltest, heisst es dann S1 -> loopmidi -> TM -> -> loopmidi -> S1 (das ist aber, aus meiner Sicht, mit dem Finger durchs Auge am Knie gekratzt.).

Ich nehme mal nicht an, dass Du Dir den USerGuide vom TM zu Gemüte geführt hast, denn dann würden Deine Fragen anders aussehen.
Jedenfalls führt da kein Weg dran vorbei, wenn Du verstehen willst, wie das Ding arbeitet.
Du hättest dann auch rausgefunden, dass TM kein VST ist, also auch nicht als solches "in" S2 arbeiten kann.
 
Rex
Rex
Registriert
19.07.12
Beiträge
2.001
Reaktionen
1.037
Punkte
5.265
Für den Fall, das Du es auf ein VSTi loslassen wiolltest, heisst es dann S1 -> loopmidi -> TM -> -> loopmidi -> S1
Ja, so sehe ich das auch. Genauer betrachtet mit zwei loopmid ports (einen als input den anderen als output) die ich als externe Geräte angelegt habe. Aber das funktioniert bei mir nicht trotz verschiedenster ausprobierter Varianten.


Ich nehme mal nicht an, dass Du Dir den USerGuide vom TM zu Gemüte geführt hast
Falsche Annahme! Mehr als einmal.


TM kein VST ist, also auch nicht als solches "in" S2 arbeiten kann.
Ich habe auch nicht behauptet dass es ein VST ist. Ist mir klar, dass es ein externes Programm ist, dass angesteuert wird.


Vielen Dank für deine bisherige Antwort.

Aber die eigentliche Frage, wie ich dass explizit mit Studio one zum Laufen bringe ist leider immer noch offen.

Noch weitere Ideen bzw, hat jemand Praxiserfahrung mit dem Teil?
 
tubeless
tubeless
Gesperrter User
Registriert
02.05.09
Beiträge
15.308
Reaktionen
2.067
Punkte
22.901
Aber das funktioniert bei mir nicht trotz verschiedenster ausprobierter Varianten.
DAS ist ne ziemlich allgemein gehaltene Ansage, mit der man schlussendlich nichts anfangen kann.

Bei dem, was Du da versuchst, gibts zu viele Möglichkeiten, warum "es" nicht funktioniert, besonders unter Anbetracht der Tatsache, dass dieses "es" nicht näher bekannt und spezifiziert ist.

Deshalb nutzt Dir meine Aussage sicher auch nichts, wenn ich sage, dass "es" bei mir funktioniert.....
Jedenfalls manchmal.

:D

Es bleibt dazu zu sagen, dass manchmal ein Neustart Wunder wirken kann, wenn man mit solchen Tools wie loopmidi rummacht und dabei des Öfteren mal den Treiber aufs Riff gesetzt hat. Wenn da irgendwas gecrasht ist, kann man danach alles mögliche probieren, es tut nicht richtig, man bekommt aber auch keine Fehlermeldung, wenn der MIDI-Treiber teilweise oder partiell tot ist.
 
Rex
Rex
Registriert
19.07.12
Beiträge
2.001
Reaktionen
1.037
Punkte
5.265
dass "es" bei mir funktioniert
Dann zeig doch mal, wie es funktioniert (zumindest manchmal).
Ist doch weitaus sinnvoller als wenn ich schreibe was bei mir, aus welchen Gründen auch immer, nicht funktioniert hat.

Screen shots wären am einfachsten und hilfreichsten:
Geräteeinstellungen für die zwei loopmidi ports
Transmidifier (input, output)-Oberfläche
miditrack spur-info (eingang, ausgang)


Mein Dank hierfür im voraus
 
tubeless
tubeless
Gesperrter User
Registriert
02.05.09
Beiträge
15.308
Reaktionen
2.067
Punkte
22.901
Macht nicht so richtig Sinn - und das jetzt nicht, weil Du meinem Vorschlag nicht folgen willst. ;)

Es würde Sinn machen, wenn ich wüsste, warum es funktioniert. Oder, warum nicht....
Vorauschicken muss ich, dass ich weder loopmidi noch Transmidifier für das Gelbe vom Ei halte - da sind mir die Funktionen etwas zu sehr vereinfacht und - aus meiner Sicht - ist schwer erkennbar, was das Zeugs macht.

In erster Linie aber ist es so, dass diese Umbiegereien des MIDI-Transports schon immer eine Ursache für Probleme waren, das war schon mit Hubi´s Cable si und hat sich nicht wirklich gebessert.
Am Bespiel loopmidi will ich das mal erklären.
LM fungiert als virtuelles Kabel. Da MIDI-Verbndungen eigentlich OneWay-Verbindungen sind, müsste LM also eigentlich pro angelegtem MIDI-Port zwei Anschlüsse haben - einen In und einen Out. Das alleine schon, weil Sequencer Ins von Outs unterscheiden, und ein LM-Port nicht einfach Beides sein kann - da bekommen Programme gerne mal Probleme.
Sowieso ist der Umgang mit solchen Progs wie loopmidi nicht ganz zweifelsfrei - je nach dem hängt sich das zwischengeschaltete Programm auf, der Sequencer oder der virtuelle MIDI-Treiber, und das zumeist ohne Fehlermeldungen.


Aber egal, wie man das sieht:
Generell funktioniert die Geschichte via loopmidi.
Das kann man einfach herausfinden, indem man LM installiert, einen Port anlegt und startet, dann den Sequencer anwirft und - in S1 jetzt - in den Optionen die jeweiligen Geräte einrichtet. Dabei ist LM-In als Keyboard und LM-Out als Instrument einzurichten.
Als Nächstes richtet man eine MIDI-Spur ein, verpasst der ein paar MIDI-Events, stellt den Ausgang auf den Ausgangs-LM-Port.
Dann eine Instrumentenspur mit irgendeinem VSTi und dessen MIDI-Eingang auf den Eingangs-LM-Port, scharfschalten und LS-Symbol aktivieren.

Nun sollte man den Synthie hören können, angesteuert durch die MIDI-Spur über den Umweg des LM-Ports. Damit ist schon mal sichergestellt, dass die Grundsätzliche Technik funktionsfähig ist.

Ob die ganze Sache dann mit zwischengeschaltetem externem Programm funktioniert, steht allerdings auf einem anderen Blatt.
MIDIfier jedenfalls scheint nicht gerade wirklich fehlertolerant - da LM den gleichen Port für Out wie In anbietet, und MIDIfier diesen Port als In wie auch Out einstellbar hat, ist ganz schnell mal ne Rückkopplung gelegt, einfach aus Unachtsamkeit.
MIDIfier aber wettert diese Situation nicht ab, sondern schmiert gerne mal komplett weg. Das erscheint nicht als grosses Drama, aber eben nur so lange diese Abstürze nicht den Rest beeinflussen - was aber leider passiert.
 
tubeless
tubeless
Gesperrter User
Registriert
02.05.09
Beiträge
15.308
Reaktionen
2.067
Punkte
22.901
Falls Du ein externes Instrument ansteuern willst, schickst Du die MIDI-Spur auf den ersten LM-Port, im MIDIfier setzt Du den In auf den ersten, den Out auf das externe Instrument, bei diesem dann, falls es ein SoftSynth ist, ist der In auf den LM-Port2 zu stellen.

Mit einem Hardwareexpander funktioniert das, da ich keinen Standalone-Softsynth im Moment startbereit habe, kann ich es nicht sagen, obs damit - und ner Umlenkung innerhalb von MIDIfier von einem auf den nächsten virtuellen Port - dann wirklich tut.
Die oben beschrieben Loopgeschichte mit S1 funktioniert nämlich nicht bei mir mit zwischengeschaltetem MIDIfier, warum auch immer. Das kann jetzt am Sequencer liegen, ich geh aber eher davon aus, dass MIDIfier mit den virtuellen Ports nicht so richtig klar kommt.......
 
  • Danke
Reaktionen: Rex
Rex
Rex
Registriert
19.07.12
Beiträge
2.001
Reaktionen
1.037
Punkte
5.265
@tubeless
Danke für die Hilfestellung. Werde es am WE nochmal versuchen, auf die Reihe zu kriegen. Obwohl dein letzter Satz ja nicht so optimistich klingt und meine anfängliche Begeisterung/Interesse (nach stundenlangen erfolglosen Versuchen) etwas abgekühlt ist. Die Verwendung virtueller midicable ist wirklich recht störanfällig.

Aufmerksam wurde ich übrigens auf transmidifier durch folgenden thread (post 17), da ich mit der Anschaffung eines solchen Blasumwandler liebäugle und mir die Artikulationsswitch-Verwendung auch nützlich erschien.

http://www.neotrax.de/hard-software...ler-für-100-00-euro-ja-und-genial/index2.html


Damit ist wohl das Lautsprechersymbol gemeint,

Wieso tauchen im Gerätemanager die Midiports eigentlich zweimal auf (normal und als emuliert). Wo liegt da der Unterschied und welcher ist zu verwenden (ich nehm mal an die emulierte Version)?
 
organix
organix
Registriert
08.11.02
Beiträge
2.027
Reaktionen
355
Punkte
3.185
@tubeless
Danke für die Hilfestellung. Werde es am WE nochmal versuchen, auf die Reihe zu kriegen. Obwohl dein letzter Satz ja nicht so optimistich klingt und meine anfängliche Begeisterung/Interesse (nach stundenlangen erfolglosen Versuchen) etwas abgekühlt ist. Die Verwendung virtueller midicable ist wirklich recht störanfällig.

Aufmerksam wurde ich übrigens auf transmidifier durch folgenden thread (post 17), da ich mit der Anschaffung eines solchen Blasumwandler liebäugle und mir die Artikulationsswitch-Verwendung auch nützlich erschien.

http://www.neotrax.de/hard-software...ler-für-100-00-euro-ja-und-genial/index2.html

Ich denke mal es ist vielleicht nicht ganz verkehrt, wenn ich mich hier zu Wort melde. Denn der oben erwähnte Bericht auf Neotrax.de stammt von mir.

Zuerst einmal folgender Hinweis.
Transmidifier (Tm) ist eigentlich als Zwischenprogramm gedacht um damit sehr flexibel Artikulationen bei Sample-Libs zu wechseln. Inzwischen wurde Tm aber erweitert und kann viel mehr.
Es ist aber, wie hier erwähnt, ein komplett eigenständiges Programm welches außerhalb der DAW läuft. Es nimmt MIDI von einem externen MIDI Gerät wie Keyboard, Blaswandler etc. entgegen und je nach Bedingung verschickt es transformierte MIDI Daten.
Damit die MIDI Daten aus Tm raus und in die DAW rein kommen, benötigt man ein virtuelles Midi Interface zwischen Tm und DAW.

Und damit fängt es an ein wenig undurchsichtig zu werden.

Für mich sind diese virtuellen MIDI Kabel nichts neues, denn da gab es schon früher auch immer mal wieder Bedarf dazu. Ich habe dabei schon viele unterschiedliche Lösungen dazu versucht und muss sagen, nur wenige funktionieren wirklich ordentlich.

Loopmidi hatte ich auch probiert, hat es aber nicht lange auf meinem Rechner ausgehalten bevor ich das Teil wieder deinstalliert hatte.
Ganz früher mal recht gut war das Maple Virtual Midi Cable und wurde damals auch von vielen Seiten empfohlen. Das Teil wurde aber nicht konsequent für neue Betriebssysteme weiterentwickelt und ab Windows-Vista war da Schluss mit lustig.

Mein bevorzugtes Produkt das ich auch schon lange zu meiner Zufriedenheit einsetze ist LoopBe30 von www.nerds.de.
Es gibt dieses auch als kleinere kostenlose 1 Port Version, das nennt sich dann LoopBe1.

So, jetzt noch zu einigen wichtigen Einstellungen.
Im Transmidifier wählt man für die Ausgabe den Port des virtuellen MIDI Kabel und für die Eingabe den MIDI Port eines externen Geräts wie Keyboard, Blaswandler etc.
(Wenn es nicht verständlich genug ist, liefere ich Screenshots noch nach, bin gerade nicht im Studio)

In StudioOne legt man den virtuellen MIDI Adapter bei den externen Geräten als MIDI-Keyboard an und wählt ihn dort aber nur als Empfangsgerät und nicht als Port zum Senden. Also nur bei "Empfangen von" auswählen, "Senden an" auf "Keiner" stehen lassen. Ansonsten gibt es MIDI Loops, worauf LoopBe zum Beispiel dann die Ports automatisch muted. (Midi Loop Detection)

In einem MIDI Kanal wählt man dann entweder nur dieses angelegte externe Midi Gerät als Eingang, oder aber "Alle Geräte" um auch parallel noch von anderen MIDI Geräten Daten empfangen zu können.

Das ganze funktioniert auf meinem System (Windows-7 x64) absolut problemlos.

Mit Transmidifier wird das möglich was S1 leider im Bereich MIDI nicht kann. Die Eingangsumwandlung von MIDI.

Gruß
Markus
 
  • Danke
Reaktionen: Rex
Rex
Rex
Registriert
19.07.12
Beiträge
2.001
Reaktionen
1.037
Punkte
5.265
@organix

Vielen Dank für deine hilfreichen Hinweise.

Die einfache Eingangsumwandlung von MIDI mittels TM funktioniert jetzt auch bei mir mittels deinen Einstellungentipps.

Kannst du noch erläutern wie man diese Artikulationsswitchgeschichte mittels TM auf S1 realisiert bekommt?
Steh da immer noch auf dem Schlauch.


Dein post auf neotrax war echt toll (gibts bei neotrax eigentlich keinen dank-button)l. Könnte man als Testbericht ausarbeiten und ev auch hier mal veröffentlichen.
 
organix
organix
Registriert
08.11.02
Beiträge
2.027
Reaktionen
355
Punkte
3.185
:)
@organix

Kannst du noch erläutern wie man diese Artikulationsswitchgeschichte mittels TM auf S1 realisiert bekommt?
Steh da immer noch auf dem Schlauch.

Im Prinzip funktioniert das ähnlich wie bei den anderen DAW's und ist vom Funktionsprinzip auch etwas abhängig ob das nur mit der DAW macht, mit einem Zusatzhost wie VE-Pro, oder mit Standalone Samplern etc.

Es ist dabei ein Punkt anders wie die reine MIDI Transformation wo ich beim Blaswandler mache. Und zwar der MIDI Eingang in Tm. Bei meiner Blaswandler Lösung gehe ich direkt mit dem MIDI Interface des Blaswandler oder eines Keyboards in Tm rein und von dort raus zur DAW.

Bei der Sache mit dem Artikulationsswitching aber geht man von einem MIDI-Track der DAW raus zum Tm und von dort entweder wieder zurück zur DAW oder einem Zusatzhost wie Ve-Pro.

Man legt also in der DAW einen MIDI Track an und wählt dort als MIDI Ausgang einen virtuellen MIDI Port aus. Dieser ist dann auch Eingang in Tm.
Soll die Ausgabe aus Tm wieder zurück zur DAW erfolgen, muss man auf einem zweiten virtuellen MIDI Port wieder zurück zur DAW und darauf achten, dass in der DAW dann alle notwendigen Tracks aktiv geschalten sind.

Hier würde also ein LoopBE1 nicht mehr ausreichen, weil man 2 MIDI Ports braucht. Einen für raus aus der DAW und einen für rein.
Bei loopMidi muss man auch mehrere Ports anlegen, einer reicht da nicht mehr aus.

Transmidifier ist recht flexibel und man kann das ganze auch auf noch mehr gleichzeitige Ein- und Ausgänge ausbauen.




Dein post auf neotrax war echt toll (gibts bei neotrax eigentlich keinen dank-button)l. Könnte man als Testbericht ausarbeiten und ev auch hier mal veröffentlichen.

Ich habe bei Neotrax (das Forum leite ich) keinen Danke-Button sondern halt einen Bewerten-Button. :)

Ich habe für später mal ein Video-Review noch zum Blaswandler geplant. In Bild und Ton ist das einfach noch besser darzustellen.

Gruß
Markus
 

Ähnliche Themen

moonbooter
    • Danke
  • Artikel
Testberichte Test: Behringer Pro-1
Antworten
5
Aufrufe
17K
moonbooter
moonbooter
moonbooter
    • Danke
  • Artikel
Antworten
0
Aufrufe
32K
moonbooter
moonbooter
moonbooter
    • Danke
  • Artikel
Antworten
2
Aufrufe
15K
moonbooter
moonbooter
moonbooter
    • Danke
  • Artikel
Antworten
0
Aufrufe
20K
moonbooter
moonbooter
Loop_Breaker
Antworten
0
Aufrufe
399
Loop_Breaker
Loop_Breaker
 

Aktuelle Beiträge


Oft gelesene Themen

Oben