Information ausblenden

Plugins steuern ohne Parametersprünge

Dieses Thema im Forum "Studio One" wurde erstellt von mackie1402, 08.06.20.

  1. mackie1402

    mackie1402 Themenersteller

    Registriert seit:
    18.07.03
    Punkte:
    2.532
    2532
    hi.
    sagt mal ist es möglich in Studio One plugins zu steuern ohne das man Parametersprünge hat? Ich habe den BCR200 Controller der ja Endlosregler hat,aber wenn ich das plugin wechsle dann springt es. In Cubase zb geht es, daher geh ich mal von aus das es nicht am Controller liegt

    Weis da jemand was?
     
  2. mackie1402

    mackie1402 Themenersteller

    Registriert seit:
    18.07.03
    Punkte:
    2.532
    2532
    geht anscheinend nicht...
     
  3. Navar

    Navar

    Registriert seit:
    07.11.07
    Punkte:
    1.636
    1636
    Ich muss gestehen, dass ich das Problem nicht richtig verstehe, also was da beim Plugin Wechsel springt, es sind ja andere Werte die dann anliegen mit anderen Ranges.
    Den BCR hab ich auch sehr lange benutzt und den auf NRPN konfiguriert damit ich nicht nur diese sinnbefreite 0-127er Auflösung habe und das hat extrem gut funktioniert nachdem ich das für den BCR richtig eingestellt hatte. Aber dazu musste ich mir ein eigenes File schreiben weil man den Controller in Studio One über die GUI für NRPNs nicht konfigurieren kann.
     
  4. richie

    richie

    Registriert seit:
    31.10.08
    Punkte:
    5.981
    5981
    Parametersprünge hat man immer dann, wenn der Controller zwar MIDI-Befehle senden aber nicht empfangen kann.

    Bei Plugin A drehst du mittels MIDI-Controller z.B. das Filter zu 100 % auf - in MIDI also Stufe 127.

    Du wechselst zu Plugin B, wo der Filter des Plugins B aktuell bereits zur Hälfte aufgedreht ist - in MIDI also bei ca. Stufe 64.
    Wenn jetzt Plugin B bzw. die DAW dem Controller mitteilen will "Hey ich stehe gerade auf Stufe 64. Mach bitte ab hier weiter." Der Controller aber die Nachricht nicht empfängt oder empfangen kann, sendet der Controller ab dem letzten Wert - also ab Stufe 127. Also springt das Filter von Plugin B sofort (ungewollt) auf Stufe 127 = Parametersprung.

    Wenn man das nicht haben will, muss der Controller MIDI-Daten ausgeben als auch empfangen können, damit dieser nicht immer "stur" ab dem letzten MIDI-Wert sendet.

    Der BCR kann das aber meines Wissen nach. In Cubase scheint's ja zu funktionieren. In Studio One müsstest du dann den BCR als MIDI-IN und MIDI-Out wählen.
     
    Schlumpfpeter bedankt sich.
  5. Navar

    Navar

    Registriert seit:
    07.11.07
    Punkte:
    1.636
    1636
    Geht ja prima in S1, Parametersprünge hab ich da nie gesehen, natürlich immer vorrausgesetzt, dass die Parameter eben auch geschickt werden, aber dafür muss es natürlich auf Senden und Empfangen stehen und auch im Mapping entsprechend eingestellt sein. Das ist in S1 aber die Standard Prozedur für Controller. Wie gesagt, hat bei mir perfekt funktioniert mit dem BCR und ich hab das Verhalten nie gesehen.
     
  6. mackie1402

    mackie1402 Themenersteller

    Registriert seit:
    18.07.03
    Punkte:
    2.532
    2532
    habe den bsr auch als midi in und oput eingestellt.habe n generischen controller in studio one angelegt und da halt midi in und out bsr angewählt.
    @Navar
    du hast geschrieben das du dir files schriben musstest .was für files waren das?für den bsr oder für stduio one die man irgendwie einbidet oder wie kann ich das verstehen?
    habe jetzt mla n poti auf nrpn gestellt.geht aber trotzdem noch nicht.
    wenn das wirklich mit studio ohne problme funzt wäre das n grund für mich komplett zu wechseln
     
    Zuletzt bearbeitet: 16.06.20
  7. Navar

    Navar

    Registriert seit:
    07.11.07
    Punkte:
    1.636
    1636
    Entschuldige, ich hatte da länger nicht reingeschaut. Also... so ganz kriege ich es nicht mehr aus dem Kopf zusammen weil das schon eine Weile her ist und ich den BCR mittlerweile nicht mehr benutze.

    Unter Windows finden sich die Dateien für die Devices unter (für Mac kann ich da nichts sagen, hab zwar einen, aber nur zum mobilen recorden):
    "Users\<UserName>\AppData\Roaming\PreSonus\Studio One 4\User Devices"

    In diesem Ordner werden neue User Devices angelegt, ein Devices besteht aus drei Dateien, dem surface.xml in dem hinterlegt ist wie das User Device quasi aufgebaut ist, also Buttons, Fader, Encoder etc. und wie die Dinger arbeiten und das Mapping wie sie vom Gerät kommen.
    Und dann gibt es noch eine .device Datei in der dann ein Interface hinterlegt wird und wo dann auch drinnen steht welche surface.xml Datei für dieses Gerät benutzt wird. In einem anderen Ordner (surfaceData) wird dann noch eine Datei abgelegt in dem dann das Mapping von Plugin->Value->Device->Encoder hinterlegt ist. Das wird natürlich automatisch von Studio One geschrieben wenn man das Parameter Mapping macht.

    Ich hab dir hier mal eine surface.xml angefügt die ich mir geschrieben habe, ob die top funktioniert kann ich leider gerade nicht testen. Schau mal da rein, ist nicht so schwer zu lesen. Die Encoder habe ich Studio One als Fader vorgegaukelt, damit hat das für mich am Besten funktioniert, ist ja letztlich egal, Hauptsache ist, er nimmt den aktuellen Wert vom Plugin und arbeitet damit weiter.

    Es tut mir leid, dass ich Dir das nicht besser erklären kann, hätte ich mein BCR noch hätte ich es schnell nochmal getestet. Leider ist das halt vollkommen undokumentiert und momentan sicher nicht so richtig dafür gedacht, dass der User da dran rumfummelt. Das ist aus meiner Sicht ziemlich schade, weil offensichtlich eine Menge Funktionalitäten unter der Haube existieren auf die der User keinen Zugriff hat, die aber verdammt nützlich wären. Ich hab mir das so aus anderen surface Dateien und ausprobieren zusammengeklaubt und das hat gedauert bis das gepasst hat. Wenn zu so etwas wenigstens eine Dokumentation existieren würde könnte die Community da auch deutlich mehr machen. Die Oberfläche in S1 selber mit der man das erstellen kann bietet nicht alle Funktionalitäten die verfügbar sind. Warum das so ist weiß ich auch nicht, vielleicht ist die Entwicklung an der Stelle gestoppt worden weil andere Dinge wichtiger waren oder aber es kann vielleicht zu Problemen kommen wenn da was falsch konfiguriert wird.

    Ich bin auch nicht der Einzige der das gemacht hat, ich meine mich daran zu erinnern, dass ich nach Recherche auch auf andere Anleitungen gestoßen bin die das besser beschrieben haben als ich das hier könnte. Ist halt nur dummerweise schon ziemlich lange her.
     

    Anhänge:

  8. mackie1402

    mackie1402 Themenersteller

    Registriert seit:
    18.07.03
    Punkte:
    2.532
    2532
    ey cool von dir ich test mcih da mal aus.FETTES Danke