Mit Touch Pads/Midi Keyboard einspielen ohne Delay

Dieses Thema im Forum "Ableton Live" wurde erstellt von freiezeit, 05.11.17.

  1. freiezeit

    freiezeit Themenersteller

    Registriert seit:
    15.03.17
    Punkte:
    22
    22
    Ist es möglich mit Midi Controllern wie novation launchkey und akai mpk mini in Ableton Drumgrooves und Melodien einzuspielen - OHNE - Delay?

    selbst bei 64samples puffergröße ist die Verzögerung so, dass ein saftiger Groove beim Einspielen schwer möglich ist.

    Gibts da irgendeinen Trick?
     
  2. clemensvill

    clemensvill Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    47.465
    47465
    Prinzipiell nein.
    Ohne Verzögerung geht nur mit Hardware.

    ABER:
    Bei 64 Samples sollte die Verzögerung sehr gering sein - ich würde als unbedingt die Einstellungen kontrollieren.
    (Bin aber kein Ableton-Experte) Es könnte auch am Plugin liegen.
     
  3. freiezeit

    freiezeit Themenersteller

    Registriert seit:
    15.03.17
    Punkte:
    22
    22
    Das äußerst Merkwürdige ist jedoch, dass ich in einem neuen Projekt nur eine Spur lade mit dem Piano von Ableton, also super wenig Rechenleistung. Wenn ich dann 64 Samples einstelle, gibt es einen guten Delay zwischen Antippen der Taste und dem Ton der erklingt.

    Stelle ich dann die Puffergröße auf 2048 Samples, IST DER DELAY GENAU SO LANG WIE BEI 64 SAMPLES.

    Da stimmt doch was nicht, das muss doch woanders dran liegen. Rechner ist tiptop und mein Audiointerface ist von Apogee das duet.

    Wo muss ich hier ansetzen? Mac os X Audio-Midi Setup?

    Das ding ist in Garageband ist das Delay viel kürzer, so, dass man richtig gut spielen kann. Das wirkt so, wie es sein sollte. Also liegt das Ganze wohl an Ableton?
     
    Zuletzt bearbeitet: 06.11.17
  4. freiezeit

    freiezeit Themenersteller

    Registriert seit:
    15.03.17
    Punkte:
    22
    22
    ok ich habs es waren zu viele plugins und spuren doch bereits drin im projekt... vom template her... keine ahnung wie man dann einen song damit produzieren soll?! wenn der schon anfängt mit diesen latenzen bei ein paar plugins?!

    gibts da nicht irgendwie eine Möglichkeit das zu synchronisieren mit einem externen Gerät (hardware) ? eine Art MIDI synchronisations Gerät, sodass der Rechner sich mit den Plugins beschäftigen kann und dieses Gerät die eingehenden MIDI Informationen managed?

    edit:

    Wenn ich bei einem Projekt, das noch nicht SO voll ist, auf externe Synchronisation klicke, bringt das schon was -

    ich verstehe aber nicht, wieso ich nicht in das track delay in Ableton gehen kan und dort ms / Samplerate von -23ms oder eben -1024 Samples einstellen kann. Das müsste doch die Rechenbelastung bei vielen Plugins und /oder die Puffergröße in den Haupteinstellungen ausgleichen?


    Leider passiert jedoch gar nichts....
     
    Zuletzt bearbeitet: 06.11.17
  5. clemensvill

    clemensvill Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    47.465
    47465
    Ich bin kein Ableton-User, aber es gibt doch bestimmt eine Einstellung, die der aktuellen Aufnahmespur eine Art Live-Priorität zuordnet.

    (Negatives) Track-Delay kann natürlich beim Einspielen nicht funktionieren. (Woher soll Ableton im voraus wissen, was Du gleich spielen wirst?) Track-Delay ist für die Wiedergabe gedacht - wenn Du z.B. ein Routing über einen Hardware- Aus-und Eingang machst.

    Hast Du mal getestet, ob es vielleicht an den Midi-Treibern liegt?
    z.B. Mikrofon neben das Akai und gleichzeitig das Klopfen per Audio und Midi aufzeichnen. Gibt es da Versatz?
    Hast Du unterschiedliche Plugins getestet? Insbesondere Sampler versus Synthese.
     
  6. Heartleader

    Heartleader

    Registriert seit:
    21.02.15
    Punkte:
    625
    625
    Mein Template hat ca. 180 Plugins (davon ca. 30 unterschiedliche) auf 60 Spuren geladen und ich habe 0 Delay. Hatte aber neulich mal den Effekt das ich eine Midi Verzögerung hatte. Hatte ein neues Plugin geladen was scheinbar den Fehler verursacht hatte und kaum habe ich es entfernt war das Problem gelöst. Habe das Plugin gleich gelöscht.
    Die Puffersize löst aber nicht das Problem wenn Du ein MIDI Latency hast (MIDI zu DAW). Es löst das Problem wenn Du ein Audio Latency hast. Du triggerst mit Dein Midi eine internes Instrument (MIDI Latency) und dann wird der Klang wiedergegeben (Audio Latency).
    Wenn Du jetzt kein Audiolatency mehr hast, lag es wohl an einen Plugin oder an der Vielzahl an Plugins. Den Treiber kannst DU schon mal ausschliessen. Besonders da Du gesagt hast das die Änderung der Puffergrösse kein Effekt hatte.
    Lade in einer Spur ein Instrument und step by step nach und nach alle Effekt-Plugins. Bei welchen Effekt Plugin passiert es das der Effekt auftritt? Wenn es in einer Spur nicht auftritt dann kopiere die Spur so oft wie Du Instrumente hast und wechsle nach und nach die Instrumente aus. Gibt bei einen Instrument das Problem?
    Ich bin damals auch so Vorgegangen und es lag dann nur an einen Plugin!
     
  7. Gilles

    Gilles

    Registriert seit:
    23.09.15
    Punkte:
    58
    58
    Ich würde mich mal durch das Ableton Handbuch wühlen. Ist sehr umfangreich, gut erklärt und beinhaltet zu jedem Thema was.
     
    Zuletzt bearbeitet: 22.11.17
  8. Peter Hansen

    Peter Hansen

    Registriert seit:
    24.08.17
    Punkte:
    44
    44
    Also ich mache es so, dass ich zuerst im Controller eine 4/4 Takt Sequenz mit einer Snare oder Clap generiere. Der Sound sollte eine kurze Attack und kurze Release haben (kannst Du auch noch über den Simpler oder Sampler editieren).

    Dann aktiviere ich das Metronom (Click) in Ableton und lasse das Projekt laufen. Man sollte jetzt das Sample und den Click von Ableton hören.

    Anschließend synchronisiere ich das nach Gehör. Dafür gibt es eine etwas versteckte Option die sich erst öffnet, wenn bei den Midi-Einstellungen bei den einzelnen Ports auf das kleine Dreieck vor den Geräten klickst.

    In der folgenden Anleitung unter Punkt 29.1.4 findest du das entsprechende Menü zum syncen.

    https://www.ableton.com/de/manual/link-synchronization-and-rewire/#synchronisieren-ueber-midi

    Als letztes checke ich das ganze nochmal mit einer kurzen Aufnahme der Midi-Daten weil mein Gehör doch manchmal etwas daneben liegt :D

    Achso und wenn du synchronisierst empfiehlt es sich etwaige Einstellungen wie "swing", "groove" oder "randomizer" im Projekt und im Controller zu deaktivieren.