Information ausblenden

MIDI-Aufnahme nur wenn Spur selektiert?

Dieses Thema im Forum "Logic" wurde erstellt von Grummelrocker, 05.03.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Grummelrocker

    Grummelrocker Themenersteller Moderator Ex-Rockstar Mitarbeiter

    Registriert seit:
    02.01.03
    Artikel:
    9
    Punkte:
    16.783
    16783
    Hallo zusammen,
    gestern habe ich was -für mich- seltsames festgestellt: Ich wollte zwei Spuren parallel aufnehmen, 1x Midi (Superior Drummer), 1x Audio (Bass mit IK Multimedia Amplitube).

    Auf beiden Spuren die Aufnahme aktiviert/scharf geschaltet und die Aufnahme begonnen. Wenn während des Klicks auf Aufnahme aber die Audio-Spur selektiert war, haben zwar auf beiden Spuren die "R"-Tasten geleuchtet, aufgenommen wurde aber nur die Audiospur.
    Wenn hingegen die MIDI-Spur selektiert war wurde diese aufgenommen, die Audio-Spur auch. So soll es ja auch sein. Da also alles bestens.

    Aber: Warum passiert das? Warum muss die MIDI-Spur *selektiert* sein damit da auch aufgenommen wird? Was wäre, wenn ich zwei MIDI Spuren parallel aufnehmen wollen würde? Ich kann ja nicht zwei Spuren parallel selektieren. Oder doch?

    Habe ich als Logic Noob da irgendwas verstellt?
     
  2. Flake

    Flake

    Registriert seit:
    11.05.07
    Punkte:
    1.240
    1240
    Ich kenne mich überhaupt nicht mit Logic aus und kann zum eigentlichen Thema nichts beitragen. Wenn ich aber mal von anderen Sequenzern auf Logic schließe, kann ich hoffentlich "kann ja nicht zwei Spuren parallel selektieren" widerlegen - außer bei Logic ist das komisch. Soll vorkommen.
    Solltest du's gar nicht hinbekommen, dass auch unselektierte Spuren aufgenommen werden (das klingt sehr, sehr komisch oO): Geht's bei Logic nicht mit Shift+Linksklick, mehrere Spuren zu selektieren?

    Edit: Respektive Shift+Klick bei der Apple-Maus. Oder eine andere Taste. Blöde Macs, ich kenn mich nich' aus! :D
     
  3. Grummelrocker

    Grummelrocker Themenersteller Moderator Ex-Rockstar Mitarbeiter

    Registriert seit:
    02.01.03
    Artikel:
    9
    Punkte:
    16.783
    16783
    Im Prinzip hast Du schon recht, ein mehrfach Selektieren ist vielleicht schon möglich. Mich wunderts halt, dass eine Audio-Spur aufgenommen wird wenn sie zwar "scharf" ist aber nicht selektiert, bei einer MIDI-Spur das aber nicht so ist.

    Damit muss man immer dran denken auch ja die MIDI zu selektieren...
     
  4. Flake

    Flake

    Registriert seit:
    11.05.07
    Punkte:
    1.240
    1240
    Ja, das wundert mich ja auch, obwohl ich Logic nicht kenne. War nur als Workaround gedacht, falls dieser Bug (ich hoffe, es ist einer ...) bestehen bleibt.
     
  5. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    35.564
    35564
    Ich möchte wetten, es gab da mal eine Einstellmöglichkeit, dass das Anwählen der Spuren, diese automatisch scharf schaltet. Ich komme aber ums verrecken nicht drauf, wo ... Daraus resultiert Dein Problem wahrscheinlich.

    Clemens
     
  6. Grummelrocker

    Grummelrocker Themenersteller Moderator Ex-Rockstar Mitarbeiter

    Registriert seit:
    02.01.03
    Artikel:
    9
    Punkte:
    16.783
    16783
    Nein, nicht wirklich. Mein Problem ist nicht, dass eine Spur automatisch scharf geschalten werden soll wenn sie selektiert wird (soll sie auch nicht!). Ich habe das Problem, dass auf einer MIDI-Spur die bereits scharf geschalten ist, nur dann aufgenommen wird, wenn sie während des Aufnahmevorgangs auch selektiert ist.
     
  7. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    35.564
    35564
    Ich verstehe was Du meinst und kann Dein Problem auch nachvollziehen.

    Ich meine aber, dass dieses Verhalten auf der von mir erwähnten Einstellung beruht.

    Clemens

    Edit:
    Im Logic-Handbuch steht übrigens explizit, man soll zuerst Audiospuren und dann Midispuren scharfschalten. Damit vermeidet man natürlich dieses Problem.
     
  8. frankye

    frankye

    Registriert seit:
    03.09.02
    Artikel:
    2
    Punkte:
    12.705
    12705

    Das ist so gewollt und mach auch völlig Sinn! Wenn Du 20 Instrumenten-Spuren hast kannst Du so schnell selektieren welches Instrument Du spielen willst. Das ist also das MIDI In Routing. bei Audio funktioniert es konzeptionsbedingt anders.
     
  9. Flake

    Flake

    Registriert seit:
    11.05.07
    Punkte:
    1.240
    1240
    Ohne jetzt zu sehr ins Offtopic abrutschen zu wollen: Welchen Sinn hat das Scharfschalten dann noch? Meines Erachtens sollte doch allein das Scharfschalten darüber entscheiden, auf welcher Spur aufgenommen wird und auf welcher nicht, ohne zusätzliches Selektieren. Das ist doch irgendwie eine Zwei-Klick- statt einer Ein-Klick-Lösung?
     
    Grummelrocker bedankt sich.
  10. frankye

    frankye

    Registriert seit:
    03.09.02
    Artikel:
    2
    Punkte:
    12.705
    12705

    MIDI Spuren werden automatisch "scharf" geschaltet. Das Verständnisproblem lag darin, dass bei MIDI Spuren kein Input-Routing vorhanden ist sondern das MIDI In Signal auf die Spure geroutet wird die man selektiert.
     
  11. clemenserwe

    clemenserwe Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    35.564
    35564
    Das ist so gewollt und mach auch völlig Sinn!

    Was mir im Moment nicht so recht in den Kopf will:

    Ich schalte (in genau der Reihenfolge) zwei Midispuren und eine Audiospur scharf und drücke Record.
    Verhalten in Logic Express 8.0.2:
    Beim Scharfschalten der Audiospuren sind die Record-Buttons der Midispuren komplett aus. Wenn man hinschaut sieht man wenigstens, dass wohl nichts aufgenommen wird.
    Verhalten in Logic Pro 9.1.6:
    Alle Record-Enable-Buttons leuchten kräftig rot. Man denkt also, alles wäre in Butter.

    Ergebnis bei beiden: Midi wird nicht aufgezeichnet.

    Dritter Versuch: Record enable in genau der gleichen Reihenfolge drücken und dabei "Shift" gedrückt halten -> Bewirkt eine Mehrfachselektion von der letzten angeklickten Midispur und der Audiospur. Audio und Midi wird aufgenommen.

    Meine Meinung:
    1. Es sollte eine Funktion implementiert sein, die sich den Record-Enable-Status von Midispuren auch beim Selektieren/Enablen von Audiospuren "merkt". (Wenigstens in den Einstellungen aktivierbar)

    2. Wenn das schon nicht der Fall ist, sollten wenigstens die Record-Enable-Buttons erlöschen, damit man vorher sieht, dass nichts aufgenommen wird.

    @Grummelrocker:
    Die Lösung für Dich liegt wohl im Versuch 3: Beim Scharfschalten von verschiedenen Spuren immer "Shift" gedrückt halten.

    Clemens
     
    Grummelrocker bedankt sich.
  12. Grummelrocker

    Grummelrocker Themenersteller Moderator Ex-Rockstar Mitarbeiter

    Registriert seit:
    02.01.03
    Artikel:
    9
    Punkte:
    16.783
    16783
    Sehe ich auch so - und hätte ich auch so erwartet.


    Genau so gings mir. Und deshalb kam mein Unmut auf.

    In der Tat: Die Lösung für mich ist dann "dritter Versuch". Aber unlogisch bleibts trotzdem ;-) Zumindest für mich. Wenn ich eine Spur (egal ob MIDI oder Audio) scharf geschalten habe sollte die auch aufnehmen. Egal ob selektiert oder nicht.

    Naja, Problem ist erstmal erledigt. Ich muss gerade eh etwas kämpfen... Wenn man 10 Jahre mit Cubase gearbeitet hat, gibt es zwar viele Dinge die in Logic ziemlich cool sind, aber der Cubase-Workflow (egal ob nun gut oder schlecht) hat sich halt schon in den Gehirnwindungen festgesetzt. Vom Stacked Recording über MIDI-Aufnahmen bis hin zum Drum-Editor.

    Ich bleibe mal dran und beisse mich fest :D Aber schwierig durchzuhalten ists grad schon...
     
  13. frankye

    frankye

    Registriert seit:
    03.09.02
    Artikel:
    2
    Punkte:
    12.705
    12705
    Gibt es in Logic schon seit ewig, auch bei MIDI. Einfach auf Ablage -> Projekteinstellungen -> Aufnahme gehen und dort bei MIDI den Aufnahmemodus für "Überlappende Aufnahmen" auswählen. Da geht mit Take Ordnern, oder neuen Spuren bei jedem neuen Cycle etc pp

    MIDI Aufnahme ist doch ganz simpel. Zuerst Audiopspur scharfschalten und dann einfach die MIDi Spur selektieren auf die Du aufnehmen willst, was ist daran kompliziert? Vergesst die Record-Enable Buttons bei MIDI Spuren, die verwirren nur ;-)
     
  14. Grummelrocker

    Grummelrocker Themenersteller Moderator Ex-Rockstar Mitarbeiter

    Registriert seit:
    02.01.03
    Artikel:
    9
    Punkte:
    16.783
    16783
    Das bestreite ich auch gar nicht ;) Nur wenn man von Cubase kommt hat man halt erstmal diesen Weg im Kopf.

    Ich habe nix von kompliziert geschrieben :D Nur von "unlogisch". Und das sehe ja nicht nur ich so ;)
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.