Information ausblenden

Groove Agent One und AKAI MPD32 -- MIDI CCs?

Dieses Thema im Forum "Cubase & Nuendo" wurde erstellt von setfire, 08.07.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. setfire

    setfire Themenersteller

    Registriert seit:
    08.02.06
    Punkte:
    26
    26
    Hallo zusammen,

    wie der Titel verrät, benutze ich das MPD32 mit dem GA1 (unter Cubase 5).
    Padzuweisung, Tempo-Sync und MMC-Transport sind alles keine Probleme, bzw. schon gelöst.

    Vielmehr benötige ich die die Controller Funktionen des MPD32 nicht zur Steuerung des Cubase -Mixers (also MPD32 als Generischen Controller), sondern ich würde gerne über die Fader und Potis per MIDI direkt die entsprechenden Parameter im GA1 steuern.
    Also Beispielsweise über Fader 1 am MPD die Lautstärke des dem Pad1 im GA1 zugewiesenen Samples, über Poti1 den Pan von Pad1, etc.
    Eigentlich sollte es ja mnn möglich sein, über die richtige MIDI CC den Parameter fernzusteuern, allerdings habe ich keine Ahnung, wie ich im GA1 z.B. dem Volume Regler von PADX ein MIDI CC zuweisen kann - auch die Plugin-Referenz von Cubase enthält dazu keinerlei Infos...

    In Kontakt ist es z.B. sehr einfach, da man jedem Regler per Rechtsknick ein MDI CC zuweisen kann.
    Der Rechtsklick funktioniert grundsätzlich auch im GA1, aber eben nur für die Zuweisung der Noten für die Pads, nicht für die virtuellen Potis (Volume, Pan, Cutoff, etc.)

    Würde mich freuen, wenn jemand einen Tip hat. Besten Dank im Voraus!
     
    setfire, 08.07.12
    #1
  2. rkdk

    rkdk

    Registriert seit:
    26.06.12
    Punkte:
    44.097
    44097
    darüber musste ich lachen... Rechtsknick ist gut! :-D

    Was ist mit den Quick Controls? da geht doch bestimmt was! schon probiert die mal einzusetzen?
     
    rkdk, 08.07.12
    #2
  3. setfire

    setfire Themenersteller

    Registriert seit:
    08.02.06
    Punkte:
    26
    26
    Oh, jetzt muss ich auch lachen...[​IMG] Rechtsknick...


    Habe soeben herausgefunden, dass mein Vorhaben doch über die Funktion des MPD als generischer Controller umsetzbar ist, da im Konfigurationsdialog des GC auch Parameter gelader Plugins zur Verfügung stehen.

    Hätte ich allerdings rkdk's Tip nicht bekommen, hätte ich vermutlich nicht versucht die Quick Controls über den GC zu steuern und wäre somit auch nicht zufällig auch GA1 - Parameter gestoßen. Also besten Dank an rkdk und noch nen schönen Sonntag!
     
    setfire, 08.07.12
    #3
  4. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Hallo, bitte entschuldigt, dass ich hier Totengräber spiele. Allerdings habe ich den Thread bei meinen mittlerweile seit 2 Stunden andauernden Nachforschungen gefunden und er passt einfach zu gut, um mein Problem nicht in seinem Zuge zu schildern.

    Also.. Ich möchte die Parameter des GA1 mit meinem LPD 8 steuern. Beispielsweise für den Coarse-Wert des Pads "C1"

    Jetzt habe ich den Generischen Controller soweit eingestellt, aber es tut sich nichts...

    Hier mal ein Screenshot der Einstellungen:
    http://s14.directupload.net/images/140512/g6qbpie7.jpg

    Dieses Setting, das mir das einzigst logische erschien, funktioniert NICHT. -.- Und ich bin etwas gereizt ob dieser Tatsache.

    Alle anderen Konfigurationsversuche sind ebenfalls gescheitert. Der GA1 ist übrigens via Instrumente-Rack geladen, nicht als Instrumentenspur.

    Wie konfiguriert Ihr die Parameter des GA1? Könnt ihr mir helfen? Ich bin am Durchdrehen..
     
    JohnnyTime, 12.05.14
    #4
  5. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Nimm lieber nur die Quick Controls dafür anstatt die Generic Remote.
    Geht schneller, der LPD hat ja auch nicht mehr als 8 Regler.
     
    Beatback, 12.05.14
    #5
  6. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Jop.. Jetzt der Haken: Ich habe mir ebenfalls ein MPD32 bestellt, das heißt, das Problem, dass ich damals schon nicht lösen konnte, bevor ich auf Quick Controls umgesteigen bin, holt mich wieder ein. Irgendwie muss das Problem aber zu lösen sein. QC bieten nur 8 Spots, ich habe aber mit dem MPD32 viel mehr zur Verfügung, die ich auch nutzen will. Und deshalb will ich das Problem schon mal mit dem LPD8 lösen, dessen Regler ja nicht anders funktionieren. Dann habe ich weniger Ärger, wenn das MPD32 angekommen ist.

    Kennt also jemand einen Ansatz? Irgendwie muss doch ein im Instrumentenrack geladenes Instrument per Generic Controller zu steuern sein.. Verdammte....
     
    JohnnyTime, 12.05.14
    #6
  7. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Du solltest erst mal mit dem MidiMonitor als Insert gucken was denn der Controller so sendet und im oberen Kasten eintragen.

    Du hast die Parameter fest auf den GA1 in der Generic Remote gemapped, d.h. wenn du einen 2.lädst kannst du den so nichst steuern.
    Du kannst nur den GA1 steuern der sich in dem Slot befindet wie du ihn angelernt hast.
    Sonst musst du das über Auswahl machen.

    Hier mal ein Ansatz für die Quick Controls:
     

    Anhänge:

    Beatback, 12.05.14
    #7
  8. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Danke Beatback fürs Feedback :)

    Wärst Du bitte so nett und versuchst einmal, mit deinem Midi-Controller einen Parameter eines Pads eines im Instrumentenrack geladenen Groove Agent Ones anzusteuern.

    Genau da hakt es nämlich bei mir. Plugins oder Transportfunktionen stellen kein Problem da. Irgendetwas scheint mit der Zuweisung falsch zu sein.

    Gruß
     
    JohnnyTime, 12.05.14
    #8
  9. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Welche Cubase Version hast du denn ?
     
    Beatback, 12.05.14
    #9
  10. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Ich wäre ja schon froh, wenn das funktionieren würde. Aber nicht mal bei dem 1. gemappedtn^^ tut sich was..

    Allerdings klingt Dein Ansatz vielversprechender! Wie schaffe ich es, den Parameter der GA1s in der Mehrzahl meinem LPD8 Regler zuzuweisen?

    Deshalb würde ich gerne auf Deinen obigen Ansatz weiter eingehen: In welchen obigen Kasten soll ich die vom Controller gesendeten Midi-Werte eintragen? Und wie schaffe ich es, die Parameter so anzusteuern, dass jeder geladene GA1 angesteuert wird? So weit bin ich bisher noch gar nicht gekommen, klingt aber als wäre es die vernünftigste Lösung.

    Danke für Deine Hilfe, ich freue mich auf Deine Antwort!

    Ach ja, ich nutze 5.5.3. Aber ich denke mal, das Zuweisen funktioniert vom Prinzip her in jeder Version gleich.
     
    JohnnyTime, 12.05.14
    #10
  11. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Nein, in 6 , 7 und 7.5 hat sich einiges geändert.
    Grundsätzlich funktioniert das mit der Generic Remote aber gleich es sind nur Dinge hinzugekommen.
    Im Prinzip musst du nur drauf achten das du im unteren Kasten mit der Auswahl arbeitest.
    Das bezieht sich dann auf das selektierte Gerät (Audiochannel im Mixer oder Midi Klangerzeuger im Midi Mixer).
     
    Beatback, 12.05.14
    #11
  12. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Eh..... ich kann nicht mehr ganz folgen. Tut mir Leid, dass ich Dich hier so herhalte, aber wenn wir das einmal durchklären, profitieren vielleicht noch andere davon, wenn sie ein ähnliches Problem googlen.

    Also noch mal: Ich habe ja oben den Screenshot gepostet. Diese Konfig. funktioniert nicht, was ich nicht verstehe.

    Der Sampler GA1 ist ja ein MIdi-Klangerzeuger. Wähle ich jedoch Midi-Mixer als Gerät aus, kann ich die Parameter des GA1 nicht mehr auswählen. Also wieder keine Lösung :(

    So. Deshalb was anderes: Ich glaube, mit Deinem Ansatz hast Du mich zum Kern der Midi-Technik gebracht, mit dem sich alle Probleme lösen lassen, wenn man es verstanden hat. Sorry, ich bin etwas unwissend, da ich mich bisher noch nie intensiv damit auseinandersetzen musste (die Quick-Controls boten einen Ausweg).

    Deshalb will ich jetzt die Frage umformulieren:

    Wie kann ich die Drehregler meines LPD 8´s bestimmten Parametern des Groove Agent One zuweisen? Auf die Art, die Du angesprochen hast, dass nicht ein spezieller GA dem Regler zugewiesen wird, sondern jeder, der hinzugefügt wird?

    Und dann noch etwas anderes: ich habe den Midi-Monitor als Insert geladen und mal geschaut: Ergebnis:

    Die Pads werden angezeigt, aber die Regler komischerweise überhaupt nicht. Und das OBWOHL der Midi-Input von Cubase und auch dem Plugin ausschlägt beim Drehen der Regler.
    Deshalb habe ich mal im Konfigurationsprogramm des LPD nachgeschaut: Den Drehreglern sind Werte zugewiesen. Deshalb verstehe ich schon wieder nicht, warum die Regler beim Drehen im Midi-Monitor nicht erfasst werden.. Via Quick-Controls reagieren die Regler ja auch.

    Gruß!
     
    JohnnyTime, 12.05.14
    #12
  13. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Dann solltest du erst einmal wissen was die Regler senden, sonst kann das ja gar nicht funktionieren!
     
    Beatback, 13.05.14
    #13
  14. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Den Reglern sind CC-Werte zugewiesen. Aber aus irgendeinem Grund erkennt der Midi-Monitor nur die Pads, nicht eine Aktivität der Drehregler. Ich habe auch noch andere Plugins ausprobiert, scheinbar reagiert keines mehr auf die Regler. ES SEI DENN, ich nutze Quick Control. Langsam verstehe ich die Welt nicht mehr.. Kann mir das jemand erklären?

    Hier mal zwei Screenshots, einmal aus dem Programm des LPD8, auf dem man die Zuweisung der Regler sieht, und einmal eins vom Midi-Monitor, der den Ausschlag eines Pads zeigt, aber nichts, was die Regler senden, und das OBWOHL die MIDI-Anezeige in Cubase ausschlägt.

    [​IMG]

    [​IMG]
     
    JohnnyTime, 13.05.14
    #14
  15. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Mach mal im Midi Monitor "Single CC7" aus, dann bekommst du auch die anderen CCs angezeigt!
     
    Beatback, 14.05.14
    #15
  16. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    Du musst die zuweisung zu den Quick Controls erst mal aufheben (Midi In vom MPD rausnehmen, damit Cubase die CCs in der Generic Remote bekommt).
     
    Beatback, 14.05.14
    #16
  17. JohnnyTime

    JohnnyTime

    Registriert seit:
    21.03.14
    Punkte:
    29
    29
    Das waren wie es scheint die entscheidenden Hinweise. Ich versteh zwar nicht genau, warum es jetzt funktioniert, aber na ja..

    Jetzt kann das MPD kommen :)

    Hier mal ein funktionierendes Setting für die Nachwelt:

    [​IMG]
     
    JohnnyTime, 14.05.14
    #17
  18. Beatback

    Beatback Außensaiter

    Registriert seit:
    13.03.08
    Punkte:
    15.535
    15535
    All Midi Ins ist aber nicht richtig als Midieingang.
    Eigentlich sollte nur dein LPD Midi eigetragen sein.
    Unter Midi Anschluss Einstellungen solltest du dann beim LPD Midi Eingang den Haken bei "all Midi Ins" wegmachen.
    Sonst nimmst du nämlich auf den Midispuren mit All Midi Ins als Midi Eingang die CCs mit auf, wenn du einspielst.

    Mit der Konfiguration bist du ausserdem auf dein Projekt angewiesen mit welchem du die Generic Remote angelernt hast.
    Verschiebst du den GAO in einen anderen Instrumentenslot kannst du ihn nicht mehr so steuern.
    Deswegen solltest du das ja mit der Auswahl machen.

    So hier mal das Beispiel mit der Auswahl:
     

    Anhänge:

    Beatback, 16.05.14
    #18
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.