Information ausblenden

Focusrite: Kurze Aussetzer während des Abspielens

Dieses Thema im Forum "Audio-Interfaces & Soundkarten" wurde erstellt von Jazzman_Marburg19, 23.02.19.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Jazzman_Marburg19

    Jazzman_Marburg19 Themenersteller

    Registriert seit:
    23.02.19
    Punkte:
    3
    Hallo zusammen.
    Bin neu hier und würde mich über eine Antwort sehr freuen.
    Ich habe mir eine Focusrite Clarett 2Pro USB angeschafft. Bin bisher sehr zufrieden (DAW Reason, Recording meist Gitarre) - bis auf kleine Aussetzer (Knackser) während des Abspielens von YouTube Videos.
    Ja - YouTube Videos...
    Keine Probleme wenn ich lokale mp3 abspiele oder mit Audacity einen Dauerton von 2 min Länge erzeuge.
    Habe bereits mehrere Browser (Edge, Chrome) ausprobiert (Win 10). Kein Erfolg. Mit Vimeo-Videos traten diese Knackser leider auch auf.
    Es handelt sich um Knackser die nach ca. 1-2 min auftreten. Und dann immer wieder etwa mit dem gleichen Abstand. Irgendwie hört es sich so an als ob eine Puffer vollläuft und das System beim nachladen oder Löschen des Puffers, eine kurze Atempause benötigt.
    Die aktuellsten Treiber von Focusrite sind drauf. Leider finde ich keine großen Einstellmöglichkeiten zum Abspielen in der Focusrite Software.
    Habt ihr eine Idee wonach ich noch schauen könnte oder welchen Test ich noch machen soll um das Problem besser einzugrenzen?

    Vielen Dank
    Gruß, Jazzman
     
    Jazzman_Marburg19, 23.02.19
    #1
  2. holgi

    holgi Moderator Mitarbeiter

    Registriert seit:
    11.09.05
    Punkte:
    51.271
    51271
    und in Reason isses ok?
     
    holgi, 23.02.19
    #2
  3. Jazzman_Marburg19

    Jazzman_Marburg19 Themenersteller

    Registriert seit:
    23.02.19
    Punkte:
    3
    Ja - in Reason konnte ich keinen Aussetzer feststellen.
    Irgendwie habe ich das Gefühl es konzentriert sich auf YT.

    (Danke für die schnelle Reaktion!)
     
    Jazzman_Marburg19, 23.02.19
    #3
  4. Gel Mitglieder 58746

    Gel Mitglieder 58746 Guest

    Punkte:
    0
    Ich besitze seit einigen Jahren Audio Interfaces des Herstellers. Und Audio Aussetzer kenne ich auch.. allerdings ist die Ursache schwer zu finden! In der Regel sind es aber Treiber bedingte Probleme. Doch dazu muss ich etwas ausholen wie ich zu dem Schluss kam. Und es kann durchaus sein das dies bei deinem PC vollkommen andere Gründe hat.

    Wenn es nur bei dem Cacheing von Streaming Webseiten auftritt muss der Fehler darin zu finden sein das etwas zwischen deinem
    a) Treiber und dessen Audio Ausgabe und
    b) dem Ursprung des Datenstromes
    nicht so harmoniert wie es sein "sollte". Soweit ist es auch sicher leicht verständlich.

    Ein Browser ruft für gewöhnlich über einen Funktionsaufruf zb. Flash oder andere Webbasierte Protokolle auf. Welche dann beim Play drücken den Aufruf erhalten Daten von X ab zu rufen. Dieses Abrufen kann bereits seitens der Provider "gebremst" werden. Und gibt bekannte *hust Teleko...unikations* Anbieter welche gerne auch mal ihren eigenen Streaming Diensten Prioritäten zu schustern.

    Nun muss es ja nicht am Provider liegen. Schließe ich DAS mal aus geht die Fehlersuche bei der Software los welche das ganze abspielt. Zb. Flash Player oder aber in die Browser Integrierte Software Player Lösungen.
    -> Sind diese nicht aktuell - kann das ein Problem verursachen.
    -> Sind die Settings für die Bandbreite ungeeignet - kann das Probleme verursachen (automatisches anpassen der Qualität kann Buffer Probleme verursachen).
    -> Browser können auch mal hängen und sich nicht aktualisieren.
    -> Browser Cache kann GIGABYTES an Müll belegen prüfe mit CCleaner mal die Temp Daten deines Browsers.

    Gehe ich davon aus, alles is fein. Es gibt immer noch Audio Aussetzer. Haben wir bereits vieles ausschließen können. Nun müssen wir Technisch denken! Der Stream läuft durch deinen Router. Wann wurde der das letzte mal neu gestartet bzw. ist die aktuelle Firmware darauf? Ja ja ? Weiter..

    Also der Stream wird ins Ram oder die Festplatte gebuffert. Wenn dein Ram aber nicht sauber läuft weil du irgendwelche Extreme Memory Profiles eingestellt hast und deine Festplatte nicht nach kommt oder umgekehrt in dieser Konstellation irgendwas nicht mit der Lankarte deines PCs sauber zusammen läuft kommt es zu einer Fehler Korrektur.

    Entweder Netzwerkbedingt durch Paketverluste bereits zwischen Lankarte und zb. Youtube Server. Dann könnte der Router wohl möglich nicht gut tun oder irgendwo schießt was in den Datenstrom - das kann bis zu ner schlechten Abschirmung gehen. Wenn du zb. ne alte ISDN Leitung aus den 80er/90er Jahren mit 50Gbit DSL zu bombst. Können Paketverluste auftreten welche dann FEHLERPROTOKOLLE Triggern. Diese lösen dann eine Paketfehler Anforderung aus. Wenn ein Stream nun gerade Buffert und es kommt zu solch einem Fehler - weil Paket 1289493 von 120909235013914 nicht korrekt geladen werden konnte wird für gewöhnlich der Bufferprozess unterbrochen. Das Fehlerhafte Paket erneut angefordert und danach geht das Buffering weiter.

    Das Problem dabei ist - wenn Audio und Video Daten getrennt geladen werden kommt es schon gerne mal zu einem Asynchronen Download. Und das kann dann richtig ärger bedeuten.

    In verschiedensten Variationen kann also je nach dem WO der Fehler liegt, dies zu einem Datenversatz / Delay führen welcher sich dann bis auf die Digital Analog Wandlung deiner Soundkarte durch zieht. Wenn diese dann zb. viel zu agressiv ausliest und dein Speicher oder Buffer kommt nicht nach. Kann sich das auch aufschaukeln. Und es kommt nicht nur zu hängern sondern zu Dropouts. Welche dem Player zu verdanken sind, der versucht Audio und Video Sychron wieder zu geben.

    Nun kann es aber sein das Netflix spinnt, Maxdome Läuft, sky läuft und Youtube spinnt. Aber Amazon Prime läuft wieder.. das lässt sich so erklären das jeder dieser Dienstleister andere Technologien und Player nutzt. Einige davon verwenden eine hochwertigere Buffering Funktion und Exklusive Bandbreiten Server. (gerade bei Bezahl Services zahlt man für die stabile Bandbreite!) Aber auch da kann es manchmal spinnen. Zb. wenn das Video 4k gespielt werden soll und man nur ne 5000er Leitung hat. Da rennt der Buffer dann gegen die Playtime weil schneller abgespielt wird als herunter geladen werden kann.
    Youtube macht zb. gerne eines - es beginnt lofi und geht dann wenn es genug gebuffert hat in HD hoch. Netflix und Sky machen das ebenso. Nachteil aber bei Netflix ist - hängt der Stream buffert es wieder lofi. Und dieser Modus Wechsel kann ebenfalls probleme verursachen. Weswegen eine Devise lautet Check out was du normal spielen kannst und stelle es in deinen Player Optionen FEST ein.

    Alternativ können auch unterschiedliche Browser oder Webseiten helfen! So kann ich gerade bei Live Streams ein leidvolles Lied singen das ich bei ARD / ZDF über deren Webseite andauernd Playerabstürze erlebte. Der SELBE Stream aber über Youtube direkt - lief 1a.
    Oder aber ich konnte über Chrome abspielen - ebenso über Firefox aber nicht über Internet Explorer oder Edge. Auch umgekehrt schon erlebt.

    Und nicht zu letzt kann es ja auch sein, das deine Soundkarte als USB Device von Windows 10 selbst terminiert wird. zb. weil warum auch immer die Energiesparfunktion den "ungenutzten" Usb port ausgeschaltet hat. Passiert gerne mal bei USB Festplatten. Da deaktiviert MS einfach mal Ports.

    Es kann aber auch schlicht in einem Windowsupdate begründet sein.. Windows 10 baut gerne mal Scheiße. Und nebst dem Update selbst das man dann in krasser not selbst finden muss wenn es überhaupt daran liegt - kann auch das Downloaden selbst ÄRGER bei Streaming verursachen! Denn der Service von MS reserviert sich für die Downloadzeit immer die VOLLE Bandbreite die zur Verfügung steht. Lädt nun also ein Update zb. Releasebuild mit 7 Gb im Hintergrund und installiert im Hintergrund - muss man nicht lange fragen da kann ALLES an Randerscheinung auftauchen! BSOD inclusive.

    Doch irgendwie glaube ich - bringt dich all das nicht weiter. Wenn all das nicht hilft hol dir mal ne andere Soundkarte eines anderen Herstellers und schau ob es irgendwelche relevanten Unterschiede gibt. Wenn ja - läuft tatsächlich der Treiber auf deinem System nicht rund oder verursacht Probleme mit deiner Hardware. Das ist auch möglich.
     
    Gel Mitglieder 58746, 14.03.19
    #4
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.