Information ausblenden

Auslastungs-Peaks im "Leerlauf"

Dieses Thema im Forum "Logic" wurde erstellt von Kassette, 24.06.20.

  1. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Moin Leute,

    hat jemand eine Ahnung, wie es zu diesen periodischen Auslastungspeaks kommen kann?
    Das Projekt ist im Leerlauf, also keine Wiedergabe oder irgendwelche anderen Aktivitäten.
    Da das hier ein alter Rechner ist, behindert mich das aber auch beim Abspielen usw.

    Die Projekte haben einige Spuren, als Schuldigen habe ich Superior Drummer 3 identifiziert.
    Deaktiviere ich das SD3 Plugin, ist sofort Ruhe.
    Kann es sein, dass das die permanente Midi - Abfrage ist?

    SD3_Auslastung.gif
     
  2. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Midi kann man schon mal ausschließen, wenn ich den Eingang deaktiviere, bleibt die Auslastung trotzdem.
     
  3. Supercreative

    Supercreative

    Registriert seit:
    29.06.14
    Punkte:
    2.321
    2321
    Würde mich auch mal interessieren.
    Ich habe hier ähnliche mit dem Maschine-Plugin gemacht.

    Ich nehme an das auch bei Leerlauf eines solchen Plugins etwaiige gehostete SubPlugins die CPU belasten.

    Erst dachte ich, mit dem AN/AUS-Button im Spurheader bekäme man das schnell in den Griff. Ist aber nicht so. Letztendlich deaktiviere ich das Plugin immer manuell im Kanalzug.
    Ist nur doof, dass man das Plugin dort immer manuell aus- bzw. einschalten muss. Das geht doch bestimmt einfacher, oder?
     
  4. digi

    digi DJ

    Registriert seit:
    01.10.14
    Punkte:
    5.138
    5138
    Ich habe das mal eben versucht zu simulieren. Bei mir ist absolute Stille. Hast Du auf der Spur noch andere Effekte? Vielleicht sogar noch ein Demo VST, die machen ja öfter solche Geräusche.

    Bildschirmfoto 2020-06-24 um 09.44.13.png
     
  5. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Beim Weiterverarbeiten schon (aber da arbeite ich eh nur mit Multi-Output), hier jetzt nicht.

    Bildschirmfoto 2020-06-24 um 09.52.31.png
     
  6. don_looney

    don_looney

    Registriert seit:
    24.06.20
    Punkte:
    29
    29
    Benutzt du VST2 oder VST3? Bin kein Live User und habe Superior Drummer 3 nicht, aber ich habe manchmal Peaks in Bitwig wenn ich VST3 nutze, z.B. bei Softube.
     
  7. SilentWarrior

    SilentWarrior Schrauber

    Registriert seit:
    21.07.17
    Punkte:
    20.068
    20068
    Es wundert mich. Gerade AU war doch immer so, wenn nicht gearbeitet wird, dann tut Plugin kein Saft ziehen.

    Da muss in SD irgendein "Echtzeit" Tool aktiviert sein. Evtl.irgendein Tape Effekt das pausenlose mit läuft oder so.
    Es muss von SD ein interner Effekt sein, alles andere macht keinen Sinn.
     
  8. Entone

    Entone Triangelspieler

    Registriert seit:
    04.01.03
    Punkte:
    17.848
    17848
    Früher gab es mal dieses Denormalisierungsproblem bei manchen CPUs, das hatte ich auch bei einigen Plugins. Da gab es dann "CPU-Spikes". Dagegen halfen spezielle Plugins, die ein sehr geringes Rauschen verursacht haben im 1. Pluginslot.

    http://www.digitalfishphones.com/main.php?item=2&subItem=6
     
  9. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Das denke ich auch. Werde gleich mal das processing in SD durchgehen. Da passiert ja schon einiges. Tape ist auch dabei.
     
  10. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    :)
    Danke, aber da passt ja genau gar nichts zu meinem Problem. :D
    Außer, dass ich auch kein live-User bin.
    Trotzdem nett, dass du versucht hast zu helfen.
     
    rkdk bedankt sich.
  11. bafc24

    bafc24

    Registriert seit:
    30.08.12
    Punkte:
    6.130
    6130
    Logic kann glaub kein VST:(
     
  12. rkdk

    rkdk

    Registriert seit:
    26.06.12
    Punkte:
    38.803
    38803
    Hast du es denn mal mit der AAX Pluginversion probiert?

    :D

    Ok, reicht jetzt, hilft dir nich weiter, ich weiss.
     
  13. don_looney

    don_looney

    Registriert seit:
    24.06.20
    Punkte:
    29
    29
    Wusste nicht das Logic kein VST unterstützt und ich dachte du nutzt Live. Auf dem Bild von digi ist Live im Hintergrund zu sehen, dachte das du es auch nutzt. Dort läuft AU/VST/VST3.
     
  14. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    20.857
    20857
    Klicke den An/Aus-Button mal mit gehaltener Alt-Taste. Da wird das Plugin wirklich komplett deaktiviert (und bei samplebasierten Plugins werden auch die Samples aus dem RAM geworfen). Indiziert wird das dann durch einen "verwaschenen" Plugin-Namen.
    Sämtliche Settings bleiben erhalten.
    Spur_Aus.jpg
     
    digi und Supercreative bedanken sich.
  15. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Wir sind doch hier aber im Logic-Bereich.
     
    sas und Supercreative bedanken sich.
  16. don_looney

    don_looney

    Registriert seit:
    24.06.20
    Punkte:
    29
    29
    Tja das hab ich gar nicht gesehen :D
    Bin neu im Forum :)
     
  17. Supercreative

    Supercreative

    Registriert seit:
    29.06.14
    Punkte:
    2.321
    2321
    Sehr geil! Danke!!! Tag gerettet :D:D:D

    Hab mir gerade mal im Maschine-Plugin alle Instrumente, Samples und FX-Plugins rausgekickt, um mal zu sehen, wie sich die CPU-Auslastung darstellt. Da sehe ich keine wirkliche Pegelbewegung (Spitzen). Wenn ich das Plugin dann komplett rausnehme ist das bisschen CPU-Auslastung schließlich ganz weg.

    @Kassette
    Ich denke es liegt demnach tatsächlich an irgendeiner FX-Aktivität oder SubPlugin in deinem Plugin. Den SD kenne ich nicht, deswegen kann ich dazu nix sagen.
     
  18. Sascha Franck

    Sascha Franck

    Registriert seit:
    31.10.18
    Punkte:
    20.857
    20857
    Keine Ursache. Das ermöglicht es einem übrigens auch, riesige Templates zu basteln. die betreffenden Tracks brauchen dann keinerlei Saft.
    Geht auch über diese Projektvoreinstellung:
    noetigeplugins.jpg
    Der Nachteil ist hier aber, dass die Inhalte unverzüglich geladen werden, wenn man auf eine Spur kommt (passiert einem ja besonders gerne mal bei Gebrauch der Pfeiltasten), weshalb ich mich entschieden habe, das händisch zu erledigen. Nervt nämlich echt, wenn irgendein dickes Kontaktteil einfach lädt, während man damit gar nix anstellen will. Achja, mit dem automatischen Management dürfen auch keine Regionen auf der Spur sein, das checkt Logic beim Laden des Projekts und dann werden die Spuren automatisch aktiviert. Spricht dann eben auch für eine manuelle Verwaltung.
     
    Supercreative bedankt sich.
  19. Supercreative

    Supercreative

    Registriert seit:
    29.06.14
    Punkte:
    2.321
    2321
    Aah, das schau ich mir auch nochmal an.
    Ist in meinem Fall aber halb so wild, Maschine bleibt im „Hintergrund“, während ich die Spuren per Multiout auf einzelne Spuren im schicke und dort als Audio aufnehme.
     
  20. Kassette

    Kassette Themenersteller One Take Wonder

    Registriert seit:
    05.02.16
    Punkte:
    11.850
    11850
    Leider nein, es scheint die SD3 Core-Engine zu sein. Hab wirklich alles ausprobiert - keine Besserung. Muss ich wohl einfach mit leben.
    Ich hasse es nur, wenn ich hier bei einer Recording-Session sitze und der Rechner plötzlich anfängt, an seine Leistungsgrenze zu kommen. Naja, ist eh bald ein Upgrade fällig.
    Raum ist ausgeschöpft, mehr geht nicht rein, SSD ist auch am Start.
    Das ist aber erst seit den letzten Logic-Updates so krass geworden.