Information ausblenden

Probleme bei Midieinbindung Machinedrum und virus a

Dieses Thema im Forum "Musik produzieren" wurde erstellt von ohashisano, 23.10.08.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. ohashisano

    ohashisano Themenersteller

    Registriert seit:
    10.09.08
    Punkte:
    7
    7
    Hallo Zusammen,

    so langsam versteh ich immer mehr, warum alle Leute die Musik mit Geräten machen so komische graue Ringe unter den Augen haben.

    Hab folgende Probleme:

    Mein geplantes Setup für Liveact und Produzieren sieht folgendermaßen aus:

    Microcontrol als Masterkeyboard für meine Monomachine und zum übertragen der Start/Stop etc. messages an alle meine Geräte. (Midi out Keyboard, Midi in Monomachine). Aus meiner Monomachine geh ich mit midi through auf midi in meiner Machinedrum. Soweit so gut. Jetzt geh ich mit meinem midi out der Machinedrum auf midi in meines Virus A.

    Geplant hatte ich mit meiner Machiedrum über den Step Sequenzer und über 3-5 interne von mir belegte Midimachines meinen Virus anzusteuern. Mit den anderen freien Tracks wollt ich Beats erzeugen etc. Was soweit auch funktioniert. Kann z. B. 3 Midimachines auf Track 14-16 legen und so Sounds des Virus layern und dazu auf Track 1 eine beliebige Machine z.B eine Bd laufen lassen. Jetzt habe ich aber festgestellt, das wenn ich z.B. eine beliebige Machine z.B. EFM auf Track 1 lege und dort ein HiHat anwähle und dann dieses z.B. Retriggern will, dann sendet meine Machinedrum an den Virus das z.B. in diesem Fall der cutoff filter gleich mit aufgeht. Das darf doch eigentlich gar nicht sein da ja das retriggern der Highhat intern ja nichts mit der midimachine auf z.B. track 13 oder dem senden von midibefehlen an den virus zu tun hat. Oder doch? So etwas in der Art passiert nun ständig bei unterschiedlichen machines, kits etc. Pitche ich z.B. eine Bassdrum so verändert sich z.B der oszi am virus und so weiter und so fort. Kann ich das irgendwie beenden ist nun meine Frage? Oder kann ich meine machinedrum etwa entweder nur als Steuergerät für meinen Virus verwenden oder eben nur als Drumcomputer und nicht beides gekoppelt? Wäre ja der Witz.
    Senden tu ich übrigens von der Machinedrum Kanal Globalchannel 1-4 und der virus ist auf midikanal 1 gestellt. Hab auch schon unterschiedliche Midikanäle ausprobiert ist überall das selbe.

    Zum anderen habe ich noch ein machinedrum internes Problem. Folgende Ausgangslage: Machinedrum factory reset ausgeführt. Dann auf Track 13 in einem unbelegten pattern eine Midimachine geladen und ein paar trigs aktiviert. Sendet auf Channel 1 an den Virus A. Kann fernsteuern, Noten ferngesteuert über die Midimachine ändern. Funktioniert alles wunderbar. Auch mit mehreren Midimachines die alle auf dem gleichen Midikanal 1 senden. Lade ich jetzt aber ein neues Pattern und einen neuen Kit und mache alles wie zuvor sendet meine Monomachine keine Mididaten mehr an meinen Virus. Nur dadurch, dass ich ein neues Pattern angewählt habe. Kann z.B. auch den Kit wo alles wunderbar funktioniert in das neue Pattern laden und es tut sich ebenfalls nichts. Kann das nicht verstehen. Nur in diesem einen Pattern und mit diesem Kit steuern die Midimachines meinenVirus an. Müßte doch aber x beliebig funktionieren.

    Falls hier jemand Rat weiss, wär ich dankbar.

    Hoffentlich kam das auch verständlich rüber. Hab versucht so genau wie möglich zu sein.

    Gruß
     
    ohashisano, 23.10.08
    #1
  2. x2mirko

    x2mirko

    Registriert seit:
    07.08.07
    Punkte:
    2.496
    2496
    Hi und Willkommen im Forum :)

    Ok. Sollte so funktionieren. Sieht bei mir ähnlich aus (nur ohne Monomachine davor und mit nem anderen Synth dahinter)

    Im Grunde musst du doch von der Machinedrum nix senden, abgesehen von den Midimachines. Ich würde erstmal in den globalen Einstellungen (Function + Pattern/Song Umschalter) unter Midi den Base Channel komplett abschalten. Dann kann eigentlich nix unerwünschtes mehr gesendet werden. Hab das grade mal per MidiOX getestet - Meine MD sendet bei abgeschalteten Base Channel exakt gar nix mehr, wenn ich an den Reglern drehe. Was höchstens noch sein könnte, wär, dass da was über Sysex läuft - aber teste es erstmal so. Wenns immer noch probleme gibt, kannst du ja mal schaun, ob du am Virus einstellen kannst, dass er kein Sysex empfangen soll (wenn meine Erinnerung nicht ganz daneben ist, geht das).

    Warum die Monomachine? Nur verschrieben und du meinst die Midimachine? Sonst bin ich jetzt etwas verwirrt - die Monomachine kann doch eh nix senden, die ist ja nur per Through verbunden.

    Da weiß ich jetzt auch noch nix - habs grad versucht nachzuvollziehen, aber bei mir funktioniert das ohne Probleme. Erklär doch vielleicht mal GANZ Schritt für Schritt, was du machst (auch wenns mühsam ist, irgendwo muss ja n Fehler liegen).

    Mir ist aber auch noch nicht 100% klar, ob und wie du bis jetzt das ansteuern per Midimachines verstanden hast, evtl liegt da ja irgendwo der Fehler. Also ganz kurz:
    Die Midimachines sind ja von 01 bis 16 durchnummeriert. Die Nummern sind identisch mit den Midichannels, auf denen sie übertragen (Also Midimachine 05 sendet auf Midikanal 05). Der Virus A ist ja Multimodefähig. Also addest du z.B. Midimachine 01, 02 und 03 und kannst damit verschiedene patches im Multimode vom Virus ansteuern.

    Der Base Channel der Machinedrum hat damit überhaupt nix zu tun. Der gibt nur an, auf welchen Channels die MD die Triggerdaten von ihren internen Patterns und die Steuerdaten der Machines sendet. DAS sollte man ausschalten, wenn man noch ein Gerät hinter die MD hängt, das kein Drumcomputer oder ne DAW ist. Dann kann man per Midimachine exakt bestimmen, an welche Channels welche Daten sollen. Das sollte man dann auch so machen, dann gibt es (zumindest bei mir) auch keine Probleme mehr mit der ansteuerung von Synths.

    mfg,
    Mirko
     
    x2mirko, 24.10.08
    #2
  3. Frank6502

    Frank6502

    Registriert seit:
    08.02.04
    Punkte:
    8.602
    8602
    hallo

    es ist nicht korregt verkabelt.

    weil live ist immer der sequenzer master .

    in deinen fall die monomachine

    die meisten synthesizer bieten daher einen mastermode mit softhrough an.



    zur loesung.... den viru an den midiout von monomachine..- /

    softthrough der monomachine aktivieren.
    erkennt manndaran das der viru dann live mitspielt.

    sysexfilter der monomachine aktivieren...ist vorteilhaft.

    andere loesung wäre ein midimerger oder der pc als master... mit ocx oder als sequenzer.

    lg frank
     
    Frank6502, 24.10.08
    #3
  4. x2mirko

    x2mirko

    Registriert seit:
    07.08.07
    Punkte:
    2.496
    2496
    das sollte aber keinen unterschied machen. Ich kann schon nachvollziehen, warum er diese Verkabelung gewählt hat.
    Ich persönlich würde es ähnlich machen wie du vorgeschlagen hast, Frank (wenn ich ne Monomachine hätte :D), ABER es müsste auch so gehen und die Probleme liegen im Grunde nur im Zusammenspiel zwischen Virus und Machinedrum, da bin ich mir ziemlich sicher.

    mfg,
    mirko
     
    x2mirko, 24.10.08
    #4
  5. ohashisano

    ohashisano Themenersteller

    Registriert seit:
    10.09.08
    Punkte:
    7
    7
    Hallo Mirko,

    erstmal zum Basechannel. Das war`s. Uff. Unglaublich.

    Mir war da prinzipiell nicht klar, dass der Base channel nur intern benötigt wird und nichts mit dem Kanal zu tun hat auf dem die midimachines senden. Dachte das muß parallel eingestellt werden.

    Zum anderen ist deine Verwirrung gerechtfertigt. Muss natürlich machinedrum und nicht monomachine heißen. Sorry. Hab mich da vertan im Eifer des Gefechts.

    Nochmal zu den Midimachines. Das Sytem der Midimachines hab ich verstanden. Also, hatte das Problem mit den Midimachines vor einigen Tagen. Hab daraufhin alles gesichert und factory reset ausgeführt um alle Fehlerquellen meinerseits auszuschließen. Nächster Schritt: Pattern E01 aufgerufen, komplett unbenutzten Kit geladen. Track 1, E12 Bd geladen. Trigs auf 1,5,9,13 gesetzt. Dann Midimachine 1 (Virus steht auf Kanal 1) auf z.B. Track 2 geladen, Trigs auf 3,7,11,15 gesetzt. Start. Es ertönt eine Bassdrum und der Virus trällert. Gut. Funktioniert auch mit mehrern Midimachines auf unterschiedklichen Tracks. Auch auf dem selben Midikanal oder auch beliebig von 1-16 verteilt.
    So, jetzt rufe ich das Pattern "egal was für eines" auf. Leer oder werksseitig belegt, egal. Versichere mich, das entsprechend trigs gesetzt wurden. Mute ist aus. Start. Es kommen keine mididaten mehr bei meinem Virus an. Bleibt einfach stumm. Keine volle Note für korrekten Midiempfang,
    aber auch keine mit leerem Notenkopf für falschen Kanal. Kann aber suspekterweise über die Midimachine programm changes am Virus fernsteuern,. Kommt also was an, nur die gesetzten trigs/Noten werden nicht mehr übertragen.
    Habe nur ein anderes Pattern aufgerufen und evtl. trigs gesetzt. Sonst nichts. Kit ist derselbe.
    Geh ich dann zurück zu meinem Pattern E01 trällert der Virus wieder los. Aber nur in diesem Pattern.

    Da gibt`s noch ein paar andere Eigenheiten aber das würde jetzt nur verwirren. Mich würd einfach mal interessieren, ob das bei dir so funktioniert.

    Irgendwie macht das auch einen Unterschied bei mir, ob ich ein noch nie benutzten Kit mir selber zusammenstelle oder einen werksseitig vorhandenen abändere (Midimachine beliebig auf einen track legen). Da kann ich durch die verschieden Patterns hüpfen und überall funktionierts.

    Na gut. Hoffe mal, dass hier keine Idiotie meinerseits vorliegt. Aber das stresst mich und hab jetzt echt lange rumgedoktert. Für mich einfach nicht nachzuvollziehen.

    Danke dir erstmal.

    Gruß Alex
     
    ohashisano, 24.10.08
    #5
  6. ohashisano

    ohashisano Themenersteller

    Registriert seit:
    10.09.08
    Punkte:
    7
    7
    Hallo Frank,

    habe die Verkabelung extra so gewählt; habe daurch für meinen Einsatzbereich mehr Möglichkeiten. Die Kanäle der monomachine sind eigentlich immer voll belegt. An meiner Machinedrum kann ich den Virus aber mit minimum 3-5 Kanälen ansteuern was komplett andere möglichkeiten eröffnet. Die monomachine steuere ich über das masterkeyboard und den Rest über die machinedrum direkt. Wird mir sonst alles zu viel hickhack bis alles funktioniert. Zum anderen möcht ich meinen Rechner nur zum Aufnehmen und Endbearbeitung meiner fertigen Songs verwenden. Sonst verlier ich mich immer in den Möglichkeiten. Momentan reiner Selbstschutz. Grins
    Danke dir auf jeden Fall für deine Anregungen und probiere das mit der mo-
    nomachine mal aus.

    Gruß Alex
     
    ohashisano, 24.10.08
    #6
  7. x2mirko

    x2mirko

    Registriert seit:
    07.08.07
    Punkte:
    2.496
    2496
    Erstmal: Dir ist klar, das der Sequencer der Monomachine auch nochmal 6 Zusatztracks für Midi hat? Hab ich jedenfalls gelesen. Hab selbst keine und kanns nicht ausprobieren, aber bin mir ziemlich sicher. Sequencing müsste also auch damit gehen (natürlich etwas kofortabler wegen auf Noten und Akkorde ausgerichtetem Sequencer mit Keyboardunterstützung).

    Aber jetzt zu deiner Beschreibung:
    Du arbeitest im "Classic"-Patternmodus denke ich? Habs ausprobiert und da hab ich exakt dasselbe Problem. Erstaunlich. Weiß jetzt auch nicht, woran das liegt - scheint irgendein Softwarefehler zu sein - da würde ich mal Elektron anschreiben. Entweder wissen die, worans liegt und wie mans beheben kann oder die könnens zumindest mit dem nächsten Firmwareupdate beheben. Jedenfalls keine Idiotie deinerseits ;)

    Ich hab das Problem einfach noch nie bemerkt, weil ich praktisch nur im Extended-Modus unterwegs bin (allein schon wegen der Parameterlocks).

    Als Workaround könntest du auch den Extendedmodus nutzen, in dem das ohne Probleme funktioniert. Da müsstest du nur eben den Patterns dasselbe Kit zuweisen. Solange du nicht Live mit einem Pattern verschiedene Kits ansteuern willst, ist das überhaupt kein Problem - und selbst das könnte man hinbekommen, immerhin gibts ja relativ viele Speicherplätze für Patterns.

    mfg,
    Mirko
     
    x2mirko, 24.10.08
    #7
  8. ohashisano

    ohashisano Themenersteller

    Registriert seit:
    10.09.08
    Punkte:
    7
    7
    Dank dir für deine Rückmeldung. Vielleicht schreib ich die echt mal an.

    Werd das mit der Monomachine mal parallel testen. Ist ja kein act. Bin gerade noch am einarbeiten mit den Geräten. Das mit den seperaten Midikanälen wußte ich schon aber irgendwie erscheints mir momentan so sympathischer. Falls sich das Gegenteil rausstellt, kann ich damit so gar noch besser leben.

    Hab seither nur mit dem Rechner Sound gemacht. Und ich muss ehrlich saachen, dat ging ein bißchen stressfreier. Nichtsdestrotrotz, bin echt zufrieden mit der MD und der MM. Nur was echt zum kotzen ist, ist die Bedienungsanleitung. Ist zwar schon machbar, aber teils etwas mühsam alles auf Englisch durchhacken zu müssen. Und für den Preis sollte ne Übersetzung schon drin sein. Würd vor allem Neulingen wie mir das Leben manchmal etwas vereinfachen.

    Auf jeden Fall nochmal Danke

    Gruß Alex
     
    ohashisano, 24.10.08
    #8
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.