Information ausblenden

mp3 => wav = stille ab 15khz?!?

Dieses Thema im Forum "Musik produzieren" wurde erstellt von micha, 02.12.02.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. micha

    micha Themenersteller

    Registriert seit:
    09.08.02
    Punkte:
    84.225
    84225
    hi,

    bei der umwandlung von mp3 in wav werden die frequenzen über 15khz auf unter-104db gesetzt.....egal ob ich im audioeditor ne mp3 öffne und sie als wav abspeichere oder ob ich z.b. mit MP3ToWav o.ä. wandle...........woran liegt das? kennt ihr das problem? könnt ihr das mal ausprobieren, obs bei euch auch so ist...??? es funzt wohl, wenn ich das wav abspiele und gleichzeitig aufnehme, dann hab ich alle frequenzen.........is aber echt lästig auf die art und weise...... :-D

    mit der soundkarte (sblive1024) dürfte es ja eigentlich nix zu tun haben oder??

    gruß,

    micha
     
    micha, 02.12.02
    #1
  2. neil

    neil

    Registriert seit:
    15.09.02
    Punkte:
    1.041
    1041
    hi, micha!

    das bestimmte frequenzen mp3-bedingt wegfallen, ist ganz normal und liegt an der daten-komprimierung, das könnte durchaus bei 15kHz der fall sein - das mit dem abspielen und aufnehmen verstehe ich allerdings nicht ganz. du kriegst da nicht einfach ein rauschen drauf und die musik bleibt unter 15kHz??? wäre ja nicht der sinn der sache;-)

    martin
     
    neil, 02.12.02
    #2
  3. micha

    micha Themenersteller

    Registriert seit:
    09.08.02
    Punkte:
    84.225
    84225
    hi neil,

    also, wenn ich ne mp3 datei in winamp abspiele kriege ich alle frequenzen angezeigt (die pegel hüpfen auf der ganzen länge :-D ) auchim audioeditor bei der analyse.............also wenn cih dann aufnehme kriege ich das ganze spektrum.......nur beim wandeln klappt es nicht und ich weiß nicht warum...........

    gruß,

    micha
     
    micha, 02.12.02
    #3
  4. mkropfbe

    mkropfbe

    Registriert seit:
    09.10.02
    Punkte:
    1.127
    1127
    das ist ganz normal... wird von Fraunhofer im algorithmus so definiert ... alles ueber 15KHz is weg...
    verwende zB Ogg Vorbis, und da ist mehr da...
     
    mkropfbe, 13.12.02
    #4
  5. NULL

    NULL Guest

    Punkte:
    0
    Ja mp3 hat ja nur rund 1/10 der ursprünglichen Größe. Das wird erreicht, indem in 1. linie die Frequenzen die auserhalb des Höhrbaren bereich liegen, weggeschnitten werden.

    Kann es vielleicht sein, das du z.B. ein Hall oder ähnliche FX über eine mp3 gelegt hast? Dann würde es nämlich erklären, warum die mp3 dann bei der Analyse wieder diese Frequenzen hat.

    Denn beim aufnehmen des Mithörens einer mp3, dürftest du nichts über 15 Khz sehen können. Seitdenn der Rechner hätte was hinzuinterpretiert (Spectralizer, Enhancer etc)

    Und die Anzeige von Winamp ist eh nicht so 100% :p
     
    NULL, 13.12.02
    #5
  6. micha

    micha Themenersteller

    Registriert seit:
    09.08.02
    Punkte:
    84.225
    84225
    hi,

    also ich hab keine effekte drüber gelegt oder eq'ing o.ä........definitiv nicht.....:-D

    wenn ich in winamp ne mp3 abspiele, sehe ich wie alle balken ausschlagen....:) du weißt was ich mein', hehehe...die frequenzanzeige eben....die schlägt also auch ganz rechts aus :).................nach dem wandeln halt nicht mehr ca. das letzte fünftel wird dann nicht mehr angezeigt............

    ich hab mit allen qualitätsvarianten rumgetestet und der highcut verschiebt sich mit steigender qualität in höhere frequenzbereiche (spektrumanalyse in soundforge)....128kb ca 15kHz.......320kb ca 17 kHz.........das, denke ich, liegt aben an den unterschiedlichen komprimierungsraten?!?!

    kann es denn sein, daß winamp und konsorten frequenzen dazu emulieren, oder so? würde dann erklären, warum beim abspielen und gleichzeitigem aufnehmen in soundforge alle frequenzen da sind....sie werden zumindest bei der spektrumanalyse angezeigt........?!?!

    naja, mir gehts eben darum: wenn ich meine mp3-files nach samples durchhöre, hab ich mir bisher immer aufgeschrieben, was, wann, wo und hinterher die einzelnen files in sf geöffnet und mir die samples rausgeholt.........jetzt nehme ich halt direkt beim abhören, wenn mir was gefällt, auf....geht auch und dauert nur ein wenig länger..........

    das blöde an dem highcut nach dem wandeln is halt, daß audiocd's dann entsprechend schlechte quali haben...........

    naja, ich schätze halt das das technisch bedingt ist und sich nicht ändern läßt........

    okay, danke für die anteilnahme :-D ........

    gruß,

    micha
     
    micha, 13.12.02
    #6
  7. mkropfbe

    mkropfbe

    Registriert seit:
    09.10.02
    Punkte:
    1.127
    1127
    wenn du zB lame zum encodieren verwendest (gibts zumindest unter linux, windoof weiss ich nicht, verwend ich nicht :)
    da kannst du einstellen, ab wo er den hi-cut machen soll, egal von der kbit rate.
    aus der man page zu lame:

    Filter options:
    -k keep ALL frequencies (disables all filters),
    Can cause ringing and twinkling
    --lowpass <freq> frequency(kHz), lowpass filter cutoff above freq
    --lowpass-width <freq> frequency(kHz) - default 15% of lowpass freq
    --highpass <freq> frequency(kHz), highpass filter cutoff below freq
    --highpass-width <freq> frequency(kHz) - default 15% of highpass freq
    --resample <sfreq> sampling frequency of output file(kHz)- default=automatic
     
    mkropfbe, 14.12.02
    #7
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.