Information ausblenden

Kontakt-Libraries - Content Missing ?!

Dieses Thema im Forum "Software-Instrumente und Sample-Libraries" wurde erstellt von R-Kelly, 07.02.19.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    Moin,

    Wenn ich meine Sample Libraries aus organisatorischen Gründen oder Platzgründen in andere Pfade, Partitionen, Ordnern oder neuen Drives verschiebe dann kann Kontakt diese ja logischerweise nicht mehr finden. Nun öffne ich Kontakt Standalone und kann die fehlenden Libraries unter dem Library-Tab wieder neu "locaten" und alles ist scheinbar erstmal wieder gut..

    Wenn ich allerdings ein DAW-Projekt laden möchte, dass zuvor noch mit dem alten Pfad gespeichert wurde dann kommt jedesmal die blöde Meldung "Content Missing" und ich muss ihm bei jedem einzelnen Projekt und jedem einzelnen Kontakt Instrument mit "Browse for Folder" sagen, wo er nun die vermissten Samples findet!
    Obwohl ich zuvor über die Locate Funktion in Kontakt Standalone doch schon gesagt habe wo sich der neue Library-Pfad befindet?!

    Das ist mega nervig und extrem Zeitaufwendig!!! Ein Projekt das ich gerade laden will, wo z.B. Session Strings Pro2 enthalten ist (mit ca. 35.000 Samples) dauert auf die Weise über EINE STD!!! Und das trotz SSD!

    Wieso kann Kontakt nicht einfach den neuen Library-Pfad laden den er doch schon zugewiesen bekommen hat und meckert die ganze Zeit rum? Bei anderen VST's funktioniert das doch auch?! Wenn ich die Library verschiebe von Plugins wie z.B.
    Nexus
    EzDrummer, EzKeys
    Spectrasonics etc.
    Dann weise ich dem Plugin genau einmal an wo sich nun der neue Pfad vom Sample Content befindet und gut ist!

    Verstehe nicht wieso das nicht einfacher gelöst wird. Denn so lassen sich Projekte gar nicht so einfach austauschen, von zwei Leuten die das selbe Komplete Ultimate Bundle besitzen..:confused:
     
    R-Kelly, 07.02.19
    #1
  2. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    52.791
    52791
    Hast du die aktuellste Version von Kontakt installiert?
     
    Kosaken-Kaffee, 07.02.19
    #2
  3. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    Nein bin noch bei Kontakt 5. Wieso ist es da denn anders?
     
    R-Kelly, 07.02.19
    #3
  4. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    52.791
    52791
    Vielleicht ist es ein Bug, der in einer aktuelleren Version korrigiert worden ist?
     
    Kosaken-Kaffee, 07.02.19
    #4
  5. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    nee das glaub ich kaum. Das war auch schon bei Kontakt 4 nicht anders..
     
    R-Kelly, 07.02.19
    #5
  6. Kosaken-Kaffee

    Kosaken-Kaffee Überschätzte Legende

    Registriert seit:
    04.10.16
    Punkte:
    52.791
    52791
    Ja, aber innerhalb von Kontakt 5 gibt es unterschiedliche Versionen. Hast du da die aktuellste?
     
    Kosaken-Kaffee, 07.02.19
    #6
  7. rocking.xmas.man

    rocking.xmas.man Faderhalter

    Registriert seit:
    19.05.17
    Punkte:
    5.118
    5118
    das ist bei Kontakt 5 so. letztlich speichert Kontakt pro Session ja alle Einstellungen der geladenen nkis - vielleicht als eine art encapsulated light nki, keine Ahnung.
    Es geht aber deutlich schneller, wenn du Kontakt nicht automatisch suchen lässt, sondern jeweils den Pfad der missing samples angibst.
     
    rocking.xmas.man, 07.02.19
    #7
  8. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.547
    30547
    Das liegt, glaube ich, eher daran, dass in den Projekten deiner DAW noch die alten Pfade mit abgespeichert sind.
     
    Realist, 07.02.19
    #8
  9. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    ja aber irgendwie scheint dann Kontakt nicht so richtig mit der DAW zu kommunizieren. Die DAW meckert ja nicht sondern Kontakt, weil er angeblich die Samples vermisst
     
    R-Kelly, 07.02.19
    #9
  10. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.547
    30547
    Kannst ja mal nen Test machen.
    Einfach ein neues, frisches Projekt erstellen und Kontakt laden.
     
    Realist, 07.02.19
    #10
  11. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    in dem Fall ist es ja kein Problem. Mir geht's aber um dutzende ältere Projekte die noch die alte Verzeichnisstruktur hatten. Irgendwann werden Festplatten voll dann tauscht man die gegen neue oder schnelle SSD's aus und muss seine Libraries umstrukturieren.

    Wenn man nun dutzende Projekte hat wo man ständig manuell jedes einzelne Instrument neu locaten muss dann hat man ein riesiges Chaos am Start und man kann erstmal Filme gucken bis man seine Projekte wieder öffnen kann
     
    R-Kelly, 07.02.19
    #11
  12. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.547
    30547
    Ja, das ist ziemlich nervig.
    Eine echte Lösung hab ich aber leider auch nicht parat.
    Bei Gearslutz schreibt jemand von Verküpfungen zum Überlisten. aber ob das funktioniert oder besser ist, weiß ich ich auch nicht so genau.
    https://www.gearslutz.com/board/mus...akt-libraries-new-drive-mess-up-template.html
    Am Besten ist es natürlich bei einem Wechsel der Festplatte den alten Laufwerksbuchstaben und die Verzeichnisstruktur für die neue Festplatte/SSD zu übernehmen.
    Samples z.B. liegen bei all meinen Systemen seit ewigen Zeiten auf E und Projekte auf F.
    Wenn ich dann ein neues BS aufspiele oder eine grössere Platte einbaue wird alles gleich wieder richtig erkannt.
     
    Realist, 07.02.19
    #12
    R-Kelly bedankt sich.
  13. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    Ja das wäre wohl der einzige Workaround. Nur wenn du vorher z.B. partitioniert hast und in Zukunft nicht mehr partitionieren willst dann wird auch das so einfach nicht funktionieren. Trotzdem Danke für den Gearslutz-Link! Schau ich mir mal genauer an
     
    R-Kelly, 07.02.19
    #13
  14. Ran

    Ran

    Registriert seit:
    02.08.02
    Punkte:
    3.936
    3936
    Edit: (über die datenträgerverwaltung) ... irgendwo kann man auch ordnern ein laufwerksbuchstaben zuweisen. dann sollten die samples wohl gefunden werden.

    Doppeledit verdammt nochmal: In der Datenträgerverwaltung kann man ein Volume in einem Ordner bereitstellen. Vielleicht hilft das ja...
     
    Zuletzt bearbeitet: 07.02.19
    Ran, 07.02.19
    #14
    Realist bedankt sich.
  15. ABMusic

    ABMusic

    Registriert seit:
    27.11.16
    Punkte:
    501
    501
    Hi R-Kelly,
    ohhh , eine Stunde ist ja doch arg lange. Ich kenne dieses Problem auch. Ich arbeite mit Win10 und habe bemerkt wenn der Defender aktiv ist checkt der die Samples erst mal. Deaktiviere ich den Defender geht es etwas schneller.

    Ja und mit älteren Projekten habe ich auch das Problem mit der Pfadsuche . Ob Kontakt 4 - 5 - 6 ,da sollte sich mal was ändern.

    LG
    Andy
     
    ABMusic, 08.02.19
    #15
    R-Kelly bedankt sich.
  16. Realist

    Realist Moderater Gruftie Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    30.547
    30547
    Du kannst im Defender auch eine Ausnahme hinzufügen. Dann klammert er betreffende Ordner aus. Bei mir habe ich das bei den Samples gemacht.

    Zu der langen Ladezeit. Wie rocking xmas schon geschrieben hat, wenn die "Samples Missing"-Meldung kommt, sollte man Kontakt nicht automatisch suchen lassen. Das dauert ewig. Am Besten immer die Funktion "Browse for folder" nutzen und selbst die Library auswählen.
    Man kann auch einmalig erst einen Batch-Resave über die Standalone-Version machen.
    Dann schreibt Kontakt alle Pfade neu.
    https://support.native-instruments....-bei-KONTAKT-Libraries-beheben-Batch-re-save-
    Die Meldung bei alten Projekten in der DAW behebt diese Fubktion zwar nicht, aber so ist man zumindest bei neu erstellten Projekten auf der sicheren Seite.
     
    Realist, 08.02.19
    #16
    ABMusic und R-Kelly bedanken sich.
  17. Phelice

    Phelice Tonträger

    Registriert seit:
    26.01.16
    Punkte:
    798
    798
    Hast du mal versucht mit Symlink das Problem zu lösen?
    Ich hatte nämlich bevor Logic bei einem der letzten Updates die Funktion dazu bekam, seine zusätzlichen Inhalte bspw. auf einer externen Platte zu speichern, mit Symlink das Ganze im Griff.
    Und ich konnte nachdem ich die Inhalte auf die externe verschoben hatte und den Symlink hinterlegt hatte, auch weiterhin ohne Probleme ältere Projekte öffnen, weil der Symlink eben deinem Rechner vorgaugelt, dass der alte Pfad nach wie vor erhalten ist. Das müsste in deinem Fall eigtl. genauso klappen.
     
    Phelice, 08.02.19
    #17
    R-Kelly bedankt sich.
  18. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    Ja das mach ich ja sowieso immer. Aber wenn bei einem Instrument wie Session Strings Pro II 35.000 Samples gescannt werden müssen, dauert das trotzdem ewig und ich bin auf Mac und habe zum Glück keine Virenscanner drauf.

    Schade, hatte die Hoffnung das Batch-re-save das Problem lösen könnte. Den Artikel hab ich zwar gelesen aber immernoch nicht genau verstanden wozu nun diese Funktion gut sein soll.. Wenn Kontakt die Pfade neu schreibt, warum meckert er dann weiterhin?

    Es gibt hier unter Optionen noch die Database. Habe mich damit noch nie wirklich auseinandergesetzt aber sah, dass dort teilweise immer noch die alten Pfade gespeichert sind. Diese kann man manuell removen und die aktuellen Pfade neu hinzufügen aber vermutlich wird auch diese Option das Problem mit den alten Projekten nicht beheben..
     

    Anhänge:

    R-Kelly, 08.02.19
    #18
  19. R-Kelly

    R-Kelly Themenersteller

    Registriert seit:
    08.03.07
    Punkte:
    4.981
    4981
    Nein hab ich noch nicht aber das wäre vielleicht ein Workaround. Es wäre nett wenn du mal erklären magst wie das bei den Kontakt Libraries genau funktioniert? Und ist das nur Mac only oder funzt das auch mit Windows?
     
    R-Kelly, 08.02.19
    #19
  20. Phelice

    Phelice Tonträger

    Registriert seit:
    26.01.16
    Punkte:
    798
    798
    Also Symlink funktioniert meines Wissens auf Windoofs ebenso wie auf´m Mac.
    Ich selbst habe es bis jetzt jedoch nur auf dem Mac genutzt für o.g. Fall.
    Du kannst es meines Wissens entweder über die Konsole machen (hatte ich aber selbst nicht ganz geschnallt) oder du lädst dir einfach den Symlinker runter und machst es damit.
    Du gehst letzten Endes hin und verschiebst einfach den gewünschten Ordner mit dem Kontakt-Kontent und legst dir anschließend einfach nochmal genau diesen Ordner mit Sylink als eine Art Alias im Ursprungsverzeichnis an. Und sobald dein Hostprogramm versucht die Inhalte zu laden, fungiert dieser Symlink wie eine Art Umleitung zum neuen Pfad. Das hat halt den Vorteil, dass dein Programm nicht mitbekommt, dass die Inhalte nicht mehr unter dem eigentlich Pfad stehen und du innerhalb von Kontakt keine ewige Suche laufen lassen musst und darüber hinaus auch bei Updates die Daten direkt unter dem neuen Pfad abgestellt bekommst.

    Ich schaue mal grad ob ich ein passendes Tutorial finde.
     
    Phelice, 08.02.19
    #20
    CFR und R-Kelly bedanken sich.
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.