Information ausblenden

Keyboard spielt durchweg...

Dieses Thema im Forum "Anschlusstechnik & Routing" wurde erstellt von Erazor, 11.01.13.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Hallo zusammen!
    Ich habe vor einpaar Tagen einen Threat erstellt, indem ich das Problem hatte, ein Fantom X7 Keyboard wie ein VST in cubase zu nutzen. Dies klappt jetzt auch wunderbar jedoch habe ich jetzt folgendes Problem:

    Egal welches andere VST ich öffne, mein Fantom spielt gleichzeitig mit. Ich will praktisch mein Fantom als MIDI-Keyboard nutzen aber es soll die eigene Library nur dann spielen, wenn ich auch auf dem passenden Fantom MIDI-Channel bin und nicht DURCHWEG wenn ich auf die Tasten drücke. Ich hoffe ich habe es einigermaßen verständlich erklärt und ihr könnt mir helfen [​IMG]

    Gruß und Danke
     
    Erazor, 11.01.13
    #1
  2. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    11.249
    11249
    Carcinome, 12.01.13
    #2
    Erazor bedankt sich.
  3. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Hey Carcino, vielen Dank für deine schnelle Antwort, dass werde ich morgen gleich versuchen!!
    Heißt also ich kann das Keyboard ganz normal als MIDI Keyboard benutzten, aber das Audiosignal
    wird erst:

    - beim öffnen des VST`s

    und

    - ausschließlich wenn ich auf dessen MIDI Channel bin übertragen, oder?
     
    Erazor, 12.01.13
    #3
  4. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    11.249
    11249
    Hier ist nochmal im oberen Teil die Funktionsweise von "Local Off" beschrieben (lass Dich nicht von "Korg" irritieren):

    http://www.iub.edu/~emusic/361/localcontrol.htm

    Wenn Du also eine Spur mit dem Keyboard bespielst, die einem VSTi zugewiesen ist erklingt auch nur das VSTi. Möchtest Du dann das Fantom oder andere Hardware anspielen musst Du in Cubase der Spur den entsprechenden MIDI-Output und Kanal des Geräts zuweisen.

    Falls Du OHNE Computer spielen möchtest musst Du das Fantom natürlich wieder auf "Local On" stellen... (Es gab schon verzweifelte Menschen, die dachten ihr Keyboard wäre kaputt, aber dabei stand es nur auf "Local Off", daher der Hinweis)
     
    Carcinome, 12.01.13
    #4
    Erazor bedankt sich.
  5. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Super, vielen Dank für deine Antwort! Ich werde das heute Abend versuchen und gebe bescheid ob es funktioniert!
     
    Erazor, 12.01.13
    #5
  6. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Habs jetzt so gemacht wie du es mir gesagt hast und klappt einwandfrei!! Vielen Dank!!
    Leider hat sich nun schonwieder ein Problem ergeben und zwar synchronisiert mein Fantom die Presets & Lautstärke nicht wenn ich ein cubase Projekt öffne indem ich schon mit dem Fantom gearbeitet habe. Wärend ich an einem Projekt arbeite, klappt die synchronisierung einwandfrei, nur sobald ich cubase schließe und wieder öffne oder das Fantom aus und wieder einschalte kommt die Standartlautstärke und die Standartpresets. Wie kann ich das Problem lösen??

    Besten Dank schonmal!!
     
    Erazor, 12.01.13
    #6
  7. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    11.249
    11249
    Das stellst Du im "Inspector" von Cubase ein nachdem Du die betreffende MIDI-Spur für das Fantom angeklickt hast (siehe unten). Dann müsste sich das Fantom jedesmal, wenn das Projekt gestartet wird neu dementsprechend einstellen.
     

    Anhänge:

    Carcinome, 12.01.13
    #7
    Erazor und metropolis bedanken sich.
  8. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Okey perfekt, dass werde ich versuchen. Mein Problem ist einfach das ich auch gerne Release, Attack usw. korrekt synchronisieren will. Wie soll ich das am Besten machen? (Schade das es kein VST dafür gibt das würde soviel einfacher machen...)
    Danke für die Mühe Carcinome!!
     
    Erazor, 13.01.13
    #8
  9. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    11.249
    11249
    Da hast Du mindestens drei Möglichkeiten:

    1. Den angepassten Sound im Roland abspeichern und dann von den neuen Speicherplatz verwenden.

    2. Über MIDI-Controller den Klang aus Cubase heraus verändern. Ich habe mal die Anleitung des Fantom heruntergeladen. Auf Seite 299 unter "MIDI Implentation" siehst Du welcher Controller welchen Klangparameter beeinflusst. Diese kannst Du z.B. über die "Quick-Controls" im "Inspector" von Cubase verändern. Hierzu schaue mal im Cubase-Handbuch nach. Hinweis: Du musst bei der Zuweisung der "Quick-Controls" dann unter "Alle CC" suchen. Es liest sich komplizierter als es ist (obwohl man sich erstmal in die Materie hineindenken muss). Hierüber hast Du zumindest die Möglichkeit 8 klanggestaltende Parameter zu verändern. Das müsste aber eigentlich reichen. Und Du kannst die "Quick Controls" pro Spur frei belegen.

    3. Auch kannst Du die Controller über die diversen Editoren ("Key", "Listen") in Cubase direkt eintragen.
     
    Carcinome, 13.01.13
    #9
    Erazor bedankt sich.
  10. Erazor

    Erazor Themenersteller

    Registriert seit:
    13.07.08
    Punkte:
    132
    132
    Ahhh sehr gut!! Funktioniert jetzt auch, vielen Dank!! Bin den zweiten Punkt mit den Quick Controls durchgegangen und nun hat es funktioniert.Hab nur noch ein kleines Problem beim speichern der Quick Controls, vielleicht weißt du da auch noch eine Lösung :) (Ist hoffentlich das letzte Problem)

    Habs hier mal mit einpaar Screenshots zusammengeschnitten, ich hoffe du weißt was ich meine:

    http://s1.directupload.net/images/130113/y2gxzv53.png


    Vielen Dank nochmal Carcinome!
     
    Erazor, 13.01.13
    #10
  11. Carcinome

    Carcinome Überschätzte Legende

    Registriert seit:
    17.02.11
    Punkte:
    11.249
    11249
    Eine Möglichkeit: Du musst die "Quick-Controls" aufzeichnen:

    - Du schaltest das kleine "W" an.

    - Du lässt das Projekt laufen

    - Du stellst am Beginn des Songs den Wert mit dem"Quick-Control" auf Deinen gewünschten Wert

    - Wieder auf das "W" klicken, dann das "R" anschalten.

    - Speichern

    Schon müsste es funktionieren.

    Anmerkung: Über diesen Weg kannst Du natürlich auch kontinuierliche Controller-Bewegungen aufzeichnen.
     

    Anhänge:

    Carcinome, 13.01.13
    #11
    Erazor bedankt sich.
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.