Der ewige Cubase Bug...


WMD
WMD
Registriert
01.05.06
Beiträge
1.567
Punkte Reaktionen
176
Punkte
2.305
Hey,

seit ich denken kann, hat Cubase einen unfassbar nervgien Bug. Vielleicht ist es auch kein Bug sondern ein Logikfehler aber mir wird folgendes einfach nicht klar:

Ich nehme eine Audio Spur auf und will irgendwann das tempo des Projekts ändern. Wenn ich dazu dann das Event in den Musik Modus schalte passiert dieser Quatsch:

Cubase Bug Musik Modus.gif


Das Event wird einfach völlig wirr verschoben. Das passiert nicht immer und nicht bei jedem Event.
Ich verstehe einfach nicht warum. Das was man oben sieht wurde genau so in das projekt aufgenommen, hat auch das richtige Tempo in der Datei geschrieben (wenn ich es im Pool öffne). Deshalb verstehe ich es einfach nicht.
Der einzige Workaround ist, das Event erst als neue Datei zu schreiben und dann in den Musik Modus zu gehen, aber das nervt natürlich ohne Ende wenn man es für ein ganzes Projekt machen muss.

Gibt es hierfür irgendeinen Grund oder eine Lösung?

Danke!
LG
WMD
 
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
Wenn ich dazu dann das Event in den Musik Modus schalte passiert dieser Quatsch:

Das ist kein Bug... (Threadtitel mal ändern)
Du hast im Arrange ein ursprünglich zusammenhängendes ganzes Audio Event geschnitten, Teilbereiche daraus verschoben oder anderweitig platziert. Ein geschnittenes Event kann man immer vorne und hinten aufziehen, das ist dann der eigentliche Inhalt mir der WAV.
Die sog Events in Cubase können Audiofiles aber auch Midi Noten und Controllerdaten enthalten.

Der Musik Mode bezieht sich immer auf den Startpunkt der Audio WAV im Event Container.
Edit, nein, blöd formuliert, Event Start war gemeint. Das andere ist etwas anders. Wie geht hier eigentlich Durchstreichen?

Tempoänderungen kann man auf verschiedene Art in Cubase vornehmen.
 
Zuletzt bearbeitet:
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.589
Punkte Reaktionen
1.367
Punkte
5.745
Lieber @rkdk, leider kann ich das von @wdm beschriebene Verhalten bestätigen, denn ich habe das auch schon erlebt und trotz einiger Tests die genaue Ursache bisher noch nicht herausgefunden. Ich kann nur sagen, dass dieses "planlose Verschiebe-Verhalten" bei mir nicht immer und auch für mich nicht logisch erklärbar auftritt.
Wenn es ein gewolltes Verhalten wäre, würde sich das verschobene Event nach dem Ausschalten des Musikmodus wieder am ursprünglichen Platz befinden. Tut es aber nicht!
Falls das beschriebene Verhalten bei mir mal wieder auftritt, werde ich es weiter untersuchen.
Der Musik Mode bezieht sich immer auf den Startpunkt der Audio WAV im Event Container.
Nach meiner Erfahrung bezieht sich der Musikmodus auf den Rasterpunkt, und nach dem Schneiden eines Audioevents bekommt jedes entstandene Schnipsel einen eigenen Rasterpunkt am Beginn des neuen Events. D.h., die Lage des Rasterpunkts bestimmt die Position des Events nach dem Umschalten in den Musikmodus.
 
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
Tut es aber nicht!

Doch, doch. ich habe es eben nochmal ausprobiert.
Alles, wie es sein soll. Egal, wie ich da rumschneide oder verschiebe.
Events mit Musik Mode ON, dann Tempo verändern, der Events-Startpunkt bleibt wie es sein soll, nur alles wird sachgemäß schneller abgespielt mit neuer BPM.
Hab ihr den da angeschaltet?

144.JPG


Das hab ich auch eingestellt in den Programmeinstellungen:
Cubase Zeitbasis ProgEinst.JPG


Hier mal Filmchen, man erkennt:
- eine Drumloop (Audio WAV) in einer Spur.
Diesen Loop geschnitten, und die Schnippsel neu in in der Timeline im Arrange wild verteilt.
- Events: Musik Mode ON
- Spur Mode: ON
- Tempo wird im laufenden Betrieb verändert
(man sieht meine Eingabe im separaten schwebenden Transportfenster und wie sich der Song Pos.-Strich jeweils verlangsamt resp. schneller wird)
= Audio Event passt sich automatisch dem neuen Tempo nach an. Alles OK...

Cubase-TEMPO ÄNDERN MM MODE.gif
 
Zuletzt bearbeitet:
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
Nach meiner Erfahrung bezieht sich der Musikmodus auf den Rasterpunkt, und nach dem Schneiden eines Audioevents bekommt jedes entstandene Schnipsel einen eigenen Rasterpunkt am Beginn des neuen Events.
Der Rasterpunkt ansich ist ja noch etwas anderes.
Dieser sog. separate "Markerpunkt" ist ja - innerhalb eines Audio Events - frei verschiebbar, und jener ist nützlich um z.B. schwierigeres Material genau auf den Punkt zu alignen, in Bezug zum gewählten Quantisierungsraster. (z.B. ein langsam einschwingendes Reverse Becken, was am Transientenpeak auf der "eins" sitzen soll)
Dennoch kann ja der eigentliche Event-Start ein ganz anderer sein. Und auch weit vor diesem Rasterpunkt liegen.
 
Zuletzt bearbeitet:
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.589
Punkte Reaktionen
1.367
Punkte
5.745
Doch, doch. ich habe es eben nochmal ausprobiert.
Wie ich oben schon schrieb, das merkwürdige Verschiebe-Verhalten tritt auch bei mir nur hin und wieder auf, normalerweise ist alles in Ordnung, so wie bei Dir.
Aber ich habe ein Audiofile gefunden, bei dem ich es reproduzieren kann.
Im folgenden Video ziehe ich die Datei ins leere Projektfenster, zerschneide die Datei in 3 Events und mache dann nichts weiter, als mehrmals den musikalischen Modus ein- und wieder auszuschalten.
Es ist nach Deiner Meinung kein Bug, dass die Events nach jedem Umschalten immer weiter auseinandergezogen werden?
Man achte auch auf die Übersichtsanzeige!
Nach meinem Verständnis müsste nach dem Ausschalten des musikalischen Modus alles wieder wie vor dem Einschalten angeordnet sein :rolleyes:
Cubase11_Schneidproblem_musikalsich.gif
 
ModulationMatrix
ModulationMatrix
Faderhalter
Registriert
10.09.13
Beiträge
16.010
Punkte Reaktionen
8.070
Punkte
40.709
Ich hab dieses Verhalten auch schon erlebt. Meine Vermutungen waren bislang, jetzt rein aus dem Gedächtnis:
- es tritt möglicherweise nach variaudio Bearbeitungen auf
- es wurde für ein WAV file ein falsches tempo erkannt/zugewiesen (im Pool kontrollieren)

Wäre also ein Test wert wenn man vor der Umschaltung des Musik Modus das Tempo für alle Files im Pool checkt und auf das aktuelle songtempo setzt, ob dann das Verhalten immer noch auftaucht
 
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.589
Punkte Reaktionen
1.367
Punkte
5.745
@WMD, möglicherweise bin ich der Sache auf der Spur. Schau Dir bitte mal im Pool die Ursprungszeit der "verrückten" Audiodatei an.
Liegt die Beginnzeit (bzw. der erste Takt) des ersten Audio-Events dieser Audiodatei bei Dir evtl. VOR der Ursprungszeit?
 
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
Danke euch, verständlich und interessant wie überprüfenswert. Werd auch nochmal schauen.
 
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.589
Punkte Reaktionen
1.367
Punkte
5.745
Es hat offensichtlich auch etwas mit der rückwirkenden Aufnahme zu tun.

Wer möchte, darf es gern mal nachvollziehen:
1. Die rückwirkende Aufnahme (in den Programmeinstellungen) auf einen Wert >0 einstellen
1639262109013.png


2. Ein leeres Projekt erstellen
3. Eine Audioaufnahme starten, und zwar nicht ab 0, hier im Beispiel beginnt die Aufnahme ab 10s
1639262676203.png

4. Ein neues Projekt erzeugen und die eben aufgenommene Audiodatei in dieses leere Projekt ziehen, und zwar ganz an den Beginn!
5. Das Event in der Infozeile in den musikalischen Modus umschalten
1639262841567.png


Wenn die rückwirkende Aufnahme auf 0 eingestellt wird, taucht das Problem (zumindest in diesem Zusammenhang) nicht auf.
 
Nachtschicht
Nachtschicht
Registriert
20.08.11
Beiträge
7.840
Punkte Reaktionen
4.357
Punkte
21.051
das ist kein bug sondern nur die komplexität der materie. da gibts mehrere parameter, die greifen können, und für die es alles gute gründe geben kann:

- rasterpunkt
- file beginn
- spur auf musikalisch gestellt ja/nein
- file auf musikalisch gestellt ja/nein (wird gerne vergessen)
- beinhaltet das audiofile unsichtbaren preroll, etwa weil man vorauseilende aufnahme aktiviert hat?
- file verschoben oder liegt es auf der ursprungszeit?

kann man alles in verschiedenen szenarien gebrauchen. und wenn man auf diese komplexität keinen bock hat, dann ist halt der schnellste weg, select all, "auswahl als datei", und dann auf musikalisch umschalten. dann sind alle diese potentiellen schalter und möglichkeiten und eventuelle aufziehbarkeiten und eventuelle sonderfälle wie unmusikalisches audiofile aber auf musikalischer audiospur mit zwei klicks entfernt - und man hat ne simplizissimus daw a la garage band.

in den 90s hätte man sich vielleicht dann noch beschwert, dass das doch aber 600MB festplattenplatz kostet, aber heutzutage?
 
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
So...
Eben gerade längere Aufnahme getätigt.
Einfach kurz mal das Online Radio zu diesen Testzwecken mitgeschnitten,
bei der Aufnahme immer mal unterbrochen, fortlaufende Schnippsel liegen also wild vor.

Mit folgender Einstellung - ich hatte dort sogar 2 (!) Sekunden eingestellt:

2.JPG


Dann:
- Musik Mode auf alle Audio Events aktiviert.
- Tempo verändert. Von 30 BPM auf 300 und diverse Zwischenwerte.

ERGEBNIS:
Es verschob sich überhaupt NICHTS.

Alle aufgenommenen Audio Events waren exakt dort, wo man sie auch erwartet. Alles Timingkorrekt.


Beweisfilmchen hier:
Cubase-TEST TEMPO ÄNDERN OK.gif



Keine Ahnung, was bei euch los ist. Aber hier klappt es wie es sein soll. Es tut mir ja leid. :(

Werde es aber nochmal mit anderen Cubase Versionen, hab auch noch ne Elements auf nem Notbook, checken. Warum auch nicht.
 
Zuletzt bearbeitet:
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.589
Punkte Reaktionen
1.367
Punkte
5.745
Hallo @rkdk, hattest Du alle Schritte so nachvollzogen, wie von mir oben beschrieben? D.h., hast Du das Audiofile in ein neues leeres Projekt ganz an den Anfang gezogen?
 
rkdk
rkdk
Registriert
26.06.12
Beiträge
20.234
Punkte Reaktionen
11.964
Punkte
56.688
Hallo @rkdk, hattest Du alle Schritte so nachvollzogen, wie von mir oben beschrieben? D.h., hast Du das Audiofile in ein neues leeres Projekt ganz an den Anfang gezogen?
Lieber @akStudio ,
genau nach deiner Anleitung danke dir. Und weil ich dem ganzen auf die Schliche kommen wollte, habe ich alles in allen Varianten ausprobiert. Auch mit Projekt schliessen, neues, mal mit dragdrop von einem zum anderen neuen offenen, mal mit MusikMode on/off vorher nachher, mal mit Event Start mitten wo im Projekt, mal am Anfang wie bei deiner Anregung, mit Audio Pre Offset paar Sekunden und mal ohne mit Null Sekunden. Was soll ich sagen,
ich kann den Fehler nicht nachvollziehen. Ich denk mir das ja nicht aus. :(
Einzig hüpfte der Cyclebereich in der Timeline bei Tempoänderung immer woanders hin, keine Ahnung ob der in zeitbasiert war oder so. Und wenn MM an, wur5de das File auf vollen Takt gestretched 8was ich gut finde, wusste gar nicht, dass er das machen kann mit externem Material ohne Zeitbezug). Also, ich probiere da nochmal was rum. Auch auf nem anderen Rechner. Aber gewährt mir Zeit, grad viel am Hut.
 
WMD
WMD
Registriert
01.05.06
Beiträge
1.567
Punkte Reaktionen
176
Punkte
2.305
Hier ist ja einiges passiert:eek:
Danke für den Austausch und die vielen Tipps!
Mir geht es nach wie vor wie @akStudio . Es ist ein völlig willkürliches hin und her. Aber NICHT JEDES MAL.
Vielleicht ist es kein Bug sondern alles genau wie es sein soll, dann verstehe ich allerdings nicht wie es sein soll.

Es passiert bei mir exakt so wie von @akStudio in Post #6 gezeigt. Und im selben Projekt funktioniert es mit anderen Dateien völlig problemlos.

Bei mir sind immer ca. 3 Sekunden Pre Record eingestellt, aber das brauche ich auch, kann es also nicht auf 0 stellen.
Ich werde auch nochmal suchen ob ich irgendeinen Zusammenhang feststellen kann.
 
Nachtschicht
Nachtschicht
Registriert
20.08.11
Beiträge
7.840
Punkte Reaktionen
4.357
Punkte
21.051
einfach angewöhnen, vor solchen aktionen einmal alles "auswahl als datei".
dann ist es so garage band style "set and forget".

wenn du aber sowohl das garage band style set and forget, ABER auch die endlose optionitis von prerecordings, aufziehbaren files, manuell stellbaren syncpunkten, verschiedenen formen von musikalischem mode (z.b. spur nur musikalisch = recycle, audiofile musikalisch = warp) und ketchup und majo in der hinterhand behalten willst, dann machst du VOR dem "auswahl als datei" einfach bei allen spuren eine kopie der spurversion.

- alle spuren auswählen
- "version kopieren" im spurversions-menü
- cubase kopiert das ganze arrange als spurversion 2
- jetzt auswahl als datei für garage band vibe
- jederzeit auf jeder spur wieder zurückgehen auf spurversion 1 für maximum-nerd-flexibility

best of all worlds.
 
Nachtschicht
Nachtschicht
Registriert
20.08.11
Beiträge
7.840
Punkte Reaktionen
4.357
Punkte
21.051
und nicht vergessen: wenn du die FILES auf musikalisch stellst, und sie aber im audiofenster ein anderes tempo eingestellt haben als das aktuelle projekttempo, dann "verbiegen" die sich sofort in dem moment, in dem du sie auf musikalisch stellst. und das soll auch so, weil sie dann von dem im audiofenster eingestellten original tempo auf das aktuelle projekt-tempo gebogen werden.

heisst: wenn du audiofiles hast, die du erstmal nur auf musikalisch stellen möchtest, ohne dass sich was ändert:

- alle diese audiofiles im audiofenster selektieren (geht am schnellsten indem man im arranger "select all" Ctrl+A drückt, und dann "auswahl im audiofenster finden" Ctrl+F)
- die dort selektierten files auf das aktuelle projekttempo einstellen (in der spalte Tempo das aktuelle projekt tempo eintragen, wird dann für alle selektierten files übernommen)
- dann auf musikalisch stellen
 
WMD
WMD
Registriert
01.05.06
Beiträge
1.567
Punkte Reaktionen
176
Punkte
2.305
Genau, alle nötigen Dinge die man VOR Auswahl als Datie machen muss, mache cih schon immer. Das ist auch alles ein ganz guter Workaround, aber so etwas in einem riesen Projekt zu machen wo überall verteil die Audio Schnipsel liegen und man sie nicht alle in ein riesen langes Event rechnen will pro Spur ist eben leider sehr aufwendig, daher auch dieser Thread.
Zumal es sehr nervig ist stummgeschaltete Events (die man vllt später braucht) zu ent-muten, dann neu schreiben, dann wieder muten.
Alles leider oft sehr umständlich und zeitintensiv, aber so ist es nunmal;)
 
Nachtschicht
Nachtschicht
Registriert
20.08.11
Beiträge
7.840
Punkte Reaktionen
4.357
Punkte
21.051
Genau, alle nötigen Dinge die man VOR Auswahl als Datie machen muss, mache cih schon immer. Das ist auch alles ein ganz guter Workaround, aber so etwas in einem riesen Projekt zu machen wo überall verteil die Audio Schnipsel liegen und man sie nicht alle in ein riesen langes Event rechnen will pro Spur ist eben leider sehr aufwendig, daher auch dieser Thread.
Zumal es sehr nervig ist stummgeschaltete Events (die man vllt später braucht) zu ent-muten, dann neu schreiben, dann wieder muten.
Alles leider oft sehr umständlich und zeitintensiv, aber so ist es nunmal;)


die alternative wäre weniger funktionalität. das wäre aber ein grosser verlust. weil time-stretching bis heute halt kein verlustfreier prozess ist, ist es eben umso wichtiger, dass man z.b. nur audiospuren, aber nicht audiofiles auf musikalisch stellen kann. damit hat man quasi eine art recycle im arranger, und arrangierte drum klötzchen gehen mit dem tempo mit, ohne selber gestretcht zu sein. oder du hast möglichkeiten wie, das ganze projekt in zählzeiten zu schnipseln und das schneller zu drehen, und alle audiofiles haben halt statt generellem stretching wieder nur eine recycle-repositionierung. was bei geringen tempo änderungen einfach viel besser (weil 100% artefaktfrei klingt).

was gemutetes und ähnliches angeht, wie schon weiter oben geschrieben, sowas würde ich alles skippen. einfach alle spuren anwählen und "spurversion kopie erstellen" anwählen (-> cubase erstellt das, was man z.b. in protools lingo eine neue playlist nennen würde). dann bei dieser neuen playlist select all und audio als datei - und wenn du je nochmal von irgendwo irgendwas brauchst, wechselst du einfach an der stelle in die alte playlist und holst dir das da.

das sind 4 klicks und fertig. und kostet halt bisschen speicherplatz, aber aus heutiger sicht sind das ja nun wirklich peanuts.
 

Ähnliche Themen

W
Antworten
8
Aufrufe
367
Wurzel49
W
L
Antworten
4
Aufrufe
711
rkdk
rkdk
oove
Antworten
37
Aufrufe
2K
rkdk
rkdk
tim_heinrich
    • Danke
  • Artikel
Antworten
3
Aufrufe
8K
Manu84
M
 

Neue Antworten


Oft gelesene Themen

Oben