Information ausblenden

Quantisierung komisch

Dieses Thema im Forum "REAPER" wurde erstellt von stoman, 06.08.11.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Ich schon wieder - tut mir ja auch leid. ;)

    Ich versuche gerade, eine eingespielte Midi-Spur zu quantisieren. Alle Einstellungen habe ich so, wie ich sie von Cubase gewöhnt bin, vorgenommen, also z.B. näherungsweises Quantisieren (Strength = 75%), Raster auf 1/8 Note gestellt, usw.

    Wenn ich nun Reaper auffordere, die Quantisierung vorzunehmen, erwarte ich, dass Noten, die z.B. 25% links einer Gitterposition sind, auf das Gitter zu bewegt werden. Dem ist aber nicht so; sie werden stattdessen ein Stückchen vom Gitter weg bewegt, so dass sie im Ergebnis weiter vom Rasterpunkt entfernt liegen als zuvor. Erneute Quantisierung bewirkt dann gar nichts mehr.

    Wo ist hier schon wieder mein Denkfehler? Quantisierung ist doch eigentlich eine höchst simple Angelegenheit. Warum muss man da so um die Ecke denken?

    Tschö,
    Steffen
     
  2. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Also, ick wees nich ... Für mich riecht das nach einem Bug.

    Auf jeden Fall verhält sich die Funktion VÖLLIG unlogisch und ganz anders als in sämtlichen anderen DAWs.

    So ist das leider völlig unbrauchbar. :(

    Tschö,
    Steffen
     
  3. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    swing eingestellt?
     
  4. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Nein, "straight".

    ... und ich bin schon beim nächsten Problem. ;)

    Tschö,
    Steffen
     
  5. user01

    user01

    Registriert seit:
    07.07.10
    Punkte:
    2.420
    2420
    solltest du der englischen sprache mächtig sein, so empfehle ich dir, deine sorgen doch mal im offiziellen reaper forum zu posten. dort wird dir sicherlich eher geholfen als hier.

    zwar gibt es dort auch ein deutsches unterforum, besonders viel los ist da aber imho auch net.
     
  6. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Jo, bin ich - ich halte mich ohnehin hauptsächlich in englischsprachigen Foren auf. Aber so wichtig, dafür im Reaper-Forum aktiv zu werden, war mir die Sache doch nicht. Ich habe inzwischen nämlich erkennen müssen, dass Reaper für mich nur dann wirklich ernsthaft zu gebrauchen ist, wenn ich fertig bearbeitetes Audiomaterial mische. Für Midi-Projekte sowie Audiomaterial, das noch editiert werden muss, stoße ich sofort an Grenzen oder muss auf externe Werkzeuge ausweichen. Da bin ich mit Cubase um ein Vielfaches schneller.

    Aber ab und zu nutze ich den Sensenmann jetzt zum Mastern. :)

    Tschö,
    Steffen
     
  7. suboptional

    suboptional

    Registriert seit:
    19.01.09
    Punkte:
    8.720
    8720
    Falls das Quantisierungs-Problem noch besteht dann stell doch mal nen Screenshot von deinen Einstellungen hier rein.
     
  8. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    In einem neu angelegten Projekt hat's hingehauen. Ich vermute, dass das Problem irgendetwas mit der Selektion zu tun hatte. Anscheinend klappt das Einrasten am Gitter nicht immer exakt, daher war der Selektionsanfang eine Achtelnote vor dem Takt. In dem Fall scheint Reaper sich nicht um das Gitter zu scheren sondern ab Beginn der Selektion zu rechnen.

    Seltsames Verhalten, aber wenn man's weiß ...

    Was ich noch nicht herausgefunden habe, ist, warum Reaper manchmal Midi-Daten aufnimmt und manchmal nicht (in dem Fall wird dann ein leerer Part, oder - in Reaper-Slang - ein leeres "Item" auf der Spur erzeugt).

    Auch ist es manchmal möglich, im Editor mittels Mausrad ein- und auszuzoomen, und manchmal geht's nicht. Das Muster, nach dem das funktioniert, habe ich auch noch nicht erkannt.

    Kann man eigentlich einen Part (ein "Item" ) bequem duplizieren, ohne umständlich mit der Maus rechts am Rand zupfen und zufällig an der richtigen Stelle loslassen zu müssen? Ich denke an eine Funktion analog zu Ctrl-D in Cubase.

    Tschö,
    Steffen
     
  9. DrownedInTrance

    DrownedInTrance

    Registriert seit:
    30.06.11
    Punkte:
    25.080
    25080
    Das duplizieren geht, indem man Strg gedrückt hält und dann das Item auf die gewünschte Stelle zieht.

    Das Zoomen mit dem Mausrad geht nur, wenn das Fenster auch aktiv ist, also vorher mit der Maus angewählt wurde.

    Wenn man MIDI aufnehmen möchte, muss man vorher als Eingang für die Spur den Midicontroller und den Entsprechenden Channel auswählen und die Spur auf "Record Armed" setzen. Dann sollte das klappen !
     
  10. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Nö, das war ja alles korrekt. Sonst hätte Reaper auch nicht so getan, als würde aufgenommen. Aber ich hab's herausgefunden: Reaper meint, im Loop-Modus die Aufnahme löschen zu müssen, wenn man wieder am Anfang anlangt. Auweia ... hoffentlich kann man das ändern.

    Ich mach' mich mal auf die Suche. So ist das ja Murks.

    Tschö,
    Steffen
     
  11. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Das funktioniert nicht. Wenn der Part nicht bei 0:00 beginnt, fügt Reaper dann am Anfang des Duplikats Stille ein, d.h. es wird offenbar immer vom 0:00 beginnend kopiert.

    Vielleicht muss man den Part irgendwie anders bearbeiten/kennzeichnen. Die Partbearbeitung ist zur Zeit noch eine Herausforderung für mich, weil ich da durch Cubase sehr verwöhnt bin. Aber so schnell gebe ich nicht auf. ;)

    Tschö,
    Steffen
     
  12. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Hier mal ein Beispiel.
     

    Anhänge:

  13. user01

    user01

    Registriert seit:
    07.07.10
    Punkte:
    2.420
    2420
    das wäre mir neu. reaper legt wenn du im loop-modus aufnimmst für jeden durchgang einen neuen take an. du hast wahrscheinlich nur den ersten take gesehen (in dem fall vertikal reinzoomen) oder hast die anzeige mehrerer takes deaktiviert (kannst du per default mit ctrl+l ein- und ausschalten).

    ebenso kannst du in den preferences (gib ins find-feld "take" ein) festlegen, ob reaper im loop-recording den ersten und letzten take automatisch löscht, falls diese nicht komplett sind.
     
  14. user01

    user01

    Registriert seit:
    07.07.10
    Punkte:
    2.420
    2420

    wo ist das problem? strg gedrückt halten und fröhlich duplizieren 8)

    [​IMG]

    EDIT: seh gerade, dass du mit duplizieren das meinst, was in reaper loopen heisst. wenn du einen part loopen willst, also nach rechts verlängern, dann musst du das item so zurechtschneiden, dass der loop passt und anschliessend glue item ausführen.

    du kannst das format, welches reaper beim gluen schreibt in den project settings festlegen.
     
    stoman bedankt sich.
  15. user01

    user01

    Registriert seit:
    07.07.10
    Punkte:
    2.420
    2420
    [​IMG]
     
    stoman bedankt sich.
  16. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Ach, so - ich hatte am rechten Rand gezupft und das oben gezeigte Ergebnis erhalten. Aber, wie gesagt: Ich hatte gehofft, es gäbe eine bequemere Möglichkeit, wie bei Cubase, wo man nicht mühselig mit der Maus positionieren muss. Einfach Ctrl-D, und der Part wird hinten angefügt. Offenbar kann Reaper das aber nicht. Dann ist das eben so.

    Was das Aufnehmen betrifft, hatte ich in den Preferences bereits alles so eingestellt, wie Du vorgeschlagen hast. Mehrere Takes sehe ich nicht, und es wird immer das, was vorher auf der Spur war, gelöscht, obwohl es während der Aufnahme noch mit abgespielt wird.

    Kruzifix, das wird doch hinzubekommen sein ...

    Eine Stunde gebe ich mir noch, dann ist Sense (upps, kein Wortspiel beabsichtigt. ;) ).

    Tschö,
    Steffen
     
  17. user01

    user01

    Registriert seit:
    07.07.10
    Punkte:
    2.420
    2420
    was spricht dagegen, dir dafür eine custom action anzulegen?

    mit dem recording hab ichs grad bei mir getestet (mit einer frischen installation) und es funktioniert so wie immer: einwandfrei.

    zieh dir das manual rein, ich sags gerne wieder :allesroger:
     
  18. suboptional

    suboptional

    Registriert seit:
    19.01.09
    Punkte:
    8.720
    8720
    Options -> Show all takes in lanes (when room) aktivieren.
    Dann musst du ggf die Spur noch breiter machen um alle Takes sehen zu können.
     
  19. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    @user01:
    Ich hab' schon viereckige Augen vom Handbuch-Lesen! ;)

    Da steht leider das, was ich suche, nicht, oder nur sehr versteckt drin. Und am Monitor Handbücher lesen ist SEHR anstrengend.

    @suboptional:
    Danke, wird probiert.

    Kann man denn irgendwie das Verhalten anderer DAWs nachbilden, bei denen neues Midi-Material in den aktiven Take eingefügt wird, statt diesen zu überdecken?

    Es wird bei mir immer nur der zuletzt aufgenommene Take abgespielt. :(

    Tschö,
    Steffen
     
  20. stoman

    stoman Themenersteller Mitschwätzer

    Registriert seit:
    06.08.05
    Punkte:
    21.731
    21731
    Ok, ich hab's. Auch das geht also nicht so, wie man es eigentlich erwarten würde, aber immerhin kann man verschiedene Ebenen (Takes) gleichzeitig abspielen, wenn man das unsinnige Standardverhalten umkonfiguriert. Diese Ebenen sollten sich dann miteinander verkleben lassen. Alles in allem recht umständlich und langwierig ... da könnte man den Arbeitsfluss noch deutlich verbessern.

    Schöne Grüße,
    Steffen
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.