Problem mit DX7 als Masterkeyboard in Logic X

  • Ersteller Flux-Kompensator
  • Erstellt am

Flux-Kompensator
Flux-Kompensator
Registriert
06.09.06
Beiträge
60
Punkte Reaktionen
2
Punkte
215
Hallo zusammen,

ich hatte bis Logic 8 auf meinem alten Mac-Book die Möglichkeit meinen DX7 als Masterkeyboard über eine Motu MK 828 mit Firewire zu benutzen.
Nun auf neuem Macbook mit Logic X und einer kleinen Motu M2-Schnittstelle funktioniert nichts.
Ich kann zwar erkenne, dass Logic die gespielten Noten erkennt (werden aber alle durchgestrichen angezettelt) aber es kommt kein Ton und keine Aufnahme ist möglich.
Hat da jemand einen Tipp für mich?
Das nur 2-oktavige "Oxygen" funktioniert als Master reibungslos. Hat aber für das was ich nun gerne machen möchte zu wenig Oktaven/Tasten

Grüße
Flux
 
T
therealelfatale
DAW-Offizier
Registriert
30.09.20
Beiträge
370
Punkte Reaktionen
186
Ort
NRW
Punkte
980
Hast du den richtigen Midi Kanal ausgewählt? Hast du den local off modus an? hast du versucht den treiber zu deinstallieren und neuinstallieren und dann nochmal zu versuchen?
 
Flux-Kompensator
Flux-Kompensator
Registriert
06.09.06
Beiträge
60
Punkte Reaktionen
2
Punkte
215
Alle Midi-Kanäle von "Alle" einzeln bis 16 durchprobiert.
Midi wird ja komischerweise erkannt, denn in der oberen Leiste (nennt sich wohl Steuerungsleiste) kann ich ja sehen, welche Noten auf dem DX7 gespielt werden. Nur das Notensymbol daneben ist durchgestrichen. Auch zeigt er mir "kein Output" an und auch da habe ich alle Kanäle durchprobiert.
Und beim Recorden schreibt er keine Noten. Leiste für Softwareinstrument ist danach wieder leer.
Treiber muss ich für M2 eigentlich nicht deinstaillieren, denn wenn ich Audio über M2 reingehe, funktioniert alles. Zudem wird mir M2 auch als Midi-Eingang angezeigt.
Jetzt solltest Du mir aber noch erklären, was Du unter "Local Off"-Modus verstehst?

Grüße Flux
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.298
Punkte Reaktionen
7.447
Punkte
39.500
1. Lade Dir mal Midi-Monitor runter und schau Dir an, was da genau ankommt.
Ist Freeware, aber nicht mit Geld zu bezahlen.

2. Hast Du in den Einstellungen>Erweitert die Werkzeuge aktiviert?

3. In Einstellungen>Midi>Eingänge wird das M2 angezeigt?

4. Schau mal im Environment:
a) Drücke CMD+8 CMD-0 um das Environment zu öffnen.
b) Wähle links oben bei Layer "Klick & Port" aus.
c) Jetzt siehst du u.A. ein Keyboard und ein Objekt mit dem Namen "Eingangsanzeige". Siehst du jetzt etwas in der Eingangsanzeige, wenn du auf deinem Keyboard spielst?
 
Zuletzt bearbeitet:
Flux-Kompensator
Flux-Kompensator
Registriert
06.09.06
Beiträge
60
Punkte Reaktionen
2
Punkte
215
Hallo Clemens,
sorry für späte Antwort.

Midi Monitor zeigt mir Aktivität an, sobald ich eine Taste drücke.
Hatte ja auch oben schon beschrieben, dass die Steuerungsleiste auch Aktivität anzeigt, sobald eine Taste gedrückt wird.
Durch mein vieles Try-and -Error hatte ich sogar die Funktion aktiviert, die den DX7 als Midi-Controller arbeiten lässt.
Muss diese Funktion wieder über die Steuerung umgehen, denn nun voreingestellt.

Es kommt also ein Midi-Signal an.
Was nicht geht ist recorden oder irgendeinen Ton bei einem x-beliebigen Software-Instrument heraus zubekommen.
Über die Tastenkombination komme ich nur ins Environment-Fenster der Audiodateien. Da scheint was falsch zu sein.
Über CMD+7 komme ich in die Event-LIste, die mir eigentlich die Midi eingespielten Spuren anzeigen sollte. Die ist jetzt natürlich leer, denn ich kann ja nichts einspielen.
Einen Layer mit "Klick&Port" finde ich da nicht.

Über CMD 0 komme ichin die Midisettings.
Da finde ich auch den Layer und die Abbildung des Tasteninstruments.
Als Eingang wird die M2 angezeigt. Meiner Meinung nach auch richtig.
Und hier wird es kurios.
Sobald ich auf dem Bildschirm auf die kleine Tastatur drücke ertönt ein Ton, die Note wird durch Buchstaben und Ziffern angezeigt und das Notensymbol vor den Ziffern ist eindeutig nicht durchgestrichen.
Sobald ich das über den DX7 mache wird die Note als Buchstabe und Ziffer angezeigt, jedoch das Notensymbol davor ist durchgestrichen. Die Tastaturabbildung bleibt unberührt. Also kein Ton.

Mein Fazit: Signal kommt an, wird aber irgendwie in Logic nicht verwurschtelt.
Und sorry, das kenne ich so nicht. Wie gesagt, auf altem Rechner und noch mit Logic 8 hat alles auf Anhieb funktioniert.
Auch die kleine Oxygen-Tastatur tut sofort was ich will.

Schau mal Bild mit der durchgestrichenen Note
Grüße

Flux
 

Anhänge

  • Bildschirmfoto 2022-01-09 um 20.23.53.png
    Bildschirmfoto 2022-01-09 um 20.23.53.png
    128 KB · Aufrufe: 45
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.298
Punkte Reaktionen
7.447
Punkte
39.500
Über CMD 0 komme ichin die Midisettings.
Sorry, Schreibfehler meinerseits.

Mir fällt auf, dass die Noten auf Midikanal 8 ankommen.
Manche Instrumente spielen nur, wenn sie Noten auf Kanal 1 empfangen.
Ich würde das der Einfachheit halber am DX7 umstellen. (Sendekanal auf 1)
Durch mein vieles Try-and -Error hatte ich sogar die Funktion aktiviert, die den DX7 als Midi-Controller arbeiten lässt.
Muss diese Funktion wieder über die Steuerung umgehen, denn nun voreingestellt.
Darin könnte der Grund liegen.
Schau mal in den Controllerzuweisungen (Menü>LogicProX>Bedienoberflächen>Controllerzuweisungen), ob da evtl. Befehle mit Noten verknüpft sind.
Testweise könntest Du im Benutzerordner unter Username/Library/Preferences mal die Dateien
- com.apple.logic.pro.cs
- com apple.logic10.plist
auf den Desktop verschieben.
Die werden dann beim nächsten Logic-Start neu angelegt und Deine bisherigen EInstellungen sind neutralisiert.
Bitte nur verschieben, damit Du sie im Zweifel wieder zurücklegen kannst.
 
Sascha Franck
Sascha Franck
Registriert
31.10.18
Beiträge
16.172
Punkte Reaktionen
7.313
Punkte
38.165
Nur mal so nebenbei: Die durchgestrichenen Noten sind Note-Off Befehle. Irgendwas scheint da am DX nicht sauber zu ticken - denn die Note-Offs kommen ja durch.
 
P
Phase1
Registriert
11.02.21
Beiträge
22
Punkte Reaktionen
15
Punkte
68
Vermutlich ist das jetzt nicht wirklich hilfreich, aber ich erinnere mich, dass mein oller DX-7 immer schon midimäßig etwas eigen war.

Zum Beispiel musste ich bestimmte Soundmodule zwingend via Atari anschließen, weil der DX sich weigerte, direkt mit ihnen zu kommunizieren. Da kam dann maximal ein erster Ton raus und das war's dann. Das hatte möglicherweise etwas mit fehlender Unterstützung des MIDI-"running status" zu tun, sagte mir gerade noch eine in einer Hallwolke verklingende Stimme der Erinnerung eines alten Mannes.
Und dass der velocitymaßig nur von 1-100 überträgt, weisst du hoffentlich auch? Kann man aber sicher auch in Logic mappen.
 
T
therealelfatale
DAW-Offizier
Registriert
30.09.20
Beiträge
370
Punkte Reaktionen
186
Ort
NRW
Punkte
980
Alle Midi-Kanäle von "Alle" einzeln bis 16 durchprobiert.
Midi wird ja komischerweise erkannt, denn in der oberen Leiste (nennt sich wohl Steuerungsleiste) kann ich ja sehen, welche Noten auf dem DX7 gespielt werden. Nur das Notensymbol daneben ist durchgestrichen. Auch zeigt er mir "kein Output" an und auch da habe ich alle Kanäle durchprobiert.
Und beim Recorden schreibt er keine Noten. Leiste für Softwareinstrument ist danach wieder leer.
Treiber muss ich für M2 eigentlich nicht deinstaillieren, denn wenn ich Audio über M2 reingehe, funktioniert alles. Zudem wird mir M2 auch als Midi-Eingang angezeigt.
Jetzt solltest Du mir aber noch erklären, was Du unter "Local Off"-Modus verstehst?

Grüße Flux
die Tonerzeugung ausschalten. Bei manchen Geräten kann es sein, dass wenn die eigene Tonerzeugung an ist, bei midi nur note off signale gesendet werden oder garnichts.
 
fuzzfilth
fuzzfilth
Auskenner
Registriert
30.10.20
Beiträge
83
Punkte Reaktionen
58
Punkte
257
Ein normaler DX-7 sendet immer anständige Note-On- und Note-Off-Befehle, egal ob Local On/Off (allerdings nur mit einem Velocitybereich von 0-100, aber das hat den Flux bislang auch nicht gestört). Entweder der DX-7 hat ne Macke oder das MIDI-Interface im M2. Kannst du den DX-7 mal ganz oldskool an einen anderen Synthi anstöpseln und schauen ob zumindest das funktioniert ? Dann weißt du wo der Fehler liegt.
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.298
Punkte Reaktionen
7.447
Punkte
39.500
Auch die kleine Oxygen-Tastatur tut sofort was ich will.
Hat das Oxygen einen Midi In oder Midi Out?
Je nachdem könntest Du testen, den DX-7 über das Oxygen anzuschliessen (Midi In) und damit rauszufinden, ob das M2 funktioniert.
Oder Du könntest das Oxygen mit dem M2 testen - wenn das funktioniert müsste es am DX-7 liegen.

Mannomann ... ich meine, das Problem mit den durchgestrichenen Noten hätte ich schon mal gehabt, aber ich komme nicht mehr drauf ...

Teste zur Sicherheit noch mal ein anderes Midikabel.
 
Flux-Kompensator
Flux-Kompensator
Registriert
06.09.06
Beiträge
60
Punkte Reaktionen
2
Punkte
215
Hallo zusammen,

das mit den Note-Off-Signalen scheint genau das Problem zu sein und ist genau das, was ich mir nicht erklären kann.
Wie gesagt, auf Logic 8 und über die MK828 hat es probemlos funktioniert. Leider gibt es das System bei mir nicht mehr.
Am DX7 wurde jedoch in der Zeit nichts an den Einstellungen geändert. Hatte ja auch keine Veranlassung dazu.
Auf die Idee mit DX7 über Oxygen in die M2 zu gehen hatte ich auch schon gedacht, aber das funktioniert leider nicht, denn Oxygen hat nur USB und keine Midi-Anschlüsse.
Auch meine alte Motu mit Firewire wieder rauszukramen und es über die zu versuchen, geht leider nicht, denn Apple hat keine Firewire-Anbindung mehr am Macbook und ich keinen Adapter.
Andere Synthies existieren bei mir leider nicht, daher kaum ein Vergleich möglich.
Jedoch hatte ich den Gitarrensynth Roland GR55 aus Spass schon mal dran und das hat auch problemlos über die M2 funktioniert.

Beruhigt mich jedoch schon mal, dass ihr auch ein leichtes Stirnrunzeln habt wegen den Note-Off-Signalen. :) Dachte schon ich bilde mir das nur ein. Ursache wird wohl doch im DX7 liegen und da wird die Fehlersuche wohl recht zäh werden.

Grüße
Flux
 
clemenserwe
clemenserwe
Moderator
Teammitglied
Registriert
03.03.09
Beiträge
16.298
Punkte Reaktionen
7.447
Punkte
39.500
Beruhigt mich jedoch schon mal, dass ihr auch ein leichtes Stirnrunzeln habt wegen den Note-Off-Signalen.
Aber an sich müsste der Midi-Monitor das dann auch anzeigen.
Also mal nur die Taste runterdrücken und schauen, was der Midimonitor anzeigt.

Achso - hast Du schon Treiber- und Firmware-Version bei Motu kontrolliert?
 
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.594
Punkte Reaktionen
1.368
Punkte
5.754
Sicher hast Du außer dem DX7 noch irgendetwas anderes an MIDI- verarbeitender Hardware, z.B. einen anderen Synth oder ein Soundmodul. Versuch das doch mal über den DX7 zu spielen, wenn das geht, kannst du den DX erstmal als Fehlerquelle ausschließen.
 
Flux-Kompensator
Flux-Kompensator
Registriert
06.09.06
Beiträge
60
Punkte Reaktionen
2
Punkte
215
Sicher hast Du außer dem DX7 noch irgendetwas anderes an MIDI- verarbeitender Hardware, z.B. einen anderen Synth oder ein Soundmodul. Versuch das doch mal über den DX7 zu spielen, wenn das geht, kannst du den DX erstmal als Fehlerquelle ausschließen.
Ja, das hatte ich doch oben schon geschrieben, nur war die Vorgehensweise anders rum. Daher blieb nur der DX7 als Fehlerquelle ;-)

Aber keine Panik mehr, ich habe das Problem gefunden.
Hat leider einige Zeit zum googeln gebraucht, aber die Lösung ist folgende gewesen.
Der DX7 verfügt über eine kleine 2032 Batterie mit 3 Volt. Die soll die Speicherdaten sicherstellen. Da kam ich leider nicht gleich drauf.drauf, dass da ´ne Batterie drin sein könnte. Im Manuel hatte ich dann etwas von Batterie-Check-Taste gelesen und die sagte dann, das ich doch bitte mal nach einer neuen schauen sollte.
Blöd dabei ist nur, dass die Batterie auch Funktionen während des Netzbetriebs unterstützt, dabei aber extrem lange Haltbarkeit gezeigt hat. Genauer gesagt war die jetzt wohl gut 30 Jahre drin. Made in Japan stand noch drauf, als richtig vintage. :)
Das bedeutet jedoch, wenn die kleine Batterie schwach auf der Brust ist, dann kann man alle Einstellungen machen wie man will, es geht nix.
Daher den DX7 aufgemacht, Platine ausgebaut, Batterie abgelötet (Ja, die ist tatsächlich angelötet!!!!), neue Batterie rein und angelötet, alles wieder eingestöpselt und verschraubt. Wem langweilig ist, der kann sowas mal auf Youtube anschauen :)
Sämtliche Werkspresets sind dabei natürlich weg, aber die brauch ich sowieso nicht, dafür konnte ich mich wieder mit den Midieinstelllungen beschäftigen.
Und: Jetzt kommen richtige Noten an und keine Note-Off mehr.
Danke für Eure Tipps!


Grüße

Flux
 
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.594
Punkte Reaktionen
1.368
Punkte
5.754
Batteriewechsel :oops: - hab ich selber schon bei mehreren DX7 / TX7 gemacht.
Das hätte ich ehrlich gesagt nicht vermutet, denn normalerweise sieht man es am Display, wenn die Batterie schlapp macht.
Aber schön, dass Du den Fehler gefunden hast!
 
akStudio
akStudio
Registriert
31.10.12
Beiträge
1.594
Punkte Reaktionen
1.368
Punkte
5.754
Andere Synthies existieren bei mir leider nicht, daher kaum ein Vergleich möglich.
Ja, das hatte ich doch oben schon geschrieben
Sorry, das hatte ich in meiner Antwort oben übersehen.
Aber als Nachtrag noch ein Tipp, falls jemand anderes mal ein ähnliches Problem mit einem Synthi hat (nicht nur mit dem DX7) und der Verdacht naheliegt, dass MIDI-Daten nicht korrekt gesendet werden:
Wenn kein anderer Synthi als Empfänger zur Verfügung steht, dann kann man ihn mal LocalOff schalten und dadurch in unabhängige Sender- und Empfänger-Units auftrennen. Die Klangerzeugung könnte man dann über eine äußere MIDI-Verbindung (MIDI-Kabel von Out->In) ansteuern. Natürlich muss man dafür sorgen, dass empfängerseitig die entsprechenden MIDI-Rcv-Funktionen eingeschaltet sind.
 
P
Phase1
Registriert
11.02.21
Beiträge
22
Punkte Reaktionen
15
Punkte
68
Batteriewechsel :oops: - hab ich selber schon bei mehreren DX7 / TX7 gemacht.
Stimmt, eine Batterie ist drin, es gibt sogar eine Abfrage der Spannung mittels Servicemode. Mein DX-7 wird nächstes Jahr 40 und die erste ist noch drin und geht. Vielleicht sollte ich die Batterie als "vintage old stock, time-tested" anbieten.

Möglicherweise krieg ich eines Tages sogar für die ollen Rolands und Oberheims noch Geld...
 
Zuletzt bearbeitet:

Ähnliche Themen

Can
    • Danke
  • Artikel
Antworten
11
Aufrufe
35K
oove
oove
J
Antworten
1
Aufrufe
2K
JoeHot
J
M
  • Artikel
Testberichte Test Yamaha MOXF 6/8
Antworten
9
Aufrufe
121K
Can
Can
B
Antworten
3
Aufrufe
1K
rockadeaz
R
 

Neue Antworten


Oft gelesene Themen

Oben