Information ausblenden

Midimodul nicht da

Dieses Thema im Forum "REAPER" wurde erstellt von Alfredo, 16.07.08.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Hallo,

    ich bin gerade ins Programm Reaper eingestiegen, also noch Anfänger. Trotzdem erlaube ich mir mal eine Frage an die Profis zu richten.

    Ich habe ein Audio-Interface, eine Drumcomputer und ein Soundmodul, das ich in Reaper einbinden möchte. Der Drumcomputer und Midi-Interface sind mit USB am Rechner angedockt. Das Soundmodul über den Midi-Ausgang des Audio-Interfaces. Heute wollte ich Reaper konfigurieren für den Midi-Betrieb. Dabei wurde mir in den Einstellungen sowohl der Drumcomputer wie auch das Audio-Interface angezeigt, leider aber nicht das Soundmodul. Wie kann ich Reaper beibringen, dass da auch noch ein Soundmodul ist, was über bestimmte Midi-Kanäle angesprochen werden soll?

    Für jeden Tipp wäre ich dankbar.
    Gruß
    Alfredo
     
    Alfredo, 16.07.08
    #1
  2. Lacunaflow

    Lacunaflow Influencer Mitarbeiter

    Registriert seit:
    25.12.06
    Artikel:
    5
    Punkte:
    88.596
    88596
    Welcome! :)


    Midi Sendet keinerlei Information über das angeschlossene gerät (im gegensatz zu USB)

    Du musst dein Soundmodul über das Audio Interface ansprechen!


    Gruß...
     
    Lacunaflow, 16.07.08
    #2
  3. fmo

    fmo

    Registriert seit:
    14.12.04
    Punkte:
    13.151
    13151
    Wäre mal interessant gewesen, zu erfahren, welcher Drumcomputer das ist ...
     
    fmo, 16.07.08
    #3
  4. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Meinst Du, dass ich das Soundmodul ebenfalls über USB ansprechen soll? A
     
    Alfredo, 16.07.08
    #4
  5. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Das Soundmodul ist übrigens ein Roland XV-2020
     
    Alfredo, 16.07.08
    #5
  6. Cos

    Cos

    Registriert seit:
    24.11.03
    Punkte:
    7.442
    7442
    Eine Midi-Verbindung ist eine sehr simple Datenverbindung, eine Plug&Play Geräteerkennung wie z.B. bei USB gibt´s da nicht. Das heißt, dass du in Reaper zunächst mal den Midi-Ausgang auswählen musst, an dem dein Soundmodul hängt. Dann musst du einen Midikanal einstellen, über den du dein Soundmodul ansprechen willst. Das Soundmodul muss auf den selben Kanal (oder auf "Omni" -> alle Kanäle) eingestellt werden. Beim deinem Soundmodul kannst du wahrscheinlich gleichzeitig mehrere Sounds parallel ansprechen, für die du dann jeweils die Midi-Empfangskanäle einstellen kannst. In Reaper lassen sich sicherlich mehrere Midi-Spuren anlegen, über die du dann auf den entsprechenden Kanälen jeden Sound deines Moduls ansteuern kannst.

    Grüße
    Cos
     
    Cos, 16.07.08
    #6
  7. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Danke für den Hinweis, doch ist die Sache irgendwie verhext. Ich habe früher mal mit einer Cakewalk LE-Version gearbeitet, da hat es eigentlich geklappt. Doch bei Reaper habe ich einfach keine Peilung mehr. Vielleicht darf ich das kurz erklären:

    Ich habe eine Midi-Tastatur, die per Midi-.Out mit dem Audiointerface verbunden ist. Über USB sind ein Drumcomputer und ein Soundmodul (beides Roland) am Rechner angeschlossen. Bei Preferences sind bei Midi-Divieces alle angeschlossenen Geräte enable und werden auch so angezeigt. Angenommen, ich will eine einzige Midi-Spur auf Midi-Kanal 10 (also Drumcomputer) aufnehmen. Was muss ich jetzt in der Spur-Anzeige bzw. in dem Menü bei Input und Output eingeben, damit endlich was zu hören ist?
    Irgendwie fluppt das bei mir nicht.
     
    Alfredo, 16.07.08
    #7
  8. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    Ich verstehe nicht, wieso deine Midi-Geräte über USB am Rechner hängen. Deine Midi-Tastatur hängt doch auch am Interface, wie du schreibst.

    Bei mir läuft Midi ausschließlich über das Interface (Tascam U-122). Edit: Der Sound der Midi-Geräte läuft dann wiederum in die Audio-Eingänge des Interface.

    LG
    M
     
    moio, 17.07.08
    #8
  9. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Danke für Deinen Hinweis. ich habe die USB-Variante genommen, weil Midi irgendwie nicht funktionierte. Aber vielleicht habe ich da nur was falsch gemacht.
    Ich werde mal folgende Konfiguration versuchen:
    Wenn ich jetzt das Midi-Keyboard (line out) an Tascam Liine In.
    Tascam Line out an Soundmodul Line In). Soundmodul Midi Thru an Drum-Computer Midi-in.
    Jetzt müsste dann ja unter Preferences nur noch das Audiointerface als Eingang und Ausgang stehen, oder?
    Und wie kann ich dann Reaper klarmachen, welches Modul angespielt werden soll? Das habe ich nämlich im Programm noch nicht richtig geschnallt. Ich muss ja über die Software die verschiedenen Geräte ansprechen können. Und dass Programm muss ja auch irgendwie gesagt bekommen, dass es z.B. auf Midi-Kanal 10 nur den Drumcomputer ansprechen soll, nicht aber die Drumspur auf Kanal 10 des Soundmoduls.
    Wie muss ich das machen? Wäre Dir für eine Hinweis sehr dankbar.
     
    Alfredo, 17.07.08
    #9
  10. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    Was für ein Tascam-Interface hast du denn? Auch das U-122 oder Nachfolger?

    Ist das, was du "Midi-Keyboard" nennst vielleicht ein Master-Keyboard (nur Steuerung, keine Sounds)? Dann bringt es gar nichts, wenn du das direkt ans Interface anschließt, denn was sollte es da steuern?

    Soweit ich mich erinnere (ich arbeite nicht mehr mit externen Midi-Geräten), war es so:

    -Masterkeyboard -->Midi-Thru (bin mir aber nicht 100% sicher) der Tongeneratoren (Drums, Sounds)

    -Ausgang Midi-Tongeneratoren --> Midi-Eingang/Interface (und umgekehrt:)

    -Eingang Midi-Tongeneratoren --> Midi-Ausgang/Interface


    oder so. mit midi thru bin ich mir nicht so sicher, probiers aus.
    M




    Edit: sonst probier das ganze doch erstmal ohne keyboard, da kann ja icht soviel verkehrt gehen:

    Ausgang/Interface an Eingang/Soundmodul, Eingang/Interface an Ausgang/Soundmodul.
     
    moio, 17.07.08
    #10
  11. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Probiere ich aus. Allerdings die Sache mit der Midi-Tastatur kann nicht ganz richtig sein. Die hat zwar keine eigenen Sounds, doch werden ja Midi-Befehle ausgegeben (gedrückte Taste, Velocity etc), die vom Soundmodul wiedergegeben werden müssten. Für Versuchszwecke werde ich mal nur mit dem Soundmodul arbeiten. Für eine dauerhafte Lösung brauche ich aber eine Variante, wo ich über die Tastatur die Module ansprechen kann.
     
    Alfredo, 17.07.08
    #11
  12. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    Zitat:
    <Die hat zwar keine eigenen Sounds, doch werden ja Midi-Befehle ausgegeben (gedrückte Taste, Velocity etc), die vom Soundmodul wiedergegeben werden müssten. >


    Genau, deswegen muss meiner Ansicht nach das Keyboard an die Midi-Geräte und nicht an das Interface. Denn wie willst du die Midi-Geräte ansteuern, wenn du das Keyboard ans Interface schließt?

    man korrigiere mich, wenn ich Blödsinn erzähle ...
     
    moio, 17.07.08
    #12
  13. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Bei einem Test mit Sonar LE hat es aber so geklappt. Deswegen wundert mich die Sache. Über das Audio-Interface (also dessen Midi-In und Out) kann man doch Befehle an die angeschlossenen Geräte geben, oder?
     
    Alfredo, 17.07.08
    #13
  14. fas1piano

    fas1piano

    Registriert seit:
    20.04.07
    Punkte:
    4.837
    4837
    mach doch mal folgendes:

    - nimm eine sequenz in reaper auf. stumm oder mit einem vst. klappts? wenn nicht, hast du midi out vom keyboard mit midi in vom interface verkabelt?

    das interface taucht in reaper auf (bzw. wenn das keyboard ein eingebautes interface hat und über usb angeschlossen wird, dann eben das)?

    du hast es für midi und control in den prefs unter midi aktiviert?

    den richtigen eingangskanal am track angewählt und scharfgestellt, monitor an?

    - wenn du die sequenz hast, dann lass sie von reaper abspielen. schau dir das routing an, richtiger midi port, richtiger midi kanal. verbinde den midi out des interface mit dem XV2020. schau dir die bedienungsanleitung des XV 2020 an - welcher midi kanal? etc.

    wenn alles richtig ist, müsste der jetzt den entsprechenden sound spielen.

    - wenn das alles passt, dann versuch, ob du duch den scharfgestellten track "hindurch" dein modul spielen kannst. monitoring muss dafür glaube ich an sein.

    @ moio
    sinn der übung ist, dass die midi daten auch aufgenommen werden.

    lG f
     
    fas1piano, 17.07.08
    #14
  15. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    Moin fas1piano ,

    so, ich habe jetzt den Text durchgeführt. Ich habe das Midi-Keyboard mit USB an den REchner angeschlossen und gleichzeitig per Midi-out an das Interface. Den Out-Ausgang habe ich mit dem In vom Soundmodul verbunden. Dann habe ich über den Midi-Editor mal ein paar Noten eingegeben. Die wurden dann auch vom Soundmodul abgespielt. Unter Pref/ Midi-Device sind bei mir bei Input wie bei output sowohl das Keyboard wie auch das Tascam als Midi eingestellt (also Enable).

    Dann habe ich noch einen Versuch gemacht, eine Midi-Spur mit dem Keyboard aufzunehmen. Hat auch geklappt. Was aber nicht funktioniert, ist die Sache mit dem Drumcomputer. Den habe ich über Midi-Thru des Soundmoduls verbunden. Das führte aber dazu, dass er nur wie wild irgendwelche Presets abspielte.

    Die zweite Sache, die mir aufgefallen ist, die Sounds werden nicht besonders laut abgespielt. Auch wenn ich per Midi-Controller die Lautstärke auf volle Pulle stelle, ist es nicht besonders laut. Das kann natürlich mit dem Interface (Tascam US 1641) zusammenhängen. Dort gibt es einem Mixer-Regler, mit dem man die Signale, die von den Midi-Eingängen und den anderen Signal-Quellen kommen, mischen kann. Doch die Midi-Sachen bleiben im Gegensatz zu den anderen Signalquellen (z.B. eingespielte Gitarre als Audio-Datei) recht leise.

    Und in der Pegelanzeige der jeweiligen Spur bewegt sich nichts, wenn da was abgespielt wird. Muss man da noch eine besondere Sache aktivieren?

    Aber bis hierher schon mal einen herzlichen Dank für den Tipp, sodass ich wenigstens schon ein kleines Stück weiter bin.
    Alfredo
     
    Alfredo, 17.07.08
    #15
  16. fas1piano

    fas1piano

    Registriert seit:
    20.04.07
    Punkte:
    4.837
    4837
    " Hat auch geklappt. Was aber nicht funktioniert, ist die Sache mit dem Drumcomputer. Den habe ich über Midi-Thru des Soundmoduls verbunden. "

    schließ den doch mal direkt an. wenns dann klappt, musst du im soundmodul was umstellen.

    "Das kann natürlich mit dem Interface (Tascam US 1641) zusammenhängen. Dort gibt es einem Mixer-Regler, mit dem man die Signale, die von den Midi-Eingängen und den anderen Signal-Quellen kommen, mischen kann. "

    das verstehe ich nicht ganz - kann es sein, dass du midi daten und audio daten durcheinander bringst? midi daten haben an sich keinen pegel, es sind ja nur steuerdaten.

    lG f
     
    fas1piano, 21.07.08
    #16
  17. Alfredo

    Alfredo Themenersteller

    Registriert seit:
    16.07.08
    Punkte:
    17
    17
    @@fas1piano
    So, Drumcomputer läuft jetzt auch. War ein Fehler von mir in der Einstellung in Reaper. Habe den Drumcomputer direkt an den PC via USB angeschlossen, das klappt. Midi-Thru macht die Sache wohl zu kompliziert. Hauptsache, es funktioniert zunächst mal so.

    Mit dem Regler hat es Folgendes auf sich. Dreht man den Mix-Regler am Tascam nach links, werden die Midi-Spuren lauter, wenn man nach rechts dreht, die Audiospuren (also alles, was ich direkt mit Gitarre als Audio einspiele, Softwaresythesizer etc.). Esist also ein Regler, der beide Signalquellen mischen soll.
    Da die Midi-Dateien nur Steuerdaten sind, wie ich ja vermutet habe, wird im Pegel-Anzeiger von Reaper auch nur ein rotes Signal angezeigt, offensichtlich "ein Midi-Befehl ist eingegangen". Muss ich aus den Midi-Daten erst eine Audio-Spur machen, damit mir der Pegel angezeigt wird? Und zweite Frage: Ich habe mal mit VST-Instrumenten und Synthezisern rumexperimentiert. Wenn man die einbindet, werden die Midi-Steuerdaten bzw. Spuren ja von diesen Synthiz abgespielt. Das klappt auch. Wie kann ich aber, wenn ich einen solchen Klangerzeuger in die Spur gelegt habe, dessen Menü aufrufen, um die Regler dieses Teils editieren zu können? Wenn ich ein VST-Instrument etc. aufrufe, wird mir dessen Oberfläche angezeit. Wenn ich diese Oberfläche aber später noch einmal einsehen will, wie kann ich die für die jeweilige Spur wieder sichtbar machen?

    Kann mir vorstellen, dass diese Fragen nerven, aber ich arbeite mich an diesem Scheiß im Moment ab und komme nicht mehr zum Musik machen. Und das kann ja nicht Sinn der Sache sein, oder?

    Wäre Dir also -trotz Nerverei- dankbar für eine Antwort.

    Gruß
    Alfredo
     
    Alfredo, 22.07.08
    #17
  18. Lacunaflow

    Lacunaflow Influencer Mitarbeiter

    Registriert seit:
    25.12.06
    Artikel:
    5
    Punkte:
    88.596
    88596
    Moin!

    Um das Vsti oder Vst zu sehen musst du auf das grün leuchtende "FX" klicken!

    Gruß...
     
    Lacunaflow, 22.07.08
    #18
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.