Information ausblenden

Aufnahmeverzögerung mit Hardware ab Projektanfang

Dieses Thema im Forum "REAPER" wurde erstellt von Noizebreaker, 03.07.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Moinsen,

    Mal wieder was entdeckt:

    Gestern habe ich festgestellt das bei allen Aunahmen mit verschied. externen Synthesizern, ab Projektanfang / Takt 1, die Aufnahme leicht verzögert einschaltet, bzw. sich erst leicht 'verschluckt' bevor sie voll hörbar ist. Beginne ich erst ab Takt 2 auf zunehmen (mache ich 'eh meistens ) ist alles sofort ab Taktanfang da. Gibt es da evtl. etwas was ich übersehen habe, z.B. Einstellungstechnisch?
    Ich frage deshalb, weil es in Logic und Studio One mit Hardware nicht passiert (von wegen Interface-Latenz, Presonus FP10), mit Softsynths in Reaper auch nicht.
    Ab Takt 2 aufnehmen tue ich deshalb weil manche DAW, z.B. Logic, manchmal einen Teil der ersten Note beschneidet.....
     
    Noizebreaker, 03.07.12
    #1
  2. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Hm, :kratzamkinn:
    was hast du denn jetzt eingestellt?
    Routing manuell gebaut?
    Plugin für die Einbindung der Hardware verwendet?
     
    kickback, 03.07.12
    #2
  3. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Sowas macht generell Sinn.
    Bei Start ab Takt eins gibt es genügend Situationen, bei denen im ersten Moment ne Menge Daten - und seien es nur Controllerdaten wie Program Changes, Volumedaten und so weiter - abgeschickt werden. Die sollten aber eigentlich schon draussen sein, bevor die Musik anfängt.

    Es ist eine gute Praxis, die sogenannte PreRoll-Zeit aus dem Bandmaschinen-Jahrhundert zu übernehmen..... ;)
     
    tubeless, 03.07.12
    #3
  4. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Also es versetzt exakt 1 Takt /Beat........ab Anfang. Habe normal eine Spur für Midi und eine für Audio angelegt und auch mit ReaInsert ist es das gleiche. Routing manuell gebaut...? Weiß nicht ob ich das gerade richtig verstehe? Also die ganz normale Einrichtung einer Midi & Audiospur mit den entsprechend ausgewählten Audio u. Midizuweisungen im Audio und Midiinterface..........


    @tubeless

    Ja ,ich denke da hast du völlig recht, daher mache ich das auch schon länger. Aber mich interessiert es halt dahingehend weil es bei Reaper halt so extrem ist und in den anderen erwähnten DAW's eben nicht so zum tragen kommt...Irgendwo dran muß es liegen.

    Grüsse
     
    Noizebreaker, 03.07.12
    #4
  5. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    hui...

    egal ob nun Viertel oder Takt. Das ist irgendwie... viel :D


    Nun, du kannst ja entweder eine Midi-Spur auf einen Hardwareausgang schicken und via Audioeingang auf eine zweite aufnehmen, ODER reainsert in die Midispur werfen und das Ergebnis in der "Midi-Spur" aufzeichnen.

    Du machst aber irgendwie beides? Oder hast du eh beides einzeln versucht?

    Hast du bei reainsert denn eine delay compensation eingestellt oder auto detect gemacht?


    Mich auch, aber ehrlich gesagt nicht so brennend :D
    Ich fang sogar meistens erst irgendwo bei Takt9 an.

    Wie auch immer: auf die schnelle konnte ich das Problem bei mir leider nicht nachvollziehen :(
     
    kickback, 03.07.12
    #5
  6. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Ja, dann habe ich dich richtig verstanden, ich habe beides einzeln versucht und jau es iss' viel :)
    Keine delay compensation eingestellt........auto detect gemacht....alles wie gehabt (ohne auto detect vergrößert es sich sogar noch etwas)
    Das sagt ja das es bei dir funktioniert, dann muß hier irgendwo 'n 'Wurm' rumkriechen.
     
    Noizebreaker, 04.07.12
    #6
  7. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Nicht zwangsweise. Vielleicht ist es ja nur Zufall, dass es bei mir mit dem einen Gerät (ich hab's mit meinem E-Piano ausprobiert) funktioniert.

    Ganz ehrlich: ich würd mich nicht besonders viel Gedanken machen. Midi und Takt 1 ist generell nicht die beste Idee, also fang einfach weiter hinten an und denk dir einfach "schei## reaper" :D

    Vielleicht liegt's am Buffering, irgendwelchen anticipative FX processing-setting (render ahead),... herumprobieren könnte man viel, aber ob es sich auszahlt?
     
    kickback, 04.07.12
    #7
    Noizebreaker bedankt sich.
  8. karumba

    karumba Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    "herr doktor, immer wenn ich so mache habe ich schmerzen" - "na dann machen sie doch einfach nichtmehr so". ;-)

    ich nutze reaper, ich weiss aber nicht ob das problem bei mir auch exisiert, denn ich fange auch immer bei takt 2 an. ist gewohnheit bzw. habe ich so noch etwas luft nach vorne fürs exportieren, wenn der kunde mir die spuren mal zu knapp geschnitten anliefert.
     
    karumba, 04.07.12
    #8
  9. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Ja...ich lass' es so laufen, mache ich ja 'eh schon. Dann krieg' ich's eben nicht raus und da es ja sonst (später eben) normal funktioniert kann ich damit leben.

    Dank' euch. [​IMG]

    @karumba

    Also wenn das deineHardware betrifft und du hättest das Problem auch, hättest du es 100%ig gemerkt.
    Bei Software tritt es ja nicht auf.
     
    Noizebreaker, 04.07.12
    #9
  10. karumba

    karumba Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    welches soundkarte & buffersize hast du?
    ich habe die RME hammerfall DSP & meine buffer size ist auf 1024 samples (44khz).
     
    karumba, 04.07.12
    #10
  11. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Hi karumba,

    Ich hab 'n Presonus FP10 und als Midi interface 'n Edirol UM880 . Buffersize? Das in deutsch in Reaper jetzt die 'Blockgröße', oder? 128.......früher mal 256....(Puffergröße wäre dann die bessere Übersetzung gewesen....)
     
    Noizebreaker, 04.07.12
    #11
  12. karumba

    karumba Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    ich stelle den wert bei mir in der software zu soundkarte ein.
    hast du mal probiert den wert hoch zu setzen?
     
    karumba, 04.07.12
    #12
    Noizebreaker bedankt sich.
  13. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Nein.
    Du musst die Latenz im Controlpanel Deiner Karte einstellen. Das Panel kann man allerdings auch aus dem Sequencer aufrufen, es ist aber nicht Bestandteil des Sequencers.
    Mir scheint, Du schraubst da an der falschen Stelle..... ;)

    Benutzt Du überhaupt ASIO-Treiber? ODer wenn nein - welche dann?
     
    tubeless, 04.07.12
    #13
  14. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Okay,nein, dann schraubeich an der falschen Seite. 8) , mal schauen....Nein, kein ASIO-Treiber, bin mit ' nem Stück Obst unterwegs, Core-Audio Treiber. :)
    Aber das FP 10 stand auch auf 1024 Samples.
     
    Noizebreaker, 04.07.12
    #14
  15. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Das passt dann auch.
    Wenn ich das richtig mitbekommen habe, sind die besser als die ASIO-Treiber aufm PC.... ;)

    Nun weiss ich bei Mac nichts.
    aber allgemein ist es so: Die Blockgrösse ist der kleinste Teil desZwischenspeichers, der für die Pufferung benutzt wird.
    Dann kommt die Anzahl der Blöcke, und beides miteinander multipliziert ergibt normalerweise dann den Puffer. Was da am Ende besser ist - grosse Blöcke oder viele Blöcke, das weiss ich allerdings auch nicht...... :D

    Also zB könnte ein Block 10 Samples gross sein, 100 Blöcke gibt dann 1000 Samples Puffergrösse. Oder so. Oder so ähnlich.... ;)

    PS:
    Lass doch mal nen Creenshot von dem Apfeleinstelldialog sehen. Dann kann man sich auch als Nicht-Apfler was drunter vorstellen....
     
    tubeless, 04.07.12
    #15
    Noizebreaker bedankt sich.
  16. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Ich kann mein eigenes (floating) Window nicht ablichten, aber hier mal 'n link der Core Audio Einstellungen in Logic:

    http://help.apple.com/logicpro/mac/...al/index.html#chapter=44&section=4&tasks=true

    Im I/O steht dann halt mein FP10. Das Control Panel erübrigt sich hier denn:

    Macintosh OSX
    The audio drivers for the FIREPOD/FP10 are to be included in the CORE AUDIO of Macintosh OSX 10.3.5 and later.

    Im Control Panel kann ich nur noch betreffend der Clock Sync zwischen u. wählen. Mit den Blockgrößen habe ich schon rumgetestet, das ändert leider auch nix.
     
    Noizebreaker, 04.07.12
    #16
  17. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    22.901
    22901
    Und was ist da mit der I/O-Buffer Size?
     
    tubeless, 04.07.12
    #17
  18. Noizebreaker

    Noizebreaker Themenersteller

    Registriert seit:
    19.01.11
    Punkte:
    930
    930
    Ja...., das entspricht dem von karumba gesagten. Aaaaaber....tubeless....
    Ich bin ja hartnäckig beim Fehlersuchen und ich hab's gefunden...und wieder dazu gelernt....puuh ey......
    The Winner, ähh die Lösung ist:

    Der Fehler lag hier bei folgender Einstellung....ich bin nochmals alles durchgegangen und... Ich habe mir letztens komplett neue Track Templates für all meine Hardware-Maschinen angelegt. So weit, so gut...Da mehrere Tastaturen vorhanden sind wähle ich bei Midi natürlich 'Alle Eingänge ' aus.
    Aus unerfindlichen Gründen habe ich dann aber auch 'Alle Kanäle' statt wie sonst Kanal 1' ausgewählt. Und das mag der Reaper eben nicht und bekommt so Anfälle von 'Midilatenz Versatzwahnsinn'. Alle Kanäle wieder auf Kanal 1 geswitched und gut ist wieder, wie in Logic etc...... verschluckt 'ma kurz gelegentlich einen Teil der ersten Note.....Aber dafür fange ich ja erst bei Takt 2 an......Gute alte PreRoll-Nummer eben;)


    Danke mal wieder für eure Tipps, Geduld und Hilfestellung :right:

    Grüsse
    Noize
     
    Noizebreaker, 04.07.12
    #18
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.