Information ausblenden

Audio-Treiber-Konfigurations-Prblem

Dieses Thema im Forum "Ableton Live" wurde erstellt von artico, 28.06.08.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. artico

    artico Themenersteller

    Registriert seit:
    27.11.07
    Punkte:
    119
    119
    tag.

    ich hab heute in Live etwas an den Audiotreiber-Einstellungen geändert.
    hab von MME/DirectX auf ASIO umgestellt.das Prblem war dann allerdings: Ich hatte keine Soundausgabe mehr bei anderen Anwenudungen, sei es Musik im Windows Media Player oder bei Videos bei youtube etc...
    der Sound in Live funktioniert dagegen allerdings.

    muss ich die Einstellungen ändern oder brauch ich n neuen Treiber??
     
  2. werner_o

    werner_o

    Registriert seit:
    16.10.06
    Punkte:
    1.842
    1842
    Etliche Soundkartentreiber beherrschen sogenanntes "Kernel Streaming":
    via WDM oder Direct Sound angesprochen können dann mehrere Programme gleichzeitig auf diesen Wiedergabetreiber zugreifen und parallel Sound ausgeben.

    Sobald aber ein Programm (etwa Ableton) via ASIO auf die Soundkarte zugreift, sind die benutzten Aufnahme-/Wiedergabetreiber für andere Programme gesperrt und beispielweise der Windows-Mediaplayer kann dann nicht mehr auf diese Treiber der Soundkarte zugreifen und somit auch keinen Sound ausgeben.

    Ein neuer Treiber wird Dir darum normalerweise nichts bringen, weil das genannte Phänomen immer auftritt. Du kannst halt normalerweise nicht Ableton und den Mediaplayer gleichzeitig verwenden. Sobald Du Ableton schließt, funktioniert auch der Mediaplayer etc. wieder.

    Einige Programme (etwa Cubase) bieten aber die Option, beim Betrieb im Hintergrund (also minimiert) die per ASIO angebundene Soundkarte freizugeben, damit andere Software darauf zugreifen kann. Evtl. kann das auch Ableton, was ich aber nicht definitiv weiß.
    Aber auch dann kann nur ENTWEDER Ableton (im Vordergrund ausgeführt) ODER etwa der Mediaplayer (im Vordergrund ausgeführt) auf die Soundkarte zugreifen, nicht aber beide Programme simultan.

    Bei mehrkanaligen Soundkarten (etwa meiner Terratec EWS88D mit 10x In und 10x Out) und integriertem Mixer geht es dann aber oft doch mit etwas Frickelei:
    Bei mir könnte ich dann beispielweise den Wiedergabetreiber Out 7/8 in Cubase deaktivieren (sodaß Cubase den unter ASIO nicht anspricht) und ich würde Out 7/8 danach in der Systemsteuerung zum Standard-Audio-Wiedergabegerät machen, damit etwa der Mediplayer darauf zugreifen kann, selbst wenn Cubase im Vordergrund läuft.
    Im Mixer der EWS88D könnte ich dann die Signale von Cubase (etwa die Wiedergabetreiber Out 1/2 bis 5/6) mit dem vom Mediaplayer verwendeten Out 7/8 zusammenmischen und den Mix beider Programme am Out 1/2 abhören.

    Schreibe darum hier mal, welche Soundkarte Du genau verwendest. Je nach Modell könnte das darum auch bei Dir mit etwas Frickelei gehen:
    insbesondere wenn die einen separaten SPDIF-Out-Treiber zusammen mit einem internen Mixer hat kann man dann Dein Problem evtl. mit den richtigen Einstellungen lösen.

    Gruß
    Werner
     
  3. artico

    artico Themenersteller

    Registriert seit:
    27.11.07
    Punkte:
    119
    119
    hmm.., also ich hab Ableton jetzt zu aber im Media Player hör ich immer noch nichts... :-(

    hier mal meine Einstellungen bei Live:
     

    Anhänge:

    • al.jpg
      al.jpg
      Dateigröße:
      42,9 KB
      Aufrufe:
      112
  4. werner_o

    werner_o

    Registriert seit:
    16.10.06
    Punkte:
    1.842
    1842
    Du verwendest anscheinend Onboard-Sound ohne eigene "echte" ASIO-Treiber, und dann solltest Du die Freeware ASIO4ALL installieren und unter Ableton nutzen.

    Danach können wir weiterreden.

    Gruß
    Werner
     
  5. artico

    artico Themenersteller

    Registriert seit:
    27.11.07
    Punkte:
    119
    119
    so, hab's jetzt bei Live eingestellt.
    danke erstmal für die schnelle Hilfe (top! :) )

    -ich hatte erst ne version von ASIO4ALL drauf, hab aber vergessen dass ich die deinstalliert hab -.-
     
  6. artico

    artico Themenersteller

    Registriert seit:
    27.11.07
    Punkte:
    119
    119
    hmm also, ich kann mir jetzt im ASIO4ALL-Modus videos bei youtube angucken(mit ton) bzw. im media player musik hörn, aber mit dem interface aufnehmen kann ich in dem modus SEIT GERADE EBEN nicht mehr ???
    im MME/DirectX-Modus isses genau andersrum: interface läuft, nur media player etc. nich
    kacke
     
  7. werner_o

    werner_o

    Registriert seit:
    16.10.06
    Punkte:
    1.842
    1842
    Du bist anscheinend recht unerfahren und drückst Dich leider sehr unpräzise aus.

    WAS WILLST DU EIGENTLICH ERREICHEN?

    So gut wie niemand, der Ahnung hat, nutzt ein Programm (etwa Ableton Live), welches via ASIO auf die Soundkarte zugreift, GLEICHZEITIG mit Programmen wie "Mediaplayer" oder "youtube-Playback via Browser", weil dann Probleme vorprogrammiert sind.
    Die Hintergründe dazu hatte ich ja bereits ausführlich erläutert.

    Sowas geht selten mit Onboardsound, und selbst mit meiner professionellen 20-kanaligen Soundkarte Terratec EWS88D müßte ich schon tricksen, damit sowas funktionieren kanm.

    Gruß
    Werner
     
  8. artico

    artico Themenersteller

    Registriert seit:
    27.11.07
    Punkte:
    119
    119
    ich weiss nich, ob du es so verstanden hgast, aber jedenfalls benutz ich das natürlich NICHt gleichzeitig, bzw. parallel.
    was ich erreichen will: dass ich(egal, ob ich es in Ableton erst umschalten muss oder nicht), das Interface nutzen kann, und im selben "Modus" auch Musik hörn kann etc. muss ja nicht gleichzeitig sein, wär ja sowieso sinnlos.

    momentan ist es nämlich so, dass ich das interface zwar nutzen kann, und wenn ich dann Live schließe, kann ich keine musik hörn etc, auch nicht, wenn ich die einstellunge in Live ändere...
     
  9. noland

    noland

    Registriert seit:
    04.06.08
    Punkte:
    166
    166
    Was ist so schlimm an verschiedenen Profilen für die Soundkarte? Bei mir sind das vier clicks um zwischen denen zu wechseln. Bevor ich ableton starte schalte ich auf das ableton profil und danach wieder zurück. Eigentlich kein Aufwand...
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.