Information ausblenden

Ableton Tutorials (technische Problemlösungen)

Dieses Thema im Forum "Ableton Live" wurde erstellt von twinnpeaks, 08.01.13.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. twinnpeaks

    twinnpeaks Themenersteller

    Registriert seit:
    23.02.11
    Artikel:
    112
    Punkte:
    2.040
    2040
    Meine lieben Ableton-Kollegen,

    da immer mal wieder technische Probleme in Ableton Live auftauchen und diese im Forum fleißig gelöst werden, gibt es nun den offiziell gepinnten Sammel-Thread für Tutorials, die sich nur mit den technischen Problemen beschäftigen. Für andere Tutorials wie "How to make a bla" gibt es den anderen Tutorial-Thread.

    Bitte auch Threads hier rein posten, die im Forum gelöst wurden.

    Das hier ist nur ein Sammel-Thread! Bei Fragen zu dem jeweiligen Tutorial, bitte den User per PN kontaktieren oder einen regulären Thread erstellen, der das Tutorial wieder aufgreift.

    @ksoa: und danke für die Idee mit dem Thread :)
     
    twinnpeaks, 08.01.13
    #1
    ksoa bedankt sich.
  2. ksoa

    ksoa

    Registriert seit:
    17.07.09
    Punkte:
    3.270
    3270
    Hi,
    danke für den Thread. Mir ist es selbst schon oft passiert, dass ich technische Probleme hatte, aber trotz Suchfunktion nicht auf einen schon existierenden Thread dafür gestoßen bin - deshalb finde ich so einen "Problem + Lösung only" -Thread recht cool.

    Hier eine Lösungsmöglichkeit, um Festplattenaussetzer zu beheben

    Ich hatte große Probleme mit Festplattenüberlastung in Ableton 8 (8.3.4), obwohl ich eine schnelle SSD habe.
    Die Festplattenüberlastungsanzeige hat bei Benutzung von viel Audiomaterial (mit und ohne RAM Modus) regelmäßig geblinkt und es gab Wiedergabeaussetzer, was für ein Liveset natürlich tödlich ist.
    Meine Notebook Konfig: Win7 64bit, OCZ Vertex 4 128gb SSD, i7 3612QM Prozessor 4x 2.10 GHz und 8GB RAM.

    Per Ableton Support habe ich folgendes erfahren:

    Man kann gewisse Zusatzfunktionen von Ableton aktivieren, indem man in den Ableton Settings Ordner (dort, wo sich auch die Preferences.cfg Datei befindet - unter Win7 ist das im Appdata Ordner) eine neue Textdatei namens "options.txt" hinzufügt.

    In diese kann man diverse Befehle eingeben.

    Der für mein Problem nötige Befehl ist: "-UseFileSystemCacheForReading=Off"

    Damit wird das Windows Cache System für Lesevorgänge der Festplatte während der Nutzung von Ableton deaktiviert. (Soweit ich das verstanden habe)

    Bis jetzt habe ich keine Festplattenaussetzer mehr.
    Auch wenn ich mein Liveset ungewöhnlich nutze und auch im Arrangementview tracks abspiele und gleichzeitig Clips abspiele hab ich höchstens ein minimales Aufblinken der D-Anzeige, aber ohne hörbaren Wiedergabeaussetzer.

    Diese Lösung hilft natürlich nicht bei der klassischen Festplattenüberlastung durch mangelnde Read/Write Geschwindigkeit der Festplatte, sondern nur bei bestimmten Fällen, bei denen das Windows Cache System Ärger macht.

    Das Windows Cache System kann unter Umständen (wie in meinem Fall) durch zu viele große Dateien verlangsamt werden. Siehe hierzu:
    http://msdn.microsoft.com/en-us/lib...

    "The amount of I/O performance improvement that file data caching offers depends on the size of the file data block being read or written. When large blocks of file data are read and written, it is more likely that disk reads and writes will be necessary to finish the I/O operation. I/O performance will be increasingly impaired as more of this kind of I/O operation occurs."
     
    ksoa, 08.01.13
    #2
    Maunds und chrk bedanken sich.
  3. twinnpeaks

    twinnpeaks Themenersteller

    Registriert seit:
    23.02.11
    Artikel:
    112
    Punkte:
    2.040
    2040
    Hier eine Lösung, wenn ein ''time-gestretched-tes'' Sample beim Befehl „Auf neue MIDI-Spur slicen“ im Original-Tempo, statt im gestretchten Tempo gesliced wird:

    Beispiel-Szenario: Beim beliebigen Sample werden mit den Warpmarkern vier Slices erzeugt. Der dritte Slice wird durch ziehen des entsprechenden Markers ge-“timestretched“. Beim Anwenden der Funktion „Auf neue MIDI-Spur slicen“ wird dieser jedoch nicht gestretched. Wo liegt das Problem?

    Die Lösung: Nehme den time-gestretchedten Clip in der Arrange-Ansicht als neuen Clip auf, klicke mit der rechten Maustaste auf den Clip und wähle „konsolidieren“, so wird das Sample im entsprechenden Bereich gestretched und die Warp-Marker sind zurückgesetzt. Anschließend wird in der Arrange-Ansicht der neue Clip angewählt und im Kontext-Menü „Auf neue MIDI-Spur slicen“ geklickt. Nun wird der gestretchte Clip in einer neuen Spur korrekt gesliced.
     
    twinnpeaks, 20.02.13
    #3
    feskapunk20 bedankt sich.
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.