Information ausblenden

Problem mit MIDI Loopback Device (MIDIyoke)-funktioniert nicht!

Dieses Thema im Forum "Musik produzieren" wurde erstellt von NULL, 10.10.02.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. NULL

    NULL Themenersteller Guest

    Punkte:
    0
    Hi,

    wer kennt sich mit diesen Loopback Teilen aus? Ich habe MIDIYoke installiert, um z.B. einen Arpeggiator und einen Softwaresynth über Cubase zu steuern und diese Instrumente in mein Cubasearrangement mit einzubinden.

    Das geht doch normalerweise, oder?

    Ich habe mich aber da wohl übernommen, denn ich kriege das nicht zum Laufen. Konkret also:

    ich stelle im Cubasearrangement den Ausgang der MIDIspur auf einen der virtuellen Ausgänge z.B. 01.Dann den Eingang z.B. vom Arp-X8 auch auf den virtuellen. Den Ausgang vom Arp-X8 auf ein Soundmodul oder den Kartensynth.
    Und es geht nicht.

    klingt Kompliziert - ich weiß!!!

    Was also ihr MIDI Götter mache ich falsch, und, welche Rolle spielt das Tool
    MIDI-ox. Des hab ich gleich mitgesaugt von gleiche Firma, dachte es gehört zusammen.

    Ich bin in Englisch aber doch zu mies, kapiere es nicht.Nicht mal wozu ich das MIDI-ox brauche. HIIIILFE!

    o.k. ich kann auch ohne sowas leben, brauch auch kaum mal nen Arp.
    Wollte das doch bloß mal probieren...
    Ach so ich hab z.Z. noch die SB 16 Karte, aber das spielt glaub ich dabei keine Rolle, oder?

    Naja, vielleicht findet sich unter Euch jemand, der da mal Licht in das Dunkel bringen kann, würde mich sehr freuen.

    Gruß

    Holger
     
    NULL, 10.10.02
    #1
  2. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    <hr>
    > ich stelle im Cubasearrangement den Ausgang der MIDIspur auf einen der
    > virtuellen Ausgänge z.B. 01.
    <hr>
    Vielleicht hast Du Dich nur verschrieben, falls nicht:
    Ausgang immer mit Eingang oder umgekehr verbinden. Nie Ausgang mit Ausgang oder Eingang mit Eingang.

    Also auch nicht den Ausgang der MIDIspur mit den virtuellen Ausgang 01.

    Den Ausgang der Midispur verbindest Du mit dem Midieingang des Loopbacks. Der sendet das Signal an seinen Ausgang, den Du am Eingang Deines Softwaresynths etc. konfigurierst. Dann sollte es klappen.

    Midi-ox ist in diesem Zusammenhang nicht wichtig. Aber für viele Midifunktionen kann es ein hilfreiches "Schweizer Taschenmesser" sein.
     
    HaSBACHMeSBACH, 10.10.02
    #2
  3. NULL

    NULL Themenersteller Guest

    Punkte:
    0
    Hallo und erstmal vielen Dank für Deine schnelle Antwort.

    Ich hab da wohl ein generelles Verständnisproblem.
    Ich bekomme doch die virtuellen Ports sowohl als Eingang UND als Ausgang angezeigt.

    Bestimmt habe ich da einen Klemmer, wenn es um das Einstellen des Ausgangs in Cubase geht. Das tue ich im Arrang.fenster.Du sagst nicht Ausgang mit Ausgang verbinden,muß ich evtl. in MME Setup alle anderen Eingänge ausschalten?

    Ich glaub heute ist's zu spät. Werde mich morgen mal weiter mühen.

    so long & Danke Dir
     
    NULL, 10.10.02
    #3
  4. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    Hi!

    <hr>
    > muß ich evtl. in MME Setup alle anderen Eingänge ausschalten?
    <hr>
    Eigentlich nicht. Nach der Installation von Midiyoke sollten 8 Eingänge und 8 Ausgänge vorhanden sein. Die Eingänge sollten jeweils auf die Ausgänge mit der gleichen Nummer zurückgeroutet werden.
    Ich hab' das vor kurzen grad gemacht. Und es hatte auch auf Anhieb geklappt, ohne daß ich irgendwo die Konfiguration ändern mußte.

    *schautmalkurzwieeresselbsgemachthat*

    Die Midispur hat als Mididevice: MIDI Yoke NT: 1
    Und im PlugIn steht: MIDI Yoke NT: 1

    Haben beide den gleichen Namen und es wird automatisch nur die Eingänge, bzw. Augänge als Auswahl angegeben. Da kann man eigentlich gar nichts falsch machen. Vielleicht liegt das Problem gar nicht beim Midi-Loopback-Device?

    Ich benutze momentan Version MIDI Joke Junction NT 1.59.

    Ohh. Ich sehe grad, in der Anleitung von MidiYoke steht:
    [MIDI Keyboard In] ==> [In MIDI-OX Out] ==> [Out MIDI Yoke In] ==> [In Sequencer]

    Man kann das Midi-Signal durch MIDI-ox schicken (Die Notation von dem Beispiel ist mir aber auch noch nicht ganz klar.). Aber das nur am Rande.
     
    HaSBACHMeSBACH, 11.10.02
    #4
  5. NULL

    NULL Themenersteller Guest

    Punkte:
    0
    Hello again,

    habe immer noch Probleme mit Midi Yoke. Jetzt hab ichs aber wenigstens einmal hinbekommen, 2 programme parallel laufen zu lassen.
    Ich verstehe das so, daß dieses Programm mir sozusagen virtuelle MIDIkabel
    zue Verfügung stellt, richtig?
    Was soll ich sagen, ich denke auch da ist nicht viel verkehrt zu machen. was bei einem Prog Eingang ist, soll beim anderen Ausgang sein.

    Nur: Mir meldet Yoke immer wieder: MIDI Feedback detecdet, Disabling Port ...
    Ich krieg nicht raus, warum, wie da die Zusammenhänge sind.
    Außerdem kann nur ein Prog auf die SB zugreifen, dabei ist es geblieben.

    Gruß

    Holger
     
    NULL, 13.10.02
    #5
  6. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    Hi!

    Du hast eine Midi-Schleife? Hmm

    <hr>
    > ich stelle im Cubasearrangement den Ausgang der MIDIspur auf einen der
    > virtuellen Ausgänge z.B. 01.Dann den Eingang z.B. vom Arp-X8 auch auf
    > den virtuellen. Den Ausgang vom Arp-X8 auf ein Soundmodul oder den
    > Kartensynth.
    <hr>
    Ich versuch' mal zu vermuten, wo das Midi-Signal langläuft:
    1. Cubase spielt die Noten ab und sendet sie an das MidiYoke Kanal 01.
    2. Dieser sendet die Daten an Dein Arp-X8 (was ist das überhaupt?), welches irgendwas mit dem Midi-Daten anstellt, um sie dann an das Soundmodul weiterzuleiten.
    3. Das Soundmodul bekommt die Midi-Daten über sein Midi-In und freut sich.

    Jetzt zu meiner Vermutung:
    Das Soundmodul ist ebenfalls über Midi-Out mit Deiner Soundkarte verbunden und kann Midi-Signale (z.B. von Drehreglern) an Cubase über Deine Soundkarte senden. Das Modul ist evtl. so konfiguriert, daß es die einkommenden Midi-Signale an seinen Ausgang routet.
    Cubase empfängt auf dem Kanal von Punkt 1 ebenfalls diese Midi-Signale, die es grad selbst erst abgeschickt hat. Da es aus der Standardkonfiguration her einkommende Signale auf dem aktuellen Kanal wieder absendet, wird MidiYoke zum zweiten Mal mit den gleichen Midi-Daten gefüttert. Dieses erkennt den Schwindel und meldet den Fehler. (Sendet evtl. sogar Dein Arp-X8 auf irgendeinem oder allen Midi-Kanälen, insbesondere auf den virtuellen?)

    Kannst ja mal gucken, ob dieses Szenario zutrifft oder teilweise zutrifft. Ansonsten beschreib' mal Deine interne, sowie externe Verkabelung.
     
    HaSBACHMeSBACH, 13.10.02
    #6
  7. NULL

    NULL Themenersteller Guest

    Punkte:
    0
    Hello @ Hasb...

    Ja das is N Ding nich?

    "...Ich versuch' mal zu vermuten, wo das Midi-Signal langläuft:
    1. Cubase spielt die Noten ab und sendet sie an das MidiYoke Kanal 01.
    2. Dieser sendet die Daten an Dein Arp-X8 (was ist das überhaupt?), welches irgendwas mit dem Midi-Daten anstellt, um sie dann an das Soundmodul weiterzuleiten.
    3. Das Soundmodul bekommt die Midi-Daten über sein Midi-In und freut sich...."

    Jo, so is das, Du hast den Signalfluß exakt beschrieben, aber wir brauchen es gar nicht ganz so kompliziert machen.

    Laß mal das Soundmodul weg, statt dessen routen wir das Signal vom Arp-X8 zum SB Synth (Interner Wavetablesynth).
    Außerdem habe ich im Cubase Arrangement nur eine einzige Spur, mit dem Ausgang MIDIYoke 1.

    bekomme sofort wieder die Fehlermeldung.

    Da kann ich wohl nix gegen machen.
    Habe schon Cubase neu installiert. It's The same.

    Was is das denn, der Arp-X8? Na das ist ein Arpeggiator von der Firma Technotoys (Shareware). Die gibts nicht mehr- leider!
    Den habe ich mir da mal gekauft für n Appel+ n Ei und ich finde den Spitze!

    What Is Arp-X8?

    "...Arp-X8 is an “octal arpeggiator” - that is, eight arpeggiators all rolled into one. An arpeggiator is a device that scans a musical keyboard and then plays the pressed notes in sequence, thus forming an electronic approximation of the traditional arpeggio.
    While most arpeggiators offer limited control over the arpeggiation - usually an up/down button and maybe a range control - Arp-X8 expands on that considerably by offering 10 different motion algorithms, along with rhythm controls and a host of other variations. Each of the eight arpeggiators can have entirely different settings, and can even play on independent MIDI channels, for incredibly dense clouds of sound..."

    So steht das in der Onlinehilfe. Ich habe keinen Arp. in meinem Keyboard und der in Fruitys ist nicht toll, Cubase Arp. kenn ich noch nicht so, glaub aber auch da ist weder der Funktionsumfang noch die Raffinesse und Einfachheit im Handling da.

    Nun hat mir der Jim von Technotoys (der Entwickler) allerdings alle seine Schätze for nothing zur Verfügung gestellt, so bin ich nun neuerdings auch Besitzer von XG 909, einer super Drummachine und Seq 303, einem (das hätte jetzt keiner gedacht) Stepsequenzer.

    Das alles obwohl ich eigentlich gar keine solche Musik vordergründig mache (bin ein Poprock oder Rockpop Mensch)
    Nojoa, was solls. Für Dich ist das sicher Spielkram, mir reicht es aber aus, um paar Farbtupfer zu streuen.

    Gruß

    Holger
     
    NULL, 15.10.02
    #7
  8. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    Hi!

    Tja, dann bin ich jetzt erstmal ratlos. Vielleicht hat ja noch jemand anders eine Idee, wo die Midi-Schleife entstehen kann. :-(

    <hr>
    > Für Dich ist das sicher Spielkram, mir reicht es aber aus, um paar Farbtupfer
    > zu streuen.
    <hr>
    Hey, kochen wir alle nicht mit Wasser? :p

    [ Geändert von HaSBACHMeSBACH am 16.10.2002 10:49 ]
     
    HaSBACHMeSBACH, 16.10.02
    #8
  9. NULL

    NULL Themenersteller Guest

    Punkte:
    0
    Hi Hasb...,

    danke Dir für die Hilfe, auch wenn der Fehler nicht zu finden ist.

    gruß

    musicfanta
     
    NULL, 20.10.02
    #9
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.