Information ausblenden

Performanceprobleme

Dieses Thema im Forum "REAPER" wurde erstellt von MoeSurface, 04.09.08.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Hey Leutz,

    ein kleines Problem plagt mich soeben mit Reaper..
    Ich habe meinen PC neu aufgesetzt da der echt schon lahm war und jetzt wollt ich mal Reaper ausprobieren (Direct Sound) hab dazu ein Projekt des Mixing Praxis Guide reingeladen, dass das meine Maschine mit Effekten (47 Tracks [3Ghz, 1GB Ram, SATA Festplatte]) nicht packen würde war mir klar, deswegen mal alles auf neue Takes gerendert und FX deaktiviert... siehe da die Wiedergabe ruckelt noch immer so dass mans kaum anhören kann...
    Dabie läuft reaper alleine (kein virenscanner oder ähnliches) und das nur mit 25%Prozessorauslastung und 200mb Ram, kann ich dem vielleicht über Kommandozeilenbefehle mehr zukommenlassen, oder is mein PC einfach zu lahm für die Wiedergabe?

    glg
    Moe
     
    MoeSurface, 04.09.08
    #1
  2. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    Hi,

    dass dein PC zu lahm ist, kann ich mir kaum vorstellen. Hast du Reaper denn optimiert?
    Ich hatte früher mal ähnliche Probleme wegen der Darstellung. Es gibt unter "Optionen" irgendwo ein Kästchen, bei dem du der Grafikengine/der Darstellungsgeschwindigkeit aller Spuren/des Mixers eine geringere Priorität zuweisen kannst ("lazy" ). Das gibt Ressourcen für die optimale Wiedergabe frei.

    Desweiteren natürlich: Latenz. Solange du nur abspielst, kannst du die Latenz hochsetzen. Ich arbeite mit 1024 Samples relativ ruckel- und knacksfrei frei. Dass Reaper bei einem aktuellen Projekt mit 80 Spuren ca. 1-2 Sekunden braucht, bis es abspielt, stört mich dabei weniger.

    Du kannst auch mal im Reaper-Forum schauen. Dort sitzen die Profis, die genau wissen, wo man drehen, klicken und schalten muss.
    Grüße
    M
     
    moio, 04.09.08
    #2
  3. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    Schau mal, hier ist der alte Thread aus dem Reaper-Forum, in dem ich damals mein Problem gestellt habe. Die Antworten waren sehr ausführlich , sogar mit grafischer Anleitung. Die Reaper Optionen-Maske hat sich seitdem natürlich wieder verändert, aber manche Einstellungen gibts noch. Vielleicht hilft es dir:

    http://forum.cockos.com/showthread.php?t=12666

    lg
    m
     
    moio, 04.09.08
    #3
  4. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Hey vielen vielen Dank moio, werd das mal durchackern!

    hab auch einen 64er 3000+ :D
     
    MoeSurface, 04.09.08
    #4
  5. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Hab nun mal die Einstellungen übernommen die der typ gepostet hat, ohne effekten läufts jetzt flüssig, ich glaube aber ehrlich gesagt nicht dass ichs schaffe 47 Tracks mit vsts laufen zu haben...
    aber so 30-35 gehn schon, das is ja schonmal was :)

    geht der Thread von dir im Cockos Forum noch wo weiter oder war das alles nach deinen deutschen Grüßen? :D

    ich werd auf jeden Fall noch am Problem arbeiten!
     
    MoeSurface, 04.09.08
    #5
  6. bensummerfield

    bensummerfield

    Registriert seit:
    17.04.05
    Punkte:
    13.535
    13535
    47 Tracks mit VST-Effekten sind auch ne Menge Holz...da wäre ein Dual-Core Prozessor schon angebracht und etwas mehr Ram.
     
    bensummerfield, 04.09.08
    #6
  7. moio

    moio

    Registriert seit:
    14.02.06
    Punkte:
    789
    789
    @MoeSurface:
    ging nicht weiter, glaube ich.

    bensommerfeld hat recht: das ist schon arg viel für einen einsamen Athlon. Denk mal über einen duo-prozessor nach.

    Ich habe mir bspw. einen günstigen, älteren zugelegt (E 2200 mit 2 x 2,2 Gh) - der Unterschied ist wirklich enorm! Habe wie gesagt gerade ein Projekt mit 80 Spuren, die meisten mehrfach mit Effekten belegt, und die Auslastung liegt nur bei ca. 25-30%.

    Grüße
    m
     
    moio, 04.09.08
    #7
  8. Asta6Stas

    Asta6Stas

    Registriert seit:
    25.05.07
    Punkte:
    235
    235
    Hab jetzt auch das gleiche Problem, nur mit 5 VSTi Spuren.
    Hab alle Einstellungen, von dem oben geposteten Link übernommen, bringt aber nichts.

    Mein System:
    3,06Ghz, 512MB, Emu 1212m

    Liegt das wirklich am Arbeitsspeicher???

    Danke!
     
    Asta6Stas, 04.09.08
    #8
  9. brucie

    brucie

    Registriert seit:
    31.08.06
    Punkte:
    1.554
    1554
    Kann, muss aber nicht...

    Kommt auch auf die VSTis an.

    512 MB sind aber auch schon recht dürftig.
     
    brucie, 04.09.08
    #9
  10. bensummerfield

    bensummerfield

    Registriert seit:
    17.04.05
    Punkte:
    13.535
    13535
    schau doch einfach mal im task-manager, wie dein speicherverbrauch ist, dann weisst dus. vsti brauchen aber auf jeden fall speicher, ja.
     
    bensummerfield, 04.09.08
    #10
  11. Asta6Stas

    Asta6Stas

    Registriert seit:
    25.05.07
    Punkte:
    235
    235
    Asta6Stas, 04.09.08
    #11
  12. bensummerfield

    bensummerfield

    Registriert seit:
    17.04.05
    Punkte:
    13.535
    13535
    Schau dir mal den "Performance Meter" in den "View"s im Reaper an. Da siehst du CPU und RAM Auslastung genau und wie nahe Reaper am Limit ist. Aber deine CPU Auslastung is ja schon ziemlich am Limit.
     
    bensummerfield, 04.09.08
    #12
  13. Asta6Stas

    Asta6Stas

    Registriert seit:
    25.05.07
    Punkte:
    235
    235
    Okay, werde ich machen. Danke Ben!
     
    Asta6Stas, 04.09.08
    #13
  14. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Kann ich Reaper irgendwie sagen dass er sich mehr speicher und CPU gönnen soll?

    Bei meinem Projekt mit 47 Spuren hab ich teilweise 60% Leerlauf und 500mb ungenutzten Speicher, kann ich Reaper manuell mehr zusichern?

    lg


    edit:

    falscher alarm, lag am windows task manager, das performancemeter zeugt von 75% für die effekte!
     
    MoeSurface, 05.09.08
    #14
  15. Asta6Stas

    Asta6Stas

    Registriert seit:
    25.05.07
    Punkte:
    235
    235
    So, hab jetzt den Performance Meter angeschaut.
    Sieht so aus (wenns anfängt zu ruckeln):

    CPU: 89,4%

    Disk total: 0B/s
    Disk read: 0B/s
    Disk write: 0B/s

    RAM use: 232MB
    System free: 84MB/511MB

    FX CPU use: 80,24% (5effects)

    Da muss ich wohl den Prozessor wechseln, oder?

    Danke!
     
    Asta6Stas, 05.09.08
    #15
  16. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Sieht schwer danach aus, bei mir is halt nichts mehr mit wechseln (AMD Sockel 754) :D
     
    MoeSurface, 05.09.08
    #16
  17. bensummerfield

    bensummerfield

    Registriert seit:
    17.04.05
    Punkte:
    13.535
    13535

    Der erste Schritt wäre, die Latenz so hoch wie möglich zu schrauben, falls du das noch nicht gemacht hast.
    Dann ist bevor man upgraded auch immer die Frage, ob man sinnvoll arbeitet. Viele Einsteiger wissen noch nichts von Gruppenspuren oder Automation und verschwenden dadurch unnötig CPU- und RAM-Ressourcen. Wenn du z.B. einen Vocal-Track auf 3-4 Spuren (eine Spur für Vers, eine für Refrain, eine für Vers2, etc..) verteilst, verschwendest du viel Ressourcen - das geht auch auf 1 Spur und mit Automation (sowohl Spurparameter wie Lautstärke und Panning als auch die Effekte lassen sich von den Einstellungen her automatisieren).
    Auch kann man die Plugins unter dem Aspekt der "Ressourcenschonung" auswählen, dazu müsste man wissen, was für Plugins du genau nutzt.
     
    bensummerfield, 05.09.08
    #17
  18. MoeSurface

    MoeSurface Themenersteller

    Registriert seit:
    30.10.07
    Punkte:
    1.395
    1395
    Man kann doch falls es ganz schlimm kommt mit Takes arbeiten und die Effekte einfach auf Bypass, wirkt doch bestimmt auch recourcenschonend, obwohl ich das arbeiten mit Takes schon noch etwas verwirrend bzw. kompliziert finde!
     
    MoeSurface, 05.09.08
    #18
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.