Information ausblenden

Modular Synth VCA - Fragen

Dieses Thema im Forum "Do-It-Yourself (DIY)" wurde erstellt von mingorius, 09.02.19.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. mingorius

    mingorius Themenersteller

    Registriert seit:
    07.12.15
    Punkte:
    270
    270
    Hallo,

    ich beginne gerade, mir einen modularen Synth selbst zu bauen.

    Bis jetzt habe ich ein Doepfer MIDI-CV-Modul, einen selbstgebauten VCO und habe diesen VCA gebreadboardet:

    https://kassu2000.blogspot.com/2015/10/vca.html

    Der VCA funktioniert generell, allerdings gibt es 2 Dinge, die mich noch stören:

    - Zu Beginn jeden neuen Tones kommt ein deutlich hörbares "Klacken" oder übertrieben lautes Attack.
    Kann das am Gate-Signal liegen, das mit bis zu 8V deutlich über den "normalen" 5V liegt?

    - Wenn ich den Saw-Out vom VCO zum VCA patche, klingt bis auf das Attack alles gut! Wenn ich aber den Triangle-Out patche (besonders wenn Pitch-CV vom Doepfer in den VCO läuft), sind auf einmal Rauschen und andere Nebengeräusche zu hören. Wie kann das Pitch-CV-Signal des Doepfer zum VCO mit dem VCA zusammenhängen?

    Vielen Dank für die Hilfe!
     
    mingorius, 09.02.19
    #1
  2. LM18

    LM18 Ator Mitarbeiter

    Registriert seit:
    05.05.10
    Punkte:
    52.552
    52552
    Du verwendest keinen ADSR um den VCA anzufahren, sondern gibst einfach das Gatesignal auf den Eingang?

    Knacken
    Das wird wohl ein Wellenformanschnitt sein.
    Das VCA öffnet so schnell das es kein Einschwingen gibt.
    Edit:
    In der Schrift beschreibt der Autor, das er +5 V spezifiziert.
    Setz mal die Spannung auf +5 V runter...

    Die Triangle enthält weniger Obertöne.
    Eventuelle Störgeräusche werden da nicht so maskiert.

    Die CV von Interface sollte eigentlich clean sein und nicht jittern oder verrauscht sein...

    Vielleicht kannst du dir die Spannungen mal mit einem Scope anschauen...
     
    LM18, 09.02.19
    #2
    HarrySH bedankt sich.
  3. HarrySH

    HarrySH

    Registriert seit:
    03.06.10
    Punkte:
    6.168
    6168
    Zuerstmal super daß Du so nenn Synth baust. Ich habe mir Anfang der 80er den Formant-Synth von Elektor gebaut. Bei diesem Projekt habe ich ne Menge über Op-Amps gelernt.

    So, an deiner Stelle kenne ich jetzt nicht Schaltungen und wie Du diese verbunden hast. Wenn Du das Schaltungsbeispiel des VCA´s übernemmen hast, dann würde ich das gleichmal canceln. Die beiden Transistoren der Differenzschaltung sollten als Matched-Pärchen ausgelgt sein. Also entweder so lange Transitoren ausmessen bis sie möglichst die gleichen Parameter haben. Oder eben ein ein Matched-Pärchen kaufen. Ein Matched-Paar wäre z.B. der LM 394-Chip. Trotzdem würde ich das anders machen, weil diese Schaltung mit Sicherheit Temperaturabhängig ist.

    Du solltest Dir mal volgenden Baustein ansehen:

    http://www.ti.com/lit/ds/symlink/lm13700.pdf
    erhältlich bei Reichelt:

    Der LM 13700 ist ein sogenannter "Operational Transconductance Amplifier", kurz OTA. Der abgespeckte OTA, ein LM 3080 wurde damals in allen Schaltungsteilen des Formant-Synth´s eingesetzt. Ein OTA ist ein Amp, der über eine Steuerleitung ein Audiosignal beeinflußen kann. Im Datenblatt des 13700er sind eine Menge Schaltungsbeispiele für verschiedene Audioschaltungen ersichtlich. Noch bessere Chips gibt es von That.

    Wichtig ist bei einem solchen Analog-Synth, daß das zu verabeitende Analog-Signal vor dem CV-Signal, also zeitlich, anliegt. Sonst kann es zu solchen unkontrollierten Signalen, wie in deinemFall, kommen.

    Aus deiner Beschreibung kann ich das nicht ganz nachvollziehen, weil eben die Gesamtschaltung fehlt.
     
    HarrySH, 09.02.19
    #3
  4. HarrySH

    HarrySH

    Registriert seit:
    03.06.10
    Punkte:
    6.168
    6168
    Jo, ich sehe gerade die Antwort vom LM18. Wäre natürlich interessant wie Du deinen VCO und den VCA mit welchen Signalen fütterst. Das Gatesignal des Doepfer darf natürlich nicht auf den Audioeingang des VCA´s gelangen. Und ein ADSR-Signal ist nur für den Steuereingang bestimmt.
     
    HarrySH, 09.02.19
    #4
    LM18 bedankt sich.
  5. mingorius

    mingorius Themenersteller

    Registriert seit:
    07.12.15
    Punkte:
    270
    270
    Vielen Dank erstmal für die schnellen und kompetenten Antworten!

    Das Patch sieht so aus:

    aus der DAW per MIDI ins Doepfer -> aus dem Gate-Ausgang des Doepfer in den CV-In des VCA
    aus dem VCO SAW-Ausgang in den Audio-In des VCA

    Bis zu dieser Stelle (noch ohne CV-Pitch-Signal) gibt es keine Störgeräusche (bis auf das "harte" Attack).

    Wenn ich zusätzlich aus dem Doepfer das CV-Pitch-Signal in den VCO patche kommen die Störgeräusche.

    Das Gate-Signal auf +5V zu begrenzen werde ich ausprobieren!

    Was kann ich beeinflussen/ändern, damit das Audio-Signal vor dem CV-Signal anliegt?
     
    mingorius, 09.02.19
    #5
  6. HarrySH

    HarrySH

    Registriert seit:
    03.06.10
    Punkte:
    6.168
    6168
    Du musst natürlich z.B. den CV1-Out vom Doepfer mit dem Eingang des VCO´s verbinden. Der CV-Out liefert ja die Steuerspannung für die Tonhöhe des VCO-Signals. Das Ausgangssignal, also das Sägezahn- bzw. das Dreiecksignal geht dann in den Audioeingang des VCA´s.
    Den Gate-Out des Doepfer schließt Du an den Gate- bzw. den Steuereingang des VCA´s an.

    Also der CV-Out liefert mit Hilfe des VCO´s den Ton und das Gatesignal dient nur dazu, den Ton im VCA durchzu lassen oder zu sperren. VCA heißt ja "Spannungsgesteuerter Verstärker". Das Gatesignal, wie der Name schon sagt, dient nur als Steuerspannung. Normalerweise durchläuft dieses Gatesignal erst einmal eine sog. ADSR-Elektronik und dann erst in den Steuereingang des VCA´s. Mit dem ADSR kann man dann den VCA so steuern, daß ein Ton z.B. langsam ein- (Attack) und wieder ausschwingt (Decay-Sustain-Release). Der VCA ist nichts anderes als ein spannungsgesteuertes Potentiometer.

    Das Gatesignal könntest Du mal, vorrausgesetzt Du hast einen Oszi, so messen: Auf einem Kanal stellst Du das CV-Signal des Doepfer dar und auf dem anderen Kanal das Gatesignal. Jetzt mus bei jedem Tastendruck das Gatesignal etwas später ausgelöst werden als das CV-Signal. Könnte nämlich sein, daß das Doepfergerät das schon berücksichtigt. Ansonsten muss man das hardwäremäßig lösen.

    Beim Formant hatte man damals noch kein Midi. Und die Tastatur musste man selbst zusammen bauen. Die Zeitverzögerung wurde damals durch 2 Kontakte je Taste eingestellt.

    Hier noch Info:
    https://www.uni-muenster.de/imperia...hnik_didaktik/entwicklung_bau_synthesizer.pdf

    http://dl.lojinx.com/analoghell/ElektorFormantMusicSynthesiser.pdf
     
    HarrySH, 10.02.19
    #6
    LM18 bedankt sich.
  7. LM18

    LM18 Ator Mitarbeiter

    Registriert seit:
    05.05.10
    Punkte:
    52.552
    52552
    @HarrySH
    Wenn die CV für die VCOs erst nach der Gatespannung durch die Tastatur geschaltet wird, hört man die Tonerzeugung eventuell umspringen wenn man den Ton wechselt.
    Insbesondere wenn man die Taste langsam runterdrückt.

    Deswegen wird zeitlich beim Tastenanschlag zuerst die Pitch-CV geschaltet und dann Gate.

    BTW - Das soll nicht belehren sondern nur klarstellen... :)
    Für Belehrungen in Sachen Elektronik, Mathematik und auch andere Lager und Lehren, bin ich einfach nicht gebildet genug.
    Aber in manchen Angelegenheite kann ich mitquatschen ;-)

    VCA
    Das mit den 5V ist normalerweise die, das die Regelung bei 0 V keine Verstärkung bedeutet und bei +5 V volle Verstärkung.
    Das wäre der Standard.
    Was ich nicht weiß ist, was passiert wenn man den Steuereingang mit 3 V = 8 V mehr überfährt.

    Ich meine irgendwo gelesen/gehört zu haben das meine Doepfer VCAs bis 10 V tolerant sind und nicht abrauchen.
    Anyways könnte man einfach eine Zenerdiode vorschalten und dann wäre Frieden, oder?

    ADSR
    Alle ADSR haben eine Attackphase.
    Beim Doepfer A-140 sind es als schnellstes 100 µs.
    Das bedeutet der VCA regelt schnellstens in 100 µs auf und das könnte reichen die Wellenform nicht hart anzuschneiden und einen Knack eher verhindern.
    Vielleicht ist auch der Audiopfad nicht ganz Gleichspannungsfrei?

    Selber bauen ohne Messzeug Oszi ist auf jeden Fall mysteriöser vom Charakter her... :)
     
    Zuletzt bearbeitet: 10.02.19
    LM18, 10.02.19
    #7
  8. mingorius

    mingorius Themenersteller

    Registriert seit:
    07.12.15
    Punkte:
    270
    270
    Meine nächste Anschaffung wird ein Oszilloskop sein... ;-)

    Mit welcher Hardware kann ich das Gate-Signal zeitlich verzögern? Funktioniert da ein Gate-Delay-Circuit?
     
    mingorius, 10.02.19
    #8
  9. LM18

    LM18 Ator Mitarbeiter

    Registriert seit:
    05.05.10
    Punkte:
    52.552
    52552
    Frage einfach mal bei Doepfer nach, ob dieser Effekt überhaupt auftritt.
    Ich vermute nein, von daher brauchtst du auch kein Gate-Delay oder ähnlich.

    Ich habe 2 Doepfer Interfaces und da tritt dieser Effekt nicht auf.
    Das ist ein konstruktives "Problem" bei vollanaloger Technik.

    Da brauchte die Tastatur 2 Schaltkontakte je Taste - Der Eine für die Pitch-CV und die Andere für die statische Gatespannung.
    Und damit zuerst die Pitch-CV rausgeht musste man die Tastenkontakte so kalibrieren, das die Pitch-CV zuerst rausgeht und die VCOs auf ihrer richtige Tonhöhe spielen bevor die VCAs aufmachen.

    Das ist ja bei einem digitalen Interface ja nicht gegeben und der Hersteller wird dafür gesorgt haben, dass diese Störung gar nicht erst auftritt.

    Zur Frage nach einem möglichen Modul käme zum Beispiel Dopefer A-162 in Frage.

    Warum ich immer von Doepfer rede?
    Die Bude ist 20 Minuten von mir zu Hause entfernt - Zum Einen...
    Das andere ist das Preis-Leistungsverhältniss - Doepfer Module sind von der Preisfindung her vernünftig kalkuliert und man bleibt im Rahmen.

    Das Modulsortiment ist sehr vollständig, zumindest was den vollanalogen Teil angeht.
    Gerade im Bereich der Utilities knackt man eigentlich jede Nuss.
     
    LM18, 10.02.19
    #9
    HarrySH und molemuc bedanken sich.
  10. LM18

    LM18 Ator Mitarbeiter

    Registriert seit:
    05.05.10
    Punkte:
    52.552
    52552
    So...

    Ich habe mit jetzt mal die Spannungen angesehen/gemessen.
    Die VCOs (MOOG und Doepfer) geben zwischen 3 - 5,5 V als Audio raus.
    Der Standard LFO von Doepfer auch so um 5,5 V, je nach Wellenform und Frequenz.

    Die einzige Festspannungsquelle die ich habe, ist von der Mother-32 die VC-Mixerspannung und die ging rauf bis 5,35 V.
    Wenn ich die auf den VCA-Eingang gebe ist alles OK.
    Ein durchgeleiteter 1 kHz "Sinus" kommt auch so wieder raus. Sinus in "" weil es aus dem VCO kein lupenreiner Sinus ist.

    Aber - aus meinen KORG SQ-1 Sequencern kommen aus wahlweise bis zu 8,00 V Pitch-CV raus.
    Also habe ich die abgegriffen und auf den VCA Steuereingang gesteckt.

    Und siehe da, ab 5,6 V fängt das durchgeleitete Audio das clippen an.
    Ich habe hierfür in Cubase ein VST-Scope von Melda (free) zum anschauen verwendet.

    Hören tut man es sowieso.

    Also würde ich vermuten, das die Störungen vom @mingorius dem Überfahren der VCA Schaltung auf der Steuerseite geschuldet sind.
    Von möglichen schaltungstechnischen Problemen im Design oder Bauteile-Unsymetrien bei der Auswahl mal abgesehen...

    Schritt 1 = Die Gatespannung von 8 V auf 5 V runtersetzen um wieder in die Schaltungsspezifikation reinzurudern... :)
     
    LM18, 10.02.19
    #10
    HarrySH bedankt sich.
  11. HarrySH

    HarrySH

    Registriert seit:
    03.06.10
    Punkte:
    6.168
    6168
    Jo, Du hättest recht, wenn das VCO-Signal nach dem Gate ausgegeben wird. Ich habe eher folgendes nicht erklärt:

    Ich gehe jetzt mal von meinem Formant aus, ein reiner Analogsynth. Beim Oszillator liegt bereits nach dem Einschalten am Ausgang des Oszillators ein Audiosignal an. also z.B. ein Sägezahnsignal oder was auch immer. Deshalb braucht der VCO kein Gatesignal sondern nur alle anderen Module wie ADSR, VCF, VCA etc. Deshalb kann man eine Taste auch loslassen und das Audiosignal erklingt weiter weil der VCO auch dann weiter das Nutzsignal liefert.

    Wenn nun das Gatesignal zeitlich verzögert wird und eine neue Taste gedrückt wird, baut der VCO erst eine neue Frequenz auf und dann werden nachfolgende Module mittels verzögertem Gatesignal freigegeben.

    @mingorius

    Die 5V würde ich jetzt auch mal einstellen. Da solltest Du auf der sicheren Seite sein. Mach erst mal die Änderungen in deiner Schaltung, dann sieht man weiter.
     
    HarrySH, 10.02.19
    #11
    LM18 bedankt sich.
  12. mingorius

    mingorius Themenersteller

    Registriert seit:
    07.12.15
    Punkte:
    270
    270
    Vielen Dank nochmal für die Tips!

    Es stellen sich nun auch erste Erfolge ein:

    die Nebengeräusche beim Triangle-Out des VCO waren ein Ground-Problem.

    Das Gate konnte ich noch nicht auf 5V begrenzen. Wenn ich das gemacht habe, melde ich mich wieder!
     
    mingorius, 10.02.19
    #12
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.