Information ausblenden

Latenzausgleich Ardour

Dieses Thema im Forum "Musik produzieren" wurde erstellt von boesebande, 02.10.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. boesebande

    boesebande Themenersteller

    Registriert seit:
    02.10.12
    Punkte:
    8
    8
    Hey!

    Ich bin ausgewiesener Ubuntu-Freund und Nutzer. Zum Recorden nutze ich derzeit ein Zoom H2 als Interface und Ardour + Hydrogen. Ich arbeite nur mit Audiodateien.
    Mein Problem: Ich schaffe es nicht, meine Gitarrenspur "in time" aufzunehmen. Es liegt nicht an meinen spielerischen Fähigkeiten :). Nach der Aufnahme muss ich immer die Spur nachträglich verschieben.
    jack_iodelay habe ich schon ausprobiert und in JACK die Eingangslatenz entsprechen angepasst.
    Das Audiosignal kommt jedoch nie auf den Beat genau.

    Liegt's am Interface oder muss ich auf Analogrecording umsteigen?

    Vielen Dank für die Hilfe!

    Volker
     
    boesebande, 02.10.12
    #1
  2. rbschu

    rbschu

    Registriert seit:
    30.01.17
    Punkte:
    3.344
    3344
    Hi Volker,
    ich bezweifle, dass Du hier bezüglich Ubuntu (Studio) / Dreamstudio oder einer entsprechenden Arbeitsschiene ausreichend Kommentare kriegst, um Dein Problem zu lösen. Ich habe den Eindruck, die meisten User hier nutzen Windoof. Leider. Auch in bin wahrlich nicht sehr beschlagen mit Ubuntu, obwohl ich schon seit langem gern damit sowie mit Ardour arbeiten würde. Deshalb kann ich Dir nur einen Tipp geben, den User Barto (https://recording.de/myRecording/Profil/Barto) mal per PM zu kontaktieren, der ebenfalls mit Hydrogen auf einem Linux-System arbeitet. - Und schöne Grüße von mir...

    ;-)
     
    rbschu, 02.10.12
    #2
  3. anthe

    anthe

    Registriert seit:
    13.08.08
    Punkte:
    6.057
    6057
    User "zettberlin" taucht sicher auch in Kürze auf :)

    lg
    Andi
     
    anthe, 02.10.12
    #3
    rbschu bedankt sich.
  4. zettberlin

    zettberlin

    Registriert seit:
    24.03.08
    Punkte:
    2.202
    2202

    Da bin ich schon ! ;-)

    Wie sehen denn Deine Einstellungen für Jack aus?

    Und: Spielst Du auf den Klick von Ardour oder auf eine vorhandenen Drumspur oder dergleichen?
     
    zettberlin, 02.10.12
    #4
  5. boesebande

    boesebande Themenersteller

    Registriert seit:
    02.10.12
    Punkte:
    8
    8
    hey!

    Also, die Drumspur habe ich von Hydrogen direkt in Ardour aufgenommen, mit JACK als time-master.
    Zu dem Ardour-Klick bzw. der Drumspur nehme ich auf.
    Laut Jack hab ich ne Latenz von 46,2 ms. Nach JACK_IODELAY Ausgabe hab ich ne Latenz von 23,6ms und es wird vorgeschlagen 512 als Eingangs- bzw. Ausgangslatenz zu setzen.
    Echtzeit ist aktiviert, Samplerate 44,100.

    Mit den Settings bekomme ich nahezu genaue Aufnahmen hin, aber eben nicht genau drauf ohne zu schieben.

    Jetzt wird's interessant: nehme ich ein Signal auf zwei Spuren gleichzeitig auf, sind die beiden Spuren untereinander NICHT synchron.

    Denke, das ZOOM H2 ist jetzt nicht gerad die Supersoundkarte - da muss ich wohl nochmal nachbessern.

    Ich fänd es nur spannend, ob mit einem "besseren" Interface die Probleme verschwinden. Das würde den Arbeitsaufwand erheblich erleichtern.
     
    boesebande, 03.10.12
    #5
  6. zettberlin

    zettberlin

    Registriert seit:
    24.03.08
    Punkte:
    2.202
    2202
    Na gut, dann wundert es mich nicht, dass das timing nicht perfekt wird.
    Ardour2 hat zwar eine Latency-Compensation, die ist aber hakelig(wird in Ardour3 besser).

    Ich begegne dem Problem einfach mit niedrigen Latenzen. Normalerweise stelle ich für Aufnahmen folgendes ein:

    für mein MAudio Mobilepre USB-Interface:

    /usr/bin/jackd -u -dalsa -dhw:2 -r48000 -p128 -n3 -m -Xseq

    als 3 periods/buffer, buffer 128 bei 48KHz ergibt 8ms Latenz

    für meine MAudio Audiophile PCI Soundkarte:

    /usr/bin/jackd -u -dalsa -dhw:2 -r48000 -p64 -n2 -m -Xseq

    das gibt etwa 5.3 ms Latenz

    In beiden Fällen ist die Latenz roundtrip, also die tatsächliche Gesamtverzögerung.

    Bis 10ms habe ich eigentlich noch nie Probleme mit lag gehabt.

    Na dann sollte zumindest Systemseitig alles richtig eingestellt sein und Du kannst eigentlich nach Bedarf mit den Settings für Periods und Buffer experimentieren. Ich sag mal so: wenn Du auf einem halbwegs modernen PC nicht wenigstens mit 10ms stabil arbeiten kannst, stimmt irgend was anderes nicht. Gelegentliche xruns(3-5 einzelne pro Stunde) würde ich ignorieren, solange es nicht knackt.


    Faszinierend: das kann eigentlich nur bedeuten, dass Ardour die dann sequenziell und nur scheinbar parallel aufnimmt. Dabei schreibt es immer einen bffer auf die eine, dann einen auf die andere Spur, je größer die Buffer desdo größer die Abweichung? Hmmmm...

    Na gut: aber wenn Du gleichzeitig zwei Signal vom Interface aufnimmst (vulgo: Stereo), geschieht das natürlich nicht OK?

    Das Zoom ist OK und sollte an sich auch die oben genannten Latenzen erlauben, Allerdings ist es eigentlich ein Fieldrecorder und ich weiß nicht, inwiefern sein internes Interface von der Recorderelektronik beeinflusst wird. Es ist jedenfalls *möglich*, dass ein einfaches aber rein dafür gebautes Interface bessere Werte möglich macht.

    Ausprobieren ist KIng ;-)
     
    zettberlin, 03.10.12
    #6
  7. boesebande

    boesebande Themenersteller

    Registriert seit:
    02.10.12
    Punkte:
    8
    8
    Danke für die Hinweise. Hab jetzt noch mal ein bisserl rumprobiert.
    Ich komme nah ans richtige Timing ran, bin aber noch nicht exakt da - ich bleib da dran.

    Ich behelfe mir bisher mit einem kleinen Trick: Jede neue Spur nehme ich von Anfang an auf spiele auf dem Instrument den Ardour-Klick mit, dann hab ich ne Referenz zum schnellen verschieben.

    Nun, ich frickel mal weiter rum....vll. bis Ardour 3 draußen ist :). Ohne basteln und ausprobieren macht Linux ja auch keinen Spaß ;)


    Danke nochmal!
     
    boesebande, 04.10.12
    #7
  8. boesebande

    boesebande Themenersteller

    Registriert seit:
    02.10.12
    Punkte:
    8
    8
    So, gefrickelt und gefummelt und immer wieder die Werte verändert......läuft!! Jetzt ist alles tight :) zumindest hört man es nicht....

    Danke für alles!

    SY
     
    boesebande, 04.10.12
    #8
  9. Sogyra

    Sogyra

    Registriert seit:
    11.11.09
    Punkte:
    3.517
    3517
    Egal ob die Latenzen groß oder klein sind(es sind IMMER welche vorhanden), braucht man das aufgenommene Sample im Sequenzer nur noch richtig schneiden und an die entsprechende Stelle positionieren. Das ist der Weg unabhängig vom Betriebssystem und Software. (ich arbeite übrigens mit beiden-XP und Ubuntu, jedoch XP nur für Audio, und Ubuntu für Video).
     
    Sogyra, 04.10.12
    #9
  10. boesebande

    boesebande Themenersteller

    Registriert seit:
    02.10.12
    Punkte:
    8
    8
    Nach dieser Info hab ich schon soo lange gesucht - Danke!

    Und ich dachte schon es läge an Ardour bzw. inus. Wollte schon auf nen HD-Rekorder umsteigen oder XP mit Cubase umsteigen.

    Es hat mich bisher einfach nur genervt, dass egal wie gut ich einspiele, ich doch immer schieben muss. Jetzt kann ich zumindest so einpielen, dass ich es während der Aufnahme nicht höre und nachher schieben - wenn überhaupt. Für meine Zwecke ist es zZt absolut ausreichend.


    THX
     
    boesebande, 05.10.12
    #10
  11. zettberlin

    zettberlin

    Registriert seit:
    24.03.08
    Punkte:
    2.202
    2202
    Bei niedrigen Latenzen stellt man sich auch irgendwann darauf ein, zumindest, wenn man die Klangerzeugung in the box macht, geht das ganz gut.

    Ich sehe aber auch bei rein akustischen Aufnahmen zu, dass ich möglichst nur ein Signal im Monitor höre, das genau wie der Clicktrack aus dem Rechner kommt. Wenn ich singe, liegt das Ausgangssignal des Rechners laut auf dem Kopfhörer -- solange die Latenz unter 10ms bleibt, funktioniert das sehr gut.
     
    zettberlin, 05.10.12
    #11
  12. Rainer_Hain

    Rainer_Hain

    Registriert seit:
    23.12.11
    Artikel:
    2
    Punkte:
    4.429
    4429
    Die Info ist aber völliger Quark. Man muss jedenfalls auf Mac und PC nicht nach einer Aufnahme das Sample schneiden und verschieben. Eine samplegenauer Aufnahme ist seit vielen Jahren absoluter Mindeststandard. Wenn man schneidet, dann um schlechtes Timing von Musikern zu korrigieren, aber doch nicht um die Aufnahme an den richtigen Startpunkt zu setzen. Was im übrigen auch nicht helfen würden, denn wenn der Sequenzer den Startpunkt schon nicht genau kennt, dann kann er auch während der Aufnahme nicht synchronisieren. Dann kann man das File hin- und herschieben, wie man will, es wird nie in-sync sein.

    Es gab selbst in der Steinzeit der DAWs nur dann Probleme, wenn der jeweilige Treiber des Audio-Interfaces die Latenz entweder falsch meldete oder sie nicht konstant war oder - wie bei der berüchtigten Terratec EWS64 - bei verschiedenen Betriebsarten die Puffer änderte, ohne das dem Host mitzuteilen. Aber wer arbeitet noch mit solcher Hardware?

    Wie auch immer:
    Wenn das ein Problem der Software wäre, bräuchte man sich nicht über die geringe Verbreitung von Linux für Audioanwendungen zu wundern. Ich glaube das aber eigentlich nicht, denn kein Entwickler würde eine Software ins Freie entlassen, die das nicht kann - auch nicht unter Linux.

    Ich würde das Problem daher eher beim Treiber für die Hardware vermuten, was Dir aber vermutlich auch nicht hilft.
     
    Rainer_Hain, 19.10.12
    #12
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.