Information ausblenden

Interrupt !

Dieses Thema im Forum "Musik produzieren" wurde erstellt von daycook, 27.08.02.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. daycook

    daycook Themenersteller

    Registriert seit:
    26.08.02
    Punkte:
    210
    210
    Hy Leutz !
    Meine Soundk. belegt Interrupt 5 . Aber leider Teilt sie sich den Platz mit noch zwei Objekten !
    Jetzt meine Frage : Welche Komponenten müssen Unbedingt einen eigenen Interrupt alleine Belegen ? Außer meiner Soundkarte ! Damit ich weiß , wohin ich die zwei anderen verbannen kann !?
    Danke !
    G.
    Daniel
     
    daycook, 27.08.02
    #1
  2. Gunny

    Gunny

    Registriert seit:
    24.08.02
    Punkte:
    290
    290
    Hi Du,

    Probiers mal mit IRQ ''9'',
    Bei mir teilen sich zwei Audiokarten, eine Netzwerkkarte u USB.

    EWX24/96, RME Digi PST mit 6ms, funktioniert problemlos mit Win XP bei den anderen weiss ich nicht (95,98,)

    Ich hoffe ich konnte Dir helfen, Ciao.
     
    Gunny, 27.08.02
    #2
  3. daycook

    daycook Themenersteller

    Registriert seit:
    26.08.02
    Punkte:
    210
    210
    Hy Gunny !
    Wenn ich den Interrupt ändern möchte ( Häkchen weg bei Automatische Einstellung ) und dann auf Einstellung klicke bekomme ich die Meldung : Diese Resourcen einstellung kann nicht geändert werden !
    ???????

    G.
    Daniel
     
    daycook, 28.08.02
    #3
  4. NULL

    NULL Guest

    Punkte:
    0
    Hi

    schau mal nach im BIOS ob evtl. IRQ´s fest zugeordnet sind.
    Unter NT und WIN2K gibts ne Übersicht über alle IRQ´s welches Gerät welchen
    benutzt.
     
    NULL, 28.08.02
    #4
  5. BennyJ

    BennyJ

    Registriert seit:
    29.06.02
    Punkte:
    475
    475
    Hi,

    Falls du einen ACPI-kompatiblen PC hast (also nicht viel älter als 2 Jahre) und Windows 2000/XP einsetzt, kannst du die IRQs nicht ändern, da Windows das selbst verwaltet. An sich ist das auch gut so, leider halten sich manche Soundkarten aber nicht an die PCI-Spezifikationen und haben dann Probleme, wenn sie sich den IRQ mit anderen Geräten teilen müssen. Du kannst in dem Fall noch versuchen, Wndows neu zu installieren und beim Setup gleich am Anfang auszuwählen, dass du die "Stanard-HAL" und nicht die "ACPI-HAL" verwenden willst. Aber selbst das führt oft nicht dazu, dass man die IRQs per Hand ändern kann. Bei mir hat es geholfen, die Karte in einen anderen Slot zu stecken. So beakm sie nach einigen Versuchen einen eigenen IRQ.
     
    BennyJ, 28.08.02
    #5
  6. Gunny

    Gunny

    Registriert seit:
    24.08.02
    Punkte:
    290
    290
    Hi

    Der Benny hat volkommen Recht, entweder andere PCI Steckplatz
    wenn das nicht geht dann auf STANDART PC umstellen.
    Und zwar genau dann, wenn Windows2000/XP nach Treiberdiskette für SCSI
    geräte frägt, must Du ''F5'' Taste drücken, einmal oder mehrmals.

    Nach ein paar sekunden hast Du die auswahl zwischen Standart, ACPI oder Muliprocessor PC. Mit den Cursortasten auswählen usw.

    Beachte aber das Dein PC nicht mehr von alleine runterfährt, den must dann
    manuell auschalten.
     
    Gunny, 28.08.02
    #6
  7. Gunny

    Gunny

    Registriert seit:
    24.08.02
    Punkte:
    290
    290
    Hi,

    Noch was Resourcen,
    Da würdest den Speicherbereich ändern, also anderer Speicherbereich und das führt zu Konflikten mit anderen Geräten. Ist gut das man das nicht so einfach ändern kann.

    Ich hab z.B. PCI-Steckplatz nr. 4 für meine RME aber die braucht keinen ganzen IRQ, und die EWX auf nr. 2,

    Bei mir in Systeminfo ist der ''5'' gar nicht dabei, der ist warscheinlich für was
    anderes reserviert, ''12'' ist auch nicht dabei.

    Vieleicht hilt Dir das weiter.
    Gruß Gunny.
     
    Gunny, 28.08.02
    #7
  8. daycook

    daycook Themenersteller

    Registriert seit:
    26.08.02
    Punkte:
    210
    210
    Hy !
    Also erst mal Danke für euer Feedback !
    Und zweitens , XP liegt noch vor mir , momentan ärger ich mich noch mit Me rum ! ( Aber nicht mehr lange)
    Aber sagt mal , kann man die IRQ's nicht einfach manuell zuordnen ?
    Hab die Karte auch schon umgesteckt , aber ich bekomme sie einfach nicht solo auf ein Interrupt ! Oder wie soll ich dann die 2 anderen Geräte von Interrupt 5 ( oder halt von dem Interrupt den meine Soundkarte benutzt ) runter bekommen ?
    G.
    Daniel
     
    daycook, 29.08.02
    #8
  9. Gunny

    Gunny

    Registriert seit:
    24.08.02
    Punkte:
    290
    290
    Hi,

    Der IRQ 5 ist normalerweise für LPT (Druckerport), ältere Soundkarten z.B. sind auf diesen Intrerupt voreingestellt. ich weis nicht genau wie's bei Deiner jetzt ist, das konnte man früher per Jumper auf der karte selbst einstellen.

    Du must im BIOS nochmal nachschauen ob ''Plag & Play OS'' auf ''YES'' oder ''NO'' steht gegebenfall experimentieren.
    Nicht benötigte Geräte wie COM2 oder COM1, deaktivieren(im BIOS natürlich).
    Den IRQ 5 reservieren, falls dein BIOS das unterstützt.

    Vielleicht hilfts, viel Spaß.
    MFG Gunny.
     
    Gunny, 30.08.02
    #9
  10. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    Hi!

    Die Geräte sind Gruppen zugeordnet, denen man wiederum IRQs zuordnen kann. z.B bekommen benachbarte PCI-Slots immer den gleichen IRQ zugewiesen.
    Normalerweise sollten alle Geräte inzwischen IRQs sharen können. Es gibt auch Fälle, wo sich zwei Karten einfach nicht miteinander vertragen, aber mit anderen gehts dann doch. Dann könnte man einfach mal alle Kombinationen ausprobieren und die Karten in andere PCI-Slots stecken.

    Dabei würde ich die Karten nacheinander installieren und zwischendurch neu booten und Treiber installieren. Und wenn das Gerät nicht mehr geht, die letzte installierte Karte woanders installieren. Fang' mit dem Problemfall Soundkarte am besten an.

    Du kannst auch mal versuchen, den IRQ Deiner Karte auf legacy umzuschalten. (im Bios, eventuell mußt Du irgendwelche Automatismen abschalten).

    Wenn man ACPI abschaltet, aber APM eingeschaltet läßt, dann sollte man mit Standard-PC Kernel von Win2000 ein automatisches Ausschalten des Rechners beim Runterfahren hinbekommen. Nur muß man definitiv auf den Ruhezustand verzichten. Wichtig ist, daß der Kernel von Win2000 passend zu den Bioseinstellungen gewählt wurde. Stellt man das Bios vor der Installation ein, dann wählt der Installer von Win2000 den richtigen Kernel automatisch. Problematisch ist es natürlich, wenn der ACPI sich gar nicht mehr abschalten läßt. (Wie z.B. bei meinem aktuellen Board, mein vorheriges hatte noch dieses Feature)

    Im Bios hast Du (bei einem guten Board) die Möglichkeit den PCI-AGP-ISA-Slot Gruppen IRQs händisch zu setzen. Damit kannst Du das OS zwingen diese IRQs zu verwenden.
    Wenn der Rechner neu booten und die Liste aller Plug&Pray-Geräte auflistet, dann schnell Pause-Taste drücken (die ist oben rechts) und Du kannst sehen, welche Geräte welche IRQs oder DMAs zugewiesen bekommen haben und welche noch not assigned sind.
     
    HaSBACHMeSBACH, 30.08.02
    #10
  11. popsta

    popsta Administrator

    Registriert seit:
    14.04.02
    Artikel:
    273
    Punkte:
    52.347
    52347
    sorry HaSBACHMeSBACH, hier ist grade was falsch gelaufen, kannst deine antwort bitte nochmal posten?
    thx
    karsten
     
    popsta, 30.08.02
    #11
  12. HaSBACHMeSBACH

    HaSBACHMeSBACH

    Registriert seit:
    28.04.02
    Punkte:
    1.381
    1381
    Hi!

    @Popsta Für Dich wär 'ne Backup-Option schon ganz nützlich, oda? ;-)

    Was hab' ich geschrieben? *überlegt*
    Kurzversion: Ich meinte, daß Win98/Win98se/WinMe kein ACPI unterstützen und hatte vorgeschlagen, trotzdem Komponente für Komponente zu installieren. Unter Win98/se/Me sollte man das sowieso tun.

    Was ich sonst so geschrieben hatte weiß ich net mehr. Sorry.
     
    HaSBACHMeSBACH, 30.08.02
    #12
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.