Information ausblenden

CPU-Spikes und Audioaussetzer bei Multitrack-Recordings

Dieses Thema im Forum "Mac und Music" wurde erstellt von colasheba, 18.02.18.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. colasheba

    colasheba Themenersteller

    Registriert seit:
    18.02.18
    Punkte:
    4
    Hallo Zusammen,

    ich habe seit längerer Zeit ein echt nerviges Problem mit meinem Macbook beim einfachen Aufnehmen mehrere Kanäle.

    Hardware:
    Macbook Pro 13" 2015
    2,7 GHz Intel Core i5
    8 GB Ram
    256 GB SSD
    Sierra 10.12.6
    Interface: Behringer X-Air 18
    DAW: Studio One 3, Waves Tracks Live, Ableton Live 9/10

    Ich nehme damit unsere Proben zur Dokumentation auf, d.h. ich nehme gleichzeitig 15 Audio Kanäle, plus eine MIDI Spur (2 Noten: Trigger an Kick und Snare) auf. Ab und zu nehme ich auch nur Schlagzeug auf. Da sind es dann 6 Audio Kanäle und die gleiche MIDI Spur.
    Das hat auch alles wunderbar funktioniert, bis vor ein paar Wochen, plötzlich Knackser und Aussetzer in den Spuren auftraten und die CPU-Lastanzeige in der DAW von normalen 4-10% auf Anschlag schoss. Sehen kann ich das nur in Studio One, die Aussetzer sind aber in anderen DAW´s trotzdem vorhanden.
    In der Aktivätenanzeige scheint aber alles gut zu sein. CPU Auslastung liegt hier bei ca. 50%
    Ich kann mich nicht erinnern, was sich geändert haben könnte, dass es mir nicht mehr möglich ist, eine simple Aufnahme machen zu können.

    Hier ein Dropbox-Link mit einem Video, das die Spikes in Studio One zeigt:


    Was ich bisher probiert habe:
    Alle möglichen Geräteblockgrößen durchprobiert bis hin zu 4096 Samples
    Wlan und Bluetooth ausgeschalten
    USB Kabel und Ports durchgetauscht
    Macbook zurückgesetzt (Festplatte formatiert, kein Backup eingespielt)
    Parameter-RAM gelöscht
    Verschiedene DAW-Versionen ausprobiert
    Anderes Interface (Behringer X32) ausprobiert
    Per Bootcamp Windows 10 + Studio One installiert.
    Hardwaretest ausgeführt (beim Start des Macbooks "D" gedrückt halten)
    Festplattendienstprogramm ausgeführt

    Ich glaube ich habe jetzt alles aufgezählt. Nichts davon hat irgendwas gebracht oder einen Fehler aufzeigen können. Ich konnte im Internet auch keine vernünftige Lösung finden, oder überhaupt einen ähnlichen Fall entdecken.
    Bei Auftritten verwende ich Ableton um Backing- und Clicktracks teils automatierst zu starten und gleichzeitg ein DMX-Interface anzusteuern. (angezeigte CPU-Last 2-3%)
    Abspielen mehrerer Spuren, auch mit Effekten in den Kanälen, funktioniert ebenso wunderbar.

    Mit meinem Windows-Laptop (i7 hq, 16GB RAM, 1TB HDD, 256GB SSD) habe ich es auch probiert. Da war alles gut.

    Ich bin wirklich am Verzweifeln und Hoffe wirklich sehr, dass ihr mir helfen könnt.

    Vielen Dank schon im Voraus!

    PS: Ich hoffe, ich habe den Beitrag richtig erstellt und nicht gegen irgendwelche Forenregeln verstoßen!
    Falls doch, bitte ich um Verzeihung.
     
  2. KonstantinBrigante

    KonstantinBrigante

    Registriert seit:
    01.06.15
    Punkte:
    101
    101
    hi grüße dich
    hast du mittlerweile herausgefunden woran es liegt ?
    Das selbe Problem habe ich mit meinen neuen MacBook pro (2017er)
    ist ein i7 ner 4 kerner und das problem habe ich von anfangan also in meinem fall schafft er schon etwas mehr, nur trotzdem ist der auffällig kurz vom anschlag viele meiner kollegen besitzen die älteren modelle und arbeiten mit den selben plugins. Bei denen läuft aber alles normal.
    2,8ghz i7
    16gb ram
    256gb ssd


    ich habe seit längerer Zeit ein echt nerviges Problem mit meinem Macbook beim einfachen Aufnehmen mehrere Kanäle.

    Hardware:
    Macbook Pro 13" 2015
    2,7 GHz Intel Core i5
    8 GB Ram
    256 GB SSD
    Sierra 10.12.6
    Interface: Behringer X-Air 18
    DAW: Studio One 3, Waves Tracks Live, Ableton Live 9/10

    Ich nehme damit unsere Proben zur Dokumentation auf, d.h. ich nehme gleichzeitig 15 Audio Kanäle, plus eine MIDI Spur (2 Noten: Trigger an Kick und Snare) auf. Ab und zu nehme ich auch nur Schlagzeug auf. Da sind es dann 6 Audio Kanäle und die gleiche MIDI Spur.
    Das hat auch alles wunderbar funktioniert, bis vor ein paar Wochen, plötzlich Knackser und Aussetzer in den Spuren auftraten und die CPU-Lastanzeige in der DAW von normalen 4-10% auf Anschlag schoss. Sehen kann ich das nur in Studio One, die Aussetzer sind aber in anderen DAW´s trotzdem vorhanden.
    In der Aktivätenanzeige scheint aber alles gut zu sein. CPU Auslastung liegt hier bei ca. 50%
    Ich kann mich nicht erinnern, was sich geändert haben könnte, dass es mir nicht mehr möglich ist, eine simple Aufnahme machen zu können.

    Hier ein Dropbox-Link mit einem Video, das die Spikes in Studio One zeigt:


    Was ich bisher probiert habe:
    Alle möglichen Geräteblockgrößen durchprobiert bis hin zu 4096 Samples
    Wlan und Bluetooth ausgeschalten
    USB Kabel und Ports durchgetauscht
    Macbook zurückgesetzt (Festplatte formatiert, kein Backup eingespielt)
    Parameter-RAM gelöscht
    Verschiedene DAW-Versionen ausprobiert
    Anderes Interface (Behringer X32) ausprobiert
    Per Bootcamp Windows 10 + Studio One installiert.
    Hardwaretest ausgeführt (beim Start des Macbooks "D" gedrückt halten)
    Festplattendienstprogramm ausgeführt

    Ich glaube ich habe jetzt alles aufgezählt. Nichts davon hat irgendwas gebracht oder einen Fehler aufzeigen können. Ich konnte im Internet auch keine vernünftige Lösung finden, oder überhaupt einen ähnlichen Fall entdecken.
    Bei Auftritten verwende ich Ableton um Backing- und Clicktracks teils automatierst zu starten und gleichzeitg ein DMX-Interface anzusteuern. (angezeigte CPU-Last 2-3%)
    Abspielen mehrerer Spuren, auch mit Effekten in den Kanälen, funktioniert ebenso wunderbar.

    Mit meinem Windows-Laptop (i7 hq, 16GB RAM, 1TB HDD, 256GB SSD) habe ich es auch probiert. Da war alles gut.

    Ich bin wirklich am Verzweifeln und Hoffe wirklich sehr, dass ihr mir helfen könnt.

    Vielen Dank schon im Voraus!

    PS: Ich hoffe, ich habe den Beitrag richtig erstellt und nicht gegen irgendwelche Forenregeln verstoßen!
    Falls doch, bitte ich um Verzeihung.[/QUOTE]

    ich habe seit längerer Zeit ein echt nerviges Problem mit meinem Macbook beim einfachen Aufnehmen mehrere Kanäle.

    Hardware:
    Macbook Pro 13" 2015
    2,7 GHz Intel Core i5
    8 GB Ram
    256 GB SSD
    Sierra 10.12.6
    Interface: Behringer X-Air 18
    DAW: Studio One 3, Waves Tracks Live, Ableton Live 9/10

    Ich nehme damit unsere Proben zur Dokumentation auf, d.h. ich nehme gleichzeitig 15 Audio Kanäle, plus eine MIDI Spur (2 Noten: Trigger an Kick und Snare) auf. Ab und zu nehme ich auch nur Schlagzeug auf. Da sind es dann 6 Audio Kanäle und die gleiche MIDI Spur.
    Das hat auch alles wunderbar funktioniert, bis vor ein paar Wochen, plötzlich Knackser und Aussetzer in den Spuren auftraten und die CPU-Lastanzeige in der DAW von normalen 4-10% auf Anschlag schoss. Sehen kann ich das nur in Studio One, die Aussetzer sind aber in anderen DAW´s trotzdem vorhanden.
    In der Aktivätenanzeige scheint aber alles gut zu sein. CPU Auslastung liegt hier bei ca. 50%
    Ich kann mich nicht erinnern, was sich geändert haben könnte, dass es mir nicht mehr möglich ist, eine simple Aufnahme machen zu können.

    Hier ein Dropbox-Link mit einem Video, das die Spikes in Studio One zeigt:


    Was ich bisher probiert habe:
    Alle möglichen Geräteblockgrößen durchprobiert bis hin zu 4096 Samples
    Wlan und Bluetooth ausgeschalten
    USB Kabel und Ports durchgetauscht
    Macbook zurückgesetzt (Festplatte formatiert, kein Backup eingespielt)
    Parameter-RAM gelöscht
    Verschiedene DAW-Versionen ausprobiert
    Anderes Interface (Behringer X32) ausprobiert
    Per Bootcamp Windows 10 + Studio One installiert.
    Hardwaretest ausgeführt (beim Start des Macbooks "D" gedrückt halten)
    Festplattendienstprogramm ausgeführt

    Ich glaube ich habe jetzt alles aufgezählt. Nichts davon hat irgendwas gebracht oder einen Fehler aufzeigen können. Ich konnte im Internet auch keine vernünftige Lösung finden, oder überhaupt einen ähnlichen Fall entdecken.
    Bei Auftritten verwende ich Ableton um Backing- und Clicktracks teils automatierst zu starten und gleichzeitg ein DMX-Interface anzusteuern. (angezeigte CPU-Last 2-3%)
    Abspielen mehrerer Spuren, auch mit Effekten in den Kanälen, funktioniert ebenso wunderbar.

    Mit meinem Windows-Laptop (i7 hq, 16GB RAM, 1TB HDD, 256GB SSD) habe ich es auch probiert. Da war alles gut.

    Ich bin wirklich am Verzweifeln und Hoffe wirklich sehr, dass ihr mir helfen könnt.

    Vielen Dank schon im Voraus!

    PS: Ich hoffe, ich habe den Beitrag richtig erstellt und nicht gegen irgendwelche Forenregeln verstoßen!
    Falls doch, bitte ich um Verzeihung.[/QUOTE]
     
    Zuletzt bearbeitet: 03.05.18
  3. colasheba

    colasheba Themenersteller

    Registriert seit:
    18.02.18
    Punkte:
    4
    Hi!

    Leider habe ich keine Lösung finden können und habe aufgegeben weiter nach einer zu suchen.
    Habe bei Gravis einen kompletten Hardwarecheck machen lassen, bei dem keinerlei Probleme erkannt worden sind.
    Ich kanns mir nur so erklären, dass der Rechner irgendwann, irgendwo her eine Überspannung abbekommen haben muss und dabei irgendwas zerschossen wurde.

    Ich hatte mir zeitweise auch das akuelle MacBook gekauft (13zoll-touchbar, i5, 265 GB) und hatte überhaupt keine Probleme damit.

    Bist du denn noch in der Garantiezeit?
     
  4. Pheeel

    Pheeel

    Registriert seit:
    08.10.11
    Punkte:
    1.565
    1565
    Wie und wo es zu Deinem Problem gekommen sein kann, weiß ich nicht.
    Das erste was ich jedoch probieren würde, wäre auf eine externe Festplatte aufzunehmen. Jede DAW rät einem dazu, eine separate Festplatte für Recording zu nutzen. Es hat vorher funktioniert, aber Rechner werden alt und leistungsschwächer. Vielleicht packt deine Festplatte die Datenmenge einfach nicht mehr. Zu viele Informationen auf einmal.
     
    KonstantinBrigante bedankt sich.
  5. WMD

    WMD

    Registriert seit:
    01.05.06
    Punkte:
    2.232
    2232
    Mit dem selben Interface wie am Mac?
    Wenn ich alles richtig verstanden habe hast du ja wirklich alles was Software technisch möglich ist schon gemacht. Aber hast du dann immer wieder mit dem Behringer Interface aufgenommen?

    Das klingt wirklich alles seltsam
    Äh...aber doch keine externe Festplatte wenn er eine interne SSD hat?Was soll denn da der Vorteil sein?

    Natürlich sollte die Festplatte nicht zu voll sein, sonst zickt er nämlich rum, aber formatiert hast du ja auch schon.

    Hast du mal eine andere DAW benutzt? Wenn auch nur Garage band um zu gucken ob es wirklich die Hardware ist?
     
  6. Pheeel

    Pheeel

    Registriert seit:
    08.10.11
    Punkte:
    1.565
    1565
    Äh...aber doch keine externe Festplatte wenn er eine interne SSD hat?Was soll denn da der Vorteil sein?

    Natürlich sollte die Festplatte nicht zu voll sein, sonst zickt er nämlich rum, aber formatiert hast du ja auch schon.

    Hast du mal eine andere DAW benutzt? Wenn auch nur Garage band um zu gucken ob es wirklich die Hardware ist?[/QUOTE]

    Ja doch. SSD is schnell und gut und alles, aber trotzdem wird einem geraten, die recording Festplatte separat zu nehmen.
    Die Puffergröße ist halt beschränkt, und wenn da schon Windows und deine DAW permanent Daten hin und her schieben, dann ist ein Teil des Puffers halt schon belegt. Nimmst Du dann noch recht große Projekte und nimmst beispielsweise 10 Spuren gleichzeitig auf, bei deiner eingestellten Samplesize und Bitrate, dann ist der Puffer voll. Alles was net direkt rübergeschickt werden kann, wird auf halt gesetzt. Und so kommt es bei Festplattenauslastung zum Aussetzen einzelner Audiospuren. Es wird auch ungemein anstrengender für die CPU, weil sie die Daten zwischenzeitig ablegt und mit der nächsten Tour rüberschicken möchte.

    Anders ausgedrückt, die Puffergröße und die Schreibgeschwindigkeit deiner Platte sind wichtig. Sie ist zwar kaum ausgelastet was schreiben betrifft, aber die Daten müssen ja auch irgendwie dort hin transportiert werden. Wenn in diesem Bus schon 10 Plätze durch windows belegt sind, und 10 Plätze durch die DAW, dann passen da net mehr viele Daten rein die zum schreiben auf die Platte geschickt werden sollen.
     
  7. colasheba

    colasheba Themenersteller

    Registriert seit:
    18.02.18
    Punkte:
    4
    Hi

    Danke für eure Lösungsvorschläge!

    Wie schon geschrieben habe ich es an einem X-32 und einem Soundcraft (genaue Bezeichnung weiss ich leider nicht mehr) ausprobiert.
    Ausserdem habe ich nen USB-Stick, sowie eine externe Festplatte angeschlossen. Hat alles nichts gebracht.
    Mit Ableton Live und Waves Tracks gibts die gleichen Probleme.
    Hatte das Macbook ja bei Gravis, die einen komplette Hardwarecheck gemacht haben und keine Fehler finden konnten.

    Habe jetzt den alten Laptop von meinem Vater mit Pentium Prozessor, 3 GB Ram und ner 500 GB HDD und alles funktioniert wir am Schnürchen. Mal von dem katastrophalen Touchpad abgesehen xD

    Meinst du, dass evtl doch die SSD im Macbook kaputt ist?
    Hätte dann der Test bei Gravis keinen Fehler auspucken müssen?
     
  8. derspencer

    derspencer

    Registriert seit:
    07.03.09
    Punkte:
    126
    126

    Ist das Problem noch aktuell ?
    Probier mal, nicht die eingebauten USB Anschlüsse, sondern ein Thunderbolt Dock, das hat mir bei einem ähnlichen Problem geholfen, ich hatte das mit mehren Rechnern (alles ab Retina Baureihe), davor nie...
     
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.