Sonar X1 - Audio-/Midisynchronisation Problem

Dieses Thema im Forum "SONAR" wurde erstellt von whitealbum, 29.01.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Hallo,
    bin gerade an einem Song, und habe ein merkwürdiges Phänomen festgestellt.
    Wenn ich den Song in Sonar X1 öffne und starte dann "hinkt" das Schlagzeug (Addictive Drums) und die Hammond (VB3) mindestens 10 bpm hinterher. Das True Piano erklingt schonmal gar nicht!
    Wenn ich kurz stoppe und wieder das Playback starte ist das Schlagzeug wieder in Sync, und das Piano wie die VB3 erklingen so, wie es gespielt wurde.
    Solange der Song offen ist, taucht das Phänomen dann nicht mehr auf.
    Nur wenn ich den Song verlasse und wieder öffne habe ich das gleiche oben beschriebene Problem.
    Woran kann das liegen?

    Grüße

    PS: Sonar Producer Expanded X1c

    EDIT: Timing Master Aufnahme und Wiedergabe ist auf meinen Wandler RME ADI-2, der mit der RME FIreface UC verbunden ist, gelegt. Lege ich diese auf Ein oder Ausgänge von der RME Fireface UC direkt, habe ich das gleiche Problem. Also, an dem kann es nicht liegen.
    In Cubase 6 und Samplitude ProX tritt das Phänomen nicht auf.
    Irgendeine Einstellungssache vermute ich, nur welche?
     
  2. Faltac

    Faltac Veteran

    Registriert seit:
    20.12.09
    Punkte:
    20.982
    20982
    Schwer von hier aus zu sagen!
     
  3. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Danke Dir faltac für ein Lebenszeichen aus dem deutschen Forum!
    Das ist ein Problem, was einem beim Lesen schon unglaublich vorkommt.
    Ich habe das Thema parallel ins Cakewalk Forum gestellt, und ein paar Antworten erhalten.

    Interessant ist der Zusammenhang mit dem "Caching" in Sonar.

    Mittlerweile taucht das Problem bei mir nämlich nicht mehr auf.
    Hintergrund: Ich habe einen 2 minütigen kurzen Song vor einem Jahr geschrieben, um Samplitude ProX 64 Bit zu testen. Den gleichen Song habe ich einfach nochmal in Sonar X1 64 Bit aufgenommen, gleiche VSTi's (bis auf das True Piano), gleiche Audiotracks.

    Aus Interesse habe ich einfach dann mal den Song in Samplitude ProX gestartet, und da lief er problemlos, mir ist nur aufgefallen das die fps in ProX auf 25 standen. Das sollte zwar nicht das Problem sein, aber das habe ich dann in X1 (da stands auf 30fps) auch noch nachgezogen.

    Dann habe ich X1 wieder geöffnet und den Song dann da gestartet, egal was ich gemacht habe, alles war wieder in sync.. Ich habe zwar die fps auf 25 geändert, aber ich denke das war nicht die Lösung.

    Ich denke, X1 hat ein Caching Problem. Wenn man in Sonar den Song auch mehrfach öffnet und schließt , merkt man das der Song deutlich schneller offen ist, als wenn man bspw. den Rechner neu startet. Das ist ja auch gut so, und das machen Cubase und ProX ja genauso.
    Aber in X1 muss sich da irgendwas, auch wenn nicht immer, verbiegen.

    mmh, bin mal gespannt, ob der Cakewalk Support da was zu schreibt.

    Grüße
    whitealbum
     
  4. tubeless

    tubeless Gesperrter User

    Registriert seit:
    02.05.09
    Punkte:
    43.059
    43059
    Also ich weiss ja nicht.
    Die Einstellung der Frames per Second ist ja sicherlich mal nicht dazu da, damit man nen Knopf zum rumspielen hat.
    Wenn man also von der Kiste verlangt, dass sie auf ne höhere Framerate syncen soll, sich dann aber wundert, wenn die Kiste das macht, dann ist doch sicher nicht im Programm der Fehler zu finden, oder nicht?
     
  5. Faltac

    Faltac Veteran

    Registriert seit:
    20.12.09
    Punkte:
    20.982
    20982
    Vor allem wenn keine externe Hardware gesynct wird.
     
  6. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Was heißt rumspielen? Der höhere Wert 30 fps war die Defaulteinstellung in Sonar X1.
    Beim Vergleich in ProX, fiel mir auf, dass dort 25 fps (PAL/Secam, passend zu 50Hz Netzstrom) eingestellt ist. Daraufhin, da alles andere fehl schlug, habe ich dann von 30 auf 25 fps in Sonar X1 umgestellt.
    Ob das dann der Grund ist, dass Audio mit Midi wieder in sync ist, muss sich erst noch zeigen
    Das schaue ich mir in der Woche nochmal in Ruhe an.
     
  7. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Kurze Info:
    Wie vermutet, hat die framerate überhaupt nichts mit der Audio-Midisynchronisation in meinem Falle zu tun. Vollkommen wurst was da steht.
    Es ist vielmehr so, dass Sonar X1 in manchen Fällen extreme Probleme hat, Audio und MIdi, wenn VSTis im Spiele sind, synchron zu halten oder auch überhaupt korrekt auszuspielen.
    Wenn man allerdings die Wiedergabe anhält und sofort wieder startet, ist das Problem für die Session vorbei.
    IM amerikanischen Cakewalk Forum ist dies manchen Usern auch aufgefallen. Vieles kann damit zusammenhängen, 64 Bit Audio Engine, Bitbridge, Caching (mein Favorit bei mir, da bei einem normalen Erstladen des Songs dies wesntlich länger dauert, aber sauber funktioniert).

    Habe dies im Cakewalk Forum nochmal aus der Versenkung geholt.
    Wenn das nix hilft, hake ich beim Cakewalk Support nochmal direkt nach.
     
  8. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Tja, mir hat das natürlich keine Ruhe gegeben, denn bei jedem Erststart des Songs, egal ob Sonar vorher auf ist, oder nicht, holperte Addcitive Drums, True Piano war gar nicht zu hören, VB3 nur teilweise, und Reaktor 5 mal erklang es komplett, mal gar nicht. Nach einem kurzen Stop, und Start durch Leertaste, alles im Lot! Das soll einer verstehen.

    Ich hatte zwischendurch die Drum Map, die ich für Addictive Drums benutzt habe, im Verdacht gehabt.
    Als ich den Output der MIdispur auf Addictive Drums, und nicht auf die Drum Map gelegt hatte, hoppelte und stotterte das Schlagzeug nicht mehr, es klang wie es sollte.
    Allerdings erklang das True Piano nach wie vor nicht, und die VB3 erklang nur teilweise, also wie gehabt, bis auf Addictive Drums.

    Alle Stereoinstrumente, True Piano, VB3 und Reaktor habe ich als einfache Instrumentenspur angelegt. Da mir nix mehr anderes eingefallen ist, habe ich die INstrumentenspur NUR von True Piano aufgeteilt (in Audio und Midispur).
    Und siehe da, alles funktioniert, auch die Instrumente, die noch als Instrumentenspur zugewiesen sind. Ich habe auch wieder die Drum Map Addictive Drums zugeordnet.
    Egal was ich anstelle, die VSTis laufen wie sie sollen, und sind auch in sync mit den Audiospuren. Freut mich natürlich, aber ...komisch ist das, verstanden habe ich das nicht.
    Soll heißen, soll ich sicherheitshalber, immer eine Audio und MIdispur für Softsynthies anlegen?
    Was sind Eure Tipps?
     
  9. netwalker007

    netwalker007

    Registriert seit:
    07.10.10
    Punkte:
    617
    617
    :)Ich hatte früher ähnliche Probleme in einem anderen Sequenzer.
    Es ist natürlich eine elegante Lösung, mit einem Mausklick eine Instrumentenspur zu erstellen, die MIDI-Daten verarbeitet und gleichzeitig einen Softsynth abspielt.

    Meine Einschätzung ist, dass diese "elegante" Lösung bei Vorhandensein vieler Spuren in die Hose gehen kann besonders dann wenn man viele Spuren hat und im ASIO-Treiber buffer size ausreizt.
    Ich halte das Anlegen von zwei Spuren irgendwie besser und auch transparenter, da in diesem Fall jede Spur nur eine Aufgabe zu bewältigen hat.
    Und die Spurenanzahl ist ja unbegrenzt.:)
    Zudem hat die Zweispurlösung entscheidende Vorteile bei Synties die mehrere Eingänge haben (z. B. Miroslav Filharmonik mit seinen 16 Kanälen).
     
  10. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Also in Samplitude und Cubase ging das eigentlich immer ohne Probleme.
    Allerdings gebe ich Dir recht, was die Übersichtlichkeit betrifft, ist das mit den getrennten Spuren schon wirklich besser.
    Vor allem in Sonar ist das dann übersichtlicher. In der Instrumentenspur sehe ich vor allem gar nicht den benutzten Synthie im Ausgang (ist ja nur im Synthierack zu sehen, allerdings ohne Bezug zur Spur).
    Wenn es wirklich daran liegen sollte, dann nutze ich halt die Midi und Audiovariante.
    Bin mal gespannt was der amerikanische Cakewalk Support schreibt.
     
  11. netwalker007

    netwalker007

    Registriert seit:
    07.10.10
    Punkte:
    617
    617
    Ein weiterer Grund fürs separate Anlegen der Spuren:
    Wenn Du mit "H" den Spurmanager einschaltest, kannst Du bequem Spurengruppen ein- und ausblenden.

    Dabei sind diverse Auswahlkriterien behilflich: (s. Bild), Du kannst Synthi- oder MIDI-Spuren separat auswählen. anzeigen lassen und den Rest ausblenden.
     

    Anhänge:

  12. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Den hatte ich auch schon entdeckt, auch eine feine Sache, aber meistens möchte ich in der Spuransicht eh' alles sehen (außer im MIxer, da brauche ich die reinen Midikanäle meistens nicht).

    Wenn wir gerade beim Entdecken sind, habe zwar zuerst etwas gesucht, und für Sends das Send Panorama entdeckt (sieht man nur, wenn der Kanalzug NICHT verkleinert dargestellt wird).
    Gerade bei Hall mag ich es, wenn bspw. eine nach links gepannte Gitarre, der Hall entsprechend "mehr" von links " kommt. Das schafft im Mix Platz!
    Die Funktion gibt es zwar auch in Samplitude, aber da konnte ich das "hörtechnisch" nicht so wahrnehmen. Allerdins sei zur Ehrenrettung von Samplitude gesagt, das Panning bei denen ist wirklich ein Panning! Extrem links ist wirklich extrem links, das habe ich bei keiner anderen DAW so wahrnehmen können (unabhängig von der verwendeten Panregel).

    Ach ja, was ich in Sonar X1 vermisse, das direkte Anspringen bestimmter Marker via Shortcut, dass scheint wirklich nicht zugehen, oder hast Du da was gefunden?
     
  13. netwalker007

    netwalker007

    Registriert seit:
    07.10.10
    Punkte:
    617
    617
    @whitealbum
    Wenn wir gerade beim Entdecken sind, habe zwar zuerst etwas gesucht, und für Sends das Send Panorama entdeckt (sieht man nur, wenn der Kanalzug NICHT verkleinert dargestellt wird).
    Gerade bei Hall mag ich es, wenn bspw. eine nach links gepannte Gitarre, der Hall entsprechend "mehr" von links " kommt. Das schafft im Mix Platz!

    :right:
    So was lese ich gerne, ein dicker Pluspunkt auch für mich! Bei SAM war es tatsächlich ziemlich wirkungslos, manchmal hatte ich Zweifel, ob es tatsächlich implementiert wäre.


    Bezüglich Marker: bin ich noch nicht soweit; falls in dieser Richtung was entdecke, melde mich. Die Markervewaltung ist bei SAM wirklich sehr elegant gelöst.
    Die Markerverwaltung ist nun klar:
    Direktes Anspringen ist nur nach dem Öffnen der Markeransicht möglich (ALT-Umsch+4). Dann in der Liste mit der Maus den gewünschten Marker markieren, Cursor springt mit der Markierung synchron zum gewünschten Marker.
    Ich werde wohl eine einfachere Tastenzuordnung ausdenken, freie gibt es genug.
     
  14. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Hi netwalker,
    Zum Send Panorama: Danke mir ging es genauso wie Dir in SAM ;-)
    Jeder wollte mir einreden, ja das geht, und zuviel sollte man auch nicht erwarten etc. ;-)
    Ne, da ich das von Cubase kenne, weiß ich was man verlangen kann, und das geht in Sonar genauso, fein das !

    Zur Markerverwaltung:
    Ja, mit viel Geklicke und Maus geht das in Sonar X1, aber nicht schnell genug, wie in Cubase oder SAM bspw. mit Shortcut "1" und man ist auf dem ersten Marker und so weiter. Leider gibt es da nix in Sonar X1, die einzigsten Shortcuts sind: vorheriger oder nächster Marker (STRG+Umschalt+Bild auf, Bild ab, oder so ähnl. bin gerade nicht am Audio-Rechner)) . Aber Marker direkt anspringen via Shortcut geht nicht, das ist wirklich schade!
    Feature Request bei Cakewalk habe ich heute bereits erstellt :)

    Grüße
     
  15. netwalker007

    netwalker007

    Registriert seit:
    07.10.10
    Punkte:
    617
    617
    Hi whitealbum,

    ja, die Markerverwaltung ist etwas umständlich, aber Du wirst auch in der Zukunft immer etwas finden, was bei einer anderen DAW besser gelöst ist:).

    Im Moment kämpfe ich mit dem Mischpult, ganz einfache Sachen kriege ich nicht hin: vor dem Mischbeginn wollte alle Kanalzüge markieren und die Fader auf - 10 dB herunterziehen. Geht ruck zuck in SAM (erster und letzter Kanafader bei gedrückter Umschalttaste anklicken, fertig und das tolle Kettensymbol schätze ich auch!).
    In Sonar habe ich dafür zuerst zwei Shortcuts kreiert: S (schmal) für Kanalzüge verengen und N for normale Breite (B war schon belegt), funktionieren prima. Auf diese Weise kann ich wesentlich mehr Kanäle erreichen.
    Nun wollte ich alle Fader miteinander koppeln - ich bin vielleicht zu blöd aber finde keine einfache Lösung dafür.
    Wenn ich versuche, nach Windows Manier alle Kanäle zu markieren, (erste und letzte Kanalnummer anklicken bei gedrückter Umschalttaste) leuchten zwar alle Kanalnummerfelder blau auf, aber die Fader bewegen sich nicht synchron.
    Ich fand vorerst nur den Gruppenmanager als Lösung, aber es ist sehr umständlich, es muß einen einfacheren Weg geben!
    Hast Du hier eine einfachere Methode gefunden?

    Edit: ich fand die Lösung[​IMG]: es geht mit einer temporären sogenannten Quickgruppe.(S. 938 im Handbuch)
     
  16. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Markerverwaltung:
    Ja, man findet immer was in einer DAW was fehlt, was in einer anderen geht [​IMG]
    Sonar hat auch ein paar Nettigkeiten, wie der Spitzenwertmarker, eine schöne Sache, die ich so in anderen DAW's nicht gesehen habe.

    Aber komme erstmal zum Take Comping, dass ist deutlich besser und sicherer als in Sam [​IMG]

    Mehrere Fader auswählen:

    Da bin ich auch erstmal gescheitert. Aber dann beim Lesen des Handbuchs, bin ich auf die Möglichkeit mit STRG, oder auswählen und STRG gestossen (glaube war bei Änderung des Ausgangsbusses mehrerer Spuren, da geht das auch so).

    Da das Handbuch sehr umfangreich ist, hat man viel zu suchen und zu lesen [​IMG]
     
  17. Faltac

    Faltac Veteran

    Registriert seit:
    20.12.09
    Punkte:
    20.982
    20982
    Wieviele Marker setzt du dir denn so in einem Song?


    Woran hängts denn?
     
  18. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    Marker:
    Zwischen 8 und 12 Marker , kommt auf den Song, und die Songabschnitte (Intro, Verse 1, Verse 2, Refrain 1, Bridge 1 etc.) an.
    Ein direktes Anspringen der Marker via simplen Shortcut a là "1" oder "2" beschleunigt ungemein die Orientierung/Bewegung im Projekt.
    Mit vorheriger und nächster Marker als Shortcut geht auch schon was , oder über die Markerliste aber das ist für mich suboptimal.
    Habe mal ein Feature Request bei Cakewalk erstellt, mal sehen, vielleicht bekomme ich ja eine Antwort bzw. ist in den nächsten Releases mit dabei.

    Bei dem Thema mehrere Fader auswählen o.ä., habe ich aktuell ja kein Problem mehr (unten drunter steht ja auch, das ich letztlich die Stelle im Handbuch gefunden habe).
    Grüße
     
  19. netwalker007

    netwalker007

    Registriert seit:
    07.10.10
    Punkte:
    617
    617
    Was ich im Sonar noch vermisse:

    es sind einige Spuren auf Solo geschaltet, nun will ich mit einem Mausklick oder Tastenkombination den Solomodus bei allen aufheben.
    In SAM geht es mit einem Mausklick.

    Die Methode Quickgruppe (mit der Str-Taste ) funktioniert hier nicht.
    Hat jemand eine Idee?
     
  20. whitealbum

    whitealbum Themenersteller

    Registriert seit:
    22.01.06
    Punkte:
    16.830
    16830
    EDIT: Im Abmischmodul sind die globalen Mute (M) und Soloschalter (S) zu finden, damit geht es.
     

    Anhänge:

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.