Information ausblenden

reaper ReaInsert bug

Dieses Thema im Forum "REAPER" wurde erstellt von karumba, 18.08.12.

Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.
  1. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    mir ist vor kurzem ein fehler (ich vermute mal dass es ein solcher ist) in reaper aufgefallen.
    der fehler lässt sich so reproduzieren:
    1. man legt 2 spuren an
    2. auf beiden spuren werden alle sends/ausgänge entfernt
    3. in beide spuren legt man den reaper effekt "ReaInsert" (man kann damit externe hardware einbinden)
    4. bei spur 1 schickt man vie ReaInsert auf einen soundkarten ausgang (z.b. ADAT 1+2)
    5. bei spur 2 schickt man vie ReaInsert auf einen anderen soundkarten ausgang (z.b. ADAT 3+4)

    wenn man nun auf beiden spuren das selbe signal laufen lässt, funktioniert alles prima & die signale werden zur gleichen zeit an die soundkartenausgänge geschickt. insertiert man aber nun bei einem der beiden spuren einen VST effekt, sind die signale an den beiden ausgängen nichtmehr synchron. insertiert man auf beiden spuren den gleichen effekt & die gleiche anzahl der effekte in gleicher reihenfolge, funktioniert es auch, aber nur dann.

    um das zu veranschaulichen, habe ich mal ein bespielprojekt vorbereitet:
    https://dl.dropbox.com/u/2216927/reaper_sidechain_problem.zip

    das projekt enthält 2 spuren, wobei beide spuren auf den standard soundkartenausgang geroutet werden, spur 1 jedoch auch Links & spur 2 auf rechts. als VST-effekt habe ich mal den baxter-EQ hergenommen. auf spur 1 ist er aktiviert & auf spur 2 deaktiviert. man kann beim abspielen sofort hören, dass das timing nichtmehr stimmt. hinweis: gelegentlich ändert sich das timing auch, d.h. man muss mal die DAW stoppen & wieder weiterlaufen lassen.

    meine frage nun: ist das wirklich ein bug, oder habe ich etwas übersehen?
    aufgefallen ist mir das bei ein paar spielereien mit sidechains (daher die bezeichnung der spuren).

    danke vorab für jede hilfe!
     
    karumba, 18.08.12
    #1
  2. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Hi,

    du insertierst den EQ ja in deinem Beispiel nach dem Insert. Nachdem (im Normalfall) alles gleichzeitig beim Master-Bus raus sollte, MUSS ja ein Track mit einem VST (oder einer Kette mit höherem PD) früher beim Hardware-Ausgang raus.

    Reaper ignoriert also offenbar, dass du nicht über den Master willst; mit einem Delay vor ReaInsert in Höhe der PDC-Differenz sollte sich das uU lösen lassen?
     
    kickback, 18.08.12
    #2
    karumba bedankt sich.
  3. sonnie

    sonnie

    Registriert seit:
    20.11.11
    Punkte:
    2.958
    2958
    Hey Karumba,
    bei mir ist es von dir Out-Of-The-Box geöffnet ohne Verzögerung irgendwo. Allerdings besitze cih den Baxter EQ auch nicht, dh. der wird nur vor-gerendert angezeigt/abgespielt. (DLLs funktionieren nicht auf nem Mac) :(
    Wenn ich irgend ein VST EQ von mir drauf haue, dann ist da aber auch kein Problem.

    Allerdings verstehe ich die Logik des VSTs nicht, da der Insert keinen return hat, greift der EQ doch garnicht...:roll:
     
    sonnie, 18.08.12
    #3
    karumba bedankt sich.
  4. sonnie

    sonnie

    Registriert seit:
    20.11.11
    Punkte:
    2.958
    2958
    Interessant, wenn ich einen Return vom gleichen Channel und Kanal einrichte, und dann mit der Delaykompensation rumspiele (dann aber wieder auf 0 stelle), dann bekomme ich deinen Versatz.
     
    sonnie, 18.08.12
    #4
    karumba bedankt sich.
  5. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Sonnie, ich glaub, du manövrierst etwas an der Fragestellung vorbei ;)

    Der von karumba beschriebene Effekt tritt dann auf, wenn ein Plugin NACH dem ReaInsert in die Kette kommt. Kannst du mit jedem beliebigen anderen Plugin selbst ausprobieren. Je mehr Latenz es verursacht, desto stärker wird es hörbar.
     
    kickback, 18.08.12
    #5
    karumba bedankt sich.
  6. sonnie

    sonnie

    Registriert seit:
    20.11.11
    Punkte:
    2.958
    2958
    Es ging doch darum, dass wenn ich nach ReaInsert ein PlugIn setze, dadurch eine Latenz entsteht, oder?
    So hatte ich das gemacht, und keine Latenz feststellen können.
     
    sonnie, 18.08.12
    #6
    karumba bedankt sich.
  7. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Bei Plugins mit nicht nennenswerten Latenzen (oder welchen, die 0 melden), wirst du's auch nicht mitbekommen.
     
    kickback, 18.08.12
    #7
    karumba bedankt sich.
  8. sonnie

    sonnie

    Registriert seit:
    20.11.11
    Punkte:
    2.958
    2958
    Okay, jetzt bin ich verwirrt.
    Was genau ist das Problem? :D
     
    sonnie, 18.08.12
    #8
    karumba bedankt sich.
  9. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Offenbar soll zB Track2 als Steuersignal für Outboard verwendet werden.
    Wenn in Track1 allerdings nach ReaInsert Plugins insertiert sind, wird das Signal von Track1 früher rausgeschickt als Track2. Das Steuersignal passt also vom Timing her nicht mit dem zu bearbeitenden Signal zusammen.


    EDIT:
    karumba, ist das Steuersignal denn, abgesehen von der Bearbeitung, identisch?
    Falls ja, könntest du es ja dann eigentlich mit einem Track mit 4 Kanälen realisieren, statt 2 Tracks zu verwenden. Dann müssten beide gleich verzögert werden.
     
    kickback, 18.08.12
    #9
    karumba bedankt sich.
  10. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    danke für eure kommentare!
    im prinzip ist es so wie kickback es verstanden hat. ich möchte das sidechain signal vor dem rausführen mit reaInsert EQen, da kommt quasi der VST EQ ins spiel. der EQ hat eine latenz von 0, ich verstehe daher nicht was reaper da falsch macht, denn es sollte ja beiden spuren gleich behandeln. das ganze sollte natürlich auch mit plugins funktionieren die eine latenz > 0 haben, aber soweit bin ich noch garnicht.
    mir ist auch aufgefallen, dass es für das reproduzieren des fehlers keine rolle spielt ob das plugin vor oder nach reaInsert kommt. das timing wird in beiden fällen nicht korrekt abgebildet. der umweg über 4 kanäle würde mir hier nichts bringen, da ich das signal ja vor dem rausschicken EQ möchte.
     
    karumba, 18.08.12
    #10
  11. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Du könntest ja dafür einen EQ insertieren, der nur auf den Channels 3&4 arbeitet und 1&2 ignoriert.

    [​IMG]
     
    kickback, 18.08.12
    #11
    karumba bedankt sich.
  12. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    ok, das könnte ich mal probieren.
    abgesehen davon, würdest du obiges (fehl-)verhalten auch als bug interpretieren?
     
    karumba, 19.08.12
    #12
  13. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Den Unterschied, wenn ein Plugin danach geladen wird nicht unbedingt. Eher ein fehlendes Feature, wenn tatsächlich der Masterbus nicht in Verwendung ist (was ja eher selten der Fall ist).
    Allerdings könntest du dann auch PDC der Plugins nach ReaInsert abschalten; sollte eigentlich funktionieren; sollte... hab's jetzt nicht ausprobiert.

    Auf der anderen Seite ist es merkwürdig, dass es auch mit Plugins passiert, die 0 Samples melden. Liegt vielleicht am anticipative FX processing? Hast du das aktiviert?

    Falls du das meinst:
    Auf die Schnelle würd ich sagen: ja (bzw nein), sollte eigentlich nicht egal sein und ein anderes Ergebnis liefern. Allerdings komm ich gerade von einem anstrengenden Abend Arbeit retour und halte mich nicht mehr für ganz zurechnungsfähig :D
     
    kickback, 19.08.12
    #13
    karumba bedankt sich.
  14. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    das problem tritt ja auch auf, wenn das plugin vor dem insert ist (eigentlich ist dass der fall wie ich ihn möchte).

    in meinem mastering-setting habe ich das für alle spuren deaktiviert.

    na dann erhol dich mal! :)
     
    karumba, 19.08.12
    #14
  15. sonnie

    sonnie

    Registriert seit:
    20.11.11
    Punkte:
    2.958
    2958
    Passiert das gleiche, wenn du das Signal ohne ReaInsert an einen Ausgang schickst, und ein Plugin in den Kanal lädst?
     
    sonnie, 19.08.12
    #15
    karumba bedankt sich.
  16. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    Also... 4-Kanal funktioniert leider nicht, da ReaInsert 16k samples Latenz verursacht und nur Stereo beherrscht. Man bräuchte also 2 hintereinander; das kann dann schon in sich nicht funktionieren. :?
     
    kickback, 19.08.12
    #16
    karumba bedankt sich.
  17. kickback

    kickback

    Registriert seit:
    14.12.05
    Punkte:
    71.622
    71622
    TADA... Eine ReaInsert-Lösung hab ich nicht, aber einen work around; 4 Spuren sind nötig, eigentlich 3, aber Zwecks Übersicht beschreib ich es einmal mit 4:

    Track 1 "quelle":
    Audiomaterial kommt dort rein
    Master/Parent send = off
    send auf Track 2 & 3

    Track 2 "Signal pre outboard":
    Bearbeitung mit Plugins vor Outboard
    Master/Parent send = off
    Hardware send = Output zu Outboard

    Track 3 "Sidechain":
    Bearbeitung mit Plugins vor Outboard Sidechain-Eingang
    Master/Parent send = off
    Hardware send = Output zu Outboard-Sidechain-Eingang

    Track 4 "return":
    Master/Parent send = on
    Input = Return von Outboard
    Monitoring = on
    Bearbeitung mit Plugins nach Outboard

    --

    Track 2 & 3 kommen gleichzeitig bei den Hardware-Ausgängen raus, auch wenn unterschiedliche Plugin-Ketten mit jeweils anderen Latenzen geladen werden.
     
    kickback, 19.08.12
    #17
    karumba bedankt sich.
  18. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    ich bin sehr sicher, dass das nicht passiert, da ich ja verschiedene kanäle parallel an mein outboard schicke & über den eingangswandler wieder in der DAW einsammle. da ich die signale dort dann parallel summiere, wäre mir das ganz sicher aufgefallen (allein 1 sample verschiebung klingt da schon extrem komisch).

    ok, danke fürs ausprobieren.

    ich habe das ganze auch mal im reaper bugforum gepostet, vielleicht weiss da einer weiter. bis dahin werde ich notgedrungen signalspur & sidechainspur gleich effektieren.

    cool, danke! das probiere ich später mal aus.
     
    karumba, 19.08.12
    #18
  19. derchris

    derchris

    Registriert seit:
    01.03.04
    Punkte:
    2.067
    2067
    Ich wuerde nicht sagen, dass dies ein Bug ist. Der ReaInsert ist dazu gedacht, Hardware einzubinden (wie der Name sagt, als Insert). Dabei ist es wichtig, dass am Parent-Bus wieder alles synchron ist und das scheint Reaper ja zu machen.

    Ich wuerde das wahrscheinlich auch rein ueber Hardware Sends machen, wie von Kickback beschrieben. Kann aber sein, dass man das Signal aufnehmen und geraderuecken muss, falls man noch weitere Spuren hat.
    Evtl. kann man das umgehen, wenn man statt der Aufnahme-Spur einen ReaInsert nimmt und dort den Send nur zum Latenz messen auf die Hardware legt, und ansonsten nicht verbindet.
    Ich muesste einiges rum patchen um das auszuprobieren, daher nur Vermutung.


    gruss, Chris
     
    derchris, 19.08.12
    #19
  20. karumba

    karumba Themenersteller Moderator Mitarbeiter

    Registriert seit:
    01.01.10
    Artikel:
    6
    Punkte:
    23.937
    23937
    am parent bus ist es aber bei verwendung von reaInsert nichtmehr synchron, denn auch wenn ich das signal zurückführe, bleibt es asynchron.

    wenn ich auf reainsert verzichte ist alles synchron, aber das entspricht quasi kickbacks workaround um auf die reaInserts zu verzichten.
     
    karumba, 19.08.12
    #20
Status des Themas:
Beachte, dass dieses Thema älter als ein Jahr ist! Möglicherweise ist es sinnvoller, einen neuen Thread zu erstellen.