Bugfixing-Thread

Dieses Thema im Forum "RECORDING.de" wurde erstellt von Bill_Presston, 30.01.17.

Schlagworte:
  1. fabianb

    fabianb Administrator

    Registriert seit:
    29.01.16
    Punkte:
    1.535
    1535
    Übrigens: Das automatisierte Chartshow-Widget ist nun online!
    War schon ne weile fertig aber es gab noch Design-Fehler.
     
    stonyroad bedankt sich.
  2. stonyroad

    stonyroad

    Registriert seit:
    09.06.04
    Punkte:
    15.479
    15479
    Rischtisch:Schwupps und da wars :D
     
  3. sts

    sts

    Registriert seit:
    09.09.08
    Punkte:
    11.256
    11256
    Also, was die Dropbox-Links angeht, habe ich zumindest eine Sache gerade schon mal ausprobiert:

    Bei einem Dropbox-Link mit "dl" statt dem von Dropbox erzeugten "www" hat der Parameter "dl" am Ende des Links (nach dem Fragezeichen) bei mir keine Auswirkungen gezeigt. Sowohl bei "dl=0" als auch bei "dl=1" hat das Abspielen im Player gleichermaßen funktioniert. Es funktioniert auch, wenn man den Parameter ganz löscht (incl. dem Fragezeichen, das als Trenner dient). Das sind schon mal drei von den zwölf Schreibweisen, die ich oben in #780 angehängt hatte. Kann natürlich sein, dass andere User zu anderen Ergebnissen kommen.

    Edit:
    Gerade ausprobiert - weitere Erkenntnisse zu "www vs. dl" und "https vs. http":
    1. Wenn man "www" statt "dl" im Link angibt, erscheint der Player sehr kurz und verschwindet dann gleich wieder, es bleibt nur eine leere Fläche zu sehen, so als stünde da nichts.
    2. Wenn ich https:// durch http:// ersetze, verursacht das bei mir keine Probleme (wie es oben in #778 von fabianb beschrieben wurde). Der Player funktioniert auch mit http://
    Es bleiben also als Fehlerursachen die Leerzeichen im Dateinamen und das "www" in der URL.
     
    Zuletzt bearbeitet: 17.07.17 um 14:07 Uhr
    oati bedankt sich.
  4. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    @sts ja, genau wie bei mir. Habe ich ja vorhin auch gesagt. Und für Bilder funktioniert es (bei mir) auch umgekehrt. Also "www" stehenlassen und dafür "dl=1" hinschreiben.
     
  5. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    Wenn du "dl=1" hinschreibst bleibt er aber da, oder? Also bei mir zumindest.
    Wie gesagt ich glaube das "https://dl.****" nur eine alternative Schreibweise von "https://www.*****?dl=1" ist.

    Verursachte bei mir ebenfalls nie Probleme, weshalb ich immer das "s" weggenommen hatte. Es funktioniert aber genausogut "https", was heutzutage ja eigentlich Standard sein sollte.

    Leerzeichen ist klar. Die haben meines Erachtens in einer URL sowieso nichts verloren.
     
  6. sts

    sts

    Registriert seit:
    09.09.08
    Punkte:
    11.256
    11256
    Ist bei mir anders: Der Player erscheint zwar dauerhaft, spielt aber nicht ab. :)
     
  7. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    Also gut, ein Demonstrationsbeispiel von mir:

    Link mit "www" und "dl=1":



    ist das gleiche wie Link mit "dl" statt "www" und "dl=0":



    was wiederrum das gleiche ist wie Link mit "dl" statt "www" und "?dl=*" komplett entfernt



    Bin gespannt bei wem das geht. Bitte kurz Bescheid sagen. Danke.
     
  8. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    P.S.: Bei mir spielen alle drei Player gleich ab. Win10 V 1703, Firefox 54.0.1
    P.P.S.: Um die genaue Schreibweise des Links zu sehen, den obigen Beitrag einfach zitieren.
     
    clemensvill bedankt sich.
  9. sts

    sts

    Registriert seit:
    09.09.08
    Punkte:
    11.256
    11256
    @oati: Der erste Link spielt bei mir nicht ab. Alle drei erscheinen dauerhaft, es sei denn, ich kann einen nicht sehen und es sind in Wirklichkeit vier oder mehr. :)

    Somit scheint es mir die sicherste und einfachste Variante zu sein, "www" durch "dl" zu ersetzen und den dl-Parameter einfach so zu lassen, wie Dropbox ihn erzeugt.
     
    oati bedankt sich.
  10. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    Ok, kannst du mal was zu deinem System + Browser schreiben. Wäre vielleicht für @fabianb interessant.
    Und ja, es sind drei Player.
     
  11. sts

    sts

    Registriert seit:
    09.09.08
    Punkte:
    11.256
    11256
    Win 7 mit Seamonkey 2.46. Ich kann den ganzen Kram später auch nochmal unter Linux probieren.
     
  12. Kosaken-Kaffee

    Kosaken-Kaffee

    Registriert seit:
    04.10.16
    Punkte:
    12.556
    12556
    Bei mir funzen alle 3 (Win 7/Chrome).
     
  13. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    Ok, Safari am iPad spielt den ersten Player ebenfalls nicht ab.
    Win 10 und Chrome wiederrum schon.
    CentOS 7 mit Firefox zeigt nichtmal die Player an - keinen der drei.
     
  14. asli

    asli

    Registriert seit:
    26.08.06
    Punkte:
    16.085
    16085
    Bei mir funktionieren alle drei Links. W10, Chrome.
     
  15. Bassmacher

    Bassmacher

    Registriert seit:
    19.03.15
    Punkte:
    1.707
    1707
    Bei mir funktioniert der erste Link nicht. Hab Win7 mit Firefox.
     
  16. sts

    sts

    Registriert seit:
    09.09.08
    Punkte:
    11.256
    11256
    Zum Beitrag #787 oben von oati:

    Unter Linux Mint 17.3 XFCE sind alle drei Links dauerhaft als Player sichtbar. Mit Seamonkey 2.46 funktioniert das Abspielen des Songs aber nur bei den letzten zwei Links. Das ist also das gleiche Ergebnis, das ich unter Win 7 hatte (erster der drei Links geht nicht). Mit Firefox 53.0.3 (weiterhin Linux) funktioniert das Playback bei allen drei Links, allerdings lässt es sich beim ersten Link nicht mehr stoppen (Pausentaste hat keine Wirkung).

    Nur der erste Link hat eine URL mit "www", die anderen beiden haben statt dessen "dl" (einmal mit und einmal ohne den zusätzlichen Parameter "dl=0" am Ende). Das spricht für mich weiterhin dafür, dass man in den Dropbox-Links das "www" durch "dl" ersetzen sollte, damit der Player auf möglichst vielen Umgebungen funktioniert.

    Übrigens ist es auch noch so, dass mir bei Eingabe des ersten Links (https://www...) in die Adresszeile des Browsers ein Download angeboten wird (das hängt aber auch mit meinen eigenen Browsereinstellungen zusammen), während beim zweiten und dritten Link (https://dl...) sich gleich ein Player öffnet (nicht derjenige, der im Forum angezeigt wird) und das Ding abspielt. Das nur so nebenbei.
     
    Zuletzt bearbeitet: 17.07.17 um 17:47 Uhr
    oati bedankt sich.
  17. Realist

    Realist Moderator Mitarbeiter

    Registriert seit:
    30.09.08
    Punkte:
    17.417
    17417
    Bei mir spielt der Zweite nicht ab. Der erste Link geht. Win7/64bit + neueste Version Firefox.
     
  18. stonyroad

    stonyroad

    Registriert seit:
    09.06.04
    Punkte:
    15.479
    15479
    Hab die Links dreimal (Sessions an -abmelden, W7, FF 54.0.1) getestet.

    Angezeigt werden die drei Player immer.
    Link1 reagiert recht "zickig": Zwei mal gings so wie vorgesehen, 1mal kam nach dem anklicken das Pausesymbol ohne das der Player was spielte und er reagierte auch nicht mehr auf Folgeklicks.
     
  19. clemensvill

    clemensvill Moderator Mitarbeiter

    Registriert seit:
    03.03.09
    Artikel:
    13
    Punkte:
    23.884
    23884
    Safari 10.1.1 - OSX 10.11.6 (El Capitan)
    Auf den ersten Versuch spielen 2 und 3.
    1 zeigt "Fehler".
    Seite Neu Laden und es spielen alle drei.

    Opera 46.0 - OSX 10.11.6 (El Capitan)
    Alle drei Links sind abspielbereit.
    Nur der erste Link hängt nach 4 sek. Abspieldauer.
    Beim zweiten Abspielversuch funktioniert's.

    In Opera sieht man Fortschrittsbalken beim Laden - da braucht der 1er am längsten.
     
  20. oati

    oati

    Registriert seit:
    19.04.05
    Punkte:
    3.588
    3588
    Ja, sehe ich auch so. Danke für die Hilfe beim Ausprobieren.